Subject: [Ibnemo] topic: box commands

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 15 Oct 2015 21:00:33 +0200

Anita (last name?) aked during our bar-bof at IETF93:

     Network orders outside of the carrier could be done in Nemo and then it would break into the “box commands”.

Not 100% sure what she meant with "box commands". Anita, if you are on this list, please elaborate.

Possibly she meant that if a customer requests some connectivity between say 2 locations,
then "intent" should be able to express that and the IBNEMO engine would translate that into
commands for each box (device) that is onvolved in the connection. Potentially that could be CLI
commands, or possibly that could be YANG/NETCONF/RESTCONF configuration commands.

Anita?

Or anyone else who has input/views on this.

Bert

---

From: Zhoutianran <[email-masked]>
Date: Fri, 16 Oct 2015 02:04:17 +0000

I guess you are right on what Anita mean.
And I agree that intent is a higher level request which can then be translated into device commands.

Tianran

> -----Original Message-----
> From: Ibnemo [mailto:[email-masked]] On Behalf Of Bert Wijnen
> (IETF)
> Sent: Friday, October 16, 2015 3:01 AM
> To: [email-masked]
> Subject: [Ibnemo] topic: box commands
> 
> Possibly she meant that if a customer requests some connectivity between
> say 2 locations, then "intent" should be able to express that and the IBNEMO
> engine would translate that into commands for each box (device) that is
> onvolved in the connection. Potentially that could be CLI commands, or
> possibly that could be YANG/NETCONF/RESTCONF configuration commands.
> 
> Anita?
> 
> _______________________________________________
> Ibnemo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ibnemo