Subject: RE: [Icar] ICAR draft charter

From: "Robert Snively" <[email-masked]>
Date: Wed, 7 Jan 2004 14:24:16 -0800

Alex,

I like this approach.  

I think you might be able to clarify the first paragraph a little
bit.  As I understand it, you are actually focusing on two
separate (and probably separable) issues with separate drafts.
I had a bit of a problem understanding what kinds of things might
be included in each of the drafts.  I believe it would help
if you were a bit more explicit about the expected scope of
each.  As an example, I could make up several different
scopes for a document considering "community review".
I would suggest you make the scope of the WG more explicit
by modifying the first paragraph to read something like the
following:  (note that I am only guessing about your intent
with the words "community review" and "structured review" and I
may be completely wrong, so your wording for each might be
completely different).

  WG Description:

	Develop mechanisms for improved cross-functional review within
	the IETF.  It is an explicit goal of the WG to come up with
	mechanisms encouraging earlier and better review of documents.
	[Should this apply to all drafts, or just standards track
technical
	drafts?]
	An early review is best for catching architectural problems
while
	they are relatively easy to solve.  It is an explicit goal
	of the WG to assure that the review process brings in 
	cross-area expertise to spot possible unforeseen interactions
and
	improve overall document quality.  Two documents are expected
	to be created:

	1)  Community Review Guidelines:
		Mechanisms and techniques to solicit early 
		cross-functional review, which may include:
		a)  Guidelines for selecting time of reviews.
		b)  Guidelines for selecting and soliciting
			review from cross-functional experts.
		c)  Other material relevant to this scope.

	2)  Structured Review Guidelines:
		Mechanisms and techniques to solicit and record
		meaningful review of documents, which may include:
		a)  Guidelines for notifying potential reviewers
			of review requirement
		b)  Guidelines for assuring reviewer participation
		c)  Guidelines for accumulating review issues
		d)  Guidelines for responding to review issues
		e)  Guidelines for measuring and achieving consensus
		f)  Other material relevant to this scope.

>    WG Description:
> 
>      Work out mechanisms for improved cross-functional review within
>      the IETF. This includes a better community review, as well as
>      more structured (formal and role-based) pre-IESG review that may
>      be used to improve scalability of the IESG review function. It is
>      an explicit goal of the WG to come up with mechanisms encouraging
>      earlier review of the documents. An early review is best for
>      catching architectural problems while they're still relatively
>      easy to solve. In particular, many cross-area interactions can be
>      spotted and dealt with, thus avoiding many "late surprises". A
>      final review can catch remaining cross-area interactions, as well
>      as deal with overall quality issues.

_______________________________________________
Icar mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/icar

---

From: "Robert Snively" <[email-masked]>
Date: Thu, 8 Jan 2004 09:00:46 -0800

As I thought about this, there is one other thing that
should be addressed.  It seems to me to be important to include
at least the obvious liaison requirements explicitly in
the charter.  Certainly, the "problem" working group's results 
should be explicitly included as inputs to the working group.
There may be others that I am not aware of that should
also be included.  If we leave out these known liaison activities,
we run the risk of replicating already completed work (and
even coming out with conflicting conclusions).

I would propose that the last paragraph of the WG
description be extended as follows:

	The WG will also coordinate with other WGs on proposed changes
to
	the IETF Working Group operations and Standards process if those
      are considered necessary.  The working group will, as part of
	its charter, address the relevant parts of the "problem" working
	group's results.

Bob Snively
+1 408 333 8135

> -----Original Message-----
> From: Alex Zinin [mailto:[email-masked]]
> Sent: Wednesday, January 07, 2004 12:25 PM
> To: [email-masked]
> Subject: [Icar] ICAR draft charter
> 
> 
> Folks-
> 
> Draft charter below. Please read. I'd like to hear from as many people
> as possible.
> 
> Thanks.
> 
> -- 
> Alex
> 
> 
>    WG name: improved cross-area review (icar)
> 
>    Chairs: <TBD>
> 
>    General Area Director(s):
>     Harald Alvestrand <[email-masked]>
> 
>    General Area Advisor:
>     Harald Alvestrand <[email-masked]>
>    
>    Mailing list: [email-masked]
>    Subscription: [email-masked]
>    Archives : 
>    
> https://www1.ietf.org/mail-archive/working-groups/icar/current
> /maillist.html
> 
>    WG Description:
> 
>      The WG will cooperate with others in starting and evaluating
>      experiments with both early reviews and structured reviews. The
>      evaluation of such experiments may be published as Informational
>      RFCs if the group so desires.
> 
>      The WG will also coordinate with other WGs on proposed changes to
>      the IETF Working Group operations and Standards process if those
>      are considered necessary.
> 
>    WG milestones:
> 
>      FEB 2004: Submit -00 draft on improved community review
>      FEB 2004: Submit -00 draft on improved structured review
>      SEP 2004: Submit draft on improved community review to
>                the IESG for publication as BCP
>      SEP 2004: Submit draft on improved structured community review to
>                the IESG for publication as BCP
>      SEP 2005: Evaluate WG progress and potential; close or recharter
> 
>