Subject: Re: [iccrg] 答复: [tcpm] New Version Notification for draft-you-tcpm-configuring-tcp-initial-window-00.txt

From: Runa Barik <[email-masked]>
Date: Thu, 6 Nov 2014 11:56:11 +0000

Hi,

   There is a typo in the draft draft-you-tcpm-configuring-tcp-initial-window-02.txt.

                if s <= theta then
                   InitCwnd = MaxIW
                 else
                   InitCwnd = theta/s * MaxIW + (1-theta/s) * MinIW
                end if

  There is also another draft draft-sallantin-iccrg-initial-spreading-01.txt. I think combining both IW function, and
 initial spreading may give better performance.

Regards,
- Runa
________________________________________
From: Joe Touch <[email-masked]>
Sent: Monday, October 27, 2014 5:33 AM
To: Youjianjie; Runa Barik
Cc: [email-masked]
Subject: Re: 答复: [tcpm] New Version Notification for draft-you-tcpm-configuring-tcp-initial-window-00.txt

On 10/26/2014 8:03 PM, Youjianjie wrote:
...
>> There are no trusted apps in the Internet; there’s no one party to “trust”
>> them.
>>
>> I.e., I have no reason to trust your apps, nor you to trust mine.
>>
>> So, ultimately, everyone needs to use the same rules and assume that
>> everyone will try to game the system.
>
> The worst is all the applications use the default maximum IW set by the system.

Please explain the alternative.

You can't know what the application will do unless you ask it OR you
wait until the application is done. In the first case, you have to trust
the application, but applications will lie for better performance. In
the second case, you have to wait until the application has buffered all
its data AND closed the socket to know - for sure - how big the window
should have been.

There's really no useful alternative, AFIACT.

Joe

---

From: Youjianjie <[email-masked]>
Date: Tue, 11 Nov 2014 01:46:23 +0000

Hi all, 

A new version has been uploaded. We fix typos and discuss the issue when APP tries to cheat the system by splitting a large flow into small ones.
Your comments are appreciated. 

A new version of I-D, draft-you-tcpm-configuring-tcp-initial-window-03.txt
has been successfully submitted by Jianjie You and posted to the IETF repository.

Name:		draft-you-tcpm-configuring-tcp-initial-window
Revision:	03
Title:		Configuring TCP's Initial Window
Document date:	2014-11-10
Group:		Individual Submission
Pages:		8
URL:            http://www.ietf.org/internet-drafts/draft-you-tcpm-configuring-tcp-initial-window-03.txt
Status:         https://datatracker.ietf.org/doc/draft-you-tcpm-configuring-tcp-initial-window/
Htmlized:       http://tools.ietf.org/html/draft-you-tcpm-configuring-tcp-initial-window-03
Diff:           http://www.ietf.org/rfcdiff?url2=draft-you-tcpm-configuring-tcp-initial-window-03

Thanks,
Jianjie

> -----邮件原件-----
> 发件人: iccrg [mailto:[email-masked]] 代表 Runa Barik
> 发送时间: 2014年11月6日 19:56
> 收件人: [email-masked]
> 主题: Re: [iccrg] 答复: [tcpm] New Version Notification for
> draft-you-tcpm-configuring-tcp-initial-window-00.txt
> 
> Hi,
> 
>    There is a typo in the draft
> draft-you-tcpm-configuring-tcp-initial-window-02.txt.
> 
>                 if s <= theta then
>                    InitCwnd = MaxIW
>                  else
>   There is also another draft draft-sallantin-iccrg-initial-spreading-01.txt. I
> think combining both IW function, and  initial spreading may give better
> performance.
> 
> Regards,
> - Runa
> Subject: Re: 答复: [tcpm] New Version Notification for
> draft-you-tcpm-configuring-tcp-initial-window-00.txt
> 
> You can't know what the application will do unless you ask it OR you wait until
> the application is done. In the first case, you have to trust the application, but
> applications will lie for better performance. In the second case, you have to
> wait until the application has buffered all its data AND closed the socket to
> know - for sure - how big the window should have been.
> 
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg