Subject: [iccrg] Small charter change?

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 12 Oct 2015 07:28:20 +0000

Hi,

the TSV ADs have noticed this bit in the ICCRG charter text (https://irtf.org/iccrg, all the way at the end):

"The ICCRG will hold 2-3 meetings per year, typically meeting for two days at a time. Critical to success is close involvement between the IETF community and the ICCRG. To this end, the ICCRG should make a presentation at each IETF (probably in the TSVWG) summarizing progress made, and what input is needed from the IETF."

Since this reporting to TSVWG at every IETF hasn't really ever happened (AFAICT), the proposal is to remove those sentences from the charter text.

Comment/objections?

Thanks,
Lars

---

From: David Ros <[email-masked]>
Date: Mon, 12 Oct 2015 10:10:18 +0200

Hi,

My co-chair is better placed to answer since he has been in this for much longer than I, but: this looks like a holdover from the old days when iccrg met (mostly?) during the PFLDnet workshop (now defunct).

=> I see no harm in removing this from the charter.

Thanks,

David

On 12 Oct 2015, at 09:28, Eggert, Lars <[email-masked]> wrote:

> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Mon, 12 Oct 2015 13:03:15 +0000

Hi all,

I generally agree that the ICCRG charter should not include processes that have never been followed. BTW, some other technologies mentioned in the ICCRG charter may also date back to good old PFLDnet times (e.g., XCP). Possibly some other paragraphs in the charter could be shortened or at least updated to 2015 hype topics ;)

But since the ICCRG charter is mentioned, I have a related question:

The TCPM charter https://datatracker.ietf.org/wg/tcpm/charter/ has a kind of liaison statement to ICCRG:

  "Changes of algorithms may require additional review by the IRTF Congestion Control Research Group (ICCRG)"

This sentence has been in the charter for a long time, and as far as I know it has only rarely been applied.

However, I have recently suggested that such a review might be appropriate for draft-khademi-alternativebackoff-ecn. My suggestion was in particular driven by the following paragraphs of the ICCRG charter:
 
  "The network research community has been very active in designing modifications and alternatives to TCP's basic AIMD algorithm [...]. However the network research community cannot, by itself, effectively evaluate any such solution for Internet-scale deployment. To do this requires the involvement of equipment vendors, network operators, and other IETF participants, in addition to the research community.

  The key goal of the Internet Congestion Control Research Group (ICCRG) therefore is to move towards consensus on which technologies are viable long-term solutions for the Internet congestion control architecture, and what an appropriate cost/benefit tradeoff is.

  To achieve this goal will require extensive evaluation of different mechanisms in a wide range of network conditions, using a mix of simulation, analysis, and experiment. It is unclear at this stage whether any single proposed solution is viable, or whether there needs to be a synthesis of ideas from many places."

IMHO these paragraphs apply reasonably well to some drafts in TCPM, e.g., regarding the evaluation "in a wide range of network conditions, using a mix of simulation, analysis, and experiment".

However, if an ICCRG review is considered useful or required for a draft in TCPM, it is not exactly clear to me what that review would actually be. Personally, I think an ICCRG presentation in TCPM summarizing the progress would make sense in such a case, but I don't know if this is my personal view only. Also, I don't know if there has ever been agreement on that inside ICCRG.

Thus, I'd be interested in a broader discussion whether TCPM can indeed refer drafts to ICCRG for review, or whether this is more an out-dated idea.
 
Thanks

Michael

-----Original Message-----
From: iccrg [mailto:[email-masked]] On Behalf Of Eggert, Lars
Sent: Monday, October 12, 2015 9:28 AM
To: [email-masked]
Cc: [email-masked]
Subject: [iccrg] Small charter change?

Hi,

Comment/objections?

Thanks,
Lars

---

From: Michael Welzl <[email-masked]>
Date: Fri, 23 Oct 2015 10:35:16 +0200

> On 12. okt. 2015, at 09.28, Eggert, Lars <[email-masked]> wrote:
> 
> Hi,
> 

Fine to remove  (and sorry for the extreme delay of this response)

Michael

---

From: Michael Welzl <[email-masked]>
Date: Fri, 23 Oct 2015 10:40:40 +0200

Hi,

and sorry for the extreme delay of this response. See below:

> On 12. okt. 2015, at 15.03, Scharf, Michael (Michael) <[email-masked]> wrote:
> 
> Hi all,
> 
> However, if an ICCRG review is considered useful or required for a draft in TCPM, it is not exactly clear to me what that review would actually be.

This is really dependent on the case it is. TCPM should address ICCRG with a specific question to be answered, or just ask for more review, and such information is collected and then handed over to TCPM. I think new-cwv is a case where this procedure worked out quite efficiently:  http://trac.tools.ietf.org/group/irtf/trac/wiki/ICCRG_newcwv

> Personally, I think an ICCRG presentation in TCPM summarizing the progress would make sense in such a case, but I don't know if this is my personal view only. Also, I don't know if there has ever been agreement on that inside ICCRG.

I think there’s no need for a common ICCRG position on this; if TCPM wants presentations summarizing things (which I’d agree can be a good idea), we can do this.

> Thus, I'd be interested in a broader discussion whether TCPM can indeed refer drafts to ICCRG for review, or whether this is more an out-dated idea.

I think it’s not an out-dated idea. For the recent case of draft-khademi-alternativebackoff-ecn I was a bit disappointed because I contacted potential reviewers and pinged them (twice I think), and nothing has happened yet. But that’s the only problem there that I can see.

Cheers,
Michael