Subject: [icnrg] ICN Baseline Scenarios draft revised

From: Konstantinos Pentikousis <[email-masked]>
Date: Tue, 18 Jun 2013 12:43:56 +0000

Dear all,

We have updated and extended the ICN Baseline Scenarios draft and we're looking forward to your comments, suggestions and text contributions.

You can get the latest version from http://datatracker.ietf.org/doc/draft-pentikousis-icn-scenarios/

Best regards,

Kostas

---

From: Nikos Fotiou <[email-masked]>
Date: Tue, 25 Jun 2013 19:15:29 +0300

Dear Kostas,

In section 3.1.2 may be a reference to the paper that describes blackadder
(this is the [PSI] reference), as well as a URL to blackadder's page(
http://www.fp7-pursuit.eu/PursuitWeb/?page_id=338) could be added.

Moreover  we have implemented (*http://tinyurl.com/oy7vods*) and published
[*] a workload generator for web, p2p,  and video traffic, specifically for
ICN experimentation. It might fit in section 3.3

Best,
Nikos

[*]Katsaros, K. V., Xylomenos, G., & Polyzos, G. C. (2012, May).
GlobeTraff: a traffic workload generator for the performance evaluation of
future Internet architectures. In *New Technologies, Mobility and Security
(NTMS), 2012 5th International Conference on* (pp. 1-5). IEEE

On Tue, Jun 18, 2013 at 3:43 PM, Konstantinos Pentikousis <
[email-masked]> wrote:

> Dear all,
>
> We have updated and extended the ICN Baseline Scenarios draft and we're
> looking forward to your comments, suggestions and text contributions.
>
> You can get the latest version from
> http://datatracker.ietf.org/doc/draft-pentikousis-icn-scenarios/
>
> Best regards,
>
> Kostas
>
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: Konstantinos Pentikousis <[email-masked]>
Date: Thu, 27 Jun 2013 15:55:40 +0000

Dear Nikos, all

Thanks for the pointers. Would you mind sending me the proposed text to be included in the draft? A diff (or track-changes .doc) would do. Feel free to send it directly to me.

In general, we do have a lot of URL references right now in the draft and I would prefer to minimize them as we move forward. Perhaps moving all URLs listed in the draft either on our wiki or in an appendix is not a bad idea. I think that the wiki page is more suitable for this (and would be both easier to maintain and update in the future). Any opinions?

Best regards,

Kostas

From: [email-masked] [mailto:[email-masked]] On Behalf Of Nikos Fotiou
Sent: Tuesday, June 25, 2013 6:15 PM
To: Konstantinos Pentikousis
Cc: [email-masked]
Subject: Re: [icnrg] ICN Baseline Scenarios draft revised

Dear Kostas,

In section 3.1.2 may be a reference to the paper that describes blackadder (this is the [PSI] reference), as well as a URL to blackadder's page(http://www.fp7-pursuit.eu/PursuitWeb/?page_id=338) could be added.

Moreover  we have implemented (http://tinyurl.com/oy7vods) and published [*] a workload generator for web, p2p,  and video traffic, specifically for ICN experimentation. It might fit in section 3.3

Best,
Nikos

[*]Katsaros, K. V., Xylomenos, G., & Polyzos, G. C. (2012, May). GlobeTraff: a traffic workload generator for the performance evaluation of future Internet architectures. In New Technologies, Mobility and Security (NTMS), 2012 5th International Conference on (pp. 1-5). IEEE

On Tue, Jun 18, 2013 at 3:43 PM, Konstantinos Pentikousis <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Best regards,

Kostas

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Konstantinos Pentikousis <[email-masked]>
Date: Fri, 28 Jun 2013 10:08:42 +0000

Dear Kashif,

Many thanks for the kind suggestions. We will take them into consideration in the next update of the draft.

Best regards,

Kostas

|-----Original Message-----
|From: Dr. Kashif Nisar [mailto:[email-masked]]
|Sent: Wednesday, June 26, 2013 2:47 PM
|To: Konstantinos Pentikousis
|Cc: [email-masked]
|Subject: RE: ICN Baseline Scenarios draft revised
|
|Dear Kostas,
|
|Thank you for your email on ICNRG and requested from us the ICN Baseline
|Scenarios draft comments, suggestions and text contributions. Please,
|find as below my comments and suggestions.
|
|In Section 2.2 Real-time Communication
|
|We need to add few lines as below:
|
|Voice over Internet Protocol (VoIP) technology has observed rapid growth
|in the world of telecommunications. VoIP offers high-rate voice services
|at low cost with good ﬂexibility, typically in a Network. In a voice
|conversation, each client works either as a sender or a receiver
|depending on the direction of trafﬁc ﬂow over the network. A VoIP
|technologically requires high throughput, less packet loss and a high
|fairness index over the network.
|
|http://www.sciencedirect.com/science/article/pii/S1084804512001713
|
|In Jacobson et al. [VoCCN] paper, we need to explain as below Scenarios:
|
|"The complex data paths of Figure 1 result from a mismatch between the
|user’s goal and the network’s means of achieving it: Alice simply wants
|to talk to Bob but the network requires that the communication be
|addressed to the IP address of Bob’s phone. All the infrastructure in
|the Figure, together with the several services, devices and DNS name
|registrations that are not shown, exist solely to map from the
|user/application’s world view into the network’s world view. One strong
|driver for content-oriented networking is that this translation
|(typically referred to as middleware) is not needed. Ideally data should
|ﬂow directly from producer to interested consumer, as shown in Figure 2.
|Our VoCCN prototype achieves.
|
|VoCCN: Voice Over Content-Centric Networks
|
|In Section 3.1.1 CCN and NDN
|Comments: I have seen that as above section CCN explained in details but
|NDN still need to explain in same section.
|
|With kind regards,
|****************************************************
|Kashif Nisar PhD MIEEE
|Senior Lecturer
|
|InterNetWorks Research Laboratory
|School of Computing
|UUM College of Arts and Sciences, (CAS)
|Universiti Utara Malaysia, 06010 UUM
|Sintok, Kedah.  Phone: +604 928 6038, Cell: +6013 5974 880
|M A L A Y S I A     Fax: +604 928 4753
|Email: [email-masked]
|****************************************************
|________________________________________
|From: [email-masked] [[email-masked]] On Behalf Of
|Konstantinos Pentikousis [[email-masked]]
|Sent: Tuesday, June 18, 2013 8:43 PM
|To: [email-masked]
|Subject: [icnrg] ICN Baseline Scenarios draft revised
|
|Dear all,
|
|We have updated and extended the ICN Baseline Scenarios draft and we're
|looking forward to your comments, suggestions and text contributions.
|
|You can get the latest version from
|http://datatracker.ietf.org/doc/draft-pentikousis-icn-scenarios/
|
|Best regards,
|
|Kostas
|
|
|_______________________________________________
|icnrg mailing list
[email-masked]
|https://www.irtf.org/mailman/listinfo/icnrg
|
|Universiti Utara Malaysia Official Website http://www.uum.edu.my
|
|Disclaimer:
|This e-mail (including any attachments) may contain confidential
|information. If you are not the intended recipient, you are hereby
|notified that any review, distribution, printing, copying or use of this
|e-mail is strictly prohibited. If you have received this e-mail in
|error, please notify the sender or Universiti Utara Malaysia (UUM)
|immediately and delete the original message. Opinions, conclusions and
|other information in this e-mail that do not relate to the official
|business of UUM and/or its group of companies shall be understood as
|neither given nor endorsed by UUM and UUM accepts no responsibility for
|the same. All liability arising from or in connection with computer
|viruses and/or corrupted e-mails is excluded to the fullest extent
|permitted by law.