Subject: [icnrg] ICNRG protocol format adoption

From: Dirk Kutscher <[email-masked]>
Date: Fri, 29 May 2015 11:58:29 +0000

Hi folks,

At the ICNRG meeting at IETF-92 [1], we determined a rough consensus for adopting the message formats and semantics in [2] and [3] as an RG work item. There was a follow-up discussion on the mailing list [4] where people expressed their views and interpretation of this.

This message is to explain the chairs expectations for future work in ICNRG, considering the rough consensus that we determined at the meeting and in subsequent mailing list discussions.

For ICNRG, the motivation for adopting a protocol format generally is to facilitate and expedite work in the RG by endorsing a common format for experiments, for future extensions etc.

The adopted format is one of those that the RG is encouraged to use for future work. Adopting this does not exclude the discussion, usage, or possible adoption of other formats. However, by adopting a specification, we set ourselves a goal to advance the specification to a level where the RG is eventually happy to publish it as an Experimental RFC.

It is important to understand that adopting an Internet Draft in an IRTF RG is something different to adopting a draft in an IETF WG (that is chartered to do normative specifications). Adopting the format specification MUST NOT be taken as an indication of present or future standardization (in the sense of IETF standards track documents).

Adopting a format also comes with expectations on the mode of operation for future work on the format. When we adopt a specification, we also transfer change control from the previous set of authors to the RG, i.e., the document becomes an RG document, and the authors advance and maintain it on behalf of the RG.

We would also expect that future changes to the specification would be reflected in implementations, including but not limited to PARC's CCNx implementation.

Please let us know if you have any question.

Dirk, Börje, Dave (ICNRG chairs)

--
[1] http://www.ietf.org/proceedings/92/minutes/minutes-92-icnrg
[2] https://datatracker.ietf.org/doc/draft-mosko-icnrg-ccnxmessages/
[3] https://datatracker.ietf.org/doc/draft-mosko-icnrg-ccnxsemantics/
[4] http://www.ietf.org/mail-archive/web/icnrg/current/threads.html#01076

---

From: Mark Stapp <[email-masked]>
Date: Fri, 29 May 2015 11:25:01 -0400

So just to clarify: you're adopting the two ccnx drafts you referred to 
as icnrg documents? will you be asking the authors to submit rg versions?

Thanks,
Mark

On 5/29/15 7:58 AM, Dirk Kutscher wrote:
> Hi folks,
>
> At the ICNRG meeting at IETF-92 [1], we determined a rough consensus
for adopting the message formats and semantics in [2] and [3] as an RG
work item. There was a follow-up discussion on the mailing list [4]
where people expressed their views and interpretation of this.
>
> This message is to explain the chairs expectations for future work
> in
ICNRG, considering the rough consensus that we determined at the meeting
and in subsequent mailing list discussions.
>
> For ICNRG, the motivation for adopting a protocol format generally
> is
to facilitate and expedite work in the RG by endorsing a common format
for experiments, for future extensions etc.
>
> The adopted format is one of those that the RG is encouraged to use
for future work. Adopting this does not exclude the discussion, usage,
or possible adoption of other formats. However, by adopting a
specification, we set ourselves a goal to advance the specification to a
level where the RG is eventually happy to publish it as an Experimental RFC.
>
> It is important to understand that adopting an Internet Draft in an
IRTF RG is something different to adopting a draft in an IETF WG (that
is chartered to do normative specifications). Adopting the format
specification MUST NOT be taken as an indication of present or future
standardization (in the sense of IETF standards track documents).
>
> Adopting a format also comes with expectations on the mode of
operation for future work on the format. When we adopt a specification,
we also transfer change control from the previous set of authors to the
RG, i.e., the document becomes an RG document, and the authors advance
and maintain it on behalf of the RG.
>
> We would also expect that future changes to the specification would
> be
reflected in implementations, including but not limited to PARC's CCNx
implementation.
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 29 May 2015 15:34:28 +0000

Yes.

--
Cheers,
Dirk

> Am 29.05.2015 um 17:25 schrieb Mark Stapp <[email-masked]>:
> 
> So just to clarify: you're adopting the two ccnx drafts you referred to as icnrg documents? will you be asking the authors to submit rg versions?
> 
> Thanks,
> Mark
>