Subject: [icnrg] ICN Layers Responsibilities

From: Boubakr NOUR <[email-masked]>
Date: Mon, 10 Apr 2017 13:07:39 +0800

Hello,

Talking about OSI and NDN Protocol stacks, and based on the attached 
figure (please, check the attached file), can we say that the Transport 
Layer in OSI has been changed by Security Layer in NDN, and Session 
Layer in OSI by Streaming Layer and so on. The same thing with other 
layer, such as Data Link has been changed to Strategies Layer. Or 
Application Layer on NDN represents all of Transport, Session and 
Application Layers in OSI model?

I’m little confusing in this point, the exact layers in NDN/ICN, more 
specifically NDN layers responsibilities.

Best regards,

---

From: Lixia Zhang <[email-masked]>
Date: Sun, 9 Apr 2017 22:23:46 -0700

> On Apr 9, 2017, at 10:07 PM, Boubakr NOUR <[email-masked]> wrote:
> 
> 
> 
> Hello,
> 
> Talking about OSI and NDN Protocol stacks, and based on the attached figure (please, check the attached file), can we say that the Transport Layer in OSI has been changed by Security Layer in NDN, and Session Layer in OSI by Streaming Layer and so on. The same thing with other layer, such as Data Link has been changed to Strategies Layer. Or Application Layer on NDN represents all of Transport, Session and Application Layers in OSI model?
> 
> I’m little confusing in this point, the exact layers in NDN/ICN, more specifically NDN layers responsibilities.
> 
since I just answered your exact same question on another mailing list:

From: Lixia Zhang <[email-masked]>
Subject: Re: [Ndn-interest] NDN Layers responsibilities
Date: April 9, 2017 at 10:18:05 PM PDT
To: Boubakr NOUR <[email-masked]>
Cc: ndn-interest <[email-masked]>

> On Apr 9, 2017, at 10:04 PM, Boubakr NOUR <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
> Hello,
> 
> Talking about OSI and NDN Protocol stacks, and based on the attached figure (please, check the attached file), can we say that the Transport Layer in OSI has been changed by Security Layer in NDN, and Session Layer in OSI by Streaming Layer and so on. The same thing with other layer, such as Data Link has been changed to Strategies Layer. Or Application Layer on NDN represents all of Transport, Session and Application Layers in OSI model?
> 
> I’m little confusing in this point, the exact layers in NDN/ICN, more specifically NDN layers responsibilities.
> 
wonder if you’ve read the NDN Tech Report001?
https://named-data.net/wp-content/uploads/TR001ndn-proj.pdf <https://named-data.net/wp-content/uploads/TR001ndn-proj.pdf>

I believe "Section 2 Architecture" in that report answers your above questions.

Lixia