Subject: [icnrg] FW: New Version Notification for draft-rahman-icnrg-deployment-guidelines-01.txt

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 18 May 2017 16:44:15 +0000

Dear Chairs (and RG members),

We have made a major update of the draft to address most of the comments received at the Chicago F2F meeting.  Among the updates are:

1)      Changed the title from “Deployment Configurations …” to “Deployment Considerations …”, and expanded the Abstract

2)      Updated the Deployment Trial Experiences (section 5)
       • Grouping them clearly as Overlay or Underlay
       • Adding new ICN2020 effort
       • Streamlining the text and making it more consistent

3)      Added reference to 5G-ICN paper that Ravi had suggested (section 3.4), and clarifying that ICN is not creating the 5G slice but simply running inside it

4)      Added reference to the TCP/IP to TCP/ICN paper that Dave Oran had suggested (section 4.1)

5)      Updated the Further Standardization effort (section 6) to clarify that the references to multiple BoFs, did not necessarily imply separate BoFs but that it could also be one consolidated BoF.  Also, clarified that the details of the protocol specification efforts will have to be done in the future by the appropriate WGs and/or BoFs (section 6&7)

6)      Added the Security Considerations (section 9)

7)      Expanded the Conclusions (section 7) to summarize the key considerations (i.e. configurations, migration paths) in addition to identifying the required new IETF standardization effort

Any feedback (from either the Chairs or RG members) would be much appreciated and we will try to address those comments in another update before Prague if required.

Best Regards,

Akbar

<http://ir.interdigital.com/File/Index?KeyFile=37447876>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 18, 2017 12:41 PM
To: Dirk Kutscher <[email-masked]>; Trossen, Dirk <[email-masked]>; Rahman, Akbar <[email-masked]>; Trossen, Dirk <[email-masked]>
Subject: New Version Notification for draft-rahman-icnrg-deployment-guidelines-01.txt

A new version of I-D, draft-rahman-icnrg-deployment-guidelines-01.txt
has been successfully submitted by Akbar Rahman and posted to the IETF repository.

Name:           draft-rahman-icnrg-deployment-guidelines
Revision:       01
Title:          Deployment Considerations for Information-Centric Networking (ICN)
Document date:  2017-05-18
Group:          Individual Submission
Pages:          19
URL:            https://www.ietf.org/internet-drafts/draft-rahman-icnrg-deployment-guidelines-01.txt
Status:         https://datatracker.ietf.org/doc/draft-rahman-icnrg-deployment-guidelines/
Htmlized:       https://tools.ietf.org/html/draft-rahman-icnrg-deployment-guidelines-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-rahman-icnrg-deployment-guidelines-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-rahman-icnrg-deployment-guidelines-01

Abstract:
  Information-Centric Networking (ICN) is now reaching technological
  maturity after many years of fundamental research and
  experimentation.  This document provides a number of deployment
  considerations in the interest of helping the ICN community move
  forward to the next step of live deployments.  The major deployment
  configurations for ICN are first described including the main overlay
  and underlay approaches.  Then proposed deployment migration paths
  are outlined to address major practical issues such as network and
  application migration.  Next, selected ICN trial experiences are
  summarized.  Finally, protocol areas that require further
  standardization are identified to facilitate future interoperable ICN
  deployments.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Ravi Ravindran <[email-masked]>
Date: Mon, 22 May 2017 20:06:54 +0000

This is the paper Akbar's email is referring to:

" 5G-ICN: Delivering ICN Services over 5G Using Network Slicing", that appeared in this month's IEEE Communication Magazine. The paper takes a service-centric view of ICN. We also discuss deployment models over a LTE framework, but the discussion is also applicable to 5G architecture discussion currently underway in 3GPP SA2 WG, where network function definitions are more generalized.

Regards,
Ravi

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Thursday, May 18, 2017 9:44 AM
To: icnrg <[email-masked]>
Subject: [icnrg] FW: New Version Notification for draft-rahman-icnrg-deployment-guidelines-01.txt

1)      Changed the title from "Deployment Configurations ..." to "Deployment Considerations ...", and expanded the Abstract

2)      Updated the Deployment Trial Experiences (section 5)
       * Grouping them clearly as Overlay or Underlay
       * Adding new ICN2020 effort
       * Streamlining the text and making it more consistent

Best Regards,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 18, 2017 12:41 PM
To: Dirk Kutscher <[email-masked]>; Trossen, Dirk <[email-masked]>; Rahman, Akbar <[email-masked]>; Trossen, Dirk <[email-masked]>
Subject: New Version Notification for draft-rahman-icnrg-deployment-guidelines-01.txt

Abstract:

The IETF Secretariat