Subject: Re: [icnrg] Review of ICN Terminology document (draft-wissingh-icnrg-terminology-01)

From: "David Oran" <[email-masked]>
Date: Wed, 24 May 2017 13:08:39 -0400

I was starting to review a couple of ICNRG current drafts, and saw that 
the term “location” is used a lot, partly to distinguish ICN from 
host-centric designs that name things based on their “location”.

I then peeked into the terminology draft and didn’t find a definition 
of “location”. While adding this might re-open some tricky 
conversations about topologically-sensitive names, name resolution 
between “location independent” and “location dependent” names 
etc. I think we are on balance better off by having an agreed definition 
of “location” in the context of ICN than waffling and not defining 
it.

What do folks think?

DaveO

---

From: Ravi Ravindran <[email-masked]>
Date: Wed, 24 May 2017 21:52:24 +0000

When we proposed forwarding labels for Interest packets, there was a push back on using the terms ID/Locator, hence we submitted this draft where we use the terms "Application Identifier and "Network Identifier", so another term if we don’t want to use the locator terminology, the draft itself focusses on the motivation on the need for network identifiers.

https://tools.ietf.org/html/draft-azgin-icnrg-ni-00

Towards the terminology draft, I had suggested to include this (NI or Locators) term during the offline group meeting at the last IETF meeting, but there were no supporters for this.

Regards,
Ravi

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of David Oran
Sent: Wednesday, May 24, 2017 10:09 AM
To: Wissingh, B.F. <[email-masked]>
Cc: [email-masked]
Subject: Re: [icnrg] Review of ICN Terminology document (draft-wissingh-icnrg-terminology-01)

I was starting to review a couple of ICNRG current drafts, and saw that the term “location” is used a lot, partly to distinguish ICN from host-centric designs that name things based on their “location”.

I then peeked into the terminology draft and didn’t find a definition of “location”. While adding this might re-open some tricky conversations about topologically-sensitive names, name resolution between “location independent” and “location dependent” names etc. I think we are on balance better off by having an agreed definition of “location” in the context of ICN than waffling and not defining it.

What do folks think?

DaveO

---

From: David Oran <[email-masked]>
Date: Wed, 24 May 2017 17:56:16 -0400

Read carefully - I said "location" not "locator". Things may or may not have locations independent of whether you decide to assign architectural or protocol constructs like a "locator" to them.

___________________________
iDevice - please excuse typos.

> On May 24, 2017, at 5:52 PM, Ravi Ravindran <[email-masked]> wrote:
>

---

From: Ravi Ravindran <[email-masked]>
Date: Wed, 24 May 2017 22:09:35 +0000

Sorry, didn’t realize it was "location", and not "locator". Sure I would support to define "location", and also clarify what "location dependent" and "location independent" naming means.

Also I would also support to define something to cover "locators" names in the draft as well, we have at least two proposals here, forwarding-labels and link objects which serves the same purpose.

Regards,
Ravi