Subject: [Id-event] Thread - Should Primary Event Be a Separate Attribute (regarding secevent-token-00)

From: Phil Hunt <[email-masked]>
Date: Wed, 1 Mar 2017 10:28:54 -0800

All,

Yaron asked me to go over all of the items marked “Thread” in the following email: https://mailarchive.ietf.org/arch/msg/id-event/u99clKDCPTrqEkOxvJpd402jXjY <https://mailarchive.ietf.org/arch/msg/id-event/u99clKDCPTrqEkOxvJpd402jXjY>

This is the first of several threads:  Should Primary Event Be a Separate Attribute

On this topic, following Yaron’s comments Mike Jones raised some points that there should be no distinction between primary events and extensions (https://mailarchive.ietf.org/arch/msg/id-event/0Hhg46ROcidQDLL7OnXUs88TJ9U <https://mailarchive.ietf.org/arch/msg/id-event/0Hhg46ROcidQDLL7OnXUs88TJ9U>).  Summarizing:
* Processors will run through all of them regardless. It is not necessarily helpful to understand which is a primary vs. extension
* Let’s drop distinction between primary vs. extension. You can simply express one or more sets of event attributes in a single JWT

My proposal is to drop this terminology in the text and keep the attribute multi-valued. The purpose of the attribute is to inform the reader what events are being asserted and what additional data may be present. It is up to the reader to ultimately infer meaning when one or more URIs are present.  Further, when multiple URIs are present it must still to make a combined statement about a single state change about a subject. It must not be used to convey multiple distinct (e.g. transactions) events about a subject.

Assuming everyone agrees, I will plan to remove these distinctions in the next update with some new text. Please comment if you have concerns.
Phil

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

---

From: Mike Jones <[email-masked]>
Date: Wed, 1 Mar 2017 18:35:33 +0000

I believe we already had consensus to drop the primary/secondary distinction, which we intentionally did before adoption of the working group draft.  I believe any such distinction will both be unhelpful and result in syntactic complexity.  Please let’s finish stamping out the notion that any of the events in a SET are somehow different than the others.

                                                                -- Mike

From: Id-event [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Wednesday, March 1, 2017 10:29 AM
To: ID Events Mailing List <[email-masked]>
Subject: [Id-event] Thread - Should Primary Event Be a Separate Attribute (regarding secevent-token-00)

All,

Yaron asked me to go over all of the items marked “Thread” in the following email: https://mailarchive.ietf.org/arch/msg/id-event/u99clKDCPTrqEkOxvJpd402jXjY

On this topic, following Yaron’s comments Mike Jones raised some points that there should be no distinction between primary events and extensions (https://mailarchive.ietf.org/arch/msg/id-event/0Hhg46ROcidQDLL7OnXUs88TJ9U).  Summarizing:
* Processors will run through all of them regardless. It is not necessarily helpful to understand which is a primary vs. extension
* Let’s drop distinction between primary vs. extension. You can simply express one or more sets of event attributes in a single JWT

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: William Denniss <[email-masked]>
Date: Wed, 1 Mar 2017 11:22:36 -0800

I agree with your proposal.

They're all just events. Up to implementors to define & categorize their
events how they like.

On Wed, Mar 1, 2017 at 10:28 AM, Phil Hunt <[email-masked]> wrote:

> All,
>
> Yaron asked me to go over all of the items marked “Thread” in the
> following email: https://mailarchive.ietf.org/arch/msg/id-event/
> u99clKDCPTrqEkOxvJpd402jXjY
>
> On this topic, following Yaron’s comments Mike Jones raised some points
> that there should be no distinction between primary events and extensions (
> https://mailarchive.ietf.org/arch/msg/id-event/0Hhg46ROcidQDLL7OnXUs88TJ9U).
> Summarizing:
> * Processors will run through all of them regardless. It is not
> necessarily helpful to understand which is a primary vs. extension
> * Let’s drop distinction between primary vs. extension. You can simply
> express one or more sets of event attributes in a single JWT
>
> My proposal is to drop this terminology in the text and keep the attribute
> multi-valued. The purpose of the attribute is to inform the reader what
> events are being asserted and what additional data may be present. It is up
> to the reader to ultimately infer meaning when one or more URIs are
> present.  Further, when multiple URIs are present it must still to make a
> combined statement about a single state change about a subject. It must not
> be used to convey multiple distinct (e.g. transactions) events about a
> subject.
>
> Assuming everyone agrees, I will plan to remove these distinctions in the
> next update with some new text. Please comment if you have concerns.
> Phil
>
> www.independentid.com
> [email-masked]
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 1 Mar 2017 11:43:11 -0800

Thanks Mike and William. Good to know.

All…please chime in.  I will plan to remove the primary vs. extension text.

Regarding Mike’s comment. When I looked through my records, it was some offline discussion at OpenID and elsewhere and the “consensus” was not actually formally part of the list.

Note also:  the draft submission deadline is Mar 13 for Chicago.  I don’t think we will get through all of these threads by then.  I am focusing on the distribution draft re-write for then. Either way, we should have a lot teed up for Chicago.

Phil

> On Mar 1, 2017, at 11:22 AM, William Denniss <[email-masked]> wrote:
> 
> They're all just events. Up to implementors to define & categorize their events how they like.
> 
> On Wed, Mar 1, 2017 at 10:28 AM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/id-event <https://www.ietf.org/mailman/listinfo/id-event>
> 
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 1 Mar 2017 19:50:02 +0000

I’m willing to propose edits to finish removing the primary/secondary distinction from the SET spec before the submission deadline so that you can continue to focus on the distribution spec.  I think that removing the distinction will help us have a more focused discussion in Chicago, since that confusing language will be behind us.

                                                                -- Mike

From: Id-event [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Wednesday, March 1, 2017 11:43 AM
To: William Denniss <[email-masked]>
Cc: ID Events Mailing List <[email-masked]>
Subject: Re: [Id-event] Thread - Should Primary Event Be a Separate Attribute (regarding secevent-token-00)

Phil

On Mar 1, 2017, at 11:22 AM, William Denniss <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, Mar 1, 2017 at 10:28 AM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
All,

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: Phil Hunt <[email-masked]>
Date: Wed, 1 Mar 2017 11:52:00 -0800

Thanks Mike,

Let’s give it another day in case someone has a strong opinion.

Phil

> On Mar 1, 2017, at 11:50 AM, Mike Jones <[email-masked]> wrote:
> 
> www.independentid.com <http://www.independentid.com/>
> [email-masked] <mailto:[email-masked]>
>  
>  
>  
>  
>  
> 
>  
> On Mar 1, 2017, at 11:22 AM, William Denniss <[email-masked] <mailto:[email-masked]>> wrote:
>  
> www.independentid.com <http://www.independentid.com/>
> [email-masked] <mailto:[email-masked]>
>  
>  
>  
>  
>  
> 
>  
>

---

From: Marius Scurtescu <[email-masked]>
Date: Wed, 1 Mar 2017 15:43:25 -0800

I also think it makes sense to remove the primary/secondary distinction.

Marius

On Wed, Mar 1, 2017 at 11:52 AM, Phil Hunt <[email-masked]> wrote:

> I’m willing to propose edits to finish removing the primary/secondary
> distinction from the SET spec before the submission deadline so that you
> can continue to focus on the distribution spec.  I think that removing the
> distinction will help us have a more focused discussion in Chicago, since
> that confusing language will be behind us.
>
>                                                                 -- Mike
>
> *From:* Id-event [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Phil Hunt
> *Sent:* Wednesday, March 1, 2017 11:43 AM
> *To:* William Denniss <[email-masked]>
> *Cc:* ID Events Mailing List <[email-masked]>
> *Subject:* Re: [Id-event] Thread - Should Primary Event Be a Separate
> Attribute (regarding secevent-token-00)
>
> Regarding Mike’s comment. When I looked through my records, it was some
> offline discussion at OpenID and elsewhere and the “consensus” was not
> actually formally part of the list.
>
> Note also:  the draft submission deadline is Mar 13 for Chicago.  I don’t
> think we will get through all of these threads by then.  I am focusing on
> the distribution draft re-write for then. Either way, we should have a lot
> teed up for Chicago.
>
> Phil
>

---

From: Justin Richer <[email-masked]>
Date: Sat, 4 Mar 2017 17:56:36 -0500

+1, drop "primary" and keep it an object

  -- Justin

On 3/1/2017 1:28 PM, Phil Hunt wrote:
> following email: 
> https://mailarchive.ietf.org/arch/msg/id-event/u99clKDCPTrqEkOxvJpd402jXjY
>
> On this topic, following Yaron’s comments Mike Jones raised some 
> points that there should be no distinction between primary events and 
> extensions 
> (https://mailarchive.ietf.org/arch/msg/id-event/0Hhg46ROcidQDLL7OnXUs88TJ9U). 
>  Summarizing:
> My proposal is to drop this terminology in the text and keep the 
> attribute multi-valued. The purpose of the attribute is to inform the 
> reader what events are being asserted and what additional data may be 
> present. It is up to the reader to ultimately infer meaning when one 
> or more URIs are present.  Further, when multiple URIs are present it 
> must still to make a combined statement about a single state change 
> about a subject. It must not be used to convey multiple distinct (e.g. 
> transactions) events about a subject.
>
> Assuming everyone agrees, I will plan to remove these distinctions in 
> the next update with some new text. Please comment if you have concerns.
> Phil
>
> www.independentid.com <http://www.independentid.com>