Subject: [Id-event] Fwd: New Version Notification for draft-hunt-secevent-stream-mgmt-00.txt

From: Phil Hunt <[email-masked]>
Date: Sun, 29 Oct 2017 22:54:44 -0700

As requested, the Control Plane API draft that was originally part of draft-hunt-secevent-distribution has been broken out as a separate draft below.

This draft includes sections from the distribution draft plus extensive addition of examples showing different ways profilers, implementers and deployers can manage subjects depending on their requirements. The spec provides significant discussion on extensibility for profiling drafts and the extension of Stream configuration to support new delivery methods. The intention is to demonstrate how the proposal supports all of the published use cases from SCIM (draft-hunt-secevent-usecases) and RISC (draft-scurtescu-secevents-risc-use-cases.

While the draft is somewhat long, the amount of normative language is minimal (as this is a profile of SCIM). The bulk of this document is taken up in about 35 figures showing simple examples of how to use the Control Plane, along with schema and data definitions required for SEC EVENT Streams.

This draft is an alternative proposal to draft-scurtescu-secevent-event-stream-mgmt-api published for discussion at IETF100.

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-hunt-secevent-stream-mgmt-00.txt
> Date: October 29, 2017 at 10:41:43 PM PDT
> To: "Phil Hunt" <[email-masked]>
> 
> 
> A new version of I-D, draft-hunt-secevent-stream-mgmt-00.txt
> has been successfully submitted by Phil Hunt and posted to the
> IETF repository.
> 
> Name:		draft-hunt-secevent-stream-mgmt
> Revision:	00
> Title:		SET Security Event Stream Management and Provisioning
> Document date:	2017-10-29
> Group:		Individual Submission
> Pages:		48
> URL:            https://www.ietf.org/internet-drafts/draft-hunt-secevent-stream-mgmt-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-hunt-secevent-stream-mgmt/
> Htmlized:       https://tools.ietf.org/html/draft-hunt-secevent-stream-mgmt-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-hunt-secevent-stream-mgmt-00
> 
> 
> Abstract:
>   This specification defines a "control plane" service which enables a
>   client (e.g. an Event Receiver) to establish, monitor, and manage a
>   Security Event Token Stream.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 30 Oct 2017 05:59:15 +0000

Thanks Phil

On Sun, Oct 29, 2017 at 10:54 PM Phil Hunt <[email-masked]> wrote:

> As requested, the Control Plane API draft that was originally part of
> draft-hunt-secevent-distribution has been broken out as a separate draft
> below.
>
> This draft includes sections from the distribution draft plus extensive
> addition of examples showing different ways profilers, implementers and
> deployers can manage subjects depending on their requirements. The spec
> provides significant discussion on extensibility for profiling drafts and
> the extension of Stream configuration to support new delivery methods. The
> intention is to demonstrate how the proposal supports all of the published
> use cases from SCIM (draft-hunt-secevent-usecases) and RISC
> (draft-scurtescu-secevents-risc-use-cases.
>
> While the draft is somewhat long, the amount of normative language is
> minimal (as this is a profile of SCIM). The bulk of this document is taken
> up in about 35 figures showing simple examples of how to use the Control
> Plane, along with schema and data definitions required for SEC EVENT
> Streams.
>
> This draft is an alternative proposal to
> draft-scurtescu-secevent-event-stream-mgmt-api published for discussion at
> IETF100.
>
> Phil
>
> www.independentid.com
> [email-masked]
> *From: [email-masked]
> *Subject: **New Version Notification for
> draft-hunt-secevent-stream-mgmt-00.txt*
> *Date: *October 29, 2017 at 10:41:43 PM PDT
> *To: *"Phil Hunt" <[email-masked]>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-hunt-secevent-stream-mgmt-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-hunt-secevent-stream-mgmt/
> Htmlized:
> https://tools.ietf.org/html/draft-hunt-secevent-stream-mgmt-00
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-hunt-secevent-stream-mgmt-00
>
>
> Abstract:
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!