Subject: [Id-event] I-D Action: draft-ietf-secevent-token-03.txt

From: [email-masked]
Date: Thu, 26 Oct 2017 17:27:31 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Security Events WG of the IETF.

        Title           : Security Event Token (SET)
        Authors         : Phil Hunt
                          William Denniss
                          Morteza Ansari
                          Michael B. Jones
	Filename        : draft-ietf-secevent-token-03.txt
	Pages           : 24
	Date            : 2017-10-26

Abstract:
   This specification defines the Security Event Token, which may be
   distributed via a protocol such as HTTP.  The Security Event Token
   (SET) specification profiles the JSON Web Token (JWT), which can be
   optionally signed and/or encrypted.  A SET describes a statement of
   fact from the perspective of an issuer that it intends to share with
   one or more receivers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-secevent-token/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-secevent-token-03
https://datatracker.ietf.org/doc/html/draft-ietf-secevent-token-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-token-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Phil Hunt <[email-masked]>
Date: Thu, 26 Oct 2017 17:32:24 -0700

This draft  incorporates feedback from comments and discussion since the WGLC.

* Corrected subscriber to Event Receiver
* Removed “nbf” claim
* Introduced “toe” or time of event
* Figure 3 moved “sub” to event payload in figure
* Clarified use of nonce when differentiating from JWTs
* Editorial improvements and clarifications

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>
> On Oct 26, 2017, at 5:27 PM, [email-masked] wrote:
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=13DdZOaFgaD-HGP2pOCNkOpTyRnnTGRb7VnJexYAGCc&e= 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dsecevent-2Dtoken-2D03&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=BksQtIbBnjpETfC7vLs92O1B3-ZnlZQlMCrUBG8QbCA&e= 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dsecevent-2Dtoken-2D03&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=VpIQD9_-bNURLCQCxp-hVvXMul6YgqSO8Nxw1X1KHbg&e= 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dsecevent-2Dtoken-2D03&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=aydXxUYGSvtw1dd4n39uYsU-QKVu9lBPPVYxIy2UjiU&e= 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=mUk0Dul3biGp6ditTT_cLwjqiqu1kyHHgYP2i8K5ymU&e= 
> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=iE3v6CSLR7pkOg7J2eBLwuzxpnZwAfRFFI_QfqXJZy8&s=ZNG7JDnbqH3z0vVbAlHsaF8rHDSCPzG-IUK3uQDwNME&e=