Subject: [Id-event] IETF 100 draft agenda

From: Dick Hardt <[email-masked]>
Date: Mon, 30 Oct 2017 14:09:02 -0700

Here is the draft agenda. Mike, Phil, Marius, Annabelle - please let me
know who is presenting what where it is xxx

Thanks!

Here are the documents we will be discussing:

https://datatracker.ietf.org/doc/draft-ietf-secevent-delivery/
https://datatracker.ietf.org/doc/draft-ietf-secevent-token/
https://datatracker.ietf.org/doc/draft-scurtescu-secevent-event-stream-mgmt-api/
https://datatracker.ietf.org/doc/draft-hunt-secevent-stream-mgmt/

/Dick

-----
IETF 100 Singapore
Bras Basah Monday Nov 13, 2017, 13:30 - 15:30

Agenda Setting                          Dick Hardt (chair)        13:30 -
13:40
Security Event Token (SET)              xxx                       13:40 -
14:00
SET Delivery using HTTP                 xxx                       14:00 -
14:20
Chair Slides on Managment APIs          Dick Hardt (chair)        14:20 -
14:30
Management API for SET Event Streams    xxx                       14:30 -
14:50
SET Stream Managment and Provisioning   Phil Hunt                 14:50 -
15:10
Management API Discussion               Dick Hardt (chair)        15:10 -
15:20
AOB                                     Dick Hardt (chair)        15:20 -
15:30

---

From: Dick Hardt <[email-masked]>
Date: Mon, 30 Oct 2017 14:25:53 -0700

resending with fixed width formating for agenda for easier reading. :)

-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Mon, 30 Oct 2017 14:32:40 -0700

Dick,

I believe Mike won't be able to make the monday meeting. so Mike and I are working on a presentation for the current state of set that I will do. 

Not much has happened with delivery other than removing verify event (because that was going in control plane). I can do that very quickly. 

I do have concerns about config on control planes and delivery streams when firewalls are involved. I will include a couple of slides on this that may be important to control plane discussion. 

I can do my control plane ID draft proposal after marius/annabelle's. It will be similar to the deck we discussed at the amazon hq f2f. 

Phil

> On Oct 30, 2017, at 2:09 PM, Dick Hardt <[email-masked]> wrote:
> 
> Here is the draft agenda. Mike, Phil, Marius, Annabelle - please let me know who is presenting what where it is xxx
> 
> Thanks!
> 
> Agenda Setting                          Dick Hardt (chair)        13:30 - 13:40
> Security Event Token (SET)              xxx                       13:40 - 14:00   
> SET Delivery using HTTP                 xxx                       14:00 - 14:20 
> Chair Slides on Managment APIs          Dick Hardt (chair)        14:20 - 14:30
> Management API for SET Event Streams    xxx                       14:30 - 14:50 
> SET Stream Managment and Provisioning   Phil Hunt                 14:50 - 15:10    
> Management API Discussion               Dick Hardt (chair)        15:10 - 15:20
> AOB                                     Dick Hardt (chair)        15:20 - 15:30
> 
> 
>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 30 Oct 2017 14:39:38 -0700

Hey Phil, Thanks! I'll slot you in for the SET slot. Let's see if one of
the other authors will do the Delivery.

On Mon, Oct 30, 2017 at 2:32 PM, Phil Hunt (IDM) <[email-masked]>
wrote:

> Dick,
>
> I believe Mike won't be able to make the monday meeting. so Mike and I are
> working on a presentation for the current state of set that I will do.
>
> Not much has happened with delivery other than removing verify event
> (because that was going in control plane). I can do that very quickly.
>
> I do have concerns about config on control planes and delivery streams
> when firewalls are involved. I will include a couple of slides on this that
> may be important to control plane discussion.
>
> I can do my control plane ID draft proposal after marius/annabelle's. It
> will be similar to the deck we discussed at the amazon hq f2f.
>
> Phil
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Ddelivery_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=Uluwi3dKSdNUwdiLtSP9giOhZid7jXJ9EYVbh2QL6vs&s=X8effseMjaVrorik11cxrRI-bs3SnJC8dZrtyE_Frzc&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=Uluwi3dKSdNUwdiLtSP9giOhZid7jXJ9EYVbh2QL6vs&s=Bhsx1KCP0LaIZS2Ds3UTMnMSAoCVbo24WpxlSgTwW3M&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dscurtescu-2Dsecevent-2Devent-2Dstream-2Dmgmt-2Dapi_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=Uluwi3dKSdNUwdiLtSP9giOhZid7jXJ9EYVbh2QL6vs&s=mcaEERiRwA93hAlqRNn-7upsprLemACARBfCG88a_KY&e=>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dhunt-2Dsecevent-2Dstream-2Dmgmt_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=Uluwi3dKSdNUwdiLtSP9giOhZid7jXJ9EYVbh2QL6vs&s=bqT3s9Srdn6iMJDjWvSk_nZL7qud6yrBD6LH5Qr09cA&e=>
>
> /Dick
>
> -----
> IETF 100 Singapore

---

From: Adam Dawes <[email-masked]>
Date: Tue, 31 Oct 2017 00:20:57 -0700

Thanks for sending out the agenda.

>From our perspective, there are two important issues that are blocking
implementation and I think it would be very helpful to shift the agenda a
bit so we have more time to discuss these. It would be very beneficial to
implementors if we could resolve these issues so we can finish our services
and start to receive operational feedback on the specs.

   - Management API resolution. We have two approaches (Phil's
   <https://tools.ietf.org/html/draft-hunt-secevent-stream-mgmt-00>  and
   Marius/Annabelle's
   <https://datatracker.ietf.org/doc/draft-scurtescu-secevent-event-stream-mgmt-api/>).
   The management API is the key to being able to scale our implementation and
   start interop with multiple providers. Perhaps Phil and Marius/Annabelle
   can each provide a summary of their drafts and we can have try to reach
   consensus.
   - Single/multiple event per SET
   This is currently being discussed on list and within RISC working group.
   It would be helpful to also nail this down to free up our engineers to
   build this right the first time instead of making a guessing and having the
   community later choose differently.

In addition, but less critically, we'd like to propose the following topics
too:

   - "toe" SET attribute
   - authorization header for push delivery
      - receiver configures full authorization header as static/bearer
      header
   - composite subject claim defined in SET
      - present RISC approach as example

On Mon, Oct 30, 2017 at 2:39 PM, Dick Hardt <[email-masked]> wrote:

>> I believe Mike won't be able to make the monday meeting. so Mike and I
>> are working on a presentation for the current state of set that I will do.
>>
> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn
> about projects I am working on!
>
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
>

-- 
Adam Dawes | Sr. Product Manager | [email-masked] | +1 650-214-2410

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 31 Oct 2017 09:21:08 -0700

For
https://datatracker.ietf.org/doc/draft-scurtescu-secevent-event-stream-mgmt-api/
Annabelle and I are proposing a two part presentation: I will present the
current draft and changes since Prague, Annabelle will then present a
concrete example of profiling this management API spec in RISC.

The delta on the delivery spec is relatively small, I am happy to present
that as well.

Marius

---

From: Dick Hardt <[email-masked]>
Date: Tue, 31 Oct 2017 21:22:02 -0700

Hi Adam

Thanks for raising these points. I think all of them will be covered in the
agenda, but I will clarify where they will be covered.

The agenda is set up for both management APIs to be presented, and then I
have a slot for the WG to discuss how to proceed.
I expect the issues wrt. the SET document will be addressed in the time
allotted for SET, similarly for the "toe" attribute.
The authorization header I would expect to be covered in the SET Delivery
time slot.

wrt. composite object, that also should be discussed in the SET time slot
-- I think the proposal is that subjects NOT be in SET, and that each
profile defines how subjects are represented.

Phil: would you confirm you will be covering these topics in your slot on
SET?

Marius: same for the authorization header in the Delivery discussion?

/Dick

On Tue, Oct 31, 2017 at 12:20 AM, Adam Dawes <[email-masked]> wrote:

>    This is currently being discussed on list and within RISC working
>    group. It would be helpful to also nail this down to free up our engineers
>    to build this right the first time instead of making a guessing and having
>    the community later choose differently.
>
> In addition, but less critically, we'd like to propose the following
> topics too:
>
>    - "toe" SET attribute
> <(650)%20214-2410>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 31 Oct 2017 21:23:02 -0700

Thanks Marius. I've updated the agenda to reflect above. Also please note
the authorization header discussion brought up by Adam in my previous email.

On Tue, Oct 31, 2017 at 9:21 AM, Marius Scurtescu <[email-masked]>
wrote:

> For https://datatracker.ietf.org/doc/draft-scurtescu-
> secevent-event-stream-mgmt-api/ Annabelle and I are proposing a two part
> presentation: I will present the current draft and changes since Prague,
> Annabelle will then present a concrete example of profiling this management
> API spec in RISC.
>

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 31 Oct 2017 23:04:01 -0700

> the authorization header discussion brought up by Adam in my previous email.

Yes, I will cover the authorization header.

>> For https://datatracker.ietf.org/doc/draft-scurtescu-seceven
>> t-event-stream-mgmt-api/ Annabelle and I are proposing a two part
>>>> I can do my control plane ID draft proposal after marius/annabelle's.
>>>> It will be similar to the deck we discussed at the amazon hq f2f.
>>>>
>>>> Phil
>>>>