Subject: Re: [Id-event] SecEvent WG last calls

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tue, 1 Oct 2019 15:59:05 +0000

I would similarly like to understand this decision considering there are multiple documents still in flight.

--
Annabelle Richard Backman
AWS Identity

From: Id-event <[email-masked]> on behalf of Marius Scurtescu <marius.scurtescu=[email-masked]>
Date: Friday, September 6, 2019 at 9:14 AM
To: Yaron Sheffer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Id-event] SecEvent WG last calls

Why is the WG wrapping up?

Anything we can still do to keep Subject ID in the WG?

On Fri, Sep 6, 2019 at 6:13 AM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
We concluded last call for the Poll and the Subject ID drafts.

The working group supported publication of the Poll draft. Authors, please address the comments that were raised in the last call, republish and we will request publication.

There was insufficient support for the Subject ID draft. We are planning to wrap up the WG as soon as we push the Poll draft to the IESG, and so the chairs will work with the authors of the Subject ID draft and with the AD to publish the draft outside of the WG.

Thanks,
                Yaron

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 06 Oct 2019 18:22:13 +0300

Hi Marius, Annabelle,

Once we have published the Poll document, the WG would have achieved its goal of standardizing a format and protocol(s) for event transmission. We polled the group and there is no interest/energy in follow-up work, so there’s no value in keeping the group open. Please note that the mailing list will remain available, as is common at the IETF for closed working groups.

We are not closing the WG immediately. We are only proposing to wrap up once the Poll document has been handed to the IESG. And personally I can be convinced to delay closure until the docs have gone through IETF last call and IESG review.

Thanks,

                Yaron

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tuesday, 1 October 2019 at 19:00
To: Marius Scurtescu <marius.scurtescu=[email-masked]>, Yaron Sheffer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Id-event] SecEvent WG last calls

-- 

AWS Identity

On Fri, Sep 6, 2019 at 6:13 AM Yaron Sheffer <[email-masked]> wrote:

Thanks,

                Yaron

[email-masked]

---

From: Mike Jones <[email-masked]>
Date: Tue, 8 Oct 2019 15:39:15 +0000

Per my note on the WGLC thread, I would like to see the WG continue the subject identifiers work until it is published as an RFC.  It’s an important piece in making the SecEvents work broadly useful.  There was additional interest in it expressed by those working on the new Continuous Access Evaluation Protocol (CAEP) last week during IIW.  That will be a new use case for the document.

I would also advocate keeping the working group open until all the working group drafts have been published as RFCs.

                                                       -- Mike

From: Id-event <[email-masked]> On Behalf Of Yaron Sheffer
Sent: Sunday, October 6, 2019 8:22 AM
To: Richard Backman, Annabelle <[email-masked]>; Marius Scurtescu <marius.scurtescu=[email-masked]>
Cc: [email-masked]
Subject: Re: [Id-event] SecEvent WG last calls

Hi Marius, Annabelle,

Thanks,
                Yaron

From: "Richard Backman, Annabelle" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 1 October 2019 at 19:00
To: Marius Scurtescu <marius.scurtescu=[email-masked]<mailto:marius.scurtescu=[email-masked]>>, Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] SecEvent WG last calls

From: Id-event <[email-masked]<mailto:[email-masked]>> on behalf of Marius Scurtescu <marius.scurtescu=[email-masked]<mailto:marius.scurtescu=[email-masked]>>
Date: Friday, September 6, 2019 at 9:14 AM
To: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] SecEvent WG last calls

Thanks,
                Yaron

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cde1c4971c1c54ec178a808d74a70fed6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C637059721485078910&sdata=foD7S5LUPas3lRJG2YZg%2F%2FZYHU%2F%2Bp1EHWdkZPRPy2oM%3D&reserved=0>

---

From: Adam Dawes <[email-masked]>
Date: Tue, 8 Oct 2019 09:19:59 -0700

+1

Agree with Mike that subject identifier work is very important. Other specs
like RISC need subject identifiers and it will be more useful to have these
defined at IETF than having it defined as part of other specs.

On Tue, Oct 8, 2019 at 8:39 AM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> Per my note on the WGLC thread, I would like to see the WG continue the
> subject identifiers work until it is published as an RFC.  It’s an
> important piece in making the SecEvents work broadly useful.  There was
> additional interest in it expressed by those working on the new Continuous
> Access Evaluation Protocol (CAEP) last week during IIW.  That will be a new
> use case for the document.
>
>
>
> I would also advocate keeping the working group open until all the working
> group drafts have been published as RFCs.
>
>
>
>                                                        -- Mike
>
>
>
> *From:* Id-event <[email-masked]> *On Behalf Of *Yaron Sheffer
> *Sent:* Sunday, October 6, 2019 8:22 AM
> *To:* Richard Backman, Annabelle <[email-masked]>; Marius Scurtescu
> <marius.scurtescu=[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Id-event] SecEvent WG last calls
>
>
>
> Hi Marius, Annabelle,
>
>
>
> Once we have published the Poll document, the WG would have achieved its
> goal of standardizing a format and protocol(s) for event transmission. We
> polled the group and there is no interest/energy in follow-up work, so
> there’s no value in keeping the group open. Please note that the mailing
> list will remain available, as is common at the IETF for closed working
> groups.
>
>
>
> We are not closing the WG immediately. We are only proposing to wrap up
> once the Poll document has been handed to the IESG. And personally I can be
> convinced to delay closure until the docs have gone through IETF last call
> and IESG review.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *"Richard Backman, Annabelle" <[email-masked]>
> *Date: *Tuesday, 1 October 2019 at 19:00
> *To: *Marius Scurtescu <marius.scurtescu=[email-masked]>,
> Yaron Sheffer <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Id-event] SecEvent WG last calls
>
>
>
> *From: *Id-event <[email-masked]> on behalf of Marius
> Scurtescu <marius.scurtescu=[email-masked]>
> *Date: *Friday, September 6, 2019 at 9:14 AM
> *To: *Yaron Sheffer <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Id-event] SecEvent WG last calls
>
>
>
> The working group supported publication of the Poll draft. Authors, please
> address the comments that were raised in the last call, republish and we
> will request publication.
>
>
>
> There was insufficient support for the Subject ID draft. We are planning
> to wrap up the WG as soon as we push the Poll draft to the IESG, and so the
> chairs will work with the authors of the Subject ID draft and with the AD
> to publish the draft outside of the WG.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cde1c4971c1c54ec178a808d74a70fed6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C637059721485078910&sdata=foD7S5LUPas3lRJG2YZg%2F%2FZYHU%2F%2Bp1EHWdkZPRPy2oM%3D&reserved=0>
>

---

From: Phil Idm Hunt <[email-masked]>
Date: Tue, 8 Oct 2019 20:58:57 -0600

+1

Phil

> On Oct 8, 2019, at 10:19 AM, Adam Dawes <adawes=[email-masked]> wrote:
> 
> +1
> 
> Agree with Mike that subject identifier work is very important. Other specs like RISC need subject identifiers and it will be more useful to have these defined at IETF than having it defined as part of other specs.
> 
>> On Tue, Oct 8, 2019 at 8:39 AM Mike Jones <Michael.Jones=[email-masked]> wrote:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=pS4X8c0jgFKlCQescQZzUhzUU35vRt7-ndrmVQNTI6Y&s=TIVeoqMxev_FfSnLq0ou_jNLKqO-T8jj-gZmhDqs81o&e=

---

From: Dick Hardt <[email-masked]>
Date: Wed, 9 Oct 2019 07:46:12 -0700

Yaron and I appreciate the value of the subject identifier work, but that
has not been reflected by the working group.

Only a small minority of those that attend the in-person WG meetings
responded to the subject identifiers draft WG LC, and none of those
responses provided feedback on the draft, which has us question how
carefully the WG reviewed the draft.

It is now October, and the WG LC was in August.

As Yaron stated previously, the chairs will work with the AD and the
authors to publish the draft outside of the WG given the lack of response
from the WG
ᐧ

On Tue, Oct 8, 2019 at 9:20 AM Adam Dawes <adawes=
[email-masked]> wrote:

> +1
>
> Agree with Mike that subject identifier work is very important. Other
> specs like RISC need subject identifiers and it will be more useful to have
> these defined at IETF than having it defined as part of other specs.
>
>> I would also advocate keeping the working group open until all the
>> working group drafts have been published as RFCs.
>>
>>
>>
>>                                                        -- Mike
>>
>>
>>
>> *To:* Richard Backman, Annabelle <[email-masked]
>> <richanna@amazon..com>>; Marius Scurtescu <marius.scurtescu=
>> [email-masked]>
>> *Cc:* [email-masked]
>> The working group supported publication of the Poll draft. Authors,
>> please address the comments that were raised in the last call, republish
>> and we will request publication.
>>
>>
>>

---

From: Dave Tonge <[email-masked]>
Date: Wed, 9 Oct 2019 17:33:51 +0200

I am also keen to see the subject identifiers draft move forward, it has
many useful applications.

Also as an FYI the poll spec is being used by UK OpenBanking:
https://openbanking.atlassian.net/wiki/spaces/WOR/pages/998801568/Event+Notification+API+Specification+-+v4.0-draft7

Dave Tonge
Co-Chair FAPI WG, OIDF