Subject: [Id-event] SSE changes to the Subject Identifiers Spec

From: Atul Tulshibagwale <[email-masked]>
Date: Sun, 12 Jul 2020 19:38:32 -0700

Hi all,
We've made a number of changes to the subject-identifiers spec in the
OpenID "Shared Signals and Events" working group. I have incorporated these
changes in a pull request to the present draft in the repository
https://github.com/richanna/secevent.

Please review the changes here:
https://github.com/richanna/secevent/pull/1

Summary of the changes:

   1. Defined "Subject Principals" as management entities that are
   represented by the subject identifiers
   2. Defined "Subject Principal Administrative Groupings" or SPAGs that
   may be used for certain events that pertain to the entire grouping. IRL
   Spags may be tenants in a multi-tenanted host or may be OUs or groups
   within a tenant.
   3. Defined the following Common Claims that may be applied to any
   subject identifier:
      1. spag_id: An optional claim that can be used to ensure uniqueness
      of the subject identifier within the SPAG.
      2. category: An optional claim that can be used to define the scope
      of the subject identifier. E.g., Does a phone number represent
the user or
      the device the user is using. The category can disambiguate this.
   4. Added a SAML subject identifier type as was needed by some use cases
   in SSE.
   5. Added myself as a co-author, given the scope of these changes.

Thanks,
Atul

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 13 Jul 2020 11:44:15 +0300

Hi Atul,

Thank you for your contribution!

You are introducing 3-4 new concepts into this draft (including the notion of “conformance” which you have not listed below). I think it would be more appropriate to start an email thread on this list on each one, in order to gauge the working group’s interest. In general the IETF reserves the PR process for smaller, editorial changes, or else for changes that had already been discussed by the mailing list.

Thanks,

                Yaron

From: Id-event <[email-masked]> on behalf of Atul Tulshibagwale <atultulshi=[email-masked]>
Date: Monday, July 13, 2020 at 05:38
To: <[email-masked]>, Openid-specs-risc <[email-masked]>
Cc: Annabelle Richard <[email-masked]>, Marius Scurtescu <[email-masked]>, michaeljones_fwd <[email-masked]>
Subject: [Id-event] SSE changes to the Subject Identifiers Spec

Hi all,

We've made a number of changes to the subject-identifiers spec in the OpenID "Shared Signals and Events" working group. I have incorporated these changes in a pull request to the present draft in the repository https://github.com/richanna/secevent.

Summary of the changes:

Defined "Subject Principals" as management entities that are represented by the subject identifiers
Defined "Subject Principal Administrative Groupings" or SPAGs that may be used for certain events that pertain to the entire grouping. IRL Spags may be tenants in a multi-tenanted host or may be OUs or groups within a tenant.
Defined the following Common Claims that may be applied to any subject identifier:
spag_id: An optional claim that can be used to ensure uniqueness of the subject identifier within the SPAG.
category: An optional claim that can be used to define the scope of the subject identifier. E.g., Does a phone number represent the user or the device the user is using. The category can disambiguate this.
Added a SAML subject identifier type as was needed by some use cases in SSE.
Added myself as a co-author, given the scope of these changes.
Thanks,

Atul

_______________________________________________ Id-event mailing list [email-masked] https://www.ietf.org/mailman/listinfo/id-event

---

From: Atul Tulshibagwale <[email-masked]>
Date: Mon, 13 Jul 2020 08:40:14 -0700

Hi Yaron,
Thanks for the suggestion, I will start a new thread for each topic. Just
FYI as background: We have discussed these changes in the OpenID Shared
Signals and Events group, but happy to discuss them here again.

Atul

On Mon, Jul 13, 2020 at 1:44 AM Yaron Sheffer <[email-masked]> wrote:

> You are introducing 3-4 new concepts into this draft (including the notion
> of “conformance” which you have not listed below). I think it would be more
> appropriate to start an email thread on this list on each one, in order to
> gauge the working group’s interest. In general the IETF reserves the PR
> process for smaller, editorial changes, or else for changes that had
> already been discussed by the mailing list.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Id-event <[email-masked]> on behalf of Atul
> Tulshibagwale <atultulshi=[email-masked]>
> *Date: *Monday, July 13, 2020 at 05:38
> *To: *<[email-masked]>, Openid-specs-risc <
> [email-masked]>
> *Cc: *Annabelle Richard <[email-masked]>, Marius Scurtescu <
> [email-masked]>, michaeljones_fwd <
> [email-masked]>
> *Subject: *[Id-event] SSE changes to the Subject Identifiers Spec
>
>
>
> Hi all,
>
>    1. spag_id: An optional claim that can be used to ensure uniqueness of
>       the subject identifier within the SPAG.
>       of the subject identifier. E.g., Does a phone number represent the user or
>    1. Added a SAML subject identifier type as was needed by some use
>    cases in SSE.
>    2. Added myself as a co-author, given the scope of these changes.
>
> Thanks,
>
> Atul
>
>
>
> _______________________________________________ Id-event mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/id-event
>

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 13 Jul 2020 19:09:10 +0300

Hi Atul,

Formally, if this is a working group document (which it currently is not, but the editors would like it to be), then the working group needs to decide on any significant changes to the document. The SSE discussion is very relevant background, but it does not replace SecEvent working group discussion/consensus.

Thanks,

                Yaron

From: Atul Tulshibagwale <[email-masked]>
Date: Monday, July 13, 2020 at 18:40
To: Yaron Sheffer <[email-masked]>
Cc: <[email-masked]>, Openid-specs-risc <[email-masked]>, Annabelle Richard <[email-masked]>, Marius Scurtescu <[email-masked]>, michaeljones_fwd <[email-masked]>
Subject: Re: [Id-event] SSE changes to the Subject Identifiers Spec

Hi Yaron,

Thanks for the suggestion, I will start a new thread for each topic. Just FYI as background: We have discussed these changes in the OpenID Shared Signals and Events group, but happy to discuss them here again.

Atul

Hi Atul,

Thanks,

                Yaron

Hi all,

Summary of the changes:

Atul