Subject: Re: [Id-event] Closing the SecEvent working group

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Thu, 2 Jul 2020 22:59:31 +0000

I’d like to hear from the working group on whether or not there is interest in completing the Subject Identifiers draft  within secevents. This work has more or less been put on hiatus given the chairs’ previous decision not to continue with it within the working group, but it remains a dependency for other work, and a number of people within the working group have expressed interest and support for it previously. If there is support within the working group for resuming and completing Subject Identifiers, then it would seem reasonable to me to do so within secevents.

–
Annabelle Backman (she/her)
AWS Identity
https://aws.amazon.com/identity/

From: Id-event <[email-masked]> on behalf of Yaron Sheffer <[email-masked]>
Date: Tuesday, June 30, 2020 at 2:06 AM
To: "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] [Id-event] Closing the SecEvent working group

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Dear WG participants,

As you’ve all seen, our last two deliverables, the SET HTTP delivery specs, have both been approved for publication as RFCs.

Since the group has now completed its mission, we propose to close it down. Unless there are objections (accompanied by credible work items) within a week, we will ask the AD to do just that. Even with the WG shut down, the mailing list will remain open for relevant discussions.

We would like to thank the authors of the Push and Poll soon-to-be RFCs, Annabelle, Mike, Marius, Morteza and Anthony. Many thanks also to the many other working group members who contributed to these quality documents.

Regards,

                Dick and Yaron

---

From: Mike Jones <[email-masked]>
Date: Thu, 2 Jul 2020 23:33:12 +0000

Thanks for raising this point, Annabelle.

I support finishing https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers in this working group.  It’s an important specification and the right people to provide actionable reviews are already in this working group.  If this moves elsewhere, it won’t get the same level of expert review that it will here.

I’ll also note that at least seven people responded positively to the WGLC and none opposed.

I agree that it’s time to finish this work.

                                                          -- Mike

From: Id-event <[email-masked]> On Behalf Of Richard Backman, Annabelle
Sent: Thursday, July 2, 2020 4:00 PM
To: Yaron Sheffer <[email-masked]>; [email-masked]
Subject: Re: [Id-event] Closing the SecEvent working group

–

From: Id-event <[email-masked]<mailto:[email-masked]>> on behalf of Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 30, 2020 at 2:06 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] [Id-event] Closing the SecEvent working group

Dear WG participants,

Regards,

                Dick and Yaron

---

From: Tim Cappalli <[email-masked]>
Date: Thu, 2 Jul 2020 23:38:29 +0000

+1

I would like to see https://tools.ietf.org/html/<https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers>draft-ietf-secevent-subject-identifiers<https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers> finished in this group.

Tim
________________________________
From: Id-event <[email-masked]> on behalf of Mike Jones <Michael.Jones=[email-masked]>
Sent: Thursday, July 2, 2020 7:33:12 PM
To: Richard Backman, Annabelle <richanna=[email-masked]>; Yaron Sheffer <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Id-event] Closing the SecEvent working group

I support finishing https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers&data=02%7C01%7Ctim.cappalli%40microsoft.com%7C38003c4334d74ac39e7308d81ee05371%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637293296108968382&sdata=qkX3A4oXlOHGt3tMv0y%2FcUKKurAWFselgdCYF7ZU8y8%3D&reserved=0> in this working group.  It’s an important specification and the right people to provide actionable reviews are already in this working group.  If this moves elsewhere, it won’t get the same level of expert review that it will here.

                                                          -- Mike

–

AWS Identity

https://aws.amazon.com/identity/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Faws.amazon.com%2Fidentity%2F&data=02%7C01%7Ctim.cappalli%40microsoft.com%7C38003c4334d74ac39e7308d81ee05371%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637293296108978377&sdata=VFIDWooi0Dw8PGq3PiAN3ZWAzjKEDv%2BIb8V1pNnkpBU%3D&reserved=0>

Dear WG participants,

Regards,

                Dick and Yaron

---

From: Phillip Hunt <[email-masked]>
Date: Thu, 2 Jul 2020 17:03:43 -0700

+1 I would like to see this finished.

Phillip Hunt
[email-masked]

> On Jul 2, 2020, at 4:38 PM, Tim Cappalli <Tim.Cappalli=[email-masked]> wrote:
> 
> +1
> 
> I would like to see https://tools.ietf.org/html/ <https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers>draft-ietf-secevent-subject-identifiers <https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers> finished in this group.
> 
> Tim
> I support finishing https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers&data=02%7C01%7Ctim.cappalli%40microsoft.com%7C38003c4334d74ac39e7308d81ee05371%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637293296108968382&sdata=qkX3A4oXlOHGt3tMv0y%2FcUKKurAWFselgdCYF7ZU8y8%3D&reserved=0> in this working group.  It’s an important specification and the right people to provide actionable reviews are already in this working group.  If this moves elsewhere, it won’t get the same level of expert review that it will here.
>  
> https://aws.amazon.com/identity/ <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Faws.amazon.com%2Fidentity%2F&data=02%7C01%7Ctim.cappalli%40microsoft.com%7C38003c4334d74ac39e7308d81ee05371%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637293296108978377&sdata=VFIDWooi0Dw8PGq3PiAN3ZWAzjKEDv%2BIb8V1pNnkpBU%3D&reserved=0>
>  
>  
> From: Id-event <[email-masked] <mailto:[email-masked]>> on behalf of Yaron Sheffer <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event

---

From: Bjorn Hjelm <[email-masked]>
Date: Thu, 2 Jul 2020 22:29:04 -0400

Annabelle,
I would like to see this work being completed.

BR,
Bjorn

On Jul 2, 2020, at 3:59 PM, Richard Backman, Annabelle <richanna=
[email-masked]> wrote:

I’d like to hear from the working group on whether or not there is interest
in completing the Subject Identifiers draft  within secevents. This work
has more or less been put on hiatus given the chairs’ previous decision not
to continue with it within the working group, but it remains a dependency
for other work, and a number of people within the working group have
expressed interest and support for it previously. If there is support
within the working group for resuming and completing Subject Identifiers,
then it would seem reasonable to me to do so within secevents.

–

AWS Identity

https://aws.amazon.com/identity/
<https://urldefense.proofpoint.com/v2/url?u=https-3A__aws.amazon.com_identity_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=JdLD0MPKiH-cnYaRWq00dc9RaqFuwKAR2s9Y6qctmCY&s=sg2xiXxfFuwR2T2OCtgdsW708HRdK2DeOSvVtx3HhKo&e=>

*From: *Id-event <[email-masked]> on behalf of Yaron Sheffer <
[email-masked]>
*Date: *Tuesday, June 30, 2020 at 2:06 AM
*To: *"[email-masked]" <[email-masked]>
*Subject: *[EXTERNAL] [Id-event] Closing the SecEvent working group

*CAUTION*: This email originated from outside of the organization. Do not
click links or open attachments unless you can confirm the sender and know
the content is safe.

Dear WG participants,

As you’ve all seen, our last two deliverables, the SET HTTP delivery specs,
have both been approved for publication as RFCs.

Since the group has now completed its mission, we propose to close it down.
Unless there are objections (accompanied by credible work items) within a
week, we will ask the AD to do just that. Even with the WG shut down, the
mailing list will remain open for relevant discussions.

We would like to thank the authors of the Push and Poll soon-to-be RFCs,
Annabelle, Mike, Marius, Morteza and Anthony. Many thanks also to the many
other working group members who contributed to these quality documents.

Regards,

                Dick and Yaron
_______________________________________________
Id-event mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=JdLD0MPKiH-cnYaRWq00dc9RaqFuwKAR2s9Y6qctmCY&s=ruzxNhwgDEh8N2N1ayOzTrCx8t1W3gLrz39-Jny_mhc&e=

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 03 Jul 2020 12:47:35 +0300

Sorry folks. We decided that this draft does not have WG support back in August, because it clearly did not have such support. Yes there are obviously people who want to see it published as an RFC. But not enough for any meaningful discussion during the WG last call (or even a positive response before the WGLC expired, we had exactly one). Nor any discussion since then. Nor a new draft version published since late July 2019.

Let me remind the group that the IETF offers two alternatives for publication, either AD-sponsored or through the ISE.

Thanks,

                Yaron

From: Bjorn Hjelm <[email-masked]>
Date: Friday, July 3, 2020 at 05:29
To: "Richard Backman, Annabelle" <richanna=[email-masked]>
Cc: Yaron Sheffer <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [E] Re: [Id-event] Closing the SecEvent working group

Annabelle,

BR,

Bjorn

On Jul 2, 2020, at 3:59 PM, Richard Backman, Annabelle <richanna=[email-masked]> wrote:

–

AWS Identity

 

Dear WG participants,

Regards,

                Dick and Yaron

---

From: Atul Tulshibagwale <[email-masked]>
Date: Fri, 3 Jul 2020 10:06:57 -0700

I would also like this work to be completed. We're working on subject-type
changes in the SSE spec, so those can be incorporated into this spec.

I'm happy to do this work within the SecEvents group.

Thanks,
Atul

On Fri, Jul 3, 2020 at 2:47 AM Yaron Sheffer <[email-masked]> wrote:

> Sorry folks. We decided that this draft does not have WG support back in
> August, because it clearly did not have such support. Yes there are
> obviously people who want to see it published as an RFC. But not enough for
> any meaningful discussion during the WG last call (or even a positive
> response before the WGLC expired, we had exactly one). Nor any discussion
> since then. Nor a new draft version published since late July 2019.
>
>
>
> Let me remind the group that the IETF offers two alternatives for
> publication, either AD-sponsored or through the ISE.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Bjorn Hjelm <[email-masked]>
> *Date: *Friday, July 3, 2020 at 05:29
> *To: *"Richard Backman, Annabelle" <richanna=[email-masked]>
> *Cc: *Yaron Sheffer <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [E] Re: [Id-event] Closing the SecEvent working group
>
>
>
> Annabelle,
>
> I’d like to hear from the working group on whether or not there is
> interest in completing the Subject Identifiers draft  within secevents.
> This work has more or less been put on hiatus given the chairs’ previous
> decision not to continue with it within the working group, but it remains a
> dependency for other work, and a number of people within the working group
> have expressed interest and support for it previously. If there is support
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__aws..amazon.com_identity_&d=DwMGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=JdLD0MPKiH-cnYaRWq00dc9RaqFuwKAR2s9Y6qctmCY&s=sg2xiXxfFuwR2T2OCtgdsW708HRdK2DeOSvVtx3HhKo&e=>
>
>
>
>
>
> *To: *"[email-masked]" <id-event@ietf..org <[email-masked]>>
> As you’ve all seen, our last two deliverables, the SET HTTP delivery
> specs, have both been approved for publication as RFCs.
>
>
>
> Since the group has now completed its mission, we propose to close it
> down. Unless there are objections (accompanied by credible work items)
> within a week, we will ask the AD to do just that. Even with the WG shut
> down, the mailing list will remain open for relevant discussions.
>
>
>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 6 Jul 2020 10:00:21 -0700

Yaron and I have discussed keeping the WG going to work on the
subject-identifiers draft. We were both disappointed in the previous
feedback from the WG in the two WGLCs we had for the document.

With more people chiming in at this time, we have decided to check if there
is renewed WG interest in subject-identifiers. To gauge the interest, we
would like to see substantive feedback on the latest draft[1] from numerous
people in the next two weeks. The cutoff will be July 20, 18:00 PDT. If we
do not see substantial feedback, we will close the WG and assist Annabelle
in publishing with the ISE.

Dick and Yaron

 [1] https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-05

Note this draft has expired, but still suits our purpose of
gauging interest.

On Fri, Jul 3, 2020 at 10:07 AM Atul Tulshibagwale <atultulshi=
[email-masked]> wrote:

>> *CAUTION*: This email originated from outside of the organization. Do
>> not click links or open attachments unless you can confirm the sender and
>> know the content is safe.
>>
>>
>>
>> Dear WG participants,
>>
>>
>>

---

From: Justin Richer <[email-masked]>
Date: Mon, 13 Jul 2020 15:34:27 -0400

+1 to finishing it and I’ll add my review to the pile this week. Apologies for the delays in doing so.

 — Justin

> On Jul 2, 2020, at 6:59 PM, Richard Backman, Annabelle <richanna=[email-masked]> wrote:
> 
> https://aws.amazon.com/identity/ <https://aws.amazon.com/identity/>
>  
>

---

From: William Denniss <[email-masked]>
Date: Wed, 15 Jul 2020 16:55:51 -0700

+1 to finish the work on secevent-subject-identifiers

On Mon, Jul 13, 2020 at 12:35 PM Justin Richer <[email-masked]> wrote:

> On Jul 2, 2020, at 6:59 PM, Richard Backman, Annabelle <
> richanna=[email-masked]> wrote:
>

---

From: Dick Hardt <[email-masked]>
Date: Wed, 15 Jul 2020 16:59:33 -0700

Hey Denniss, please see this email for current status:

https://mailarchive.ietf.org/arch/msg/id-event/A8L6ZSvw5szuPNXf2HBVRTifr44/
ᐧ

On Wed, Jul 15, 2020 at 4:56 PM William Denniss <wdenniss=
[email-masked]> wrote:

>> yaronf.ietf@gmail..com <[email-masked]>>
>> *To: *"[email-masked] <id-event@ietf..org>" <[email-masked]>