Subject: upstream/downstream interface

From: Abdelkader Lahmadi <[email-masked]>
Date: Mon, 13 Aug 2001 13:01:46 +0200

hi,

in the specification of the igmp proxy does an interface can be at the same
time an upstream interface and downstream interface?
for example if on the upstream interface there are also members of a group.

---------------------------------------------
  Lahmadi Abdelkader
  LORIA - UHP NANCY I
  CAMPUS SCIENTIFIQUE B.P.239
  54506 VANDOEUVRE-LES-NANCY CEDEX
  E-mail : [email-masked]
---------------------------------------------

---

From: Samuel Sundström <[email-masked]>
Date: Mon, 13 Aug 2001 14:50:48 +0200

hi,

  in the specification of the igmp proxy does an interface can be at
the same
  time an upstream interface and downstream interface?
  for example if on the upstream interface there are also members of a
group.

According to my understanding of the protocol, an interface of a proxy
is either upstream or downstream for a certain group. On the upstream
if (towards the multicast-tree), the proxy employs the host porton of
IGMP and on the downstream ifs it employs the router portion of IGMP.

What might confuse is the case when a member on a downstream interface
is also a sender, maybe that's what you're asking here;
Then the proxy shall forward traffic from that source (received on
that particular downstream interface) out on the other downstream
interfaces as well as the upstream interface [thus making the upstream
interface look like a downstream, maybe].

By definition, upstream is towards the tree and, hopefully, there are
some members of the group there as well.

/samuel

--
Samuel Sundstrom [[email-masked]]
IP core networks

Telia Research
Aurorum 6
SE-97775 Lulea, Sweden

---

From: Haixiang He <[email-masked]>
Date: Mon, 13 Aug 2001 09:51:42 -0400

In IGMP Proxy, we assume that there is no multicast protocol running. And the
multicast distribution tree is statically configured where the root is the
Proxy. Then we define the interface that connect the Proxy to the multicast
cloud as the upstream interface and there is only ONE upstream interface. All
other interfaces of the Proxy are considered as downstream interface(s). These
are the terms we defined to describe the protocol.

haixiang

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 13 Aug 2001 15:59:20 +0100 (BST)

On Mon, 13 Aug 2001, Haixiang He wrote:

> cloud as the upstream interface and there is only ONE upstream interface.

Just so I'm clear on this: you're not considering a proxy that
receives from the multicast cloud via one (unidirectional,
receive-only) interface, and sends traffic to the multicast cloud
via a separate (unidirectional, send-only) interface?

> All other interfaces of the Proxy are considered as downstream
> interface(s). These are the terms we defined to describe the
> protocol.

According to this, one of the unidirectional interfaces I describe
above would need to be considered as a downstream interface - although
both are enabling upstream connectivity. I find that an odd
contradiction.

cheers,

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>