Subject: Re: [idn] Let's go forward with IDNA and UTF-8

From: Dave Crocker <[email-masked]>
Date: Sat, 26 May 2001 12:19:23 -0700

Careful migration is always more complicated and, in some ways, more 
expensive than a simple switchover.

The problem is with the disruption caused by a "simple" switchover.

d/

At 10:16 AM 5/26/2001, D. J. Bernstein wrote:
>Dan writes:
> > The people saying ACE/IDNA say it is quickest and least disruptive
> > to non-IDN aware software. Those wanting UTF-8 thinks this format
> > is best for internationalisation and fear that starting with IDNA
> > will result in ACE forever.
>
>I have a much more serious concern: the short-term costs of deploying
>ACE appear to be much larger than the total costs of moving directly to
>UTF-8. See http://cr.yp.to/proto/idn.html for details.
>
>---Dan

----------
Dave Crocker   <mailto:[email-masked]>
Brandenburg InternetWorking   <http://www.brandenburg.com>
tel: +1.408.246.8253;   fax: +1.408.273.6464

---

From: "D. J. Bernstein" <[email-masked]>
Date: 26 May 2001 20:47:35 -0000

> The problem is with the disruption caused by a "simple" switchover.

You are speaking nonsense. We don't have any IDNs to disrupt. We are not
switching from one IDN solution to another. The current situation (if we
ignore the widespread UTF-8 experiments) is that IDNs simply don't work.
Our job is to extend the infrastructure to support IDNs.

---Dan