Subject: [Idr] Frequency of Decision Process

From: John Smith <[email-masked]>
Date: Tue, 8 Jul 2003 06:19:39 +0100 (BST)

Hi,

The router scans for the validity of next-hops after each 60 secs (which is the default
setting in most of the implementations) in BGP and triggers the Deicison Process for each
route which it scans. Isnt this a problem?

If a router has 100K prefixes then we shall be running the decision process so many times
each minute. I understand that most of the times nothing will happen, bit still invoking
the Decision Handler, etc must be a heavy weight process. 

Has any thought been given to this? OR am i confusing myself with something and this isnt
the actual case.

Regards,
John

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 9 Jul 2003 16:50:29 -0400

> route which it scans. Isnt this a problem?

It slows down convergence at the very least. :-)

> the Decision Handler, etc must be a heavy weight process. 

It is highly unlikely that 100K routes will have 100K BGP NEXT_HOPs. 

The process of determining that the cost to a BGP nexthop has changed
is pretty trivial.  The process of updating your routes that use the
resolved nexthop is a data lookup problem and is implementation dependent.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 9 Jul 2003 16:50:29 -0400

-- 
Jeff Haas 
NextHop Technologies