Subject: [Idr] Re: FSM review - comments on Administrative events 8.1.1 - Urgent

From: "Tom Petch" <[email-masked]>
Date: Sat, 5 Jul 2003 22:52:50 +0100

Sue

Sorry for the delayed reply; I too am inundated with spam and for
reasons I cannot comprehend your mail fell into the trap.

I do not want to fix detail yet if we are going then to make more
substantial changes lest the latter undoes the former.

I believe we should go forward from what we now have - rather than
going back to a previous version - since the changes did fix a clearly
expressed need.  But I have been surprised by how much has been added
in the most recent version.  I am not saying take it out, just that I
would not have tried to polish the text until after instead of doing
it before.

So for me the fundamental question is are we agreed that this is in
its final form, subject to clarification and polishing?

Erblichs comment suggests otherwise; my biggest reservation, not sure
how big a change it will be,  is about the two optional timers where
1) we have inconsistency with the mandatory timers in the attributes
we use
2) we have a xxxTimer with a value of seconds which confuses me; I
take the value in seconds to be the initial value, not the current
running value. And I want a xxxTimer attribute/object to be something
to stop, start and reset and I cannot reconcile that with an
'InitialValueInSeconds' object.

So I end up wanting a xxxTime object for the initial value and an
xxxTimer object for the stop, start etc.  More change than I would
like, but I do not see another solution.  I see no need to go into
more detail given the use to which to put these timers

The other reservation I have is that section 8 no longer hangs
together  eg 8.2.1.3 made perfect sense where it was until 8.1 got so
expanded.  Reading the document through I get to 8.2.1.3 and think,
hangabout, what on earth is this saying that has not already been said
more comprehensively in 8.1?  Now I can explain this as history, when
8.2.1.3 was all we had it did not matter where it was.  Others may
not, so I believe 8.2.1.3 must move into 8.1, probably near the
beginning.  (I suspect there are other such paragraphs that are less
obvious to me).  And 8.2.1.3 needs testing against what we say about
timers to ensure it is still accurate.

I want to focus on and fix these before gettting into more detail.

Tom Petch
----Original Message-----
From: Alex Zinin <[email-masked]>
To: Susan Hares <[email-masked]>
Cc: Tom Petch <[email-masked]>; [email-masked]
<[email-masked]>; [email-masked] <[email-masked]>
Date: 03 July 2003 02:00
Subject: Re: FSM review - comments on Administrative events 8.1.1 -
Urgent

>Sue,
>
>> Tom and Alex:
>
>> I need to your help on resolving Tom's comments.
>> I've got conflicting comments.
>
>> (Tom - Thanks for the note.  Your Thursday email got to me
>> delayed due to a mailer problem.  We got a lot of spam last
>> week.)
>
>> On your comments:
>
>> pre-1) 8.2.1.3 - Can you propose text? Or suggest changes?
>>          Can you confirm your text with Alex 1st?
>
>Which one is this? On peer identification?
>
>> 1) I Will change session to connection
>> 2) true/False on values
>>         Please agree with Alex on Value or just flag.
>
>editorial, no strong preference
>
>> 3) stops/starts - I'm happy to use the stops/starts.
>>         1) For optional - we do need a value to indicate the timer
is there.
>>         2) I'll be glad to use the 3 types
>>                 xxxTime in seconds (initial value)
>>               xxxTimer - starts, stops is reset etc.
>>                 xxxTimerAttribute - that signals use?
>
>>         The comments from the previous information (including
yours)
>>         indicated the stop/start values.
>
>>         Please confirm what you would like to have.
>
>ditto
>
>> 4) connection attributes
>
>>         I am glad to use connection or session attributes.
>>         I simply need you and Alex (or his AD-Commentors)
>>         to agree on a text.
>
>>         If we are banning sessions, then connections are
>>         OK with me.  I think session is a more accurate term
>>         for the FSM - but if it is binned nothing in this world
>>         can drag me into a longer discussion.
>
>ditto
>
>> But, I need again -- I need to see email from both of you
>> confirming the change.
>
>generally, if the choice of the exact text does not change
>the technical meaning, I'm happy with whatever the authors
>and the WG agree on.
>
>Alex
>

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Tom Petch" <[email-masked]>
Date: Sat, 5 Jul 2003 22:52:50 +0100

Sue

Tom Petch
----Original Message-----
From: Alex Zinin <[email-masked]>
To: Susan Hares <[email-masked]>
Cc: Tom Petch <[email-masked]>; [email-masked]

is there.
yours)