Subject: [Idr] Non Transitive Attributes

From: John Smith <[email-masked]>
Date: Wed, 9 Jul 2003 12:34:35 +0100 (BST)

Hi,
The MP_REACH_NLRI is an optional non-transitive attribute. How can then this be
advertised to peers outside its own AS (EBGP peers)?

As i understand being non-transitive means that if you dont understand the attribute then
you dump it and it has actually got nothing to do with it being able to cross the AS
boundaries. Is this how it is?

If not, then my first statement holds true.

Please help,
John

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: John Smith <[email-masked]>
Date: Thu, 10 Jul 2003 12:36:19 +0100 (BST)

Jeff,

Oh .. My doubt was that are non-transitive attributes sent outside the AS other than the
one in which they were originated?

Additionally, I think when we say non-transitive it only means that - "if you dont
recognize this attribute then ignore it OR else if its a transitive attribute then even
if you dont understand this you should pass this along to your neighbor in case he knows
and understands it" !

Regards,
John
----- Original Message ----- 
From: "Jeffrey Haas" <[email-masked]>
To: "John Smith" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 10, 2003 2:18 AM
Subject: Re: [Idr] Non Transitive Attributes

> On Wed, Jul 09, 2003 at 12:34:35PM +0100, John Smith wrote:
> > Hi,
> It is up to a speaker that understands the MP_(UN)REACH_NLRI attributes
> to place them in a new PDU.  
> 
> The fact that this must be actively done means that a speaker that
> doesn't understand the MP attributes will not propagate them to a
> speaker that does, thus leaking reachability that it doesn't use.
> 
> 
> -- 
> Jeff Haas 
> NextHop Technologies
>