Subject: [Idr] Cost to Reach the NH

From: Mareline Sheldon <[email-masked]>
Date: Mon, 7 Jul 2003 03:17:49 -0700 (PDT)

Hi,

When we say consider the cost to reach the next hop in running our decision handler is it the
cost to reach the "Nexthop" carried in the BGP UDPATE message OR is it the cost to reach the
next-hop which is resolved by doing recursive lookup. 

As an example. Suppose a router receievs an UPDATE for a prefix with next hop NH1. Let NH2 be
the next-hop which it will use to reach NH1. Given this, does it consider the cost to reach
NH1 or NH2 in its decision process?

I think its the latter - but just wanted to confirm from others.

Will appreciate any light on this.

Regards,
Mareline S.

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Reji Varghese <[email-masked]>
Date: Mon, 07 Jul 2003 11:44:50 -0400

Hi,

This has to be the cost to reach NH2,
if NH1 cannot be directly resolved (through an IGP route).
Else it has to be the cost to reach NH1.

Regards
Reji Varghese

---

From: Reji Varghese <[email-masked]>
Date: Mon, 07 Jul 2003 11:44:50 -0400

Hi,

Regards
Reji Varghese

---

From: Mareline Sheldon <[email-masked]>
Date: Mon, 7 Jul 2003 23:43:27 -0700 (PDT)

Hi Reji,

Let me clarify what i meant.

Consider a toplogy like this.

       (3)         (4)      (7)
 R1 -------- R2 ------- R3 ---- R4

R1, R2 and R4 are BGP speakers. Figures in brackets is the cost of the link.
 
Suppose R1 advertises some infrmation to R2. The IGP cost which R2 will use in its decision
handler will be 3. Now R2 advertises this information to R4. The NEXT_HOP attribute points to
R1. What is the IGP cost which R4 will consider. Will it be 7 or 14.

R4 will use R3 to forward all packets to R1. Thus when we say the cost to reach the next-hop
will it take this to be 7 i.e. cost to reach R3 or will it use 3+4+7 = 14 i.e the cost to
reach NEXT_HOP carried in BGP update. 

I gather that R4 will be aware of these costs because of the IGP running inside the network.

I would really appreciate if someone would clarify this!

Regards,
Mareline S.

---

From: Mareline Sheldon <[email-masked]>
Date: Mon, 7 Jul 2003 23:43:27 -0700 (PDT)

Hi Reji,

       (3)         (4)      (7)

Regards,
Mareline S.

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 8 Jul 2003 17:23:41 -0400

The answer is "14".

IMO this is unambiguous in the spec, given that (a) the spec talks 
about the IGP cost to the NEXT_HOP (not "next hop" or "next-hop" or 
any other variant) and (b) the spec provides a clear definition of 
"NEXT_HOP".

Regards,

--John

At 11:43 PM -0700 7/7/03, Mareline Sheldon wrote:
>>  > When we say consider the cost to reach the next hop in running 
>>our decision handler is it
>>  the
>>  > cost to reach the "Nexthop" carried in the BGP UDPATE message OR 
>>is it the cost to reach
>>  the
>>  > As an example. Suppose a router receievs an UPDATE for a prefix 
>>with next hop NH1. Let NH2
>>  be
>>  > the next-hop which it will use to reach NH1. Given this, does it 
>>consider the cost to
>>  reach

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 8 Jul 2003 17:23:41 -0400

The answer is "14".

Regards,

--John

---

From: Reji Varghese <[email-masked]>
Date: Wed, 09 Jul 2003 16:42:13 -0400

That's right.
It's the cost to reach the NEXT_HOP,
which can be the sum of costs for intermediate hops.

Regards
Reji Varghese

--
Reji Varghese
3, Highwood Drive
Tewksbury MA 01876
Phone: (978)-858-3272

---

From: Reji Varghese <[email-masked]>
Date: Wed, 09 Jul 2003 16:42:13 -0400

That's right.

Regards
Reji Varghese

--
Reji Varghese
3, Highwood Drive
Tewksbury MA 01876
Phone: (978)-858-3272