Subject: [Idr] issue 12 - sections 8.2, 8.2.1

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Jul 2003 13:54:23 -0400

Issue 12: sections 8.2, 8.2.1

    issue 12a:  comments on connecting to port 179
    issue 12b: editorial changes [all accepted] 

status: issue 12a: sent to wider mail group.
        issue 12b: all editorial changes accepted from AD

Editor's concern:

	Section 8.2.1 was the subject of a lengthy discussion
	prior to creating draft-20.  I will need to send
	12a to a wider audience.  I will ask for clarification
	from the AD-reviewer for the text change. 	

-------------------------
AD Reviewers comments
-------------------------

> 8.2.1 FSM Definition
> 
> 
>    BGP MUST maintain a separate FSM for each configured peer, Each BGP
>    peer paired in a potential connection unless configured to remain in
>    the idle state, or configured to remain passive, will attempt to  to

[remove one of to to]
[accepted]

>    connect to the other.  For the purpose of this discussion, the active
>    or connect side of the TCP connection (the side of a TCP connection
'active or connecting'?
[accepted] 

>    sending the first TCP SYN packet) is called outgoing.  The passive or
>    listening side (the sender of the first SYN ACK) is called an incom-
>    ing connection (see Section 8.2.1.1 on the terms active and passive
>    below).
> 
>    A BGP implementation MUST connect to and listen on TCP port 179 for
>    incoming connections in addition to trying to connect to peers.  For
>    each incoming connection, a state machine MUST be instantiated.

Is this true for implementations that resolve connection collision
through one FSM with two transport connections?

-----------------------
Tom Petch Comments
-------------------

proposed change:

   A BGP implementation MUST 
  **connect to and**(remove - clashes with 'in addition')
   listen on TCP port 179 for incoming connections in 
   addition to trying to connect to peers.

8.2 Description of FSM

8.2.1 FSM Definition

   BGP MUST maintain a separate FSM for each configured peer. Each BGP
   peer paired in a potential connection, unless configured to remain in
   the idle state, or configured to remain passive, will attempt to
   connect to the other.  For the purpose of this discussion, the active
   or connecting side of the TCP connection (the side of a TCP connection
   sending the first TCP SYN packet) is called outgoing.  The passive or
   listening side (the sender of the first SYN ACK) is called an incom-
   ing connection. (See Section 8.2.1.1 for information on the terms
   active and passive used below.)

   A BGP implementation MUST **connect to and**(remove - clashes with 'in addition')
   listen on TCP port 179 for

[awaits comments from the rest of the mail group

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Reji Varghese <[email-masked]>
Date: Mon, 07 Jul 2003 14:21:21 -0400

The following change is worthy to be included as
it removes the redundancy in the text.

Regards
Reji Varghese

-----------------------
Tom Petch Comments
-------------------

proposed change:

--
Reji Varghese
3, Highwood Drive
Tewksbury MA 01876
Phone: (978)-858-3272

---

From: Reji Varghese <[email-masked]>
Date: Mon, 07 Jul 2003 14:21:21 -0400

Regards
Reji Varghese

-----------------------
Tom Petch Comments
-------------------

proposed change:

--
Reji Varghese
3, Highwood Drive
Tewksbury MA 01876
Phone: (978)-858-3272