Subject: [Idr] IBGP to replace IGP

From: John Smith <[email-masked]>
Date: Tue, 16 Mar 2004 04:24:12 +0000 (GMT)

Hi,

I am very clear with the concept that IGPs cannot be used to carry the entire BGP feed as
they cant be scaled to carry so many prefixes (even assuming we add enough TLVs to make
them carry the BGP attributes).

What is not very clear to me is, why cant we use IBGP inside an AS to completely do away
with IGPs. IGPs compute the best path to reach a particular neighbor based on the link
metric. This can be achieved in BGP also, if we include a TLV to carry the link cost.
Moreover, it is *mandatory* to run BGP on all the routers if we are transiting traffic,
because if a router isnt speaking BGP then it cant forward BGP traffic. 

Cant we do away with IGPs (say in some small networks) and run only IBGP there?

Any help/clues/pointers in this regard will be really appreciated.

Regards,
Smith

___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Pekka Savola <[email-masked]>
Date: Tue, 16 Mar 2004 07:59:24 +0200 (EET)

> Cant we do away with IGPs (say in some small networks) and run only IBGP there?

How do you route point-to-point and loopback addresses if not with 
IGP?  Using static routes? :)

Otherwise, yes, IBGP has mostly replaced IGP especially wrt. external
prefixes and that's a good thing.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Pekka Savola <[email-masked]>
Date: Tue, 16 Mar 2004 07:59:24 +0200 (EET)

---

From: Benjamin Black <[email-masked]>
Date: Mon, 15 Mar 2004 22:09:48 -0800

You could certainly run BGP and statics without another protocol for 
the IGP, but why would you want to?  Convergence times, CPU load on 
RPs, etc., during changes would be rather unsatisfactory.  If you want 
to run one dynamic protocol at all costs, then what you describe below 
will work, and has worked for some, but people with real traffic don't 
waste their time with it.

Ben

---

From: Benjamin Black <[email-masked]>
Date: Mon, 15 Mar 2004 22:09:48 -0800

Ben