Subject: [Idr] BGP Marker in the Header

From: Hunju Park <[email-masked]>
Date: Thu, 18 Mar 2004 06:26:33 -0500 (EST)

Hi,
What is the need for the BGP Marker (16 bytes) containing all FFs. It is said that it was used at
times for security but i dont think its valid anymore. If anybody wants security then he can use
TCP-MD5.

Any clues,
Park

P.S.
I went through the IDR archives before posting this and couldnt find any explanation for this!
Infact,this question was raised a long time back, but nobody answered this.

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 18 Mar 2004 13:20:38 -0500

In message <[email-masked]>, Hunju Park wri
> Infact,this question was raised a long time back, but nobody answered this.

It is used to detect a horrible bug in either the sending or receiving
implementation in which packet alignment has been lost.  Those sort of
bugs are much less common that they were a decade or more ago, but it
might not hurt to keep the check in place anyway.  You can't tell what
sort of code you will be BGP peering with, including someone's kludged
together test or monitoring code.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 18 Mar 2004 13:20:38 -0500

Curtis