Subject: [Idr] Experimental code-points

From: Alex Zinin <[email-masked]>
Date: Mon, 1 Mar 2004 17:11:27 +0900

As I mentioned, RFC 3692 described experimental allocations.
Please check if it's applicable.

-- 
Alex
http://www.psg.com/~zinin/

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 1 Mar 2004 19:29:47 -0500

hi

In looking through
	
http://www.ietf.org/internet-drafts/draft-kompella-zinin-early-allocation-00
.txt

I would suggest the following change to address my concern that it
inappropriately sets the expectation that MIB OIDs will be pre-allocated.

In either the 'Introduction' or in the section 'Conditions for Early
Allocation' the following text needs to be added.

'Note that under no condition will MIB Object Identifiers (OIDs) be
allocated before the RFC is published.'

Sharon

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Monday, March 01, 2004 3:11 AM
To: [email-masked]
Subject: [Idr] Experimental code-points

As I mentioned, RFC 3692 described experimental allocations. Please check if
it's applicable.

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 1 Mar 2004 19:29:47 -0500

hi

In looking through

Sharon

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 3 Mar 2004 06:38:26 +0100

Good point. They can get an OID assigned in the experimental branch though.

Thanks,
Bert 

-----Original Message-----
From: Sharon Chisholm [mailto:[email-masked]]
Sent: dinsdag 2 maart 2004 9:30
To: [email-masked]
Cc: Wijnen, Bert (Bert)
Subject: RE: [Idr] Experimental code-points

hi 

In looking through 
        http://www.ietf.org/internet-drafts/draft-kompella-zinin-early-allocation-00.txt <http://www.ietf.org/internet-drafts/draft-kompella-zinin-early-allocation-00.txt>  

I would suggest the following change to address my concern that it inappropriately sets the expectation that MIB OIDs will be pre-allocated.

In either the 'Introduction' or in the section 'Conditions for Early Allocation' the following text needs to be added. 

'Note that under no condition will MIB Object Identifiers (OIDs) be allocated before the RFC is published.' 

Sharon 

-----Original Message----- 
From: Alex Zinin [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Monday, March 01, 2004 3:11 AM 
To: [email-masked] 
Subject: [Idr] Experimental code-points 

As I mentioned, RFC 3692 described experimental allocations. Please check if it's applicable. 

-- 
Alex 
http://www.psg.com/~zinin/ <http://www.psg.com/~zinin/>  

_______________________________________________ 
Idr mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/idr <https://www1.ietf.org/mailman/listinfo/idr>

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 3 Mar 2004 19:17:39 -0500

hi

My concern is that this is opening us up to even more queries for premature
OID assignment, for which we are most likely going to say they need to wait
for the RFC. It's a matter of cutting off a frequently asked question by
having clear text in the draft that properly sets expectations. People may
reason that if Foo qualifies then the Foo MIB does, so I'd like to see some
text in the document that will make it more clear that this isn't the case. 

Perhaps a middle ground would be to add text indicating that early
allocation of code points for the protocol is independent of the MIB OID
allocation, or something along those lines.

Sharon

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Wednesday, March 03, 2004 7:55 AM
To: Wijnen, Bert (Bert)
Cc: Chisholm, Sharon [CAR:0S00:EXCH]; [email-masked]
Subject: Re: [Idr] Experimental code-points

Bert, Sharon-

 The doc says:

>    This memo only addresses the early allocation of code points from
>    spaces whose allocation policy is "Standards Action" [2434] AND have
>    been amended to permit early allocation.  This permission must be
>    granted by the IESG, and code spaces with permission for early
>    allocation must be marked as such in the IANA registry.

 In other words, it doesn't apply to an existing registry unless IESG
approves  that this process is applicable. This leaves existing registries,
OID included,  intact unless someone takes an action.

 Is this good enough?

> In looking through 
>         
> http://www.ietf.org/internet-drafts/draft-kompella-zinin-early-allocat
> ion-00.txt 
> <http://www.ietf.org/internet-drafts/draft-kompella-zinin-early-alloca
> tion-00.txt>

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 3 Mar 2004 19:17:39 -0500

hi

Sharon

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Wednesday, March 03, 2004 7:55 AM
To: Wijnen, Bert (Bert)
Cc: Chisholm, Sharon [CAR:0S00:EXCH]; [email-masked]
Subject: Re: [Idr] Experimental code-points

Bert, Sharon-

 Is this good enough?

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sat, 6 Mar 2004 14:01:34 +0100

Aha ... good. For me that Covers it.
But... it might be good to add that "IESG approval" 
into the list of "conditions" in sect 2 as well. 
I bet people will often skip the intro and go straight to
the "what are the conditions" section to see if they can
request an early registration.

Thanks,
Bert 

> Sent: woensdag 3 maart 2004 21:55
> To: Wijnen, Bert (Bert)
> Cc: Sharon Chisholm; [email-masked]
>  In other words, it doesn't apply to an existing registry 
> unless IESG approves
>  that this process is applicable. This leaves existing 
> registries, OID included,
>  intact unless someone takes an action.
> 
>  Is this good enough?
>  
> -- 
> Alex

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 10 Mar 2004 15:27:02 -0500

hi

I'd prefer something more explicit, but I guess I can live with the current
text.

Sharon

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Wednesday, March 10, 2004 2:03 AM
To: Wijnen, Bert (Bert)
Cc: Chisholm, Sharon [CAR:0S00:EXCH]; [email-masked]
Subject: Re: [Idr] Experimental code-points

OK.

Sharon, would this work for you?

Tuesday, March 9, 2004, 6:54:03 PM, Wijnen, Bert (Bert) wrote:
> Yes.... I wonder why I did not see that ??
> Maybve I was too tired at end of IETF week.

>> Sent: woensdag 10 maart 2004 7:45
>> To: Wijnen, Bert (Bert)
>> Bert,
>>  Seems that the text already has it:
>> 
>> >    a) The code points must be from a space designated as "Standards
>> >       Action", amended by IESG approval to permit Early Allocation.
>>                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>> 
>>  Does it do the job?
>> 
>> --
>> Alex
>> Saturday, March 6, 2004, 5:01:34 AM, Wijnen, Bert (Bert) wrote:

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 10 Mar 2004 15:27:02 -0500

hi

Sharon

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Wednesday, March 10, 2004 2:03 AM
To: Wijnen, Bert (Bert)
Cc: Chisholm, Sharon [CAR:0S00:EXCH]; [email-masked]
Subject: Re: [Idr] Experimental code-points

OK.