Subject: RE: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)' to Draft Standard

From: "Susan Hares" <[email-masked]>
Date: Mon, 3 May 2004 13:48:31 -0400

Pekka:

There was a specification (now historical)
that talked about knobs between OSPF and 
BGP (RFC 1745).  We put the knobs for IGP/EGPs
into this document. 

So perhaps you want to review this document 
and look at the what it covered.  If you feel
that document is useful, let me know.
I was a co-author on this document originally, but
Dave Meyer felt it should go to historical.
Please chat with him about why he thought
it should go to historical.

If you feel this document should be updated,
please let me know.  I'm glad to engage in
a conversation about whether the OSPF/ISIS and
BGP interaction should be discussed.

Sue

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Friday, April 30, 2004 1:19 PM
To: Yakov Rekhter
Cc: Alex Zinin; [email-masked]; [email-masked]
Subject: Re: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)'
to Draft Standard 

On Fri, 30 Apr 2004, Yakov Rekhter wrote:
> > I think this is operationally a rather common (or even very common)  
> > scenario, and it would seem very disadvantageous not to tackle it in
> > this specification.  Further, there's major deployment of it (maybe
> > even multi-vendor -- probably) so there is considerable proof that it
> > works.
> > 
> > It should be the default behaviour of BGP as that's which makes the
> > most sense, operationally.  "BGP route is ... used by forwarding" does
> > not sufficiently cover the fact that people do use IGPs and there's
> > often overlap with IGP and BGP :).
> 
> People do use IGPs, and there is interaction between IGPs and BGP.
> 
> It is just that the based BGP protocol spec is *not* the place to 
> document the interaction between BGP and IGPs.

I have to disagree here.  BGP is useless without IGP.  Failing to
consider that would mean a specifition disconnected from the reality.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: David Meyer <[email-masked]>
Date: Mon, 3 May 2004 11:17:31 -0700

All,

>> it should go to historical.

	The reasoning is in RFC 3167 (Request to Move RFC 1745 to
	Historic Status).   

	Let me know if there are things not covered there that
	need clarifcation.

	Dave

---

From: David Meyer <[email-masked]>
Date: Mon, 3 May 2004 11:17:31 -0700

All,

	Dave