Subject: RE: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)' to Draft Standard

From: "Susan Hares" <[email-masked]>
Date: Mon, 3 May 2004 12:30:27 -0400

Dinara:

What exactly do you want unsubscribe:

[email-masked]

This ID is turned off.  

Sue

-----Original Message-----
From: Dinara Suleymanova [mailto:[email-masked]]
Sent: Thursday, April 29, 2004 2:01 PM
To: Pekka Savola; Yakov Rekhter
Cc: Alex Zinin; [email-masked]; [email-masked]
Subject: Re: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)'
to Draft Standard 

Hello,

Could it be possible to UN-subscribe us/me (not sure what address was added 
on your subscription list)
from your discussion list.

Thanks a lot.

Dinara Suleymanova

At 12:35 PM 4/29/2004, Pekka Savola wrote:
>On Tue, 20 Apr 2004, Yakov Rekhter wrote:
> > > >  2) The definition of active route is bad.  This fails in the
> > > >     situation where you need to export loopbacks/point-to-points to
> > > >     eBGP, but you have them in youro IGP.  The specification does not
> > > >     consider them active (not used for forwarding), and they aren't
> > > >     exported.
> > > >
> > > >     When the next-hop of the IGP route is the same as BGP next-hop,
> > > >     obviously this is no problem.  Gargi Nalawade promised to submit
> > > >     text, but hasn't, and I think Yakov said something about being
> > > >     willing to incorporate that, but obviously hasn't.
> > > >
> > > >     This was discussed at idr thread:
> > >
> > > >       issue 11.2: active route, again
> > >
> > > > Otherwise, I think this was operationally good.
> > >
> > > Sue, Yakov, please check if the ball was dropped re this one.
> >
> > First of all, the consensus of the WG (as documented in
> > draft-ietf-idr-bgp-issues) is to have the following text:
> >
> >    In the context of this document we assume that a BGP speaker
> >    advertises to its peers only those routes that it itself uses (in
> >    this context a BGP speaker is said to "use" a BGP route if it is the
> >    most preferred BGP route and is used in forwarding). All other cases
> >    are outside the scope of this document.
> >
> > While this text does not cover the case described by Pekka, it does
> > not preclude it either - handling the case described by Pekka
> > is just outside the scope of the spec.
> >
> > With this in mind I suggest that the case described by Pekka
> > should be covered in a separate Internet Draft.
>
>I think this is operationally a rather common (or even very common)
>scenario, and it would seem very disadvantageous not to tackle it in
>this specification.  Further, there's major deployment of it (maybe
>even multi-vendor -- probably) so there is considerable proof that it
>works.
>
>It should be the default behaviour of BGP as that's which makes the
>most sense, operationally.  "BGP route is ... used by forwarding" does
>not sufficiently cover the fact that people do use IGPs and there's
>often overlap with IGP and BGP :).
>
>--
>Pekka Savola                 "You each name yourselves king, yet the
>Netcore Oy                    kingdom bleeds."
>Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
>
>
>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 3 May 2004 12:30:27 -0400

Dinara:

[email-masked]

This ID is turned off.  

Sue

-----Original Message-----
From: Dinara Suleymanova [mailto:[email-masked]]
Sent: Thursday, April 29, 2004 2:01 PM
To: Pekka Savola; Yakov Rekhter
Cc: Alex Zinin; [email-masked]; [email-masked]
Subject: Re: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)'
to Draft Standard 

Hello,

Thanks a lot.

Dinara Suleymanova

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 3 May 2004 13:48:31 -0400

Pekka:

There was a specification (now historical)
that talked about knobs between OSPF and 
BGP (RFC 1745).  We put the knobs for IGP/EGPs
into this document. 

So perhaps you want to review this document 
and look at the what it covered.  If you feel
that document is useful, let me know.
I was a co-author on this document originally, but
Dave Meyer felt it should go to historical.
Please chat with him about why he thought
it should go to historical.

If you feel this document should be updated,
please let me know.  I'm glad to engage in
a conversation about whether the OSPF/ISIS and
BGP interaction should be discussed.

Sue

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Friday, April 30, 2004 1:19 PM
To: Yakov Rekhter
Cc: Alex Zinin; [email-masked]; [email-masked]
Subject: Re: [Idr] FYI: Last Call: 'A Border Gateway Protocol 4 (BGP-4)'
to Draft Standard 

On Fri, 30 Apr 2004, Yakov Rekhter wrote:
> People do use IGPs, and there is interaction between IGPs and BGP.
> 
> It is just that the based BGP protocol spec is *not* the place to 
> document the interaction between BGP and IGPs.

I have to disagree here.  BGP is useless without IGP.  Failing to
consider that would mean a specifition disconnected from the reality.

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 05 May 2004 07:26:06 -0700

Folks,

As an IDR WG co-chair it is my assessment that the IDR WG reached
a consensus to leave the following text as is.

Yakov.