Subject: RE: [Idr] Inter-operable BGP implementations - Call for information

From: "Susan Hares" <[email-masked]>
Date: Fri, 21 May 2004 17:59:25 -0400

Pekka:

In my earlier messages I assumed a context
from bgp-4 implementation report found
for your reading pleasure (and accessed
off the general IDR web page) at:

 draft-ietf-idr-bgp-implementation-00.txt 

In that report (authored by Alvaro and
myself), we have 4 inter-operable (Alcatel,
Cisco, Laurel, NextHop) whose inventors
responded to 259 questions required to verify
all features of the protocols.
This required a significant investment
of time on for any implementer.  
All issues from RFC 2026 are covered
in that document. 

Since there are greater than four implementations
of BGP in existence, the small subset of
responses will be of concern to any
member of the IESG with functioning
and engaged cognitive processes.  

Informal reports to me indicated that
for an existing and deployed implementation, this
effort had value only for the continuation of
the IETF standard process.   In order to
provide appropriate input to the IESG on
general interoperability of BGP, I need to
widen the normal 2026 survey to
include those implementations that: 	

 a)Are inter-operable with other BGP implementation, and
 b)whose implementers found that answering 259
   questions on an existing and deployed 
   implementations was too daunting to
   complete.

Section 1.4 of the implementation report
deals with this issue.  At the time of the -00.txt
draft this was incomplete because I 
did not have enough time to get a significant
number of responses.  I am now asking for
those responses in the next 2 weeks. 

Does this make the request clear? 

Perhaps this two facts will also illuminate the
value of this request to the working group.
For example, neither Juniper or Redback's
implementers filled out an implementation report.
Juniper's support of BGP standardization process has
been evident by my esteemed co-chairs active
participation for years.  Other standards or
standards reports have been generated by 
many fine BGP implementers at Juniper or Redback.

I normally attempt to be brief and assume
a substantial amount of context from existing
documents.  Please send me feedback if I am
being to terse in the future.  

Sue 

-----Original Message-----
From: Pekka Savola [mailto:[email-masked]]
Sent: Thursday, May 20, 2004 1:52 AM
To: Susan Hares
Cc: [email-masked]
Subject: Re: [Idr] Inter-operable BGP implementations - Call for
information

On Thu, 20 May 2004, Susan Hares wrote:
> I am revising the BGP implementation survey, and
> need an updated on inter-operable implementations.
> I will accept input for 2 weeks ending 6/2/04.  
> At that time, I will release version -01 of the BGP
> implementation survey. 

FWIW, if you look at RFC2026, it's not sufficient that you have
interoperable implementations (in general), there must be two
interoperable implementations of _every feature_ of the spec.

>From 4.1.2,
                                                            For the
   purposes of this section, "interoperable" means to be functionally
   equivalent or interchangeable components of the system or process in
   which they are used.

The interpretation of what this means has been quite blur, but it 
would be better that if interop tests explicitly tested each feature 
of the spec, not the spec as a whole.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Pekka Savola <[email-masked]>
Date: Sat, 22 May 2004 04:01:42 +0300 (EEST)

> All issues from RFC 2026 are covered

Not quite.  RFC2026 requires *both* implementation and
interoperability of 'functionally equivalent or interchangeable
components'.  The document just describes implementation in
excruciating detail (good! :).

Even though implementations are known to interoperate in general, I 
don't think anyone has made a question-by-question interoperability 
test .. which, depending on how you interpret RFC2026 language, could 
be required.

---

From: Pekka Savola <[email-masked]>
Date: Sat, 22 May 2004 04:01:42 +0300 (EEST)

---

From: Curtis Villamizar <[email-masked]>
Date: Sat, 22 May 2004 02:29:58 -0400

In message <[email-masked]>, Pekka Savola w
> test .. which, depending on how you interpret RFC2026 language, could 

Sounds to me more like Corperation for Open Sytems (or or whatever
they were called) that the IETF.

I don't think we're going to arrive at any sort of provable
correctness.

Maybe we should look at what OSPF did.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Sat, 22 May 2004 02:29:58 -0400

Curtis