Subject: [Idr] draft-chavali-bgp-prefixlimit-02.txt as an IDR WG document

From: Yakov Rekhter <[email-masked]>
Date: Mon, 10 May 2004 06:47:43 -0700

Folks,

Those who were in favor of accepting draft-chavali-bgp-prefixlimit-01.txt
as an IDR WG document need to say whether they are in favor of
accepting draft-chavali-bgp-prefixlimit-02.txt as an IDR WG
document.

Those who were against accepting draft-chavali-bgp-prefixlimit-01.txt
as an IDR WG document need to say whether they are still against
accepting draft-chavali-bgp-prefixlimit-02.txt as an IDR WG document,
or whether draft-chavali-bgp-prefixlimit-02.txt addressed their
objections, and they are now in favor of accepting 
draft-chavali-bgp-prefixlimit-02.txt as an IDR WG document.

And finally, comments from the folks who did not express their
opinion on draft-chavali-bgp-prefixlimit-01.txt would be
greatly appreciated.

Yakov.
------- Forwarded Message

Date:    Sun, 02 May 2004 08:50:26 -0700
From:    Yakov Rekhter <[email-masked]>
To:      [email-masked]
Subject: [Idr] draft-chavali-bgp-prefixlimit-02.txt as an IDR WG document

Folks,

We didn't get sufficient consensus to accept 
draft-chavali-bgp-prefixlimit-01.txt as an IDR WG document. 

The authors of draft-chavali-bgp-prefixlimit-01.txt produced
a new version, draft-chavali-bgp-prefixlimit-02.txt, and would
like the IDR WG to accept this *new* version as an IDR WG document.

Please send comments to the list. The deadline for comments is 
May 17, 2004.

Yakov. 

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

------- End of Forwarded Message

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 11 May 2004 19:35:15 -0400

John:

The question is two-fold

1) How many limits
	(warn, ignore/stop, disconnect)

2) What mechanisms.

It would be good to separate the
discussions into these two parts.

I hope my flurry of email has tried
to focus on this point.

Sue

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]]
Sent: Thursday, May 06, 2004 5:20 PM
To: [email-masked]
Cc: Pekka Savola
Subject: Re: [Idr] draft-chavali-bgp-prefixlimit-02.txt as an IDR WG
document

At 12:59 PM -0400 5/6/04, John G. Scudder wrote:
>At 3:04 PM +0300 5/5/04, Pekka Savola wrote:
...
>>(Both models allow changing the limit on the fly with dynamic capabilities,
>>I think.)
>
>Yes.

To clarify, what we propose in draft-keyur-prefixlimit-orf-00.txt 
allows changing the limit on the fly but uses ORFs rather than 
dynamic capabilities.

--John

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 11 May 2004 19:35:15 -0400

John:

The question is two-fold

1) How many limits

2) What mechanisms.

Sue

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]]
Sent: Thursday, May 06, 2004 5:20 PM
To: [email-masked]
Cc: Pekka Savola
Subject: Re: [Idr] draft-chavali-bgp-prefixlimit-02.txt as an IDR WG
document

...

--John

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 11 May 2004 19:37:40 -0400

Pekka and John:

The feature you describe here:

  >There is another way to specify this as well.  Each router sends the other,
  >_in advance_, when opening the BGP session, their prefix limits; these
  >values are stored per peer.  The sending router checks the length of its
  >adj-ribs-out for the peer whether it exceeds any of these limits, and raises
  >warnings, stops advertising, etc. as appropriate.  (In that model, no
  >compliant router ever exceeds these limits, even temporarily.)

Is in the original draft: It is negotiated at initial OPEN and allowed
to change while connection (ORF/Dyn-Caps are options).

So, are you happy with the 3 limits: warning, ignore, disconnect?
Do you want these limits for all prefixes, a prefix length or
some specific prefix?

Sue

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]]
Sent: Thursday, May 06, 2004 1:00 PM
To: Pekka Savola
Cc: [email-masked]
Subject: Re: [Idr] draft-chavali-bgp-prefixlimit-02.txt as an IDR WG
document

>A high-level comment:
>---------------------
>
>The model seems to be so that when the receiving BGP speaker receives the
>number of routes which exceed a warning, stop or reset limit, it sends a
>message to inform the other router about exceeding this limit, raising a
>warning, askit it to stop, or reset the session.
>
>There is another way to specify this as well.  Each router sends the other,
>_in advance_, when opening the BGP session, their prefix limits; these
>values are stored per peer.  The sending router checks the length of its
>adj-ribs-out for the peer whether it exceeds any of these limits, and raises
>warnings, stops advertising, etc. as appropriate.  (In that model, no
>compliant router ever exceeds these limits, even temporarily.)

Note that this is exactly what we've proposed in 
draft-keyur-prefixlimit-orf-00.txt.

>The main difference here appears to be that the currently specified model
>requires the receiving BGP speaker to react _after_ the incident.  I.e., if
>the neighbor accidentally advertises the whole internet (instead of e.g.,
>100 prefixes), the damage has already been done, and most probably, the BGP
>session has already been reset, because the receiving BGP speaker has
>to have prefix-limits in place in any case to ensure that neighbors
>will honour the limits.
>
>So, IMHO that would argue for notifying the router about your limits in
>advance.. and if the other router does not honor them, raise and alarm, shut
>down the session, etc. on your own if needed.
>
>If you buy the latter model, the error code 5 appears to be unnecessary.
>

Yes.

Regards,

--John