Subject: [Idr] about bgp label routes

From: shengcheng <[email-masked]>
Date: Mon, 12 Feb 2007 19:59:48 +0800

Folks, 

As per RFC3107, which define label route, I have a doubt listed as follows:

When one router receive a label route(suppose it is prefix: 10.1.1.0/24,
label: 200, nexthop: 1.1.1.1), how does the 

router understand this routes? Does it means two routes, one of which is a
label route and the other is ipv4 ordinary route of

10.1.1.0/24 with 1.1.1.1 as nexthop ? Or it means it is just one label route
?  

Thanks

Cheng

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Bhatia, Manav \(Manav\)" <[email-masked]>
Date: Mon, 12 Feb 2007 18:36:45 +0530

Cheng,
 
A labeled route is advertised as label:prefix. 
 
Router is able to parse the incoming (labeled) prefix based on the SAFI
of the route. In your example, it is just one labeled route.
 
Cheers,
Manav

________________________________

	From: shengcheng [mailto:[email-masked]] 
	Sent: Monday, February 12, 2007 5:30 PM
	To: [email-masked]
	Subject: [Idr] about bgp label routes

	Folks, 

	As per RFC3107, which define label route, I have a doubt listed
as follows:

	When one router receive a label route(suppose it is prefix:
10.1.1.0/24, label: 200, nexthop: 1.1.1.1), how does the 

	router understand this routes? Does it means two routes, one of
which is a label route and the other is ipv4 ordinary route of

	10.1.1.0/24 with 1.1.1.1 as nexthop ? Or it means it is just one
label route ?  

	Thanks

	Cheng