Subject: [Idr] BGP Next Hop attribute and MP_REACH_NLRI next hop field

From: "Rohan Sen" <[email-masked]>
Date: Wed, 30 Apr 2008 00:29:02 +0530

Hi All,

For cases in BGP (like VPN) where MP_REACH_NLRI attribute is used to carry
route information in an Update message, we also specify the next hop for the
prefixes inside this attribute itself. But if we are sending IPv4 routes
inside MP_REACH_NLRI->NLRI field, and we also add the standard Next Hop path
attribute then will that carry any special meaning? My confusion is that
whether the NLRI path attribute can coexist with MP_REACH_NLRI attribute or
not. If yes, then in which scenario.

Any help in this regard would be highly appreciated.

-- 
thanks,
Rohan Sen
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Kalpesh Zinjuwadia <[email-masked]>
Date: Tue, 29 Apr 2008 12:22:46 -0700

Does the update in your case have any ipv4-unicast NLRIs (outside the MP_REACH attr)?

Per RFC 2858 (sec 2; last para), if there are no NLRIs (except the ones in MP_REACH_NLRI) to be sent, Next-hop attribute should not be sent. Receiver should ignore Next-hop attribute, if received.

If MP_REACH_NLRI is carrying IPv4 routes, the Next-hop in this attribute itself should be used. Having the Next-hop path attribute should not change anything for these routes.

Thanks,
Kalpesh

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rohan Sen
Sent: Tuesday, April 29, 2008 11:59 AM
To: [email-masked]
Subject: [Idr] BGP Next Hop attribute and MP_REACH_NLRI next hop field

Hi All,

For cases in BGP (like VPN) where MP_REACH_NLRI attribute is used to carry route information in an Update message, we also specify the next hop for the prefixes inside this attribute itself. But if we are sending IPv4 routes inside MP_REACH_NLRI->NLRI field, and we also add the standard Next Hop path attribute then will that carry any special meaning? My confusion is that whether the NLRI path attribute can coexist with MP_REACH_NLRI attribute or not. If yes, then in which scenario.