Subject: [Idr] draft-jakma-mrai as IDR WG document.

From: Yakov Rekhter <[email-masked]>
Date: Thu, 16 Oct 2008 06:07:01 -0700

Folks,

Please send your comments on the attached. The deadline for comments
is Oct 30, 2008.

Yakov.
------- Forwarded Message

Date:    Wed, 15 Oct 2008 13:50:46 +0100
From:    Paul Jakma <[email-masked]>
To:      Inter-Domain Routing List <[email-masked]>
cc:      [email-masked]
Subject: [Idr] Lowering the recommended, default MRAI time

Hi,

Based on various reports, there appears to be some reasonably 
low-hanging fruit wrt BGP convergence times (and possibly in reducing 
the effects of path-hunting slightly): reduce the MRAI time. There 
are probably better, long-term ways to achieve same - but none have 
the same potential for rapid deployment as reducing the MRAI.

The below is an initial attempt to cover the background, and so 
justify revised recommendations of 5s and 1s-or-less for eBGP and 
iBGP MRAI respectively.

I wonder if the WG has any interest in adopting this draft.

Filename:        draft-jakma-mrai
Revision:        00
Title:           Revised Default Values for the BGP 'Minimum Route
Advertisement Interval'
Creation_date:   2008-10-09
WG ID:           Independent Submission
Number_of_pages: 8

Abstract:

This document briefly examines what is known about the effects of the
BGP MRAI timer, particularly on convergence.  It highlights published
work which suggests the MRAI interval as deployed has an adverse
effect on the convergence time of BGP.

It then recommends revised, lower default values for the MRAI timer,
thought to be more suited to today's Internet environment.

(See: http://tools.ietf.org/html/draft-jakma-mrai-00)

regards,
- -- 
Paul Jakma	[email-masked]	[email-masked]	Key ID: 64A2FF6A
Fortune:
God was satisfied with his own work, and that is fatal.
  		-- Samuel Butler
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

------- End of Forwarded Message

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Geoff Huston <[email-masked]>
Date: Fri, 17 Oct 2008 09:10:46 +1100

Hi,

I support WG adoption of this draft

   Geoff

---

From: "Bhatia, Manav \(Manav\)" <[email-masked]>
Date: Fri, 17 Oct 2008 04:43:40 +0530

Yakov,

I believe we should accept this as a WG doc.

Cheers,
Manav 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yakov Rekhter
> Sent: Thursday, October 16, 2008 6.37 PM
> To: [email-masked]
> Subject: [Idr] draft-jakma-mrai as IDR WG document.
> 
> Folks,
>

---

From: Paul Jakma <[email-masked]>
Date: Tue, 21 Oct 2008 15:02:59 +0100 (BST)

Hi,

Thanks to some comments received, I have added some clarifications to 
the document, and changed the 5s recommendation to "5s or less", for 
eBGP MRAI.

Please see:

http://www.ietf.org/internet-drafts/draft-jakma-mrai-01.txt

regards,
-- 
Paul Jakma	[email-masked]	[email-masked]	Key ID: 64A2FF6A
Fortune:
Aim for the moon.  If you miss, you may hit a star.
 		-- W. Clement Stone
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Danny McPherson <[email-masked]>
Date: Tue, 21 Oct 2008 12:52:32 -0600

On Oct 21, 2008, at 8:02 AM, Paul Jakma wrote:

> Hi,
>
> Thanks to some comments received, I have added some clarifications  
> to the document, and changed the 5s recommendation to "5s or less",  
> for eBGP MRAI.

I support the adoption of this as an IDR WG item.

> http://www.ietf.org/internet-drafts/draft-jakma-mrai-01.txt

Given section 4's recommendations, and null security
considerations, how about it recommends that implementations
SHOULD provide a knob to configure the value, independently
per-peer (eBGP or iBGP), and the ability to identify and
notify the operator if persistent or otherwise excessively
unstable prefixes exist?

-danny

---

From: Benno Overeinder <[email-masked]>
Date: Fri, 31 Oct 2008 00:14:11 +0100

I also support the adoption of this draft as an IDR working item.

-- Benno

On 10/16/2008 03:07 PM, Yakov Rekhter wrote:
> <snip/>

-- 
Benno J. Overeinder
NLnet Labs
http://www.nlnetlabs.nl/