Subject: [Idr] New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

From: "Patrick W. Gilmore" <[email-masked]>
Date: Tue, 22 Feb 2011 10:32:32 -0500

I would like to endorse Rob's draft.

-- 
TTFN,
patrick

	• To: grow at ietf.org
	• Subject: [Idr] Fwd: New Version Notification for draft-shakir-idr-ops-reqs-for-bgp-error-handling-01
	• From: Rob Shakir <rjs at rob.sh>
	• Date: Sun, 20 Feb 2011 21:21:37 +0000
	• Cc: IETF IDR <idr at ietf.org>
	• Delivered-to: idr at core3.amsl.com
	• List-archive: <http://www.ietf.org/mail-archive/web/idr>
	• List-help: <mailto:[email-masked]?subject=help>
	• List-id: Inter-Domain Routing <idr.ietf.org>
	• List-post: <mailto:[email-masked]>
	• List-subscribe: <https://www.ietf.org/mailman/listinfo/idr>, <mailto:[email-masked]?subject=subscribe>
	• List-unsubscribe: <https://www.ietf.org/mailman/listinfo/idr>, <mailto:[email-masked]?subject=unsubscribe>
Hi GROW/IDR [0],

One of the problems faced by those operators utilising BGP at the current time are the limited error handling mechanisms that exist within the protocol.  This continues to cause numerous issues, especially with the evolution of BGP-4 within autonomous systems as the signalling protocol of choice.  Where existing work items do exist, in some places they do not completely meet the requirements of modern service provider networks.  This is particularly the case where some compromise to "protocol correctness" is required to meet the robustness requirements.

To this end, the draft forwarded below intends to describe the use cases, and requirements for enhancements to the BGP-4 protocol to meet the robustness requirements of modern SP networks.  In general, most work items are already captured by existing drafts, but my require some extension to meet the requirements specified.  The draft has been presented to a number of operational communities [1], and feedback solicited as to the utility, in general, the feedback I have received is that the approach specified captures the general operational requirements for enhancements to error handling in BGP.

To the end of producing a requirements document to which other work items can be directed, I would very much welcome feedback on this draft from the GROW and IDR communities.

Many thanks in advance for your review.

Kind regards,
Rob

[0]: Please excuse this mail being sent to multiple lists, whilst the majority of the work described within the draft is within the IDR area currently, it was pointed out to me that this draft is perhaps better within the GROW space.  If there are any comments, especially from the relevant WG chairs, I'd be happy to take some guidance as to where this is most suitably discussed.

[1]: Particularly, this draft was presented at NANOG and UKNOF - the slides can be found at 
http://nanog.org/meetings/nanog51/presentations/Tuesday/shakir-bgp-error-handling_rob-shakir-FINAL2.pdf
 - I am hoping that I can make a video of the presentation available within a couple of days if this is of interest.

-----Original Message-----
From: IETF I-D Submission Tool [
mailto:idsubmission
 at ietf.org]
Sent: Sun 2/20/2011 9:03 PM
To: Shakir, Rob
Subject: New Version Notification for          draft-shakir-idr-ops-reqs-for-bgp-error-handling-01

A new version of I-D, draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt has been successfully submitted by Rob Shakir and posted to the IETF repository.

Filename:	 draft-shakir-idr-ops-reqs-for-bgp-error-handling
Revision:	 01
Title:		 Operational Requirements for Enhanced Error Handling Behaviour in BGP-4
Creation_date:	 2011-02-20
WG ID:		 Independent Submission
Number_of_pages: 22

Abstract:
BGP-4 is utilised as a key intra- and inter-Autonomous System routing
protocol in modern IP networks.  The failure modes as defined by the
original protocol standards are based on a number of assumptions
around the impact of session failure.  Numerous incidents both in the
global Internet routing table and within Service Provider networks
have been caused by strict handling of a single invalid UPDATE
message causing large-scale failures in one or more Autonomous
Systems.

This memo describes the current use of BGP-4 within Service Provider
networks, and outlines a set of requirements for further work to
enhance the mechanisms available to a BGP-4 implementation when
erroneous data is detected.  Whilst this document does not provide
specification of any standard, it is intended as an overview of a set
of enhancements to BGP-4 to improve the protocol's robustness to suit
its current deployment.

The IETF Secretariat.

---

From: "Gould, Edward" <[email-masked]>
Date: Tue, 22 Feb 2011 17:43:18 +0000

Another endorsement from me.

Edd.

Sent from my iPhone

On 22 Feb 2011, at 17:32, "Patrick W. Gilmore" <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

NOTICE AND DISCLAIMER
This e-mail (including any attachments) is intended for the above-named person(s).  If you are not the intended recipient, notify the sender immediately, delete this email from your system and do not disclose or use for any purpose.  
 
We may monitor all incoming and outgoing emails in line with current legislation. We have taken steps to ensure that this email and attachments are free from any virus, but it remains your responsibility to ensure that viruses do not adversely affect you. 

Everything Everywhere Limited
Registered in England and Wales
Company Registered Number: 02382161
Registered Office Address: Hatfield Business Park, Hatfield, Hertfordshire, AL10 9BW