Subject: Re: [Idr] I-D Action:draft-ietf-idr-rfc4760bis-00.txt

From: Yakov Rekhter <[email-masked]>
Date: Wed, 16 Feb 2011 06:12:49 -0800

Ilya,

> As I've previously mentioned in private conversation, this draft
> seem like a perfect place to address an issue of intermixing various
> SAFI of the same AFI.  The problem has been discussed here at IDR
> ("interoperability of 6PE and native -IPv6 within same network" -
> http://www.ietf.org/mail-archive/web/idr/current/m sg04364.html).
> What's group view on adding something along following line to th e
> draft: if a route has been learned from AFI=x SAFI=y1, then BGP
> speaker MAY NOT advertise it over a SAFI=y2 session unless speaker
> sets itself as NEXT_HOP?

To address the above let me propose that we'll add the following:

   A router SHALL NOT redistribute routing information received
   over one particular combination of <AFI, SAFI> into another <AFI,
   SAFI> unless explicitly configured. The implications of doing
   such redistribution are numerous and serious, but outside the
   scope of this document. If a router is explicitly configured
   to redistribute routing information received over one particular
   combination of <AFI, SAFI> over another <AFI, SAFI>, then when
   redistributing the information the router MUST set NEXT_HOP to
   self.

In the absence of any objections within the next two weeks I'll
re-issue a revised version that will include the above text.
  
Yakov.

>  
> On Jan 10, 2011, at 18:45 , [email-masked] wrote:
> 
> > A New Internet-Draft is available from the on-line Internet-Drafts director
ies.
> > This draft is a work item of the Inter-Domain Routing Working Group of the 
IETF.
> > 
> > 
> > 	Title           : Multiprotocol Extensions for BGP-4
> > 	Author(s)       : R. Chandra, et al.
> > 	Filename        : draft-ietf-idr-rfc4760bis-00.txt
> > 	Pages           : 12
> > 	Date            : 2011-01-10
> > 
> > This document defines extensions to BGP-4 to enable it to carry
> > routing information for multiple Network Layer protocols (e.g., IPv6,
> > IPX, L3VPN, etc...). The extensions are backward compatible - a
> > router that supports the extensions can interoperate with a router
> > that doesn't support the extensions.
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-idr-rfc4760bis-00.txt
> > 
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> > 
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> > <Mail Attachment>_______________________________________________
> > Idr mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/idr
> 
> /iLya
> 
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Rob Shakir <[email-masked]>
Date: Sun, 20 Feb 2011 12:28:19 +0000

Hi,

I would like to lend my support to both of the clarifications discussed herein.

In terms of the empty MP_REACH and MP_UNREACH NLRI, there are existing implementations that do treat this as an error, therefore it is of advantage from my perspective to confirm that this is not erroneous behaviour. The existing texts do not appear to provide clear guidance on this part, and I am aware of situations where this has caused disruption.

I would also like to add a +1 on the clarification of the inter-<AFI,SAFI> route distribution, as Ilya has noted previously, this leads to very unexpected consequences.

Many thanks,
Rob