Subject: [Idr] I-D Action: draft-ietf-idr-add-paths-guidelines-02.txt

From: [email-masked]
Date: Fri, 25 Nov 2011 11:08:08 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

	Title           : Best Practices for Advertisement of Multiple Paths in IBGP
	Author(s)       : Jim Uttaro
                          Virginie Van den Schrieck
                          Pierre Francois
                          Roberto Fragassi
                          Adam Simpson
                          Pradosh Mohapatra
	Filename        : draft-ietf-idr-add-paths-guidelines-02.txt
	Pages           : 22
	Date            : 2011-11-25

   Add-Paths is a BGP enhancement that allows a BGP router to advertise
   multiple distinct paths for the same prefix/NLRI. This provides a
   number of potential benefits, including reduced routing churn, faster
   convergence and better loadsharing.

   This document provides recommendations to implementers of Add-Paths
   so that network operators have the tools needed to address their
   specific applications and to manage the scalability impact of Add-
   Paths. A router implementing Add-Paths may learn many paths for a
   prefix and must decide which of these to advertise to peers. This
   document analyses different algorithms for making this selection and
   provides recommendations based on the target application.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-idr-add-paths-guidelines-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-idr-add-paths-guidelines-02.txt

---

From: "Simpson, Adam (Adam)" <[email-masked]>
Date: Fri, 25 Nov 2011 13:32:32 -0600

This is a minor update from the -01 version.

The authors would appreciate feedback on this latest version. For those that have not read the draft it attempts to fill in details about the different use cases for Add-Paths, the configuration flexibility required by these use cases, and related interoperability considerations. Any feedback is welcome but input on the specific questions below would be particularly helpful.

Path selection modes:

1. A while ago a suggestion was made that the document consider an Add-N-best-external mode. The authors have discussed this and believe such a mode does not offer useful value above and beyond the Add-N mode.

2. We discussed at the IETF81 meeting the potential value of a new path selection mode that selects all paths or the N best paths with a specific community value. The authors are inclined to add this new mode to a future version of the draft. Are there strong views for or against inclusion of this new mode?

3. Beyond the new mode discussed in the previous point, there are no plans to document any further path selection modes. If there is a compelling use case for a mode we have not considered this should be brought to our attention either on- or off-list.

Changes to the Add-Paths capability:

1. The Add-Paths capability, as currently defined in draft-ietf-idr-add-paths, provides no means of signaling the max number of paths per prefix the local speaker would like to receive from its Add-Paths capable neighbor. Routers in certain roles may have a soft or hard constraint about the number of paths per prefix they want to receive from selected peers, and could signal this constraint on a per AFI/SAFI basis to help the sender with its path selection. Would it be useful to extend the Add-Paths capability to include this max paths request? As usual, the routing consistency risks of advertising a different set of paths to different neighbors must be carefully considered.

Regards,

Authors

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, November 25, 2011 2:08 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Idr] I-D Action: draft-ietf-idr-add-paths-guidelines-02.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Inter-Domain Routing
> Working Group of the IETF.
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr