Subject: Re: [Idr] Accept draft-wkumari-idr-as0-01.txt ?

From: Brian Dickson <[email-masked]>
Date: Sun, 13 Nov 2011 18:20:44 -0500

I have read this (very succinct) draft and support it being adopted as
a WG item.

(I encourage everyone to read this and voice their opinion, BTW.)

I would support it as it stands for WGLC, should there be an interest in such.

And also "+ 1,000,000" in level of support.

Brian

On Fri, Oct 28, 2011 at 4:51 PM, John Scudder <[email-masked]> wrote:
> Folks,
>
> Please send comments to the list prior to the IDR meeting on November 15.
>
> Thanks,
>
> --John
>
> On Oct 27, 2011, at 9:29 AM, Warren Kumari wrote:
>
>> Hello IDRites,
>>
>> I would like to draw your attention to draft-wkumari-idr-as0-01.txt  ( http://tools.ietf.org/html/draft-wkumari-idr-as0-01 ) - I am asking that this draft be considered for WG adoption.
>>
>>
>> I have already received some feedback, mainly suggesting:
>>
>> - Add a text for AS number 0 as a reserved in Aggregator and AS4
>> Aggregator attribute
>>
>> - Add text for AS number 0 as a reserved value in communities and
>> extended communities. (RFC 1997 and Four-octet AS Specific Extended
>> Communities)
>>
>> Also suggested was providing a little more information on what to do it you do receive a route containing AS0  (more descriptive than just "MUST NOT accept" (for example, stating that it should be "excluded from the Phase 2 decision function")).
>>
>> Anyway, I would value your feedback and input.
>>
>> W
>>
>>
>>
>> _______________________________________________
>> Idr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/idr
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Christopher Morrow <[email-masked]>
Date: Sun, 13 Nov 2011 20:25:27 -0500

I find it odd that we need this, but accept that it is here...
I also would support this work.

thanks!
-chris

---

From: Enke Chen <[email-masked]>
Date: Sun, 13 Nov 2011 17:30:08 -0800

Support, but with the following suggestions:

1) Nit: change "bgp listener" to "bgp speaker".

2) The following language is not very precise.  Due to the incremental nature, we will need to remove the existing route too.

-----
    a BGP
    listener MUST NOT accept an announcement which has an AS number of
    zero in the AS-PATH attribute, and SHOULD log the fact that it has
    done so.
-----

    How about the following:

    An UPDATE message that contains the AS number of zero in the AS-PATH attribute
    MUST be considered as malformed, and be handled by the procedures specified in
    draft-ietf-idr-optional-transitive-04.txt

3) If this draft is adopted, we should also add AS 0 as one of the error conditions in
rfc4893bis.

Thanks.   -- Enke

On 10/28/11 1:51 PM, John Scudder wrote:
>> I would like to draw your attention to draft-wkumari-idr-as0-01.txt  (http://tools.ietf.org/html/draft-wkumari-idr-as0-01  ) - I am asking that this draft be considered for WG adoption.
>>
>>

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 13 Nov 2011 20:25:58 -0500

+1

Regards,
Jeff

---

From: Arturo Servin <[email-masked]>
Date: Sun, 13 Nov 2011 23:48:46 -0200

Warren,

Wouldn't this be a DoS attack vector if the attacker originates a valid prefix with ASN0?

It wouldn't be a global attack, but it may generate some local black holes for the victim, is it?

Regards,
-as

---

From: Jakob Heitz <[email-masked]>
Date: Sun, 13 Nov 2011 21:46:01 -0500

+1 (Enke's suggestion)

--
Jakob Heitz.

On Nov 13, 2011, at 5:28 PM, "Enke Chen" <[email-masked]<mailto:[email-masked]>> wrote:

-----
   a BGP

   How about the following:

Thanks.   -- Enke

Folks,

Thanks,

--John

Hello IDRites,

W

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: Warren Kumari <[email-masked]>
Date: Sat, 19 Nov 2011 17:57:28 -0500

> 1) Nit: change "bgp listener" to "bgp speaker".

Thank you, done.

> 3) If this draft is adopted, we should also add AS 0 as one of the error conditions in

John also provided some text for that section and Keyur suggested that we log and treat as a WITHDRAW. 

This would read as:
"This document specifies that a BGP speaker MUST NOT originate or propagate a route with an AS number of zero.  If a BGP speaker receives a route which has an AS number of zero in the AS_PATH attribute, it SHOULD be logged and treated as a WITHDRAW."

This avoids having a normative reverence to the optional-transitive draft and is (IMO) a little clearer. It also saves optional-transitive from referencing this, and so we avoid the deadlock...

Thoughts?

W

>>> I would like to draw your attention to draft-wkumari-idr-as0-01.txt  ( 
>>> http://tools.ietf.org/html/draft-wkumari-idr-as0-01
>>>  ) - I am asking that this draft be considered for WG adoption.
>>> 
>>>