Subject: Re: [Idr] Accept draft-wkumari-idr-as0-01.txt ?

From: Christopher Morrow <[email-masked]>
Date: Thu, 1 Dec 2011 15:38:47 -0500

On Sat, Nov 19, 2011 at 5:57 PM, Warren Kumari <[email-masked]> wrote:
>
> On Nov 13, 2011, at 8:30 PM, Enke Chen wrote:
>
>> Support, but with the following suggestions:
>>
>> 1) Nit: change "bgp listener" to "bgp speaker".
>
> Thank you, done.
>
>>
>> 2) The following language is not very precise.  Due to the incremental nature, we will need to remove the existing route too.
>>
>> -----
>>    a BGP
>>    listener MUST NOT accept an announcement which has an AS number of
>>    zero in the AS-PATH attribute, and SHOULD log the fact that it has
>>    done so.
>> -----
>>
>>    How about the following:
>>
>>    An UPDATE message that contains the AS number of zero in the AS-PATH attribute
>>    MUST be considered as malformed, and be handled by the procedures specified in
>>
>> draft-ietf-idr-optional-transitive-04.txt
>>
>> 3) If this draft is adopted, we should also add AS 0 as one of the error conditions in
>> rfc4893bis.
>
> John also provided some text for that section and Keyur suggested that we log and treat as a WITHDRAW.
>
> This would read as:
> "This document specifies that a BGP speaker MUST NOT originate or propagate a route with an AS number of zero.  If a BGP speaker receives a route which has an AS number of zero in the AS_PATH attribute, it SHOULD be logged and treated as a WITHDRAW."
>

a question came up recently (today) on nanog about how AS0 should be
treated wrt AGGREGATOR attributes... Should this say use of AS0
anywhere (make a list perhaps?) is verboten? (or was that assumed
already?)

> This avoids having a normative reverence to the optional-transitive draft and is (IMO) a little clearer. It also saves optional-transitive from referencing this, and so we avoid the deadlock...
>
> Thoughts?
>
> W
>
>
>>
>> Thanks.   -- Enke
>>
>>
>> On 10/28/11 1:51 PM, John Scudder wrote:
>>> Folks,
>>>
>>> Please send comments to the list prior to the IDR meeting on November 15.
>>>
>>> Thanks,
>>>
>>> --John
>>>
>>> On Oct 27, 2011, at 9:29 AM, Warren Kumari wrote:
>>>
>>>
>>>> Hello IDRites,
>>>>
>>>> I would like to draw your attention to draft-wkumari-idr-as0-01.txt  (
>>>> http://tools.ietf.org/html/draft-wkumari-idr-as0-01
>>>>  ) - I am asking that this draft be considered for WG adoption.
>>>>
>>>>
>>>> I have already received some feedback, mainly suggesting:
>>>>
>>>> - Add a text for AS number 0 as a reserved in Aggregator and AS4
>>>> Aggregator attribute
>>>>
>>>> - Add text for AS number 0 as a reserved value in communities and
>>>> extended communities. (RFC 1997 and Four-octet AS Specific Extended
>>>> Communities)
>>>>
>>>> Also suggested was providing a little more information on what to do it you do receive a route containing AS0  (more descriptive than just "MUST NOT accept" (for example, stating that it should be "excluded from the Phase 2 decision function")).
>>>>
>>>> Anyway, I would value your feedback and input.
>>>>
>>>> W
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Idr mailing list
>>>>
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/idr
>>> _______________________________________________
>>> Idr mailing list
>>>
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/idr
>>
>>
>> _______________________________________________
>> Idr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/idr
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Warren Kumari <[email-masked]>
Date: Thu, 1 Dec 2011 16:50:49 -0500

[ Changed subject to reflect new title ]

> anywhere (make a list perhaps?) is verboten? (or was that assumed

Actually Keyur Patel already pointed out the Aggregator (and AS4 Aggregator) attribute issue, and I included text in the WG version of the doc, which I posted recently (although I have just realized that I entered the text as "Aggregator" and not "AGGREGATOR", same for AS4...)

Which reminds me -- would folk please review draft-ietf-idr-as0-00 ( http://tools.ietf.org/html/draft-ietf-idr-as0-00 ) and provide feedback?
I *think* that I incorporated everyones comments, although I accidentally overwrote the changed version with an older version (never edit a file in two editors at once :-)) and so may have missed some...

W

---

From: Enke Chen <[email-masked]>
Date: Thu, 01 Dec 2011 14:18:21 -0800

Warren:

I do not agree with the new text in the draft:

----
    This document specifies that a BGP speaker MUST NOT originate or
    propagate a route with an AS number of zero.  If a BGP speaker
    receives a route which has an AS number of zero in the AS_PATH (or
    AS4_PATH) attribute, it SHOULD be logged and treated as a WITHDRAW.
    This same behavior applies to routes containing zero as the
    Aggregator or AS4 Aggregator.

-----

The presence of AS 0 is considered as an error.  The handling of the 
error condition should be specific to that attribute.  That is:

    o For the AS4_PATH and AS4_AGGREGATOR, the action is "attribute 
discard" as specified in the rfc4893bis.

    o For the AGGREGATOR, the action is also "attribute discard" as 
specified in draft-ietf-idr-error-handling-00.txt

I still think and continue to recommend that you merely describe that AS 
0 is an error condition in the draft, and let the error handling draft 
do the rest, as I suggested before:

-- Enke

On 12/1/11 1:50 PM, Warren Kumari wrote:
>> On Sat, Nov 19, 2011 at 5:57 PM, Warren Kumari<[email-masked]>  wrote:

---

From: Warren Kumari <[email-masked]>
Date: Thu, 1 Dec 2011 17:44:08 -0500

On Dec 1, 2011, at 5:18 PM, Enke Chen wrote:

> The presence of AS 0 is considered as an error.  The handling of the error condition should be specific to that attribute.  That is:
> 
>    o For the AS4_PATH and AS4_AGGREGATOR, the action is "attribute discard" as specified in the rfc4893bis.
> 
>    o For the AGGREGATOR, the action is also "attribute discard" as specified in draft-ietf-idr-error-handling-00.txt
> 
> 
> I still think and continue to recommend that you merely describe that AS 0 is an error condition in the draft, and let the error handling draft do the rest, as I suggested before:
> 

Sure -- I was trying to avoid having this draft gate on publication of the idr-optional-transitive draft, but (of course) am happy to do whatever the WG wants (hint to WG: please let me know what you want :-P)

W

>> Which reminds me -- would folk please review draft-ietf-idr-as0-00 ( 
>> http://tools.ietf.org/html/draft-ietf-idr-as0-00
>>  ) and provide feedback?

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 1 Dec 2011 17:49:30 -0500

I agree.
draft-ietf-idr-optional-transitive-04 has been recently revised and renamed
draft-ietf-idr-error-handling.

--
Jakob Heitz.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Warren Kumari
Sent: Thursday, December 01, 2011 2:44 PM
To: Enke Chen
Cc: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

W

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 1 Dec 2011 17:51:47 -0500

+1

Let's keep error condition and error handling separately

Regards,
Jeff

From: [email-masked] [mailto:[email-masked]] On Behalf Of Enke Chen
Sent: Thursday, December 01, 2011 2:18 PM
To: Warren Kumari
Cc: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

Warren:

----

-- Enke

On Sat, Nov 19, 2011 at 5:57 PM, Warren Kumari <[email-masked]><mailto:[email-masked]> wrote:

Thank you, done.

-----

   a BGP

   done so.

-----

   How about the following:

rfc4893bis.

This would read as:

already?)

W

Thoughts?

W

Thanks.   -- Enke

Folks,

Thanks,

--John

Hello IDRites,

Aggregator attribute

Communities)

W

Idr mailing list

[email-masked]<mailto:[email-masked]>

Idr mailing list

[email-masked]<mailto:[email-masked]>

Idr mailing list

[email-masked]<mailto:[email-masked]>

Idr mailing list

[email-masked]<mailto:[email-masked]>

---

From: Danny McPherson <[email-masked]>
Date: Thu, 1 Dec 2011 20:56:20 -0500

I agre with Enke here as well...

-danny

---

From: <[email-masked]>
Date: Mon, 5 Dec 2011 12:40:06 +0100

Hi Enke, all

1)

Interesting.

draft-ietf-idr-error-handling-00 says that the action MUST be
"treat-as-withdraw" unless the attribute has no effect on route
selection or installation. AS4_PATH _has_ effect on route installation
(AS loop detection in AS4_PATH).

I understand the reasons for both, yet are we sure we want to do this?
(defines 2 different error handling behavior for the same attribute,
write two draft which somehow disagree, with current wording (MUST) it
will be hard for an implementation to ever be compliant with both
documents).

I don't have a strong opinion, just raising the point for discussion.

2) draft-ietf-idr-rfc4893bis-04

"6. Error Handling

   Given that the two-octet AS numbers dominate during the transition,

   and are carried in the AS_PATH attribute by an OLD BGP speaker, in

   this document the "attribute discard" approach is chosen to handle a

   malformed AS4_PATH attribute."

"Given that the two-octet AS numbers dominate during the transition"
IMHO, I don't think this is the best reason as for example in some part
of the some inter-network, four-octet AS number could dominate. IMHO a
better reason could be that if all the ASes forming the loop are
four-octet compliant, then AS4_PATH will not be used and hence there is
no problem with that attribute. Otherwise, the AS_PATH attribute will
catch the loop.

Regards,

Bruno

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Enke Chen
Sent: Thursday, December 01, 2011 11:18 PM
To: Warren Kumari
Cc: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

Warren:

----

-----

   An UPDATE message that contains the AS number of zero in the AS-PATH
attribute
   MUST be considered as malformed, and be handled by the procedures
specified in
   draft-ietf-idr-optional-transitive-04.txt

-- Enke

	On Sat, Nov 19, 2011 at 5:57 PM, Warren Kumari
<[email-masked]> <mailto:[email-masked]>  wrote:

			 

		Thank you, done.

			2) The following language is not very precise.
Due to the incremental nature, we will need to remove the existing route
too.
			 
			-----
			   a BGP
			   listener MUST NOT accept an announcement
which has an AS number of
			   zero in the AS-PATH attribute, and SHOULD log
the fact that it has
			   done so.
			-----
			 
			   How about the following:
			 
			   An UPDATE message that contains the AS number
of zero in the AS-PATH attribute
			   MUST be considered as malformed, and be
handled by the procedures specified in

			3) If this draft is adopted, we should also add
AS 0 as one of the error conditions in
			rfc4893bis.

		John also provided some text for that section and Keyur
suggested that we log and treat as a WITHDRAW.
		 
		This would read as:
		"This document specifies that a BGP speaker MUST NOT
originate or propagate a route with an AS number of zero.  If a BGP
speaker receives a route which has an AS number of zero in the AS_PATH
attribute, it SHOULD be logged and treated as a WITHDRAW."

	a question came up recently (today) on nanog about how AS0
should be
	treated wrt AGGREGATOR attributes... Should this say use of AS0
	anywhere (make a list perhaps?) is verboten? (or was that
assumed
	already?)

Actually Keyur Patel already pointed out the Aggregator (and AS4
Aggregator) attribute issue, and I included text in the WG version of
the doc, which I posted recently (although I have just realized that I
entered the text as "Aggregator" and not "AGGREGATOR", same for AS4...)
 
Which reminds me -- would folk please review draft-ietf-idr-as0-00 (
http://tools.ietf.org/html/draft-ietf-idr-as0-00 ) and provide feedback?
I *think* that I incorporated everyones comments, although I
accidentally overwrote the changed version with an older version (never
edit a file in two editors at once :-)) and so may have missed some...
 
W

		This avoids having a normative reverence to the
optional-transitive draft and is (IMO) a little clearer. It also saves
optional-transitive from referencing this, and so we avoid the
deadlock...
		 
		Thoughts?
		 
		W

			Thanks.   -- Enke

				Folks,
				 
				Please send comments to the list prior
to the IDR meeting on November 15.
				 
				Thanks,
				 
				--John
				 
				On Oct 27, 2011, at 9:29 AM, Warren
Kumari wrote:

				Hello IDRites,
				 
				I would like to draw your attention to
draft-wkumari-idr-as0-01.txt  (
	
http://tools.ietf.org/html/draft-wkumari-idr-as0-01
				 ) - I am asking that this draft be
considered for WG adoption.

				I have already received some feedback,
mainly suggesting:
				 
				- Add a text for AS number 0 as a
reserved in Aggregator and AS4
				Aggregator attribute
				 
				- Add text for AS number 0 as a reserved
value in communities and
				extended communities. (RFC 1997 and
Four-octet AS Specific Extended
				Communities)
				 
				Also suggested was providing a little
more information on what to do it you do receive a route containing AS0
(more descriptive than just "MUST NOT accept" (for example, stating that
it should be "excluded from the Phase 2 decision function")).
				 
				Anyway, I would value your feedback and
input.
				 
				W

	
				 
				[email-masked]

				 
				[email-masked]

---

From: <[email-masked]>
Date: Mon, 5 Dec 2011 12:40:09 +0100

I agree with Enke.

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jeff Tantsura
Sent: Thursday, December 01, 2011 11:52 PM
To: Enke Chen; Warren Kumari
Cc: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

+1

Regards,

Jeff

Warren:

----

-----

-- Enke

			 

		Thank you, done.

			 
			-----
			   a BGP
			 
			   How about the following:

			 

		This would read as:

 
 
W

		 
		Thoughts?
		 
		W

			Thanks.   -- Enke

				Folks,

				Thanks,
				 
				--John

				Hello IDRites,

				 

				 
				 
				W

	
				 
				[email-masked]

				 
				[email-masked]

---

From: Jakob Heitz <[email-masked]>
Date: Mon, 5 Dec 2011 10:09:25 -0500

+1

--
Jakob Heitz.

On Dec 5, 2011, at 3:41 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

I agree with Enke.

> Let’s keep error condition and error handling separately
+1

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Thursday, December 01, 2011 11:52 PM
To: Enke Chen; Warren Kumari
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

+1

Let’s keep error condition and error handling separately

Regards,
Jeff

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Enke Chen
Sent: Thursday, December 01, 2011 2:18 PM
To: Warren Kumari
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] draft-ietf-idr-as0-00 ?

Warren:

----

-- Enke

Thank you, done.

-----

   a BGP

   done so.

-----

   How about the following:

rfc4893bis.

This would read as:

already?)

W

Thoughts?

W

Thanks.   -- Enke

Folks,

Thanks,

--John

Hello IDRites,

Aggregator attribute

Communities)

W

Idr mailing list

Idr mailing list

Idr mailing list

Idr mailing list

---

From: Enke Chen <[email-masked]>
Date: Tue, 06 Dec 2011 15:48:48 -0800

Sue,

Sure, we can certainly do that if that is what the chairs want us to do.

Basically,  we can list AS 0 as an additional error condition for the 
AS-PATH attribute.

-- Enke

On 12/6/11 3:40 PM, [email-masked] wrote:
> Enke:
>
> Are you willing to incorporate the as 0 hanlong in your error draft?
>
> Sue
> Sent via BlackBerry by AT&T
>
> From: Danny McPherson<[email-masked]>
> Sender: [email-masked]
> Date: Thu, 1 Dec 2011 20:56:20
> To: Enke Chen<[email-masked]>; Warren Kumari<[email-masked]>
> Cc: [email-masked] List<[email-masked]>