Subject: [Idr] I-D Action: draft-ietf-idr-as0-01.txt

From: [email-masked]
Date: Fri, 16 Dec 2011 10:23:24 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

	Title           : Codification of AS 0 processing.
	Author(s)       : Warren Kumari
                          Randy Bush
                          Heather Schiller
	Filename        : draft-ietf-idr-as0-01.txt
	Pages           : 6
	Date            : 2011-12-16

   This document proscribes the use of AS 0 in BGP OPEN and AS_PATH /
   AS4_PATH BGP attribute.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-idr-as0-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-idr-as0-01.txt

---

From: Warren Kumari <[email-masked]>
Date: Fri, 16 Dec 2011 13:39:30 -0500

As requested, this version separates the error definition and error handling by pointing to the draft-ietf-idr-error-handling document...

Thanks to everyone who provided feedback on -00.
W

On Dec 16, 2011, at 1:23 PM, [email-masked] wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 16 Dec 2011 13:59:23 -0500

Looks good to me.

--
Jakob Heitz.

---

From: Warren Kumari <[email-masked]>
Date: Fri, 16 Dec 2011 14:16:46 -0500

[ Trimming that announce-list and id lists, which I forgot to do in the initial mail ]  ] 

> Looks good to me.

Thank you sir.

Folk often forget how important explicit LGTMs like this are on a document.
It's always more fun / interesting to respond with concerns/ issues, but explicitly ACK'ing helps the authors know that they are doing what is asked of them. Without this it is hard for the authors to know if the lack of responses is because folk approve and haven't said so or just haven't yet had a chance to read the document...

W

---

From: Enke Chen <[email-masked]>
Date: Fri, 16 Dec 2011 17:05:47 -0800

Warren:

A couple comments:

   1) Is it really necessary to make AS 0 an error in the AGGREGATOR and 
AS4_AGGREGATOR attributes?  What is the gain?

   2) The error handling for AS4_PATH / AS4_AGGREGATOR is specified in 
rfc4893bis (draft-ietf-idr-rfc4893bis-04.txt). Thus it should be 
referenced if you specify AS 0 as an error for the AS4_PATH / 
AS4_AGGREGATOR.

Thanks.  -- Enke

do not have much impact.  Why

---

From: Warren Kumari <[email-masked]>
Date: Sat, 17 Dec 2011 12:26:10 -0500

On Dec 16, 2011, at 8:05 PM, Enke Chen wrote:

> Warren:
> 
> A couple comments:
> 
>  1) Is it really necessary to make AS 0 an error in the AGGREGATOR and AS4_AGGREGATOR attributes?  What is the gain?

I'll double check with co-authors on Monday -- I don't think it is strictly necessary to prevent attack, rather it seemed more elegant to check AS 0 where ever it occurs.

It was brought up on the NANOG list that some vendors support zero'ing out the AGGREGATOR (see Junipers "no-aggregator-id" as an example -- this appears to only zero out the router ID, but I haven't checked all implementations), so checking for AS 0 in the .*AGGREGATOR may be a bad idea, so at the moment I'm leaning towards removing it (obviously, this being a WG doc, with the WG's approval)

> 
>  2) The error handling for AS4_PATH / AS4_AGGREGATOR is specified in rfc4893bis (draft-ietf-idr-rfc4893bis-04.txt). Thus it should be referenced if you specify AS 0 as an error for the AS4_PATH / AS4_AGGREGATOR.
> 

Doh! This was mentioned a few times and I intended to do so, but it completely slipped my mind when typing... Thanks for reminding me....

W