Subject: [Idr] I-D Action: draft-ietf-idr-last-as-reservation-01.txt

From: [email-masked]
Date: Tue, 15 Oct 2013 09:33:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

	Title           : Reservation of Last Autonomous System (AS) Numbers
	Author(s)       : Jeffrey Haas
                          Jon Mitchell
	Filename        : draft-ietf-idr-last-as-reservation-01.txt
	Pages           : 4
	Date            : 2013-10-15

Abstract:
   This document reserves two Autonomous System numbers (ASNs) at the
   end of the 16 bit and 32 bit ranges, described in this document as
   "Last ASNs" and provides guidance to implementers and operators on
   their use.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-last-as-reservation

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-idr-last-as-reservation-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-idr-last-as-reservation-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 15 Oct 2013 12:51:29 -0400

We suspect this latest version clears any remaining issues.  Given that
the draft is thin IANA administravia at best, the draft may be ready for
WGLC.

-- Jeff

On Tue, Oct 15, 2013 at 09:33:49AM -0700, [email-masked] wrote:
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: David Farmer <[email-masked]>
Date: Fri, 18 Oct 2013 13:13:36 -0500

Looks good to me and I also think it is ready for WGLC.

-- 
================================================
David Farmer               Email: [email-masked]
Office of Information Technology
University of Minnesota
2218 University Ave SE     Phone: 1-612-626-0815
Minneapolis, MN 55414-3029  Cell: 1-612-812-9952
================================================

---

From: Matthew Jones <[email-masked]>
Date: Wed, 23 Oct 2013 15:30:52 +0000

I *could* take care of this.   I'm assuming that it means I need to change my diff,
including comments…

+/*
+ * Define the private AS number address range specified in RFC 6996
+ */
+#define AS_PRIV_START 64512         /**< lower bound for 2-byte private AS range */
+#define APE_RFC6996 65534
+#define AS_PRIV_END (APE_RFC6996+1) /**< upper bound for 2-byte private AS range.
+                                     @note exception to RFC 6996 value.
+                                     Previously AS_PRIV_END was incorrect (it included
+                                     65535, which is reserved), but it is best
+                                     not to change this to avoid breaking some deployed
+                                     networks that may be using that value.
+                                     So, we continue to use the plus one value instead
+                                     of the RFC 6996 specified value of 65534. */

My reading says that we are forbidden to consider 65535 as a private-as, but at the
same time, we should filter it on inbound.   So, perhaps only my comment needs to change?
(i.e. the reason we cheat on the range def is so we can influence the inbound filter?)
I think I didn't really know the reason for the range extension, and just guessed…

matthew