Subject: [Idr] draft-gredler-idr-ls-distribution-impl

From: <[email-masked]>
Date: Tue, 25 Feb 2014 10:16:49 +0000

Hi Hannes, Balaji, Saikat, Manish

Many thanks for the detailed hence useful implementation report.

I'm not that familiar with implementation reports so please excuse some possibly naive comments below:

> the BGP Link-State Information Distribution protocol as defined in [I-D.ietf-idr-ls-distribution]

Draft could change over the time. I guess it could still change.
So what about indicating the draft version number which is considered to be the reference/spec?

> Release: IOS-XR
> Release: JUNOS

Same comments for OS version.

> 4.  Link NLRI TLV support

>                  +--------------+--------+-------+-----+
>                  |              | IOS-XR | JUNOS | TBD |
>                  +--------------+--------+-------+-----+
>                  | Rcv.TLV 256  |   YES  |  YES  | --- |
[...]
>                  | Rcv.TLV 513  |   ---  |  YES  | --- |
>                  | Snd.TLV 513  |   ---  |   NO  | --- |

For the Cisco IOS-XR data, what does "---" means? Yes? No? Don't know?

> In particular we have tested our interoperability with Cisco Systems, Inc. IOS-XR implementation.

Good. Could you please share some details about the result of the tests? Something likes: all NLRI subtypes and NLRI TLV supported by both implementations (as per this document) were found to be interoperable.
---

On a side note, I'm not sure to see the value of section 7.3 "TBD Implementation", nor sentence like "The Cisco Systems, Inc. IOS-XR implementation should be interoperable with other vendor BGP-LS Protocol implementations"

Thanks,
Regards,
Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Hannes Gredler <[email-masked]>
Date: Fri, 28 Feb 2014 22:09:10 +0100

hi bruno,

see answers inline;

On Tue, Feb 25, 2014 at 10:16:49AM +0000, [email-masked] wrote:
| Hi Hannes, Balaji, Saikat, Manish
| 
| Many thanks for the detailed hence useful implementation report.
| 
| I'm not that familiar with implementation reports so please excuse some possibly naive comments below:
| 
| > the BGP Link-State Information Distribution protocol as defined in [I-D.ietf-idr-ls-distribution]
| 
| Draft could change over the time. I guess it could still change.
| So what about indicating the draft version number which is considered to be the reference/spec?

the relationship between the anchor tag and teh actual draft version is defined in the
in the <references> section:

---
11.  Informative References

   [I-D.ietf-idr-ls-distribution]
              Gredler, H., Medved, J., Previdi, S., Farrel, A., and S.
              Ray, "North-Bound Distribution of Link-State and TE
              Information using BGP", draft-ietf-idr-ls-distribution-04
                                                                   ^^^^^
              (work in progress), November 2013.

---

| 
| > Release: IOS-XR
| > Release: JUNOS
| 
| Same comments for OS version.

the test has been executed with engineering images, we will update
it with the actual release numbers as soon as product management
has determined release dates, targets platforms etc.

| > 4.  Link NLRI TLV support
| 
| >                  +--------------+--------+-------+-----+
| >                  |              | IOS-XR | JUNOS | TBD |
| >                  +--------------+--------+-------+-----+
| >                  | Rcv.TLV 256  |   YES  |  YES  | --- |
| [...]
| >                  | Rcv.TLV 513  |   ---  |  YES  | --- |
| >                  | Snd.TLV 513  |   ---  |   NO  | --- |
| 
| For the Cisco IOS-XR data, what does "---" means? Yes? No? Don't know?

'Don't know' - Manish and Saikat will update this after IETF89;
BTW repo is at https://github.com/hannesgredler/draft-gredler-idr-ls-distribution-impl

| > In particular we have tested our interoperability with Cisco Systems, Inc. IOS-XR implementation.
| 
| Good. Could you please share some details about the result of the tests? Something likes: all NLRI subtypes and NLRI TLV supported by both implementations (as per this document) were found to be interoperable.

stay tuned for the IDR meeting ;-)

| On a side note, I'm not sure to see the value of section 7.3 "TBD Implementation", nor sentence like "The Cisco Systems, Inc. IOS-XR implementation should be interoperable with other vendor BGP-LS Protocol implementations"

ok, will update this in -01;

/hannes