Subject: [Idr] [IDR] Comment to draft-ietf-idr-ls-distribution-04.txt

From: Zhuangshunwan <[email-masked]>
Date: Fri, 28 Feb 2014 17:38:40 +0800

Dear Authors,

I have a comment, see inline.

3.2.3.2.  IP Reachability Information

   The IP Reachability Information is a mandatory TLV that contains one

   IP address prefix (IPv4 or IPv6) originally advertised in the IGP

   topology.  Its purpose is to glue a particular BGP service NLRI vi

   virtue of its BGP next-hop to a given Node in the LSDB.  A router

   SHOULD advertise an IP Prefix NLRI for each of its BGP Next-hops.

   The format of the IP Reachability Information TLV is shown in the

   following figure:

 

Gredler, et al.           Expires May 22, 2014                 [Page 17]

Internet-Draft   Link-State Info Distribution using BGP    November 2013

    0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |              Type             |             Length            |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   | Prefix Length | IP Prefix (variable)                         //

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

             Figure 14: IP Reachability Information TLV Format

   The Type and Length fields of the TLV are defined in Table 4.  The

   following two fields determine the address-family reachability

   information.  The 'Prefix Length' field contains the length of the

   prefix in bits.  The 'IP Prefix' field contains the most significant

   octets of the prefix; i.e., 1 octet for prefix length 1 up to 8, 2

   octets for prefix length 9 to 16, 3 octets for prefix length 17 up to

   24 and 4 octets for prefix length 25 up to 32, etc.

   Vincent：

   For multiple IP address prefixes, if Local Node Descriptor and BGP-LS 

   Attribute are the same, maybe we can put multiple prefixes into one 

   IP Reachability Information TLV?

   In this way, some overhead bytes could be cut.

   For example:

   One IP address prefix per IP Reachability Information TLV, we can see 

   multiple Prefix NLRI in one bgp update message:

   First Prefix NLRI:

   00 03 --->Type = 3: IPv4 Topology Prefix NLRI

   00 30 

   02 

   00 00 00 00 00 00 00 01 

   01 00 --->256, Local Node Descriptors

   00 1a 

   02 00 --->512, Autonomous System

   00 04 

   00 00 00 64 

   02 01 --->513, BGP-LS Identifier 

   00 04 

   58 58 58 58 

   02 03 --->515, IGP Router-ID

   00 06 

   00 00 00 00 00 58 

   01 09 --->265, IP Reachability Information

   00 05 

   20 58 58 58 58 --->88.88.88.88/32

   Second Prefix NLRI:

   00 03 --->Type = 3: IPv4 Topology Prefix NLRI

   00 2f 

   02 

   00 00 00 00 00 00 00 01 

   01 00 

   00 1a 

   02 00 

   00 04 

   00 00 00 64 

   02 01 

   00 04 

   58 58 58 58 

   02 03 

   00 06 

   00 00 00 00 00 58 

   01 09 

   00 04 

   18 c8 01 01 --->200.1.1.0/24

   Above two Prefix NLRIs can be combined into one Prefix NLRI.

   Multiple prefixes in one IP Reachability Information TLV:

   00 03 --->Type = 3: IPv4 Topology Prefix NLRI

   00 34 

   02 

   00 00 00 00 00 00 00 01 

   01 00 

   00 1f 

   02 00 

   00 04 

   00 00 00 64 

   02 01 

   00 04 

   58 58 58 58 

   02 03 

   00 06 

   00 00 00 00 00 58 

   01 09 

   00 09 ---> Prefix Length of multiple prefix

   20 58 58 58 58 --->88.88.88.88/32 

   18 c8 01 01 --->200.1.1.0/24

   I understand aright?

Regards,

Vincent

---

From: "Saikat Ray (sairay)" <[email-masked]>
Date: Fri, 28 Feb 2014 16:03:07 +0000

If you do that, you will not be able to withdraw a single prefix (or a subset of prefixes) from the group as it is in the key portion - you would need to send withdraw for first NLRI with the previous group, and readvertise (a new) NLRI with the new group (or possibly in the other order). We decided against this complexity (also note that order of withdraw and advertisement is not guaranteed which could create routing glitches).

From: Idr [mailto:[email-masked]] On Behalf Of Zhuangshunwan
Sent: Friday, February 28, 2014 1:39 AM
To: [email-masked]
Subject: [Idr] [IDR] Comment to draft-ietf-idr-ls-distribution-04.txt

Dear Authors,

    0                   1                   2                   3

   Vincent：

   For example:

   Second Prefix NLRI:

   I understand aright?

Regards,

Vincent

---

From: Hannes Gredler <[email-masked]>
Date: Fri, 28 Feb 2014 21:53:10 +0100

i'd like to add that 'optimizing' binary protocols in the age
of 100gig links and control-plane processors which can suck
100s of MBits of TCP stream data, has long passed the
'boundary of dimishing returns' and hence has no
practical relevance.

/hannes

On Feb 28, 2014, at 5:03 PM, Saikat Ray (sairay) wrote:

> If you do that, you will not be able to withdraw a single prefix (or a subset of prefixes) from the group as it is in the key portion – you would need to send withdraw for first NLRI with the previous group, and readvertise (a new) NLRI with the new group (or possibly in the other order). We decided against this complexity (also note that order of withdraw and advertisement is not guaranteed which could create routing glitches).
>  
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr