Subject: [Idr] Call for presentations for IETF

From: "Susan Hares" <[email-masked]>
Date: Wed, 12 Feb 2014 01:05:15 -0500

Please let John and I know if you wish to make a presentation at ietf 89. 

As always IDR meeting motto is "no draft, no presentation". 

IDR is on Thursday from 13:00-15:00 GMT.   

Just respond to this email to request your presentation slot. 

Sue Hares

---

From: Thomas Mangin <[email-masked]>
Date: Wed, 12 Feb 2014 09:41:42 +0000

Even for things like : 

There is currently 4 (from memory) different draft requiring and proposing different, incompatible implementations of a TLV format in BGP.
Could some effort be put together to define ONE TLV format, so implementations do not need to include 4/5 different ones.
Could some minor changes be done to last call draft to make their format compatible with grand generalised TLV format.

People may wonder which draft ? :-)
- draft-ietf-idr-aigp-10
- draft-frs-bgp-operational-message-00
- draft-raszuk-wide-bgp-communities-03
- And there is surely some more ...

Having discussed it quickly with one of the author of the draft above, the quick overview seems to be :
 - operational = True TLV
 - aigp = almost like operational, but only a single octet for the type
 - widecomm = Really, TV , no length, and part of the extcommunity specification

So it would seems that with minor modifications, it could be possible.

Oh ! Sue, I know the answer is no, and it is great as no one want to come to its first IETF to take the stage and argue with regular attendant :-)
But at least the question has been asked and hopefully will be discussed :-)

Thomas

On 12 Feb 2014, at 06:05, Susan Hares <[email-masked]> wrote:

> As always IDR meeting motto is “no draft, no presentation”.
>  
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 12 Feb 2014 10:59:33 +0100

Hi Thomas,

>  - widecomm = Really, TV , no length, and part of the extcommunity

That is incorrect. It is not part of ext community and the encoding we are
defining requires real TLV. Please wait few days till the new revision of
the draft is posted.

I also do not think that one octet of type would be sufficient.

In BGP each attribute requires different parsing code so I am really not
sure why you can't have a flag in such parser to read and interpret one or
two octet TLVs depending on which attribute they are present at. As you
know other protocols can do this already today :)

Best regards,
R.

On Wed, Feb 12, 2014 at 10:41 AM, Thomas Mangin <
[email-masked]> wrote:

> Even for things like :
>
> There is currently 4 (from memory) different draft requiring and proposing
> different, incompatible implementations of a TLV format in BGP.
> Could some effort be put together to define ONE TLV format, so
> implementations do not need to include 4/5 different ones.
> Could some minor changes be done to last call draft to make their format
> compatible with grand generalised TLV format.
>
> Oh ! Sue, I know the answer is no, and it is great as no one want to come
> to its first IETF to take the stage and argue with regular attendant :-)

---

From: Thomas Mangin <[email-masked]>
Date: Wed, 12 Feb 2014 10:47:35 +0000

Hello Robert.

Thank you for your reply.

There is no issues having multiple parsers for TLV, I just believe it is just undesirable, therefore I am throwing the idea that we should try to limit their numbers.

I am not make assumptions about how far this idea can go. I am all for being practical but as it seems there is a need for a generic TLV format, so perhaps "we" should try to get it defined (even if informally to start with, by just having the draft using compatible formats). I have no set thought on how the TLV should be defined.

I just wanted to make authors are aware that work duplication is going on, both on the RFC definition and more from my POV for the implementation.

I agree that nowadays saving a few bytes for either length or type is not really worth it and it is safer to plan for extensibility. 

Sincerely,

Thomas

On 12 Feb 2014, at 09:59, Robert Raszuk <[email-masked]> wrote:

> That is incorrect. It is not part of ext community and the encoding we are defining requires real TLV. Please wait few days till the new revision of the draft is posted. 
> 
> In BGP each attribute requires different parsing code so I am really not sure why you can't have a flag in such parser to read and interpret one or two octet TLVs depending on which attribute they are present at. As you know other protocols can do this already today :)
> 
> Best regards,
> R.
> 
> 
> 
> On Wed, Feb 12, 2014 at 10:41 AM, Thomas Mangin <[email-masked]> wrote:
> Even for things like : 
>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 12 Feb 2014 11:58:01 +0100

Hi Thomas,

I understand and may even like your suggestion regardless how easy or hard
would be to converge with everyone on it.

The only immediate problem for IDR chairs assuming they also would support
unified TLV format across all attributes would be to halt any progress of
AIGP attribute draft with its slim TLV proposal till we have a common
agreement on the TLV format in IDR.

Otherwise I am afraid it is just too late ;)

Cheers,
R.

On Wed, Feb 12, 2014 at 11:47 AM, Thomas Mangin <
[email-masked]> wrote:

> There is no issues having multiple parsers for TLV, I just believe it is
> just undesirable, therefore I am throwing the idea that we should try to
> limit their numbers.
>
> I am not make assumptions about how far this idea can go. I am all for
> being practical but as it seems there is a need for a generic TLV format,
> so perhaps "we" should try to get it defined (even if informally to start
> with, by just having the draft using compatible formats). I have no set
> thought on how the TLV should be defined.
>
> I just wanted to make authors are aware that work duplication is going on,
> both on the RFC definition and more from my POV for the implementation.
>
> I agree that nowadays saving a few bytes for either length or type is not
> really worth it and it is safer to plan for extensibility.
>
> Sincerely,
>
> Thomas
>
>> There is currently 4 (from memory) different draft requiring and
>> proposing different, incompatible implementations of a TLV format in BGP.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 12 Feb 2014 11:00:12 -0500

> would be to converge with everyone on it.

Something I'd be fine with is a push toward an IDR-blessed Length
consistency.  Is the TL part of the length or not?  This is the item that
has varied across the specs the most.

In terms of a generic TLV, I think it has more to do with how BGP has
traditionally defined a route as some NLRI that share a common set of Path
Attributes.  I don't know that there's been much call for "and other
non-route related stuff" in BGP, at least for UPDATES.

> agreement on the TLV format in IDR.

I think individuals who push too hard to change aigp, even though it's
aberrant formatting, should be cautious in the halls of IETF.  There are
operators that will get extremely upset if we break their running feature.

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 12 Feb 2014 11:12:28 -0500

Thomas:

You are welcome to discuss these issues on the list.   I will bring up your
concern during my summary slide of the drafts. 

The reason for drafts is that so people can see your pros-cons prior to the
meeting. Or if they remote, understand your points clearly.   Many BGP
drafts  are often 1 or 2 pages of text surrounded by boiler plate.  You
could even name it  "mangin-1-TLV-Please".   

AIGP did a have two series of WG last calls and was approved.  It has 3+
implementations. I am still crafting the shepherds report this weekend
(after IETF drafts close), so the list discussion is helpful. 

Sue 

From: Thomas Mangin [mailto:[email-masked]] 
Sent: Wednesday, February 12, 2014 4:42 AM
To: [email-masked]
Cc: idr wg; John G. Scudder; Susan Hares
Subject: Re: [Idr] Call for presentations for IETF

Even for things like : 

- draft-ietf-idr-aigp-10

Having discussed it quickly with one of the author of the draft above, the
quick overview seems to be :

 - operational = True TLV
 - aigp = almost like operational, but only a single octet for the type
 - widecomm = Really, TV , no length, and part of the extcommunity
specification

Oh ! Sue, I know the answer is no, and it is great as no one want to come to
its first IETF to take the stage and argue with regular attendant :-)

Thomas

Sue Hares

_______________________________________________
Idr mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/idr>
https://www.ietf.org/mailman/listinfo/idr

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Wed, 12 Feb 2014 16:15:24 +0000

Comments In-Line..

Jim Uttaro

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Wednesday, February 12, 2014 11:00 AM
To: Robert Raszuk
Cc: idr wg; Susan Hares; John G. Scudder; [email-masked]
Subject: Re: [Idr] Call for presentations for IETF

[Jim U>] +1 

-- Jeff

---

From: Thomas Mangin <[email-masked]>
Date: Wed, 12 Feb 2014 16:49:03 +0000

Hello Susan,

Thank you for your help.

This is not an hot topic, BGP can live with disparate TLV format .. It just seems ... messy to me :-)

I fear I will not have time to write my first draft for London but if enough think it is worth some discussion time, I will find a way to make it happen .. I just believe I may just regret this statement :-)

Otherwise I am happy to speak about it informally, all what is needed is "rough consensus" of the current draft writer to update their document the same way :-)

I agree that AIGP is now way too far down the line for changes ...  I listed it as it is using a TLV format  ... 
But it may not be the same for all others drafts :-)

Thomas

On 12 Feb 2014, at 16:12, Susan Hares <[email-masked]> wrote:

> Thomas:
>  
> You are welcome to discuss these issues on the list.   I will bring up your concern during my summary slide of the drafts.
>  
> The reason for drafts is that so people can see your pros-cons prior to the meeting. Or if they remote, understand your points clearly.   Many BGP drafts  are often 1 or 2 pages of text surrounded by boiler plate.  You could even name it  “mangin-1-TLV-Please”.   
>  
> AIGP did a have two series of WG last calls and was approved.  It has 3+ implementations. I am still crafting the shepherds report this weekend (after IETF drafts close), so the list discussion is helpful.
>  
> Sue
>

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 13 Feb 2014 16:56:02 -0500

I agree that it'd be a generally nice and orderly thing to have consistent TLV usage going forward. I think any notion of going back and changing existing practice (including for specs still in draft but fairly mature, especially in terms of implementation) is wildly optimistic to say the least.

Thanks for bringing this up and I look forward to more discussion of it.

$0.02,

--John