Subject: [Idr] I-D Action: draft-ietf-idr-error-handling-11.txt

From: [email-masked]
Date: Tue, 03 Jun 2014 09:06:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

        Title           : Revised Error Handling for BGP UPDATE Messages
        Authors         : Enke Chen
                          John G. Scudder
                          Pradosh Mohapatra
                          Keyur Patel
	Filename        : draft-ietf-idr-error-handling-11.txt
	Pages           : 15
	Date            : 2014-06-03

Abstract:
   According to the base BGP specification, a BGP speaker that receives
   an UPDATE message containing a malformed attribute is required to
   reset the session over which the offending attribute was received.
   This behavior is undesirable as a session reset would impact not only
   routes with the offending attribute, but also other valid routes
   exchanged over the session.  This document partially revises the
   error handling for UPDATE messages, and provides guidelines for the
   authors of documents defining new attributes.  Finally, it revises
   the error handling procedures for a number of existing attributes.

   This document updates error handling for RFCs 1997, 4271, 4360, 4456,
   4760 and 5701.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-error-handling/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-idr-error-handling-11

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-idr-error-handling-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 3 Jun 2014 12:16:37 -0400

This version includes only the “MUST NOT” -> “must not” change I mentioned last Friday.

Since I believe this version takes into account all the feedback that has been offered to date, and since the discussion seems to have wound down, I’d like to request a new WGLC since the document has had some substantial updates. Here’s a URL for an rfcdiff between -07 (what we started the WGLC with) and the current -11: http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=draft-ietf-idr-error-handling-07&url2=draft-ietf-idr-error-handling-11

Thanks,

—John

---

From: Deniz Bahadir <[email-masked]>
Date: Tue, 03 Jun 2014 18:39:25 +0200

> Since I believe this version takes into account all the feedback that has been offered to date, and since the discussion seems to have wound down, I’d like to request a new WGLC since the document…

Don't want to sound impolite, by I guess, you might have overlooked my 
feedback/questions to draft-ietf-idr-error-handling-10.txt.
But maybe that was just too much nit-picking?

Deniz

---

From: John Scudder <[email-masked]>
Date: Tue, 3 Jun 2014 16:50:22 +0000

On Jun 3, 2014, at 12:40 PM, "Deniz Bahadir" <[email-masked]> wrote:
> Don't want to sound impolite, by I guess, you might have overlooked my feedback/questions to draft-ietf-idr-error-handling-10.txt.

It's entirely possible I missed it; I'll go review your comments a little later today. 

Thanks!

--John

---

From: John Scudder <[email-masked]>
Date: Tue, 3 Jun 2014 17:25:05 +0000

> It's entirely possible I missed it; I'll go review your comments a little later today.

I did indeed miss your note from Friday. I'll review and possibly produce a -12. (So let's hold off on the WGLC.)

--John