Subject: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

From: "Susan Hares" <[email-masked]>
Date: Mon, 15 Jun 2015 09:08:14 -0400

This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt
(6/15 - 6/29).  

http://datatracker.ietf.org/doc/draft-shaikh-idr-bgp-model/

This is the base BGP module from a merge of the OpenConfig module and other
draft (draft-zhdankin-idr-bgp-cfg).  

Please review this yang modules and comment on it on the list.   

Sue Hares 

PS - Benoit just sent out a note that an online validator is at:
www.yangvalidator.com (from the hand of Carl Moberg).   If you find errors,
please be kind to the authors because this WG chair encouraged the authors
to get an initial merged draft out for the 6/15/2015 interim.  There are
many other BGP yang drafts that will need to align with this draft.

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 15 Jun 2015 15:20:59 +0000

Yes/support
Extremely important and useful work!

Cheers,
Jeff

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 15, 2015 at 6:08 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt (6/15 – 6/29).

This is the base BGP module from a merge of the OpenConfig module and other draft (draft-zhdankin-idr-bgp-cfg).

Sue Hares

PS - Benoit just sent out a note that an online validator is at: www.yangvalidator.com<http://www.yangvalidator.com> (from the hand of Carl Moberg).   If you find errors, please be kind to the authors because this WG chair encouraged the authors to get an initial merged draft out for the 6/15/2015 interim.  There are many other BGP yang drafts that will need to align with this draft.

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 15 Jun 2015 17:30:14 +0200

Support.

On Mon, Jun 15, 2015 at 3:08 PM, Susan Hares <[email-masked]> wrote:

> This begins a 2 week WG Adoption call for
> draft-shaikh-idr-bgp-model-02.txt (6/15 – 6/29).
>
>
>
> This is the base BGP module from a merge of the OpenConfig module and
> other draft (draft-zhdankin-idr-bgp-cfg).
>
>
>
> www.yangvalidator.com (from the hand of *Carl Moberg*).   If you find
> errors, please be kind to the authors because this WG chair encouraged the
> authors to get an initial merged draft out for the 6/15/2015 interim.
> There are many other BGP yang drafts that will need to align with this
> draft.
>
>
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 15 Jun 2015 11:30:25 -0400

< WG chair hat off> 

Yes/Support - I agree with Jeff Tantsura.  Now it's rtgwg WG turn to get the
policy model into WG adoption in rtgwg.  (smile) 

Sue

Policy model is: draft-shaikh-rtgwg-policy-model-00. 

From: Idr [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Monday, June 15, 2015 11:21 AM
To: Susan Hares; [email-masked]
Cc: [email-masked]
Subject: Re: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

Yes/support

Cheers,

Jeff

From: Susan Hares <[email-masked]>
Date: Monday, June 15, 2015 at 6:08 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

Sue Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 15 Jun 2015 15:38:12 +0000

Support.

Date: Monday, June 15, 2015 at 9:08 AM

Sue Hares

---

From: Job Snijders <[email-masked]>
Date: Mon, 15 Jun 2015 17:41:48 +0200

> This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt

I support adoption.

---

From: <[email-masked]>
Date: Mon, 15 Jun 2015 16:37:35 +0000

Support.

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, June 15, 2015 3:08 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt (6/15 - 6/29).

Sue Hares

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 15 Jun 2015 14:17:47 -0400

> This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt

I support adoption of this draft.

I will state very early that it is highly likely that the draft will
need to be split into separate drafts based on the necessity to make some
components IANA managed.  It is fine to leave them in the same draft for the
time being, but the minute we get a second draft referring to components
that may need to be revised at a separate cadence a split should happen.

> many other BGP yang drafts that will need to align with this draft.  

Please also be aware that the modules have previously been shared in
yang central.  I would like to encourage the authors to continue doing this,
even if the location within the repository changes.  This permits edits to
the draft to be done in the form of precise patches rather than ad-hoc
mailing list edits.

-- Jeff

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 15 Jun 2015 11:37:16 -0700

Jeff,

+1

I know there are several repositories out there, so it would help to clarify which repository in addition to YANG central where the models should be shared (at least currently). NETMOD is encouraging folks to share their IETF models in GitHub here:

https://github.com/YangModels/yang <https://github.com/YangModels/yang>

> On Jun 15, 2015, at 11:17 AM, Jeffrey Haas <[email-masked]> wrote:
> 

Mahesh Jethanandani
[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 15 Jun 2015 16:24:51 -0400

Mahesh and Jeff: 

Thanks for pointing out the place for yang modules.  I hope that all BGP
modules will put their modules in github repositories. 

Sue 

From: Mahesh Jethanandani [mailto:[email-masked]] 
Sent: Monday, June 15, 2015 2:37 PM
To: Jeffrey Haas
Cc: Susan Hares; [email-masked]; [email-masked]
Subject: Re: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

Jeff,

+1

I know there are several repositories out there, so it would help to clarify
which repository in addition to YANG central where the models should be
shared (at least currently). NETMOD is encouraging folks to share their IETF
models in GitHub here:

https://github.com/YangModels/yang

Mahesh Jethanandani

[email-masked]

---

From: "Osborne, Eric" <[email-masked]>
Date: Mon, 15 Jun 2015 21:12:11 +0000

Support.

eric

> -----Original Message-----
> Sent: Monday, June 15, 2015 9:08 AM
> To: [email-masked]
> Cc: [email-masked]
> www.yangvalidator.com <http://www.yangvalidator.com>  (from the hand
> of Carl Moberg).   If you find errors, please be kind to the authors because
> this WG chair encouraged the authors to get an initial merged draft out for
> the 6/15/2015 interim.  There are many other BGP yang drafts that will need
> to align with this draft.
> 
>

---

From: Jon Mitchell <[email-masked]>
Date: Mon, 15 Jun 2015 22:38:23 -0400

Support for adoption.

-Jon

> On Jun 15, 2015, at 9:08 AM, Susan Hares <[email-masked]> wrote:
> 
> PS - Benoit just sent out a note that an online validator is at: www.yangvalidator.com (from the hand of Carl Moberg).   If you find errors, please be kind to the authors because this WG chair encouraged the authors to get an initial merged draft out for the 6/15/2015 interim.  There are many other BGP yang drafts that will need to align with this draft.  
>

---

From: Qin Wu <[email-masked]>
Date: Tue, 16 Jun 2015 08:51:48 +0000

Support.
Also I would like to see this draft gets in line with draft-ietf-netmod-routing-cfg-19.

-Qin
发件人: Idr [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2015年6月15日 23:38
收件人: Susan Hares; [email-masked]
抄送: [email-masked]
主题: Re: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

Support.

Sue Hares

---

From: Mohan Nanduri <[email-masked]>
Date: Tue, 16 Jun 2015 07:15:33 -0400

Support for Adoption.

Cheers,
-Mohan

---

From: t.petch <[email-masked]>
Date: Tue, 16 Jun 2015 12:33:37 +0100

If I thought that opposing adoption would make any difference, I would
oppose adoption:-)

The problem hits me on the first page, which is a list of 10 authors.
This is unlikely to be allowed in the final RFC and, in my experience,
is frowned upon for a good reason.  Ten people is a committee and, while
a small tightly focussed design team can produce good results,
committees rarely do, in the IETF.

I want to see one or two identified editors responsible for making
changes to the I-D as agreed by the WG and having 10 such is, IMHO,
likely to impede progress.

This is an issue that I think will have to be addressed at some point
and I think that the best time for that is now.

(In passing, a recent discussion on the IETF list flagged the problems
of having WG Chairs as editors of WG documents, which I think spot on).

Tom Petch

----- Original Message -----
From: "Susan Hares" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 15, 2015 2:08 PM

> This begins a 2 week WG Adoption call for
draft-shaikh-idr-bgp-model-02.txt
other
> many other BGP yang drafts that will need to align with this draft.

------------------------------------------------------------------------
--------

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 16 Jun 2015 09:54:07 -0400

Tom:

<WG chair hat on> 
Thank you for noticing the number of authors is out of balance with the IESG
statement.  For the purposes of this WG adoption call, please note the WG
chairs will address the author list in the next revision. 
<WG chair hat off> 

Sue Hares 

-----Original Message-----
From: t.petch [mailto:[email-masked]] 
Sent: Tuesday, June 16, 2015 7:34 AM
To: Susan Hares; [email-masked]
Cc: [email-masked]
Subject: Re: [Idr] WG adoption call for draft-shaikh-idr-bgp-model-02.txt

The problem hits me on the first page, which is a list of 10 authors.
This is unlikely to be allowed in the final RFC and, in my experience, is
frowned upon for a good reason.  Ten people is a committee and, while a
small tightly focussed design team can produce good results, committees
rarely do, in the IETF.

I want to see one or two identified editors responsible for making changes
to the I-D as agreed by the WG and having 10 such is, IMHO, likely to impede
progress.

This is an issue that I think will have to be addressed at some point and I
think that the best time for that is now.

(In passing, a recent discussion on the IETF list flagged the problems of
having WG Chairs as editors of WG documents, which I think spot on).

Tom Petch

----- Original Message -----
From: "Susan Hares" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 15, 2015 2:08 PM

other

---

From: Rob Shakir <[email-masked]>
Date: Tue, 23 Jun 2015 10:21:45 +0100

On 15 June 2015 at 14:08:31, Susan Hares ([email-masked]) wrote:
This begins a 2 week WG Adoption call for draft-shaikh-idr-bgp-model-02.txt (6/15 – 6/29). 

Sue,

As a co-author of this draft, I support its adoption.

Regards the comments relating to ensuring that this model is in GitHub. It has been mastered in GitHub for some time (OpenConfig repository, and corresponding directory in the netmod repo). We’ll aim to continue to master in GitHub - and would very much encourage feedback in terms of patches and/or pull-requests against this code.

Best, r.