Subject: [Idr] [Errata Held for Document Update] RFC5575 (4482)

From: RFC Errata System <[email-masked]>
Date: Tue, 16 Feb 2016 13:56:50 -0800 (PST)

The following errata report has been held for document update 
for RFC5575, "Dissemination of Flow Specification Rules". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5575&eid=4482

--------------------------------------
Status: Held for Document Update
Type: Technical

Reported by: Wesley Eddy <[email-masked]>
Date Reported: 2015-09-25
Held by: Alvaro Retana (IESG)

Section: 4 (page 11)

Original Text
-------------
   An example of a flow specification encoding for: "all packets to
   10.0.1/24 from 192/8 and port {range [137, 139] or 8080}".

   +------------------+----------+-------------------------+
   | destination      | source   | port                    |
   +------------------+----------+-------------------------+
   | 0x01 18 0a 01 01 | 02 08 c0 | 04 03 89 45 8b 91 1f 90 |
   +------------------+----------+-------------------------+

Corrected Text
--------------
   An example of a flow specification encoding for: "all packets to
   10.1.1/24 from 192/8 and port {range [137, 139] or 8080}".

   +------------------+----------+-------------------------+
   | destination      | source   | port                    |
   +------------------+----------+-------------------------+
   | 0x01 18 0a 01 01 | 02 08 c0 | 04 03 89 45 8b 91 1f 90 |
   +------------------+----------+-------------------------+

OR:

   An example of a flow specification encoding for: "all packets to
   10.0.1/24 from 192/8 and port {range [137, 139] or 8080}".

   +------------------+----------+-------------------------+
   | destination      | source   | port                    |
   +------------------+----------+-------------------------+
   | 0x01 18 0a 00 01 | 02 08 c0 | 04 03 89 45 8b 91 1f 90 |
   +------------------+----------+-------------------------+

Notes
-----
The prefix stated in the text, does not match the one encoded in the example.

10.0.1/24 should be 10.1.1/24 to match the example, or alternatively the example should change from:
0x01 18 0a 01 01
to:
0x01 18 0a 00 01

--------------------------------------
RFC5575 (draft-ietf-idr-flow-spec-09)
--------------------------------------
Title               : Dissemination of Flow Specification Rules
Publication Date    : August 2009
Author(s)           : P. Marques, N. Sheth, R. Raszuk, B. Greene, J. Mauch, D. McPherson
Category            : PROPOSED STANDARD
Source              : Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Jared Mauch <[email-masked]>
Date: Tue, 16 Feb 2016 17:36:44 -0500

[cc list trimmed for people I know that changed orgs]

The typos should obviously be corrected.  I have no opinion of which way.

- Jared

> On Feb 16, 2016, at 4:56 PM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr