Subject: [Idr] Review request for "Source/Destination Routing Using BGP-4”

From: 杨术 <[email-masked]>
Date: Sat, 26 Mar 2016 01:39:15 +0800 (GMT+08:00)

Dear all,
 
We are looking for your comments on the new draft "Source/Destination Routing Using BGP-4".

There is active work in rtgwg and homenet about src/dst routing, e.g., https://datatracker.ietf.org/doc/draft-ietf-rtgwg-dst-src-routing, https://datatracker.ietf.org/doc/draft-lamparter-homenet-isis-profile, https://datatracker.ietf.org/doc/draft-ietf-homenet-hncp, https://datatracker.ietf.org/doc/draft-ietf-homenet-dncp. We believe that src/dst routing is also useful in inter-domain routing, for TE, security and policy routing.

This document describes source/destination routing using bgp, which add a source prefix into the bgp update message. 

We would really appreciate any comments and questions about the document.
 
Best Regards,

Shu Yang

---

From: 杨术 <[email-masked]>
Date: Sat, 26 Mar 2016 01:45:14 +0800 (GMT+08:00)

The url is: https://www.ietf.org/internet-drafts/draft-xu-src-dst-bgp-00.txt

Shu Yang

> -----原始邮件-----
> 发件人: "杨术" <[email-masked]>
> 发送时间: 2016年3月26日 星期六
> 收件人: [email-masked]
> 抄送: [email-masked], [email-masked], [email-masked]
> 主题: [Idr] Review request for "Source/Destination Routing Using BGP-4”
> 
> Dear all,
>  
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 25 Mar 2016 19:23:25 +0100

Hi Shu,

I am afraid "prepending" new TLV to existing NLRI within MP_REACH_NLRI
attribute may not work that well within existing SAFIs both protocol as
well as implementation wise.

Instead I would recommend to consider reusing Type 1 and Type 2 of already
defined Flow_Spec NLRI see RFC5575.

That along with draft-ietf-idr-flowspec-redirect-ip-02.txt provides all
required BGP protocol mechanism to distribute src-dst based reachability
within BGP-4.

Best regards,
R.

On Fri, Mar 25, 2016 at 6:45 PM, 杨术 <[email-masked]> wrote:

> The url is:
> https://www.ietf.org/internet-drafts/draft-xu-src-dst-bgp-00.txt
>
> Shu Yang
>

---

From: 杨术 <[email-masked]>
Date: Sat, 26 Mar 2016 16:22:37 +0800 (GMT+08:00)

Dear Robert,

Thank you for your suggestions.  We would take them into considerations in the next version.

Best,

Shu Yang

-----原始邮件-----
发件人: "Robert Raszuk" <[email-masked]>
发送时间: 2016年3月26日 星期六
收件人: "杨术" <[email-masked]>
抄送: "idr wg" <[email-masked]>
主题: Re: [Idr] Review request for "Source/Destination Routing Using BGP-4”

Hi Shu,

I am afraid "prepending" new TLV to existing NLRI within MP_REACH_NLRI attribute may not work that well within existing SAFIs both protocol as well as implementation wise. 

Instead I would recommend to consider reusing Type 1 and Type 2 of already defined Flow_Spec NLRI see RFC5575.

That along with draft-ietf-idr-flowspec-redirect-ip-02.txt provides all required BGP protocol mechanism to distribute src-dst based reachability within BGP-4. 

Best regards,
R.

Shu Yang