Subject: [Idr] RtgDir review: draft-ietf-idr-add-paths-13

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 27 Apr 2016 20:27:00 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-idr-add-paths-13
Reviewer: Carlos Pignataro
Review Date: April 25, 2016
Intended Status: Proposed Standard

https://datatracker.ietf.org/doc/draft-ietf-idr-add-paths/

Summary:
This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:
This is an extremely well written document, very focused and with high SNR. I have a couple totally-non-critical comments and questions below.

Major Issues:
None.

Minor Issues:
I have a couple of questions rather than issues:

2.  How to Identify a Path
...
   A BGP
   speaker that receives a route SHOULD NOT assume that the identifier
   carries any particular semantics; it SHOULD be treated as an opaque
   value.

I was thinking about why “SHOULD NOT” and not “MUST NOT”, and I understand future proofing, but wondering if there’s another reason.

The path identifier has well-defined semantics: make a path unique for a given prefix, or make the {identifier; prefix} specify a path among many. Does this sentence intend to specify that a BGP receiving a route SHOULD NOT assume particular semantics of the numerical value of the field? (such as the lower value means a more important route), or SHOULD NOT assume particular semantics of the structure of the field? (such as some hierarchy, or MSB with some meaning). Or both?

Maybe, “… assume that the value or structure of the identifier carries …”?
Or maybe it is OK as is and I am reading too much into it?

6.  Applications

   The BGP extension specified in this document can be used by a BGP
   speaker to advertise multiple paths in certain applications.  The
   availability of the additional paths can help reduce or eliminate
   persistent route oscillations [RFC3345].  It can also help with
   optimal routing and routing convergence in a network.  The
   applications are detailed in separate documents.

The final sentence does not seem to add anything, other than questions. I’d suggest either adding pointers to those separate documents, or removing the sentence. This is a non-normative section.

7.  Deployment Considerations

   The extension proposed in this document provides a mechanism for a
   BGP speaker to advertise multiple paths over a BGP session.  Care
   needs to be taken in its deployment to ensure consistent routing and
   forwarding in a network, the details of which will be described in
   separate application documents.

Similarly, which documents? These seem like important considerations.

Nits:

4.  ADD-PATH Capability

   The ADD-PATH Capability is a new BGP capability [RFC5492].  The
   Capability Code for this capability is specified in the IANA
   Considerations section of this document.

Why not say "The ADD-PATH Capability is a new BGP capability [RFC5492], with Capability Code of 69” and simplify it for the reader?

9.  Security Considerations
...
  The use of the ADD-PATH Capability is intended to
   address specific needs related to, for example, eliminating the MED-
   induced route oscillations in a network
   [I-D.ietf-idr-route-oscillation-stop].  While the applications for
   the ADD-PATH Capability are outside the scope of this document, the
   users are encouraged to examine their behavior and potential impact
   by studying the best practices described in
   [I-D.ietf-idr-add-paths-guidelines].

Are these Security Considerations, Applications, or Deployment Considerations?

I hope these help,

— Carlos.

---

From: Alia Atlas <[email-masked]>
Date: Fri, 29 Apr 2016 16:30:55 -0400

Hi Carlos,

Thank you very much for your review.

Shepherd & authors,

Could you please respond and update the draft ASAP with what you agree are
improvements
as well as addressing the one IETF Last Call comment with the agreed
changes?

Thanks,
Alia

On Wed, Apr 27, 2016 at 4:27 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> Hello,
>
> I have been selected as the Routing Directorate reviewer for this
> draft. The Routing Directorate seeks to review all routing or
> routing-related drafts as they pass through IETF last call and IESG review,
> and sometimes on special request. The purpose of the review is to
> provide assistance to the Routing ADs. For more information about the
> Routing Directorate, please see ​
> http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
>
> Although these comments are primarily for the use of the Routing ADs,
> it would be helpful if you could consider them along with any other
> IETF Last Call comments that you receive, and strive to resolve them
> through discussion or by updating the draft.
>
> This is an extremely well written document, very focused and with high
> SNR. I have a couple totally-non-critical comments and questions below.
>
>
> Major Issues:
> None.
>
>
> Minor Issues:
> I was thinking about why “SHOULD NOT” and not “MUST NOT”, and I understand
> future proofing, but wondering if there’s another reason.
>
> The path identifier has well-defined semantics: make a path unique for a
> given prefix, or make the {identifier; prefix} specify a path among many.
> Does this sentence intend to specify that a BGP receiving a route SHOULD
> NOT assume particular semantics of the numerical value of the field? (such
> as the lower value means a more important route), or SHOULD NOT assume
> particular semantics of the structure of the field? (such as some
> hierarchy, or MSB with some meaning). Or both?
>
> The final sentence does not seem to add anything, other than questions.
> I’d suggest either adding pointers to those separate documents, or removing
> the sentence. This is a non-normative section.
>
> Why not say "The ADD-PATH Capability is a new BGP capability [RFC5492],
> with Capability Code of 69” and simplify it for the reader?
>

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Sun, 1 May 2016 00:23:38 +0000

On 4/27/16, 4:27 PM, "Carlos Pignataro (cpignata)" <[email-masked]<mailto:[email-masked]>> wrote:

<hat>author</hat>

Carlos:

Hi!  Thanks for the review!

I just posted version -14.

Thanks!

Alvaro.

...
Minor Issues:

I was thinking about why "SHOULD NOT" and not "MUST NOT", and I understand future proofing, but wondering if there's another reason.

Maybe, "... assume that the value or structure of the identifier carries ..."?
Or maybe it is OK as is and I am reading too much into it?

At one point in time I think we toyed with the fact that the Path ID could indicate which was the bestpath, for example.  We had added that text to cover the point that there is no specific interpretation that should be assumed.

All the Last Call reviews we got point at this piece of text, so we're modifying it to take the rfc2119 language out.