Subject: Re: [Idr] WG Adoption call for drafts for Flow Specification option 1 (RFC5575 additions (filters/actions) 3/25 to 4/8/2016

From: "Wunan (Eric)" <[email-masked]>
Date: Wed, 6 Apr 2016 03:06:42 +0000

Hi Susan, John,

I think what Lucy said makes sense. Based on what I learnt, instead of talking about the same thing with different names, those three I-Ds below seems to have different abstraction levels and scope. I'm not sure whether "a common mechanism" will be better, but WG needs to talk about the possibility.

Regards

Eric

----------------------------------------------------------------------

Message: 1

Date: Fri, 1 Apr 2016 19:24:45 +0000

From: Lucy yong <[email-masked]<mailto:[email-masked]>>

To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "'idr@ietf. org'" <[email-masked]<mailto:[email-masked]>>

Subject: Re: [Idr] WG Adoption call for drafts for Flow Specification

    option 1 (RFC5575 additions (filters/actions) 3/25 to 4/8/2016

Message-ID: <2691CE0099834E4A9C5044EEC662BB9D5726FC5A@dfweml501-mbb>

Content-Type: text/plain; charset="us-ascii"

I support adoption of followings:

https://datatracker.ietf.org/doc/draft-eddy-idr-flowspec-packet-rate/

https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-nvo3/

https://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/

https://datatracker.ietf.org/doc/draft-litkowski-idr-flowspec-interfaceset/

https://datatracker.ietf.org/doc/draft-yong-idr-flowspec-mpls-match/

The following three drafts are related to flow redirect, suggest having a common mechanism to address flow redirect instead of several and usage rules to prevent loop.

https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-redirect-tunnel/

https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-sid/

https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect/

Lucy

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares

Sent: Friday, March 25, 2016 9:47 AM

To: 'idr@ietf. org'

Subject: [Idr] WG Adoption call for drafts for Flow Specification option 1 (RFC5575 additions (filters/actions) 3/25 to 4/8/2016

IDR WG:

This begins a 2 week WG Call (3/25 to 4/8/2016) for the set of drafts to be considered in RFC5575 additions. These options are filters, actions or critical security additions.  The flow specification work has been a part of the interims since IETF 94 https://www.ietf.org/proceedings/interim/2016/02/08/idr/proceedings.html

https://www.ietf.org/proceedings/interim/2016/03/07/idr/proceedings.html

There will be a brief flow specification presentation at IETF 95, and the email list has select to start with option 1 - extending RFC5575.  We also will be gathering details on the SDN/NFV use case for option 2 (new NLRI and Wide Communities support).

This is a group call for the drafts to be considered in the flow specification work.  For each of the drafts you wish to be considered Option 1, please indicate:

1)      If this option is valuable for the DDoS deployments or another critical deployments,

2)      Do you feel this draft is useful, but not ready for adoption,

3)      Do you feel this draft is a good start for this work.

The drafts to consider are:

https://datatracker.ietf.org/doc/draft-eddy-idr-flowspec-packet-rate/

https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-nvo3/

https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-redirect-tunnel/

https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-sid/

https://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/

https://datatracker.ietf.org/doc/draft-litkowski-idr-flowspec-interfaceset/

https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect/

https://datatracker.ietf.org/doc/draft-yong-idr-flowspec-mpls-match/

And for the ordering of these filters and actions drafts - the Option 1 section out of this https://datatracker.ietf.org/doc/draft-hares-idr-flowspec-combo/

(A revised draft with just Option 1 will be posted)

Sue Hares and John Scudder

-------------- next part --------------

An HTML attachment was scrubbed...

URL: <https://mailarchive.ietf.org/arch/browse/idr/attachments/20160401/bb13ec9d/attachment.html>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 6 Apr 2016 06:01:15 -0400

Eric:

Thank you for your question about the following drafts: 

https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-
sid/

https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect
/

This is just the thing to begin to talk about on the list as part of the
adoption process.  We'll spend some time discussing the pros/cons of these
drafts on the list. 

Sue

From: Wunan (Eric) [mailto:[email-masked]] 
Sent: Tuesday, April 05, 2016 11:07 PM
To: Susan Hares; [email-masked]
Cc: [email-masked]
Subject: RE: [Idr] WG Adoption call for drafts for Flow Specification option
1 (RFC5575 additions (filters/actions) 3/25 to 4/8/2016

Hi Susan, John,

I think what Lucy said makes sense. Based on what I learnt, instead of
talking about the same thing with different names, those three I-Ds below
seems to have different abstraction levels and scope. I'm not sure whether
"a common mechanism" will be better, but WG needs to talk about the
possibility. 

Regards

Eric

Message: 1

From: Lucy yong <[email-masked]>

To: Susan Hares <[email-masked]>, "'idr@ietf. org'" <[email-masked]>

 

The following three drafts are related to flow redirect, suggest having a
common mechanism to address flow redirect instead of several and usage rules
to prevent loop.

https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-
sid/

https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect
/

Lucy

To: 'idr@ietf. org'

Subject: [Idr] WG Adoption call for drafts for Flow Specification option 1
(RFC5575 additions (filters/actions) 3/25 to 4/8/2016

IDR WG:

This begins a 2 week WG Call (3/25 to 4/8/2016) for the set of drafts to be
considered in RFC5575 additions. These options are filters, actions or
critical security additions.  The flow specification work has been a part of
the interims since IETF 94
https://www.ietf.org/proceedings/interim/2016/02/08/idr/proceedings.html

There will be a brief flow specification presentation at IETF 95, and the
email list has select to start with option 1 - extending RFC5575.  We also
will be gathering details on the SDN/NFV use case for option 2 (new NLRI and
Wide Communities support).

This is a group call for the drafts to be considered in the flow
specification work.  For each of the drafts you wish to be considered Option
1, please indicate:

1)      If this option is valuable for the DDoS deployments or another
critical deployments,

https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-
sid/

https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect
/

And for the ordering of these filters and actions drafts - the Option 1
section out of this
https://datatracker.ietf.org/doc/draft-hares-idr-flowspec-combo/

 

-------------- next part --------------

URL:
<https://mailarchive.ietf.org/arch/browse/idr/attachments/20160401/bb13ec9d/
attachment.html>