Subject: Re: [Idr] [BGP Link State] Regarding identifying BGP speakers with BGP link state information

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 19 Apr 2016 11:59:22 +0000

Hi Shashi,

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Shashikanth vh <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 19, 2016 at 6:10 AM
To: Hannes Gredler <[email-masked]<mailto:[email-masked]>>, "Jan Medved (jmedved)" <[email-masked]<mailto:[email-masked]>>, "Stefano Previdi (sprevidi)" <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] [BGP Link State] Regarding identifying BGP speakers with BGP link state information

Dear Authors,
Can you please let me know is there any  way to know the BGP speakers from the link state information.
As per information available from node descriptor, “BGP LS identifier” cannot be used to identify, since this is unique across all BGP speakers with in AS.
           +--------------------+-------------------+----------+
           | Sub-TLV Code Point | Description       |   Length |
           +--------------------+-------------------+----------+
           |        512         | Autonomous System |        4 |
           |        513         | BGP-LS Identifier |        4 |
           |        514         | OSPF Area-ID      |        4 |
           |        515         | IGP Router-ID     | Variable |
           +--------------------+-------------------+----------+
Is there any way to use Node descriptor or attribute information to know about BGP speakers among all nodes provided in LS information.
If this information is not provided in LS information, is it ok to add new filed or flag in Node attribute to identify BGP speaker.

The BGP Router ID BGP-LS identifier is defined in https://www.ietf.org/id/draft-ietf-idr-bgpls-segment-routing-epe-03.txt.

Hope this helps,
Acee

Regards,
Shashi

---

From: Saikat Ray <[email-masked]>
Date: Tue, 19 Apr 2016 09:04:37 -0700

If the consumer of BGPLS is peering with each BGP speaker, then it knows
which BGP speaker is sending an NLRI. If it is peering with a route
reflector, then the originator_id identifies the BGP speaker that sent the
NLRI.

On Tue, Apr 19, 2016 at 4:59 AM, Acee Lindem (acee) <[email-masked]> wrote:

> Hi Shashi,
>
> From: Idr <[email-masked]> on behalf of Shashikanth vh <
> [email-masked]>
> To: Hannes Gredler <[email-masked]>, "Jan Medved (jmedved)" <
> [email-masked]>, "Stefano Previdi (sprevidi)" <[email-masked]>,
> Adrian Farrel <[email-masked]>, "[email-masked]" <
> [email-masked]>
> Cc: IDR List <[email-masked]>
> As per information available from node descriptor, “BGP LS identifier”
> cannot be used to identify, since this is unique across all BGP speakers
> with in AS.
>
>            |        513         | *BGP-LS Identifier* |        4 |
>
> Is there any way to use Node descriptor or attribute information to know
> about BGP speakers among all nodes provided in LS information.
>
> If this information is not provided in LS information, is it ok to add new
> filed or flag in Node attribute to identify BGP speaker.
>
>
> The BGP Router ID BGP-LS identifier is defined in
> https://www.ietf.org/id/draft-ietf-idr-bgpls-segment-routing-epe-03.txt.
>
> Hope this helps,
> Acee
>
>
>
> Regards,
>
> Shashi
>
>

-- 
Saikat Ray
Web: http://raysaikat.googlepages.com