Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

From: [email-masked]
Date: Wed, 20 Dec 2017 01:29:57 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Flowspec Indirection-id Redirect
        Authors         : Gunter Van de Velde
                          Keyur Patel
                          Zhenbin Li
	Filename        : draft-ietf-idr-flowspec-path-redirect-03.txt
	Pages           : 12
	Date            : 2017-12-20

Abstract:
   This document defines a new extended community known as flowspec
   redirect-to-indirection-id.  This extended community triggers
   advanced redirection capabilities to flowspec clients.  When
   activated, this flowspec extended community is used by a flowspec
   client to find the corresponding next-hop information within a
   indirection-id mapping table.

   The functionality detailed in this document allows a network
   controller to decouple the BGP flowspec redirection instruction from
   the selected redirection path itself.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-flowspec-path-redirect/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-flowspec-path-redirect-03
https://datatracker.ietf.org/doc/html/draft-ietf-idr-flowspec-path-redirect-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-flowspec-path-redirect-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 20 Dec 2017 09:41:05 +0000

All,

This draft has been simplified and removed some clutter. Authors believe the draft to have reached stable content.

The flowspec indirection-ids included are: Type0 - localized indirection, Type 1&2 - node SID (index & global), Type 3&4 - binding SID (index&global) and Type 5 - global tunnel-id.

G/ 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 20, 2017 10:30
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 20 Dec 2017 10:42:31 -0500

Gunter:

Are you looking for a WG LC for this draft? 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Van De Velde, Gunter
(Nokia - BE/Antwerp)
Sent: Wednesday, December 20, 2017 4:41 AM
To: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

All,

This draft has been simplified and removed some clutter. Authors believe the
draft to have reached stable content.

The flowspec indirection-ids included are: Type0 - localized indirection,
Type 1&2 - node SID (index & global), Type 3&4 - binding SID (index&global)
and Type 5 - global tunnel-id.

G/ 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, December 20, 2017 10:30
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

Abstract:

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-flowspec-path-redirect-03
https://datatracker.ietf.org/doc/html/draft-ietf-idr-flowspec-path-redirect-
03

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 20 Dec 2017 15:51:56 +0000

Hi Sue,

Thanks. If in the next few weeks no technical mistakes are discovered, then maybe it is ready for WGLC. Time will provide feedback in IDR WG.
 
What seems a more pressing matter at this stage would be to get IANA code-points. Not sure what is the best process to get those? 

G/

On 20/12/2017, 16:42, "Susan Hares" <[email-masked]> wrote:

    Gunter:

    Sue 
    
    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of Van De Velde, Gunter
    (Nokia - BE/Antwerp)
    Sent: Wednesday, December 20, 2017 4:41 AM
    To: [email-masked]
    Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt
    
    All,

    
    G/ 

    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of
    [email-masked]
    Sent: Wednesday, December 20, 2017 10:30
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

    
    Abstract:

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 20 Dec 2017 11:01:46 -0500

I do a WG call for early adoption.   Shall I start this today? 

Sue Hares 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Van De Velde, Gunter
(Nokia - BE/Antwerp)
Sent: Wednesday, December 20, 2017 10:52 AM
To: Susan Hares; [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

Hi Sue,

Thanks. If in the next few weeks no technical mistakes are discovered, then
maybe it is ready for WGLC. Time will provide feedback in IDR WG.
 
What seems a more pressing matter at this stage would be to get IANA
code-points. Not sure what is the best process to get those? 

G/

    Gunter:

    Sue 
    
    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of Van De Velde,
Gunter
    (Nokia - BE/Antwerp)
    Sent: Wednesday, December 20, 2017 4:41 AM
    To: [email-masked]
    Subject: Re: [Idr] I-D Action:
draft-ietf-idr-flowspec-path-redirect-03.txt
    
    All,
    
    This draft has been simplified and removed some clutter. Authors believe
the
    draft to have reached stable content.
    
    The flowspec indirection-ids included are: Type0 - localized
indirection,
    Type 1&2 - node SID (index & global), Type 3&4 - binding SID
(index&global)
    and Type 5 - global tunnel-id.
    
    G/ 

    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of
    [email-masked]
    Sent: Wednesday, December 20, 2017 10:30
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-path-redirect-03.txt

    
    Abstract:

    

    

    Please note that it may take a couple of minutes from the time of
submission
    until the htmlized version and diff are available at tools.ietf.org.