Subject: [Idr] Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)

From: Alvaro Retana <[email-masked]>
Date: Fri, 6 Apr 2018 11:51:45 -0700

Dear idr WG:

draft-ietf-ospf-link-overload [1] defines a new BGP-LS
Graceful-Link-Shutdown TLV.  When an early allocation was requested, it was
mistakenly requested from the "BGP-LS NLRI-Types" registry [2], not from
the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and
Attribute TLVs” registry [3].  IANA allocated a value according to the
request: 1101.

The mistake wasn't noticed until the document was in IESG Evaluation -- we
are in the process of correcting it.  However, the 1101 code point in the
"BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute
TLVs” registry corresponds to the Peer-Node-SID, an early allocation made
to draft-ietf-idr-bgpls-segment-routing-epe [4], which says that "several
early implementations exist".

Are there implementations of draft-ietf-idr-bgpls-segment-routing-epe with
the 1101 code point?  Are there deployments of those implementations?

Thanks!

Alvaro.

[1] https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/
[2]
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#nlri-types

[3]
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv

[4]
https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 6 Apr 2018 22:05:50 +0000

Hi Alvaro,

There are implementations and deployments - https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20

Also, it looks to me that 1101 is assigned to Peer Node SID already - https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv

Also, I do not see early allocation for the BGP-LS OSPF Link Overload TLV although one is requested in the corresponding draft. Hence, I don’t see what the problem is.

Thanks,
Acee

From: Alvaro Retana <[email-masked]>
Date: Friday, April 6, 2018 at 2:51 PM
To: IDR List <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Acee Lindem <[email-masked]>
Subject: Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)

Dear idr WG:

draft-ietf-ospf-link-overload [1] defines a new BGP-LS Graceful-Link-Shutdown TLV.  When an early allocation was requested, it was mistakenly requested from the "BGP-LS NLRI-Types" registry [2], not from the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs” registry [3].  IANA allocated a value according to the request: 1101.

The mistake wasn't noticed until the document was in IESG Evaluation -- we are in the process of correcting it.  However, the 1101 code point in the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs” registry corresponds to the Peer-Node-SID, an early allocation made to draft-ietf-idr-bgpls-segment-routing-epe [4], which says that "several early implementations exist".

Are there implementations of draft-ietf-idr-bgpls-segment-routing-epe with the 1101 code point?  Are there deployments of those implementations?

Thanks!

Alvaro.

[1] https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/
[2] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#nlri-types
[3] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv
[4] https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sat, 7 Apr 2018 09:31:14 +0000

Hi Alvaro/All,

I agree with Acee. We have implementations for the BGP-LS EPE draft that are shipping and deployed and those code points were assigned via early allocation and reflected in the registry. They must not be changed.

I don’t see any issue with correcting the allocation for the BGP-LS OSPF link-overload TLV (to whatever value is available/assigned by IANA from the correct registry mentioned below).

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 07 April 2018 03:36
To: Alvaro Retana <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Idr] Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)

Hi Alvaro,

Thanks,
Acee

From: Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 6, 2018 at 2:51 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>
Subject: Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)

Dear idr WG:

Thanks!

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 12 Apr 2018 06:17:33 -0700

On April 6, 2018 at 6:05:52 PM, Acee Lindem (acee) ([email-masked]) wrote:

Acee:

Hi!

There are implementations and deployments -
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgpls-segment-routing-epe%20

Also, it looks to me that 1101 is assigned to Peer Node SID already -
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv

Also, I do not see early allocation for the BGP-LS OSPF Link Overload TLV
although one is requested in the corresponding draft. Hence, I don’t see
what the problem is.

Let me try again.  In short, I’m trying to figure out how serious the
problem is...

The early allocation for the BGP-LS OSPF Link Overload TLV was (mistakenly)
requested from the BGP-LS NLRI-Types registry [1] and a value of 1101 was
assigned.  As you know, that mistake was detected late in the process
(during IESG Evaluation!) and fixed in the -15 version
of draft-ietf-ospf-link-overload (-16 is the current one).

The BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and
Attribute TLVs registry [2] is the correct registry, and, as you point
above, the 1101 value there was assigned to the Peer Node SID
(draft-ietf-idr-bgpls-segment-routing-epe).

With this e-mail, and a similar one I sent to the lsr WG, I am trying to
figure out the impact (if any) to existing implementation from what could
be seen as overlapping assignments, and the actions we may need IANA to
take.  For example, if there were implementations of
draft-ietf-ospf-link-overload
*and* draft-ietf-idr-bgpls-segment-routing-epe with the same value (1101)
then we would have a significant problem.  However, the only answer in the
lsr list has been to point out that there are no known implementations
of draft-ietf-ospf-link-overload — and, from this thread, there is
confirmation that implementations
of draft-ietf-idr-bgpls-segment-routing-epe exist.

This is probably the best result, and makes the registry cleanup easier.

Thanks!

Alvaro.

[1]

[2]

Thanks,

Acee

From: Alvaro Retana <[email-masked]>
Date: Friday, April 6, 2018 at 2:51 PM
To: IDR List <[email-masked]>
Cc: "[email-masked]" <
[email-masked]>, "
[email-masked]" <
[email-masked]>, "[email-masked]" <
[email-masked]>, Acee Lindem <[email-masked]>
Subject: Implementations of draft-ietf-idr-bgpls-segment-routing-epe
(draft-ietf-ospf-link-overload)

Dear idr WG:

Thanks!

Alvaro.

[2]

[3]

[4]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 12 Apr 2018 13:22:38 +0000

Hi Alvaro,

Ok – it sounds like you have this under control ;^) Retain 1101 for BGP EPE and use the assign a new value for the OSPF Link Overload Attribute…

Thanks,
Acee

From: Alvaro Retana <[email-masked]>
Date: Thursday, April 12, 2018 at 9:17 AM
To: Acee Lindem <[email-masked]>, IDR List <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)

On April 6, 2018 at 6:05:52 PM, Acee Lindem (acee) ([email-masked]<mailto:[email-masked]>) wrote:

Acee:

Hi!

Let me try again.  In short, I’m trying to figure out how serious the problem is...

The early allocation for the BGP-LS OSPF Link Overload TLV was (mistakenly) requested from the BGP-LS NLRI-Types registry [1] and a value of 1101 was assigned.  As you know, that mistake was detected late in the process (during IESG Evaluation!) and fixed in the -15 version of draft-ietf-ospf-link-overload (-16 is the current one).

The BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs registry [2] is the correct registry, and, as you point above, the 1101 value there was assigned to the Peer Node SID (draft-ietf-idr-bgpls-segment-routing-epe).

With this e-mail, and a similar one I sent to the lsr WG, I am trying to figure out the impact (if any) to existing implementation from what could be seen as overlapping assignments, and the actions we may need IANA to take.  For example, if there were implementations of draft-ietf-ospf-link-overload *and* draft-ietf-idr-bgpls-segment-routing-epe with the same value (1101) then we would have a significant problem.  However, the only answer in the lsr list has been to point out that there are no known implementations of draft-ietf-ospf-link-overload — and, from this thread, there is confirmation that implementations of draft-ietf-idr-bgpls-segment-routing-epe exist.

Thanks!

Alvaro.

[1] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#nlri-types

[2] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv

Thanks,
Acee

Dear idr WG:

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 12 Apr 2018 13:28:19 +0000

Alvaro, et al,
Note that the version  the OSPF Link Overload draft (aka, OSPF Graceful Link Shutdown) sitting on the RFC Editor’s queue has a non-conflicting value suggested. See excerpt below:

BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and
   Attribute TLVs [RFC7752]

   i)Graceful-Link-Shutdown TLV - Suggested 1121

Thanks,
Acee

From: Acee Lindem <[email-masked]>
Date: Thursday, April 12, 2018 at 9:22 AM
To: Alvaro Retana <[email-masked]>, IDR List <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Implementations of draft-ietf-idr-bgpls-segment-routing-epe (draft-ietf-ospf-link-overload)
Resent-From: <[email-masked]>
Resent-To: Christian Hopps <[email-masked]>, Acee Lindem <[email-masked]>
Resent-Date: Thursday, April 12, 2018 at 9:22 AM

Hi Alvaro,

Thanks,
Acee

Acee:

Hi!

Thanks!

Alvaro.

Thanks,
Acee

Dear idr WG:

Thanks!

Alvaro.