Subject: [Idr] draft-ietf-idr-rs-bfd-05 - 2 Week WG LC from 4/13 to 4/27

From: "Susan Hares" <[email-masked]>
Date: Fri, 13 Apr 2018 11:06:14 -0400

This begins a 2 week WG LC for draft-ietf-rs-bfd-05.txt.  You can obtain the
document at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-rs-bfd/

In your comments, please consider if: 

1)      Do you know of any deployments of this technology in the Internet? 

2)      Do you believe this technology is ready for standardization? 

3)      Does this technology have the management necessary for deployment in
the Internet? 

Susan Hares

Co-chair

Shepherd

---

From: Randy Bush <[email-masked]>
Date: Fri, 13 Apr 2018 08:13:14 -0700

> This begins a 2 week WG LC for draft-ietf-rs-bfd-05.txt.  You can obtain the

i do not believe it appropriate for a co-author to support their own
document, though i have twice anti-supported a document on which i was a
co-author :)

but i do note that i am unaware of any ipr on this document.

randy

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 13 Apr 2018 13:24:45 -0400

(as an author, natch)

> On Apr 13, 2018, at 11:13 AM, Randy Bush <[email-masked]> wrote:
> 
> document, 

I think it's a bit pointless myself -- I assume authors do support it unless they step right up and say they don't (which as Randy points out is unusual but not unheard-of). In any case, I'll observe that in this case, the authors did discuss the question before asking the WG for WGLC.

> but i do note that i am unaware of any ipr on this document.

I also am unaware of any relevant IPR.

Thanks,

--John

---

From: Job Snijders <[email-masked]>
Date: Fri, 13 Apr 2018 17:31:29 +0000

Dear all,

Are there implementations? Is there an implemention report as per IDR
tradition?

If not, I don’t support progressing this draft at this moment.

The machinery described in this draft is not entirely straight forward,
without running code we should hold off on progressing.

Kind regards,

Job

On Fri, 13 Apr 2018 at 08:06, Susan Hares <[email-masked]> wrote:

> This begins a 2 week WG LC for draft-ietf-rs-bfd-05.txt.  You can obtain
> the document at:
>
>
>
> 3)      Does this technology have the management necessary for deployment
> in the Internet?
>
>
>
>
>
>
>
> Susan Hares
>
> Co-chair
>
> Shepherd
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 13 Apr 2018 17:52:56 +0000

I must agree with Job here.

In fact WG last call in general makes sense when spec is rock solid. And
very often issues come up during its implementations.

So while it may be up to chairs and ADs I am not sure why do we proceed
like this here in IDR.

On the draft itself I am not supporting it in current format (burden to use
extra SAFI on clients) IMO is not necessary.

Many thx
R.

On Fri, Apr 13, 2018, 19:31 Job Snijders <[email-masked]> wrote:

>> 3)      Does this technology have the management necessary for
>> deployment in the Internet?
>>
>>
>>
>>
>>
>>
>>
>> Susan Hares
>>
>> Co-chair
>>
>> Shepherd

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 13 Apr 2018 14:06:19 -0400

(As a co-author, yes, really. Maybe the co-chair would even disagree with some of these points, who knows.[*])

> On Apr 13, 2018, at 1:31 PM, Job Snijders <[email-masked]> wrote:
> 
> Dear all,
> 
> Are there implementations? Is there an implemention report as per IDR tradition?
> 
> The machinery described in this draft is not entirely straight forward, without running code we should hold off on progressing. 

For those who missed it, there is a bit more context in Job's earlier note, https://www.ietf.org/mail-archive/web/idr/current/msg19261.html, including

"ps. yes, i know IDR can have WGLC without running code, but given that
this is a non-trivial extension to BGP; I'd really like to see multiple
implementations that are able to interact with each other in the correct
way and a report detailing the interopability."

In this case the authors are, exactly and without pretense, requesting WGLC without running code. Which seems a funny thing coming from me -- sometimes all these hats I wear get too tight and give me a headache. Anyway, in this case we think it's worth doing the WGLC because it indicates as clearly as we can to potential implementors that the spec is "done" and will not continue to mutate. As you might recall, this particular spec has changed quite a lot over its history, more than many, and I wouldn't blame an implementor for standing back and waiting for the dust to settle before writing code. 

As we all know (and have a history of doing, as a WG) if post-WGLC implementation experience indicates a need for changes, the draft can and will be updated to take them onboard, and of course if those changes are substantive enough, I would expect a new WGLC would be needed at that point. Other groups do this same review/implementation cycle by progressing things to RFC, then implementing, then bis-ing or otherwise updating the RFCs. I am not (again, as a WG member) a fan of that, and I'm glad we don't do things that way, although our way is also not perfect as witness this discussion.

Fundamentally a WGLC is a way of asking the WG, "the authors think this is done, do you agree?" We are asking. "We have implementations" is a strong argument to support the "we are done" argument, but it's neither necessary nor sufficient and so far the WG has deemed it desirable but not required for WGLC. We think there would be no benefit, and some harm, from letting the document sit in "active WG draft" status when it's *not* in fact active and the authors have moved on to other things. Moving it to "waiting for implementation" status, if the results of the WGLC support that, is more honest and more clear. I suppose another way of doing this would be to invent some IDR pre-WGLC-WGLC that feeds into the "waiting for implementation" document state, but right now we don't have that.

Of course you and any other WG member are free to use all the facts at your disposal (including the document itself, and including any reported implementation) to decide if you want to support a WGLC, and that's fine.

Finally I'd like to ask (and this *is* with the co-chair hat on) that if we continue a wide-ranging philosophical discussion of the IDR implementation tradition as opposed to a discussion of whether the doc is ready for WGLC, that we change the subject line accordingly. 

Thanks!

--John

[*] "Do I contradict myself? Very well, then I contradict myself, I am large, I contain multitudes." --Walt Whitman