Subject: Re: [Idr] Augmenting the ietf-routing in two separate drafts

From: Qin Wu <[email-masked]>
Date: Thu, 30 May 2019 02:21:30 +0000

Acee, I know their difference, I just thought whether BGP RIB should be factored out as a separate draft or move to rtgw-yang-rib-extend since from draft name or title, I can not see rtgw-yang-rib-extend only focus on multi- next-hop support.
The current BGP base model is a little bit heavyweight to me.

-Qin
发件人: Acee Lindem (acee) [mailto:[email-masked]]
发送时间: 2019年5月23日 20:42
收件人: Qin Wu <[email-masked]>; [email-masked]
主题: Re: [Idr] Augmenting the ietf-routing in two separate drafts

Hi Qin,

Are you familiar with any BGP and/or router RIB implementations? The global RIB defined in RFC 8349 and the BRIB defined in the draft BGP YANG model you reference are very different things. The BGP RIB (BRIB) should remain under BGP as it is in the existing draft.

Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Qin Wu <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 23, 2019 at 2:37 AM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Augmenting the ietf-routing in two separate drafts

Hi, authors and all:
It is not clear to me why we define augmentation of the ietf-routing in two different draft, one is in the draft-ietf-rtgwg-yang-rib-extend-01 which augment common rib building block in ietf-routing with multiple next-hop support,
The other is in the BGP YANG model (https://tools.ietf.org/html/draft-ietf-idr-bgp-model-05#section-2..3<https://tools.ietf.org/html/draft-ietf-idr-bgp-model-05#section-2.3>) which augment ietf-routing with BGP RIB specific parameters.
I would suggest to factor out BGP RIB into a separate draft or draft-ietf-rtgwg-yang-rib-extend-01 and define lightweight BGP model and move forward.
Let me know if you have disagreement on this.

-Qin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 30 May 2019 19:35:59 +0000

Hi Qin,

Are you sure? It wouldn’t make sense to move the BGP RIB to the rtgwg-yang-rib-extend draft since the draft augments the global RIB with protocol independent extensions. I also wouldn’t put the BRIB in a separate draft. If I separated anything out, it would be the policy constructs, ietf-bgp-policy, since these augment a separate model.

Thanks,
Acee

From: Qin Wu <[email-masked]>
Date: Wednesday, May 29, 2019 at 10:21 PM
To: Acee Lindem <[email-masked]>, IDR List <[email-masked]>
Subject: RE: [Idr] Augmenting the ietf-routing in two separate drafts

-Qin

Hi Qin,

Acee

Hi, authors and all:

-Qin