Subject: [Idr] Barry Leiba's No Objection on draft-ietf-idr-bgpls-segment-routing-epe-18: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Mon, 13 May 2019 22:45:39 -0700

Barry Leiba has entered the following ballot position for
draft-ietf-idr-bgpls-segment-routing-epe-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Just editorial stuff...

Throughout: “i.e.” needs a comma after it.  So does “e.g.”.

— Section 1 —

   SR can be directly applied to either an MPLS dataplane (SR/MPLS) with
   no change on the forwarding plane or to a modified IPv6 forwarding

Make it “either to” so it’s parallel with the “or to” that comes later.

   centralized controller based BGP Egress Peer Engineering solution
   involving SR path computation using the BGP Peering Segments.  This
   use-case comprises of a centralized controller that learns the BGP

“Centralized-controller-based” is a compound adjective that needs to be
hyphenated.  “Use case” is a noun, and should not be hyphenated.  And
“comprises” should not have “of” after it (“consists of” would, though).

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 16 May 2019 09:08:38 +0000

Hi Barry,

Thanks for your review. I've accepted and updated the draft for all your editorial comments below.

A v19 of the draft has just been posted which includes these changes along with others that I had pending in my buffer from Alvaro's AD review and other IESG last call reviews.

https://tools.ietf.org/html/draft-ietf-idr-bgpls-segment-routing-epe-19 

Thanks,
Ketan

-----Original Message-----
From: Barry Leiba via Datatracker <[email-masked]> 
Sent: 14 May 2019 11:16
To: The IESG <[email-masked]>
Cc: [email-masked]; Susan Hares <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Barry Leiba's No Objection on draft-ietf-idr-bgpls-segment-routing-epe-18: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Just editorial stuff...

— Section 1 —

“Centralized-controller-based” is a compound adjective that needs to be hyphenated.  “Use case” is a noun, and should not be hyphenated.  And “comprises” should not have “of” after it (“consists of” would, though).

---

From: Barry Leiba <[email-masked]>
Date: Thu, 16 May 2019 09:50:58 -0400

Thanks, Ketan!

Barry