Subject: Re: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

From: Dhanendra Jain <[email-masked]>
Date: Thu, 2 May 2019 09:58:09 -0700

Hi Sue/All,

Thanks for this call. I support the early allocation for remaining TLVs.

Regards,
Dhanendra.

On Tue, Apr 30, 2019 at 12:00 PM Paul Mattes <[email-masked]> wrote:

> I support the early allocation.
>
>
>
>        *pdm*
>
>
>
> *From:* Susan Hares <[email-masked]>
> *Sent:* Tuesday, April 30, 2019 7:57 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Early Code Point Allocation for
> draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]
>
>
>
> This begins a 2 week call for early allocation for
> draft-ietf-idr-segment-routing-te-policy-05.txt .
>
>
>
> https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-segment-routing-te-policy%2F&data=01%7C01%7Cpamattes%40microsoft.com%7Caddfa0197348478f48fc08d6cd6b5862%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=yCB%2FlFGvaFqGSJTuLPOOb2vUk%2BDBdMKNJczsQW2pDy8%3D&reserved=0>
>
>
>
> Please note that in this draft in section 8.1-8.3 to some values with
> existing early allocation, but in sections 8.3 there are 3 values:  (ENLP
> sub-TLV, Priority sub-TLV, and Policy Name sub-TLV) that need early
> assignment.   Section 8.4, 8.5 and 8.6 define new registries which do not
> need early allocation.
>
>
>
> Please comment early and often on early allocation.   The authors have
> indicated their preference for values on this email list.
>
>
>
> The authors have indicated that they have 3+ implementations which need
> these values in order to complete the IDR implementation requirements.
>
>
>
> Cheerily, Susan Hares
>
>
>

---

From: Nandan Saha <[email-masked]>
Date: Fri, 3 May 2019 08:38:29 +0530

Support early allocation as it's required for implementation.

Thanks,
Nandan

On Tue, Apr 30, 2019 at 6:27 PM Susan Hares <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: stefano previdi <[email-masked]>
Date: Fri, 3 May 2019 12:07:40 +0200

support.

s.

On Tue, Apr 30, 2019 at 6:27 PM Susan Hares <[email-masked]> wrote:
> This begins a 2 week call for early allocation for draft-ietf-idr-segment-routing-te-policy-05.txt .
> 
>  
> 
> Please note that in this draft in section 8.1-8.3 to some values with existing early allocation, but in sections 8.3 there are 3 values:  (ENLP sub-TLV, Priority sub-TLV, and Policy Name sub-TLV) that need early assignment.   Section 8.4, 8.5 and 8.6 define new registries which do not need early allocation.
> 
>  
> 
> Please comment early and often on early allocation.   The authors have indicated their preference for values on this email list.
> 
>  
> 
> The authors have indicated that they have 3+ implementations which need these values in order to complete the IDR implementation requirements.   
> 
>  
> 
> Cheerily, Susan Hares
> 
>  
>

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 3 May 2019 11:23:49 +0000

Support!

Thanks

Regards … Zafar

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Tuesday, April 30, 2019 at 8:57 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

Cheerily, Susan Hares

---

From: Gaurav Dawra <[email-masked]>
Date: Fri, 3 May 2019 07:59:58 -0700

Suppprt.

Gaurav
LinkedIn

Sent from my iPhone

> On May 3, 2019, at 4:23 AM, Zafar Ali (zali) <[email-masked]> wrote:
> 
> Support!
>  
> Thanks
>  
> Regards … Zafar
>

---

From: Zhuangshunwan <[email-masked]>
Date: Sun, 5 May 2019 02:34:27 +0000

Support!

Thanks,
Shunwan

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, April 30, 2019 8:57 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

Cheerily, Susan Hares

---

From: Lizhenbin <[email-masked]>
Date: Sun, 5 May 2019 07:18:02 +0000

Support.

Best Regards,
Zhenbin (Robin)

--------------------------------------------------
李振斌 Robin
Mobile: +86-13651017745<tel:+86-13651017745>/+968-91797068<tel:+968-91797068>
Email: [email-masked]<mailto:[email-masked]>
发件人：Susan Hares <[email-masked]>
收件人：[email-masked] <[email-masked]>
抄 送：[email-masked] <[email-masked]>
时间：2019-04-30 20:57:39
主 题：[Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

Cheerily, Susan Hares

---

From: Przemyslaw Krol <[email-masked]>
Date: Thu, 23 May 2019 08:40:23 -0700

Greetings,

How long does this process usually take?

thanks,
pk

On Tue, Apr 30, 2019 at 9:27 AM Kausik Majumdar (kmajumda) <
[email-masked]> wrote:

>
>
> Hi Sue et all,
>
>
>
> I support the early allocation of BGP Tunnel Allocation Sub-TLVs defined
> in section 8.3 :
>
>
>
>           TBD1            ENLP sub-TLV             This document
>
>           TBD2            Priority sub-TLV         This document
>
>           TBD3            Policy Name sub-TLV      This document
>
>
>
> This would be needed for implementation.
>
>
>
> Thanks,
>
> Kausik
>
>
>
> *From:* Idr <[email-masked]> *On Behalf Of * Ketan Talaulikar
> (ketant)
> *Sent:* Tuesday, April 30, 2019 7:04 AM
> *To:* Susan Hares <[email-masked]>; [email-masked]
> *Cc:* [email-masked]; Przemyslaw Krol <
> [email-masked]>
> *Subject:* Re: [Idr] Early Code Point Allocation for
> I support the early allocation for code-points for the remaining TLVs
> defined in this WG document. We need the same for implementation.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* Idr <[email-masked]> *On Behalf Of *Susan Hares
> *Sent:* 30 April 2019 18:27
> *To:* [email-masked]
> *Subject:* [Idr] Early Code Point Allocation for
> https://datatracker..ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/
> <https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/>
>
>
>

-- 
Przemyslaw "PK" Krol |  Strategic Network Engineer ing | [email-masked]

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 24 May 2019 06:30:08 +0000

Hi PK,

AFAIK there was no objection and enough support for the Early Code Point Allocation call which concluded on 5/14. So I believe the chairs/AD would need to get this action done with IANA.

We had recommended values at the start of this discussion : https://mailarchive.ietf.org/arch/msg/idr/YmKvUQ0iuDCf_ijWUiwNz6unXAU

Reproducing it again below

          Codepoint       Description              Reference
          ------------------------------------------------------
          12              Preference sub-TLV       This document
          13              Binding SID sub-TLV      This document
          128             Segment List sub-TLV     This document
          14              ENLP sub-TLV             This document
          15              Priority sub-TLV         This document
          129             Policy Name sub-TLV      This document

Thanks,
Ketan

From: Przemyslaw Krol <[email-masked]>
Sent: 23 May 2019 17:40
To: Kausik Majumdar (kmajumda) <[email-masked]>
Cc: Ketan Talaulikar (ketant) <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

Greetings,

thanks,
pk

On Tue, Apr 30, 2019 at 9:27 AM Kausik Majumdar (kmajumda) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sue et all,

I support the early allocation of BGP Tunnel Allocation Sub-TLVs defined in section 8.3 :

Thanks,
Kausik

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Ketan Talaulikar (ketant)
Sent: Tuesday, April 30, 2019 7:04 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Przemyslaw Krol <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

Hi Sue/All,

I support the early allocation for code-points for the remaining TLVs defined in this WG document. We need the same for implementation.

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: 30 April 2019 18:27
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Idr] Early Code Point Allocation for draft-ietf-idr-segment-routing-te-policy [4/30 to 5/14/2019]

https://datatracker..ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/<https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/>

Cheerily, Susan Hares

--
Przemyslaw "PK" Krol |
 Strategic Network Engineer
ing | [email-masked]<mailto:[email-masked]>

---

From: Dhanendra Jain <[email-masked]>
Date: Fri, 24 May 2019 09:41:15 -0700

Ack on the suggested values of the code points below (14, 15 and 129).

Thanks,
Dhanendra.

On Thu, May 23, 2019 at 11:30 PM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> Hi PK,
>
>
>
> AFAIK there was no objection and enough support for the Early Code Point
> Allocation call which concluded on 5/14. So I believe the chairs/AD would
> need to get this action done with IANA.
>
>
>
> We had recommended values at the start of this discussion :
> https://mailarchive.ietf.org/arch/msg/idr/YmKvUQ0iuDCf_ijWUiwNz6unXAU
>
>
>
> *          14              ENLP sub-TLV             This document*
>
> *          15              Priority sub-TLV         This document*
>
> *          129             Policy Name sub-TLV      This document*
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* Przemyslaw Krol <[email-masked]>
> *Sent:* 23 May 2019 17:40
> *To:* Kausik Majumdar (kmajumda) <[email-masked]>
> *Cc:* Ketan Talaulikar (ketant) <[email-masked]>; Susan Hares <
> [email-masked]>; [email-masked];
> [email-masked]
> *From:* Idr <[email-masked]> *On Behalf Of *Ketan Talaulikar
> (ketant)
> ing | [email-masked]