Subject: [Idr] Comments on draft-ietf-idr-rfc5575bis

From: Zhuangshunwan <[email-masked]>
Date: Fri, 31 May 2019 06:28:36 +0000

Dear authors,

I have read this document and found that some text may have questions.

#1

4.2.9.  Type 9 - TCP flags

…

    0   1   2   3   4   5   6   7

   +---+---+---+---+---+---+---+---+

   | e | a |  len  | 0 | 0 |not| m |

   +---+---+---+---+---+---+---+---+

      Bitmask format
[Shunwan]  The “Bitmask format” here should be “Bitmask operand format” .

#2
4.2.10.  Type 10 - Packet length

      Encoding:<type (1 octet), [op, bitmask]+>
[Shunwan]  The “bitmask” here should be “value”.

Please correct me if I didn't understand it correctly, thank you！

Best regards,
Shunwan

---

From: Christoph Loibl <[email-masked]>
Date: Fri, 31 May 2019 09:34:33 +0200

Hi Shunwan,

Thanks very much for pointing that out (I was reading thru it 20+ times already… - especially #2 is something that I should have spottet earlier ;-)

#1: I think the text is rather clear here. 

Compared with section 4.3.2 (Numeric operator) the text under the table should actually say “Bitmask Operator”.

#2: You are right. The text is fine so far and even the encoding is clear but it *really* should say “value” not “bitmask”.

I will upload those editorial changes today.

Cheers Christoph

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 31.05.2019, at 08:28, Zhuangshunwan <[email-masked]> wrote:
> 
> Dear authors,
>  
> _______________________________________________
> Idr mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr>