Subject: [Idr] Augmenting the ietf-routing in two separate drafts

From: Qin Wu <[email-masked]>
Date: Thu, 23 May 2019 06:35:26 +0000

Hi, authors and all:
It is not clear to me why we define augmentation of the ietf-routing in two different draft, one is in the draft-ietf-rtgwg-yang-rib-extend-01 which augment common rib building block in ietf-routing with multiple next-hop support,
The other is in the BGP YANG model (https://tools.ietf.org/html/draft-ietf-idr-bgp-model-05#section-2.3) which augment ietf-routing with BGP RIB specific parameters.
I would suggest to factor out BGP RIB into a separate draft or draft-ietf-rtgwg-yang-rib-extend-01 and define lightweight BGP model and move forward.
Let me know if you have disagreement on this.

-Qin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 23 May 2019 12:42:15 +0000

Hi Qin,

Are you familiar with any BGP and/or router RIB implementations? The global RIB defined in RFC 8349 and the BRIB defined in the draft BGP YANG model you reference are very different things. The BGP RIB (BRIB) should remain under BGP as it is in the existing draft.

Acee

From: Idr <[email-masked]> on behalf of Qin Wu <[email-masked]>
Date: Thursday, May 23, 2019 at 2:37 AM
To: IDR List <[email-masked]>
Subject: [Idr] Augmenting the ietf-routing in two separate drafts

Hi, authors and all:
It is not clear to me why we define augmentation of the ietf-routing in two different draft, one is in the draft-ietf-rtgwg-yang-rib-extend-01 which augment common rib building block in ietf-routing with multiple next-hop support,
The other is in the BGP YANG model (https://tools.ietf.org/html/draft-ietf-idr-bgp-model-05#section-2..3<https://tools.ietf.org/html/draft-ietf-idr-bgp-model-05#section-2.3>) which augment ietf-routing with BGP RIB specific parameters.
I would suggest to factor out BGP RIB into a separate draft or draft-ietf-rtgwg-yang-rib-extend-01 and define lightweight BGP model and move forward.
Let me know if you have disagreement on this.

-Qin