Subject: Re: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 1 May 2019 14:03:55 +0000

Hi Chaitanya,

Please check inline below.

From: Idr <[email-masked]> On Behalf Of Chaitanya Varma
Sent: 30 April 2019 13:34
To: [email-masked]
Cc: Gurusiddesh Nidasesi <[email-masked]>
Subject: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

Hi,

I have couple of queries from the below draft.

https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05

  “ Typically, a controller defines the set of policies and advertise
   them to policy head-end routers (typically ingress routers).”

How do we communicate SR policies from controller? Is it through BGP-SR session or PCEP session.
[KT] This draft is all about using BGP for signalling SR Policies from a controller to the head-end routers. So yes (b) below.

a. If it is through PCEP session what happens if the PCC is non-headend?
b. If it is through BGP-SR what is the role for PCEP between PCE and PCC?
[KT] PCEP is another flavour for instantiation of SR Policies. Yet another option is using netconf/yang or another method for provisioning. This draft is about using BGP and PCEP is not required.

  “ Moreover, one or more route-target SHOULD be attached to the
   advertisement”

How Route-target should be attached to a SR-NLRI update?
[KT] As Route Target Extended Communities attribute – ref sec 1 of the draft.

Is it done through local configuration or picked up based on some dynamic parameter?
[KT] It is done by the controller and may be done via local config – either along with the SR Policy or route policy or even dynamically based on the head-end address. This would be implementation specific.

Thanks,
Ketan

Appreciate if you can help here.

Regards,
Chaitanya

..

---

From: Gurusiddesh Nidasesi <[email-masked]>
Date: Tue, 7 May 2019 17:10:30 +0530

Hi Ketan,

Thanks for the quick response.

Additionally, we have more queries as follows

*"Alternatively, a router (i.e., a BGP egress router) advertises SR*

*   Policies representing paths to itself.  In this case, it is possible*

*   to send the policy to each head-end over a BGP session to that head-*

*  end, without requiring any further propagation of the policy."*

How does an egress router advertise SR policies representing paths to
itself? Is it done through BGP configuration or any other trigger?
In the above case how ERO (SID-List) is calculated?

Regards

Gurusiddesh V N

On Wed, May 1, 2019 at 7:34 PM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> *From:* Idr <[email-masked]> *On Behalf Of *Chaitanya Varma
> *Sent:* 30 April 2019 13:34
> *To:* [email-masked]
> *Cc:* Gurusiddesh Nidasesi <[email-masked]>
> *Subject:* [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy
>
>
>
> Hi,
>
>
>
> *  “ Typically, a controller defines the set of policies and advertise*
>
> *   them to policy head-end routers (typically ingress routers).” *
>
>
>
> *[KT] This draft is all about using BGP for signalling SR Policies from a
> controller to the head-end routers. So yes (b) below.*
>
>
>
> *[KT] PCEP is another flavour for instantiation of SR Policies. Yet
> another option is using netconf/yang or another method for provisioning.
> This draft is about using BGP and PCEP is not required.*
>
>
>
> *  “ Moreover, one or more route-target SHOULD be attached to the*
>
>
>
> *   advertisement” *How Route-target should be attached to a SR-NLRI
> update?
>
> *[KT] As Route Target Extended Communities attribute – ref sec 1 of the
> draft.*
>
>
>
> *[KT] It is done by the controller and may be done via local config –
> either along with the SR Policy or route policy or even dynamically based
> on the head-end address. This would be implementation specific.*
>
>
>
> *Thanks,*
>
> *Ketan*
>
>
>

-- 
Thanks,
Gurusiddesh V N

-- 
.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 8 May 2019 10:28:28 +0000

Hi Gurusiddesh,

Please check inline below

From: Gurusiddesh Nidasesi <[email-masked]>
Sent: 07 May 2019 17:11
To: Ketan Talaulikar (ketant) <[email-masked]>
Cc: Chaitanya Varma <[email-masked]>; [email-masked]
Subject: Re: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

Hi Ketan,

"Alternatively, a router (i.e., a BGP egress router) advertises SR
   Policies representing paths to itself.  In this case, it is possible
   to send the policy to each head-end over a BGP session to that head-
  end, without requiring any further propagation of the policy."

How does an egress router advertise SR policies representing paths to itself?
[KT] By setting endpoint to it’s own router-id in the NLRI and setting the ingress router’s router-id in the router-target extended community.
Is it done through BGP configuration or any other trigger?
[KT] This would be implementation specific based on the use-case/workflow.

In the above case how ERO (SID-List) is calculated?
[KT] This is again implementation specific. It could be done by some TE module on the egress BGP router that has topology visibility from the ingress router to itself. It would be kind of reverse of how a headend computes a path from itself to an endpoint – this is the endpoint computing path to itself from some headend.
Thanks,
Ketan

Regards
Gurusiddesh V N

On Wed, May 1, 2019 at 7:34 PM Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chaitanya,

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Chaitanya Varma
Sent: 30 April 2019 13:34
To: [email-masked]<mailto:[email-masked]>
Cc: Gurusiddesh Nidasesi <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

Hi,

Thanks,
Ketan

Regards,
Chaitanya

..

--
Thanks,
Gurusiddesh V N

.