Subject: [Idr] IDR Charter discussion

From: "Susan Hares" <[email-masked]>
Date: Mon, 10 Jun 2019 15:51:03 -0400

The IDR Charter was last revised in March, 2010. 

It's time to reconsider what needs to go in the charter: 

Somethings we might include are:

.         BGP Yang modules, 

.         A general BGP Layer 3 auto-configuration or liveness, 

.         Additional  tunnel features for a optional tunnel encapsulation (a
follow-on to draft-ietf-idr-tunnel-encaps), 

.         Upgrade of the base BGP specification to Full Standard, 

.         Flow specification additions, 

.         BGP-LS basic functions (e.g.
<https://datatracker.ietf.org/doc/draft-ketant-idr-rfc7752bis/>
draft-ketant-idr-rfc7752bis-00) error handling

.         Segment routing additions to BGP, 

.         Wide Communities and other "bigger" communities , 

.         Revisions to Existing features. 

Things which will be removed because we are done: 

.         Support for 4-octet AS numbers, 

.         Add path related additions, 

.         Error handling rules for BGP in general, 

.         Revisions to the BGP 'Minimum Route Advertisement Interval', 

.         The definition of an "Accumulated IGP Metric".

In 2010, IDR started an advancement of BGP to full standard, but stopped. 

WG members indicated they wanted us to focus on the feature revisions. 

Is there anything we missed? 

Please use this thread to suggest things we should keep or drop in the
charter. 

Cheerily, Susan Hares

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 11 Jun 2019 00:58:23 +0200

Hi Sue,

> Is there anything we missed?

Can we please also consider adding to the new charter:

* *Enhancements to eBGP Path Selection*

Today we see number of proprietary solutions in this space popping left and
right.

I think it would be in the interest of the industry to work on it in the
IDR WG and deliver an IETF specification of the WG product.

Rajiv has started, but his draft - while very useful - just barely
scratches the tip of the ice berg :)

Thx,
Robert.

On Mon, Jun 10, 2019 at 9:51 PM Susan Hares <[email-masked]> wrote:

> It’s time to reconsider what needs to go in the charter:
>
>
>
> ·         BGP Yang modules,
> ·         A general BGP Layer 3 auto-configuration or liveness,
>
> ·         Additional  tunnel features for a optional tunnel encapsulation
> (a follow-on to draft-ietf-idr-tunnel-encaps),
>
> ·         Upgrade of the base BGP specification to Full Standard,
>
> ·         Flow specification additions,
>
> ·         BGP-LS basic functions (e.g. draft-ketant-idr-rfc7752bis-00
> <https://datatracker.ietf.org/doc/draft-ketant-idr-rfc7752bis/>) error
> handling
>
> ·         Segment routing additions to BGP,
>
> ·         Wide Communities and other “bigger” communities ,
>
> ·         Revisions to Existing features.
>
>
>
>
>
> ·         Support for 4-octet AS numbers,
>
> ·         Add path related additions,
>
> ·         Error handling rules for BGP in general,
>
> ·         Revisions to the BGP 'Minimum Route Advertisement Interval',
>
> ·         The definition of an "Accumulated IGP Metric".
>
>
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 14 Jun 2019 13:53:07 -0400

Sue,

On Mon, Jun 10, 2019 at 03:51:03PM -0400, Susan Hares wrote:
> ..         BGP Yang modules, 
> ..         A general BGP Layer 3 auto-configuration or liveness, 
> 
> ..         Additional  tunnel features for a optional tunnel encapsulation (a
> ..         Upgrade of the base BGP specification to Full Standard, 
> 
> ..         Flow specification additions, 
> 
> ..         BGP-LS basic functions (e.g.
> ..         Segment routing additions to BGP, 
> 
> ..         Wide Communities and other "bigger" communities , 
> 
> ..         Revisions to Existing features. 

I'm supportive for these.

One item I'd suggest for consideration is a mechanism to handle the dynamic
provisioning of new address families.

IDR currently has two drafts that overlap this space:
draft-ietf-idr-bgp-multisession
draft-ietf-idr-dynamic-cap

However, I consider both drafts to be problematic or over-broad for the
specific issue.  IMO:
- Multisession lets you spin up new sessions to handle segregation of
  address families, but complicates how routes learned across each session
  interact.
- Dynamic capabilities is overly general and has been noted to be
  problematic.  (Previous e.g.: what happens if you toggle graceful restart
  or add-paths?)

I don't suggest a solution in this mail and merely note covering proposals.
Having a targeted charter item would be useful.

-- Jeff

---

From: <[email-masked]>
Date: Mon, 17 Jun 2019 09:37:22 +0000

Sue, Jeff
 
> From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
> 
> Sue,
> 

+1
(including removing AF if possible)
 
  > problematic.  (Previous e.g.: what happens if you toggle graceful restart

+1
 
> I don't suggest a solution in this mail and merely note covering proposals.

Possibly RFC 4724/8538 (GR) could be used (as a starting point).

> Having a targeted charter item would be useful.

+1

--Bruno
> -- Jeff

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.