Subject: Re: [Idr] draft-li-idr-sr-policy-path-segment-distribution

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Tue, 11 Jun 2019 03:50:11 +0000

CC to IDR WG ML

Cheng

From: Chengli (Cheng Li)
Sent: Tuesday, June 11, 2019 11:45 AM
To: 'Shraddha Hegde' <[email-masked]>; Shraddha Hegde <shraddha=[email-masked]>; [email-masked]
Subject: RE: draft-li-idr-sr-policy-path-segment-distribution

Hi Shraddha,

Sorry for my delay. We plan to update the draft by IETF 105. Please see my reply inline.

Thanks,
Cheng

From: Shraddha Hegde [mailto:[email-masked]]
Sent: Monday, June 10, 2019 2:19 PM
To: Shraddha Hegde <shraddha=[email-masked]<mailto:shraddha=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-li-idr-sr-policy-path-segment-distribution

Authors,

Any update on these comments?

Rgds
Shraddha

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Shraddha Hegde
Sent: Tuesday, May 7, 2019 9:51 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Idr] draft-li-idr-sr-policy-path-segment-distribution

Authors,

I have a few comments on the document.

1. Section 3 :SR Policy for Path Identifier
Change to "Path Identifier for SR Policy"
 [Cheng] Looks better. Path Identifier in SR policy?  Will update in next revision.

2. sec 3 SR Policy for Path Identifier

The  path segment can appear at both segment-list level and SR policy level, and it could also appear only
at one level depending upon usecase. Path segment at segment list level and at SR-Policy level may be
same or may be different based on usecase and the ID allocation scope.
[Cheng] Agree.

3. I think there should be a separate section on allocation of Path Identifier.
The scope of allocation and resultant scaling considerations.

[Cheng] Let's see how to add it on next revision.

4. SR Path Segment Sub-TLV
The length of the SR Path Segment is defined to be of variable length.
This should be well defined for SR-MPLS to be 20 bit and  upto 128 bit
for SRv6.
 [Cheng] Agree, but I think 32bit for SR-MPLS will be better.

Rgds
Shraddha

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 24 Jun 2019 08:41:33 +0000

Hi Shraddha,

I am updating the draft, please see my reply inline.

Cheng

From: Chengli (Cheng Li)

Hi Shraddha,

Thanks,
Cheng

Authors,

Rgds
Shraddha

Authors,

1. Section 3 :SR Policy for Path Identifier
Change to "Path Identifier for SR Policy"
[Cheng] Looks better. Path Identifier in SR policy?  Will update in next revision.
[Cheng2] SR policy extensions for Path Segment should be better I think.

The  path segment can appear at both segment-list level and SR policy level, and it could also appear only
at one level depending upon usecase. Path segment at segment list level and at SR-Policy level may be
same or may be different based on usecase and the ID allocation scope.
[Cheng] Agree.
[Cheng2] Sorry for misunderstanding your point in previous email. I think we should allow the path segment to be allocated to the SID lists and Candidate path at the mean time.

For instance,  the operator would like to allocate 100 to candidate path 1, and 201, 202 to the SID list 1 and SID list 2 within it. When multiple path segments appear in different level at the same time, it means the Candidate's path segment and SID list's Path Segment should be inserted into the SID list together.

How about this text?

The Path Segment can appear at both segment-list level and candidate path level, and generally it SHOULD also appear only at one level depending upon use case . Path segment at segment list level and at candidate path level may be same or may be different based on use case and the ID allocation scope. When multiple Path Segments appear in both levels, it means the Path Segment associated with candidate path and segment list SHOULD both be inserted into the SID list.

[Cheng] Let's see how to add it on next revision.
[Cheng2] We describe it very briefly in section 5.

 [Cheng2] The length of the Path segment depends on the Segment type.  Please see https://tools.ietf.org/html/draft-li-idr-sr-policy-path-segment-distribution-01#section-3.1

Rgds
Shraddha