Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - 2 weeks Early Allocation Call [6/2/2019 to 6/16/2019]

From: "Susan Hares" <[email-masked]>
Date: Sun, 2 Jun 2019 22:27:11 -0400

This begins a 2 week Early Allocation call for parameters from: 

https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-app-specific-att
r-00

The authors are requesting for early code point allocation from 

IANA to enable implementations with suggested code points as indicated
below.

The criteria for early allocation includes:  stable working group document, 

clear technical solution and implementation interest.   The IDR chairs 

believe this document meets these criteria. Please let us know if you 

think this draft meets these criteria. 

If you support early adoption,  please include "support" in your along

with any comments about the draft's technical solution.

If you feel the draft is not ready for early adoption, please    

include "no support in your email" and indicate why. 

Cheerily Sue Hares 

--------------------------------------------

   This document requests assigning code-points from the registry "BGP-

   LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute

   TLVs" based on table below.  The column "IS-IS TLV/Sub-TLV" defined

   in the registry does not require any value and should be left empty.

The authors suggest the following value: 

   +------------+------------------------------------------+----------+

   | Code Point |         Description                      | Length   |

   +------------+------------------------------------------+----------+

   |   1122     | Application Specific Link Attributes TLV | variable |

   +------------+------------------------------------------+----------+

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 3 Jun 2019 06:07:07 +0000

Hi Sue/All,

Support the code point allocation call as a co-author. It would help implementation of this draft SR TE and Flex Algo use-cases.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: 03 June 2019 07:57
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - 2 weeks Early Allocation Call [6/2/2019 to 6/16/2019]

https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-app-specific-attr-00

The authors are requesting for early code point allocation from
IANA to enable implementations with suggested code points as indicated below.

Cheerily Sue Hares

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 3 Jun 2019 13:43:13 -0400

Sue,

> IANA to enable implementations with suggested code points as indicated

I support early code point adoption.  In general, we should keep BGP-LS docs
in sync with LSR adopted drafts that have sufficient traction.

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 3 Jun 2019 17:03:40 -0400

Jeff:

100% agree on alignment.  In fact at IETF 105,  John and I suggested to the
LSR chairs that they utilize a single draft with ISIS, OSPF, and BGP if the
BGP-LS or SR function is a "simple" copy of TLVs.   Chris and Acee have our
blessing to make it one draft - just as long as it is reviewed in IDR and
LSR.   

Sue  

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Monday, June 3, 2019 1:43 PM
To: Susan Hares
Cc: [email-masked]; [email-masked]
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - 2 weeks Early
Allocation Call [6/2/2019 to 6/16/2019]

Sue,

-- Jeff

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr