Subject: [Idr] Adam Roach's No Objection on draft-ietf-idr-bgp-ls-segment-routing-ext-15: (with COMMENT)

From: Adam Roach via Datatracker <[email-masked]>
Date: Wed, 12 Jun 2019 21:34:43 -0700

Adam Roach has entered the following ballot position for
draft-ietf-idr-bgp-ls-segment-routing-ext-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-ext/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for the work that everyone did on this document. I have only one
very minor comment.

§2.1.2:

>     Reserved: 1 octet that SHOULD be set to 0 and MUST be ignored on
>     receipt.

Making this a "SHOULD" rather than a "MUST" seems like it might interfere with
any future attempts to use this field, since compliant implementations might
have set the byte to arbitrary values.

This comment applies to other "reserved" fields in this document.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 27 Jun 2019 17:38:17 +0000

Hi Adam,

Thanks for your review. I've made the changes suggested for the reserved fields to address your and Benjamin's comments.

The version 16 has been posted with these changes:
https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-16 

Thanks,
Ketan

-----Original Message-----
From: Adam Roach via Datatracker <[email-masked]> 
Sent: 13 June 2019 10:05
To: The IESG <[email-masked]>
Cc: [email-masked]; Susan Hares <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Adam Roach's No Objection on draft-ietf-idr-bgp-ls-segment-routing-ext-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thanks for the work that everyone did on this document. I have only one very minor comment.

>     Reserved: 1 octet that SHOULD be set to 0 and MUST be ignored on

Making this a "SHOULD" rather than a "MUST" seems like it might interfere with any future attempts to use this field, since compliant implementations might have set the byte to arbitrary values.