Subject: Re: [Idr] Issue 2: Auto-configuration Requirements - LSVR layer 3 discovery and liveness requirements

From: "Susan Hares" <[email-masked]>
Date: Mon, 10 Jun 2019 15:29:15 -0400

Requirements list from draft-ietf-lsvr-l3dl-00

Layer 3 Discovery and Liveness (L3DL) provides brutally simple
   mechanisms for devices to
 
   o  Discover unique identities of devices/ports/... on a logical link,
 
   o  Run Layer 2 keep-alive messages for session continuity,
 
   o  Discover each other's unique endpoint identification,
 
   o  Discover mutually supported encapsulations, e.g.  IP/MPLS,
 
   o  Discover Layer 3 IP and/or MPLS addressing of interfaces of the
      encapsulations,
 
   o  Enable layer 3 link liveness such as BFD, and finally
 
   o  Present these data, using a very restricted profile of a BGP-LS
      [RFC7752 <https://tools.ietf.org/html/rfc7752> ] API, to BGP-SPF which
computes the topology and builds
      routing and forwarding tables.

If the a authors of this draft would suggest a different list of
requirements, 

please just respond to this email. 

Cheerily, Sue Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, June 10, 2019 3:26 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Issue 2: Auto-configuration Requirements

IDR WG: 

Does IDR think that we should include a generalized auto-discovery protocol
in the IDR WG charter? 

If so, should it be for WAN or Data Center or IPRAN topologies (grid/ring)? 

LSVR is progressing with Layer 3 liveness in  draft-ietf-lsvr-l3dl-00

https://datatracker.ietf.org/doc/draft-ietf-lsvr-l3dl/

LSVR is progressing because IDR did not have a consensus on requirements for
a general Layer 3 liveness protocol in 2018. 

This thread is to discuss the requirements for a generalized or 

a specific auto-discovery protocol associated with BGP. 

My next posts will contain the requirements for LSVR Layer 3 liveness and 

draft-xu-idr-neighbor-autodiscovery requirements 

https://datatracker.ietf.org/doc/draft-xu-idr-neighbor-autodiscovery/

Sue Hares

---

From: Randy Bush <[email-masked]>
Date: Mon, 10 Jun 2019 13:03:14 -0700

> 	computes the topology and builds routing and forwarding tables.
> 

draft-ymbk-lsvr-discovery-req-02.txt

randy