Subject: [Idr] I-D Action: draft-ietf-idr-bgp-model-06.txt

From: [email-masked]
Date: Thu, 13 Jun 2019 08:25:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : BGP YANG Model for Service Provider Networks
        Authors         : Mahesh Jethanandani
                          Keyur Patel
                          Susan Hares
	Filename        : draft-ietf-idr-bgp-model-06.txt
	Pages           : 119
	Date            : 2019-06-13

Abstract:
   This document defines a YANG data model for configuring and managing
   BGP, including protocol, policy, and operational aspects, such as
   RIB, based on data center, carrier and content provider operational
   requirements.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-model/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-bgp-model-06
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-model-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-model-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 13 Jun 2019 17:45:51 +0200

This version of the draft addresses comments received in IETF 104. Specifically,

- support for clear command with feature options has been added.
- added support for notifications
- added one more example, and collapsed groupings, resulting in fewer files.
- removed SR-TE from the model. This will be covered in a separate draft.
- incorporates review comments received by Jeff Hass.

Comments are welcome.

> On Jun 13, 2019, at 5:25 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

Mahesh Jethanandani
[email-masked]

---

From: <[email-masked]>
Date: Fri, 14 Jun 2019 13:56:20 +0000

Hi,

It's been a long time since I have looked at this model, please find some comments below. Some points may have already been discussed in some threads I may have missed, sorry for that if it is the case :)
- we need to have a consistent naming between protocols on how we call the "admin distance"/"preference", some models use "preference" or "distance", now we have "default-route-distance".
- Similar comment to " use-multiple-paths"
- I found strange to have remote-as and peer-as for example in the same hierarchy. It is a bit confusing especially because two vendors today are using one or the other in their CLI to configure the AS of the peer. Can't we have a subtree with the operational informations to solve this ?
- There is an inconsistent naming between keepalive-interval and keep-alive-configured (why an additional "-" ?)
- what happens when " route-reflector-cluster-id" is not set while "route-reflector-client" is set to true ? which cluster-id is used ?
- regarding add-path, does the model supports only "add-n-path" flavor ? (not add-all-paths)
- do "total-paths" and "total-prefixes" reaaly mean something for a peer-group ?
- is that the role of the core BGP model to define the LxVPN AFs ? Is this done in coordination with LxVPN/EVPN yang model teams ?
- could we have "MED" path selection tuning options as part of " route-selection-options" ?
- LLGR is missing while useful and deployed
- I do not see the AIGP capability activation per neighbor
- what's the difference between hold-time and hold-time-configured (same for keepalive) as both are configurable leaves ? Do you have a min-holdtime option which is deployed and very useful ?
- I was expecting "clear" actions to be RPCs

Brgds,

Stephane

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 13, 2019 17:26
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-idr-bgp-model-06.txt

Abstract:

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 14 Jun 2019 11:51:38 -0400

[Not speaking for the authors, but I've done a recent initial review.
Definitely needs more work.]

Stephane,

> - LLGR is missing while useful and deployed

LLGR isn't even an IDR draft right now.  It's not really appropriate to have
in the base yang module for BGP.

This rather goes back to a conversation I had some years ago: IDR must
decide what the "base" features of BGP are.  Things like route reflection,
confederations, damping, aigp, etc. are included in the module in spite of
the fact that they are completely *optional* extensions to 4271.

This is thus not the RFC 4271 yang module.  How much beyond that we should
go is an interesting question.

But for things that haven't even hit RFC, we should certainly keep them out
as extensions until then.

> - what's the difference between hold-time and hold-time-configured (same for keepalive) as both are configurable leaves ? Do you have a min-holdtime option which is deployed and very useful ?

Generally a negotiated value vs. the configured value.  Similar issue in BGP
MIB.

-- Jeff

---

From: <[email-masked]>
Date: Mon, 17 Jun 2019 06:40:28 +0000

Hi Jeff,

> - what's the difference between hold-time and hold-time-configured (same for keepalive) as both are configurable leaves ? Do you have a min-holdtime option which is deployed and very useful ?

[JH] Generally a negotiated value vs. the configured value.  Similar issue in BGP
MIB.

[SLI] In this case, IMO the negotiated value should be a RO value.

Brgds,

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Friday, June 14, 2019 17:52
To: LITKOWSKI Stephane OBS/OINIS
Cc: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-model-06.txt

Stephane,

-- Jeff