Subject: Re: [Idr] Can we eliminate the "IETF Review" Capablities range? [was: Re: I-D Action: draft-ietf-idr-capabilities-registry-change-04.txt]

From: Jeffrey Haas <[email-masked]>
Date: Mon, 3 Jun 2019 13:47:02 -0400

Bruno, Tom,

On Fri, May 24, 2019 at 09:49:59AM +0000, [email-masked] wrote:
> > John
> > 
> > I see it as a question of security.  The Internet used to consist of
> > friendly, helpful people who worked together to make it happen.  Now
> > there is a whole raft of evil people, some state actors, some
> > individual, some corporate - in fact, actors of any kind.
> 
> Two months ago, I would have said go for "2.a. Make 1-238 all FCFS" but as of today, I think Tom as a point.
> 
> A few random comments:
> - If an actor requests all the code points, we probably still have the ability to write an RFC and reclaim those code points. We also have one reserved code point which would allow for extensions (but with a higher incremental cost, and possibly raising the same question for the allocation policy)

I think what you're suggesting is a conversation needs to happen with IANA
about how to prevent a DoS on the FCFS range.  Providing a standards
rate-limiting mechanism (our other policies) does indeed address that.

However, I think we're better off having the conversation with IANA on how
to keep low-process while at the same time wisely assigning things.

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 3 Jun 2019 13:49:05 -0400

John,

On Thu, May 23, 2019 at 10:10:35AM +0000, John Scudder wrote:
> 2.c. Leave it as written in version 04, 1-63 IETF Review, 64-238 FCFS.
> Pro: it’s what we’ve already been discussing and nobody (other than me, in this note) has raised an objection so far.
> Con: authors are required to choose between the two ranges, experience shows that many assume that IETF Review is “better” for some reason. This holds up number allocation, retards implementation, and invokes additional administrative overhead without returning any concrete benefit.

My preference is to stay with this option.  The FCFS range is sufficiently
large that we're not impeding progress.  We also reserve the right to
re-classify the IETF review range at a later date.

-- Jeff