Subject: [Idr] [Editorial Errata Reported] RFC4271 (6256)

From: RFC Errata System <[email-masked]>
Date: Wed, 12 Aug 2020 11:36:30 -0700 (PDT)

The following errata report has been submitted for RFC4271,
"A Border Gateway Protocol 4 (BGP-4)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6256

--------------------------------------
Type: Editorial
Reported by: Anton Yushkov <[email-masked]>

Section: 5.1.3

Original Text
-------------
3) When sending a message to an external peer X, and the peer is
multiple IP hops away from the speaker (aka "multihop EBGP"):
...
- By default, the BGP speaker SHOULD use the IP address of the interface that the speaker uses in the NEXT_HOP attribute to establish the BGP connection to peer X.

Corrected Text
--------------
3) When sending a message to an external peer X, and the peer is
multiple IP hops away from the speaker (aka "multihop EBGP"):
...
- By default, the BGP speaker SHOULD use the IP address of the interface that the speaker uses to establish the BGP connection to peer X in the NEXT_HOP attribute.

Notes
-----
confusing incorrect word order:
reading the original text, the reader might think that the BGP speaker is using the NEXT_HOP attribute as part of establishing a connection with the peer

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4271 (draft-ietf-idr-bgp4-26)
--------------------------------------
Title               : A Border Gateway Protocol 4 (BGP-4)
Publication Date    : January 2006
Author(s)           : Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed.
Category            : DRAFT STANDARD
Source              : Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: John Scudder <[email-masked]>
Date: Fri, 14 Aug 2020 14:38:37 +0000

Sounds right.

—John

> On Aug 12, 2020, at 2:36 PM, RFC Errata System <[email-masked]> wrote:
> 
> [External Email. Be cautious of content]
> 
> 
> https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid6256__;!!NEt6yMaO-gk!SpELvNfLhQUuQ203AvJuTme321r3LEellWBGShISiC4EiRgcaRihajHiLAC-cQ$
>

---

From: John Scudder <[email-masked]>
Date: Tue, 18 Aug 2020 17:10:45 +0000

In due course of time, the Area Director responsible for IDR (Alvaro) will accept or reject it. I anticipate he’ll accept it, but it’s up to him.

—John

On Aug 18, 2020, at 1:05 PM, anton yushkov <[email-masked]> wrote:

Good afternoon.
How can this errata be confirmed or rejected? Do I need any further action, or will the community of specialists make a decision and report it?

пт, 14 авг. 2020 г. в 17:38, John Scudder <[email-masked]<mailto:[email-masked]>>:
Sounds right.

—John

> On Aug 12, 2020, at 2:36 PM, RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:
>
> Reported by: Anton Yushkov <[email-masked]<mailto:[email-masked]>>
>
> Section: 5.1.3
>
> Original Text
> -------------

---

From: anton yushkov <[email-masked]>
Date: Tue, 18 Aug 2020 20:05:29 +0300

Good afternoon.
How can this errata be confirmed or rejected? Do I need any further action,
or will the community of specialists make a decision and report it?

пт, 14 авг. 2020 г. в 17:38, John Scudder <[email-masked]>:

> > - By default, the BGP speaker SHOULD use the IP address of the interface
> that the speaker uses in the NEXT_HOP attribute to establish the BGP
> connection to peer X.
> >
> > Corrected Text
> > --------------
> > - By default, the BGP speaker SHOULD use the IP address of the interface
> that the speaker uses to establish the BGP connection to peer X in the
> NEXT_HOP attribute.
> >
> > Notes
> > -----
> > reading the original text, the reader might think that the BGP speaker
> is using the NEXT_HOP attribute as part of establishing a connection with
> the peer
> >
> > Instructions:
> > -------------

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 18 Aug 2020 11:02:13 -0700

Thanks Anton for filing this report!

I’ve taken care of the proper flagging.

Alvaro.

On August 18, 2020 at 1:05:41 PM, anton yushkov ([email-masked])
wrote:

Good afternoon.