Subject: Re: [Idr] AD Review of draft-ietf-idr-bgp-bestpath-selection-criteria-12 (draft-ietf-idr-tunnel-encaps)

From: Alvaro Retana <[email-masked]>
Date: Tue, 4 Aug 2020 08:53:05 -0500

Hi!

Did this conversation go anywhere?  Just curious.

Alvaro.

On May 4, 2020 at 5:46:58 PM, Rajiv Asati (rajiva) ([email-masked]) wrote:

Alvaro,

Well pointed. Back in Feb, when I went through the encap draft (recalling
the machinery like in the below excerpt) and discussed with Acee, I also
realized these two drafts being complementary in that NH verification
regard.

/
If the Tunnel Endpoint sub-TLV contains an IPv4 or IPv6 address that
is valid but not reachable,
/

The question (of yours) we need to answer is what's in scope and what's
not. For ex, what OAM protocol is used for reachability determination
should be out of scope, but where this check is executed should be. Hoping
that we have some active discussion on that.

Keyur, Srihari, Gunter, thoughts?

-- 
Cheers,
Rajiv

-----Original Message-----
From: Alvaro Retana <[email-masked]>
Date: Monday, May 4, 2020 at 2:44 PM
To: Rajiv Asati <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: Susan Hares <[email-masked]>, "[email-masked]" <
[email-masked]>, "[email-masked]" <[email-masked]>, "
[email-masked]" <
[email-masked]>
Subject: Re: AD Review of draft-ietf-idr-bgp-bestpath-selection-criteria-12
Resent-From: <[email-masked]>
Resent-To: Rajiv Asati <[email-masked]>
Resent-Date: Monday, May 4, 2020 at 2:44 PM

On May 4, 2020 at 2:10:14 PM, Rajiv Asati (rajiva) wrote:

[Explicitly adding draft-ietf-idr-tunnel-encaps to the distribution.]

Rajiv:

Hi!

> Thanks, Alvaro. While it would have been preferred to keep the (NH
selection
> / verification) logic independent, it seems that there may perhaps be the
> following 2 means to solidify the logic -
>
> a- Tunnel Encapsulation Attribute (updating rfc5512)
> b- Cost Community
>
> It seems that (a) is somewhat more progressive than (b), and clearly
conveys
> the encap preference that can be leveraged. Thoughts?
>
> If agreed, then section 3 could be updated to reflect something akin to
the
> following -
...

As a matter of fact, §5 of draft-ietf-idr-tunnel-encaps lists

* The tunnel is specified in a TLV whose Tunnel Endpoint sub-TLV
identifies an IP address that is reachable.

...as a condition for the tunnel to be considered feasible. In my
review of that document [1] I wrote this:

[major] How is reachability determined? Where (which table) should
the address be looked up in? In the sequence above, the destination
address of P and the address of the endpoint may be resolvable in
different tables...

[BTW, please also take a look at
draft-ietf-idr-bgp-bestpath-selection-criteria, which I think tries to
define a related, if not the same, concept.]

I think this is a good time for you and the authors of
draft-ietf-idr-tunnel-encaps to talk.

Thanks!

Alvaro.

[1] https://mailarchive.ietf.org/arch/msg/idr/S1nyz1sewA_Xqf63W_vz8c4L8Z0/

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Tue, 4 Aug 2020 14:26:00 +0000

Hi Alvaro,

I don’t think so. Still waiting to hear back from the authors of tunnel-encaps draft.

--
Cheers,
Rajiv

From: Alvaro Retana <[email-masked]>
Date: Tuesday, August 4, 2020 at 9:53 AM
To: Rajiv Asati <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: AD Review of draft-ietf-idr-bgp-bestpath-selection-criteria-12 (draft-ietf-idr-tunnel-encaps)

Hi!

Alvaro.

On May 4, 2020 at 5:46:58 PM, Rajiv Asati (rajiva) ([email-masked]<mailto:[email-masked]>) wrote:
Alvaro,

Well pointed. Back in Feb, when I went through the encap draft (recalling the machinery like in the below excerpt) and discussed with Acee, I also realized these two drafts being complementary in that NH verification regard.

/

The question (of yours) we need to answer is what's in scope and what's not. For ex, what OAM protocol is used for reachability determination should be out of scope, but where this check is executed should be. Hoping that we have some active discussion on that.

--
Cheers,
Rajiv

-----Original Message-----
From: Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 4, 2020 at 2:44 PM
To: Rajiv Asati <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: AD Review of draft-ietf-idr-bgp-bestpath-selection-criteria-12
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Rajiv Asati <[email-masked]<mailto:[email-masked]>>
Resent-Date: Monday, May 4, 2020 at 2:44 PM

Rajiv:

Hi!

> Thanks, Alvaro. While it would have been preferred to keep the (NH selection
> It seems that (a) is somewhat more progressive than (b), and clearly conveys
> If agreed, then section 3 could be updated to reflect something akin to the
> following -
...

Thanks!

Alvaro.