Subject: Re: [Idr] Questions from the IDR session

From: Kaliraj Vairavakkalai <[email-masked]>
Date: Wed, 28 Jul 2021 01:04:32 +0000

Sure Sue. I will copy Swadesh and Haibo to this thread here and answer the questions.

Hi Swadesh,

>1. Swadesh about the efficiency of sending two routes versus Color?

Ref: topology in slide#6 in attached presentation.

Similar to BGP-LU, BGP-CT gives the flexibility of originating CT-route at PE11, or at ASBR13/ASBR14.
So following options exist:

  1.  When originating at PE11, there will be one route received at PE25. NLRI: “RD_PE11: PE11”.
  2.  And yes, when originating at ASBRs with unique-RDs, there will be two routes received at PE21.  NLRIs: RD_ASBR13:PE11, RD_ASBR14:PE11.
            This helps in identifying who originated a particular route. ASBR13 or ASBR14.

  1.  If this is not desired, and loss of troubleshooting ability is OK, then both ASBRs can originate NLRI: “RD_X:PE11” prefix routes. Then it will become same as a).

In CAR, using NLRI: “C1:PE11” model, because of dual role of ‘Color’, option b) cannot be supported. i.e. we cannot identify which ASBR originated a particular route because the NLRI doesn’t have a distinguisher.
One of the ASBR originated-routes is hidden by path-selection at the first BGP-path-selection ‘pinch-point’. And upstream nodes cannot exercise that specific ASBR path if desired.
With CT that option exists. Because no path-hiding happens (thanks to RD), all available paths are available to upstream PE21.

Hi Haibo,

>2. Haibo’s question on using next-hop and color to match transport routes.
>The key in BGP CT route does not match with the key used for VPN route resolution.

                  For the VPN-route resolution, “BGP PNH and color-community” is used.
Similarly, For the CT-route resolution, “BGP PNH and transport-target community” is used.

So it is the same. The key for BGP route resolution is “BGP nexthop and mapping-community”.

IOW, in regular BGP nexthop-resolution, a BGP-route just resolves a <nexthop-address> received on the route.
And with CT, the Mapping-community (Color-community/Transport-target) additionally qualifies the type of transport-tunnel to be taken,
And so the resolution happens on basis of <nexthop-address , mapping-community> tuple. Hope I understood your question right.

Thanks
Kaliraj
From: Susan Hares <[email-masked]>
Date: Tuesday, July 27, 2021 at 4:57 PM
To: Kaliraj Vairavakkalai <[email-masked]>
Cc: 'idr-chairs' <[email-masked]>
Subject: Questions from the IDR session
[External Email. Be cautious of content]

Kaliraj:

Would you help the IDR WG by answer the questions
1. Swadesh about the efficiency of sending two routes versus Color?
2. Haibo’s question on using next-hop and color to match transport routes.
The key in BGP CT route does not match with the key used for VPN route resolution.

Thank you, Sue

Juniper Business Use Only

---

From: Kaliraj Vairavakkalai <[email-masked]>
Date: Wed, 28 Jul 2021 01:08:41 +0000

Sorry, missed attaching the reference ppt. PFA..

From: Idr <[email-masked]> on behalf of Kaliraj Vairavakkalai <kaliraj=[email-masked]>
Date: Tuesday, July 27, 2021 at 6:05 PM
To: Susan Hares <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: 'idr-chairs' <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Idr] Questions from the IDR session
[External Email. Be cautious of content]

Hi Swadesh,

Hi Haibo,

Thanks
Kaliraj

Kaliraj:

Thank you, Sue