Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

From: "Susan Hares" <[email-masked]>
Date: Fri, 16 Jul 2021 06:11:04 -0400

This begins a 2 week WG LC and IPR statement on -07.txt:  

The addition of a new FAD Unknown Sub-TLV to 
draft-ietf-idr-bgp-ls-flex-algo-07.txt
 
See:  
 
<https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-flex-algo-07#se
ction-3.6>
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-flex-algo-07#sec
tion-3.6

or the whole draft page at: 

The IETF datatracker status page for this draft is:
 <https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-flex-algo/>
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-flex-algo/

This WG LC does not include any other section of the draft. 

The WG should consider:

1) Is section 3.6 ready for publication, 

2) Does section 3.6 help the IDR draft match the LSR draft?

3) Does this addition help deployments?  

All authors need to resend their IPR statements for -07.txt to the list. 

Sue Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 16 Jul 2021 11:25:58 +0000

I support publication with this addition. While the precise usage is beyond the scope of the document, it is clear that it would be useful for diagnostic purposes.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Friday, July 16, 2021 at 6:11 AM
To: IDR List <[email-masked]>
Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

See:

https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-flex-algo-07#section-3.6

The WG should consider:

Sue Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 16 Jul 2021 11:52:42 +0000

Hello Sue,

I am not aware of any IPR related to this document.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: 16 July 2021 15:41
To: [email-masked]
Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

See:

The WG should consider:

Sue Hares

---

From: Peter Psenak <[email-masked]>
Date: Fri, 16 Jul 2021 14:16:36 +0200

Hi Sue,

I am not aware of any undisclosed IPRs related to this document.

thanks,
Peter

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 19 Jul 2021 19:46:44 +0000

Ketan, Peter, Shawn, Gaurav,

Section 3 of the draft-ietf-idr-bgp-is-flex-algo-07 specifies the Calculation-Type as between 0-127. But the IANA sites shows that  IGP Algorithm Types has 2-127 unassigned, and 128-255 assigned to Flex Algorithm.

https://www.iana.org/assignments/igp-parameters/igp-parameters.xhtml
2-127
Unassigned
128-255
Flexible Algorithms (TEMPORARY - registered 2018-06-06, extension registered 2021-04-22, expires 2022-06-06)
[draft-ietf-lsr-flex-algo<https://www.iana.org/go/draft-ietf-lsr-flex-algo>]

Is it correct?

Thanks, Linda Dunbar

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Friday, July 16, 2021 5:11 AM
To: [email-masked]
Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

See:

https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-flex-algo-07#section-3.6<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-idr-bgp-ls-flex-algo-07%23section-3.6&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C088fea25de5f4a4977d808d948421e5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637620271097361322%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oWTqgAX%2F5KgHojTU188%2BwrwC4uhOpshWr0OA934saxs%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-flex-algo/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-bgp-ls-flex-algo%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C088fea25de5f4a4977d808d948421e5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637620271097371278%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=THPhVBpwqZvcZXK6HI75UMbBkJhYmXLv6R0CSX5TcaY%3D&reserved=0>

The WG should consider:

Sue Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 22 Jul 2021 09:00:41 +0000

Hi Linda,

Thanks for your review.

The draft is correct about the Calculation Type being between 0-127. This is derived from the underlying IGPs. Please refer to the IGP specification (specifically https://datatracker.ietf.org/doc/html/draft-ietf-lsr-flex-algo-17#section-5) in this regards.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Linda Dunbar
Sent: 20 July 2021 01:17
To: Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

Is it correct?

Thanks, Linda Dunbar

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: Friday, July 16, 2021 5:11 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

See:

The WG should consider:

Sue Hares

---

From: Gaurav Dawra <[email-masked]>
Date: Thu, 22 Jul 2021 07:13:52 -0700

Support. Not aware of any IPR.

Gaurav
LINKEDIN

Sent from my iPhone

> On Jul 16, 2021, at 3:11 AM, Susan Hares <[email-masked]> wrote:
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 22 Jul 2021 15:58:49 +0000

I support progressing the draft.
Section 3.6 is a necessary addition given the encoding paradigm used by BGP-LS since day one.

   Les

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Friday, July 16, 2021 3:11 AM
To: [email-masked]
Subject: [Idr] Week WG LC on addition to draft-ietf-idr-bgp-ls-flex-algo-07.txt (7/16 to 7/30/2021)

See:

The WG should consider:

Sue Hares