Subject: [Idr] I-D Action: draft-ietf-idr-bgp-model-11.txt

From: [email-masked]
Date: Sun, 11 Jul 2021 21:48:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : BGP YANG Model for Service Provider Networks
        Authors         : Mahesh Jethanandani
                          Keyur Patel
                          Susan Hares
                          Jeffrey Haas
	Filename        : draft-ietf-idr-bgp-model-11.txt
	Pages           : 153
	Date            : 2021-07-11

Abstract:
   This document defines a YANG data model for configuring and managing
   BGP, including protocol, policy, and operational aspects, such as
   RIB, based on data center, carrier, and content provider operational
   requirements.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-model/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-model-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-model-11

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 12 Jul 2021 20:55:36 -0700

Hi WG,

For details on issues addressed as well as issues that are still open regarding this draft please refer to the link here <https://github.com/mjethanandani/ietf-bgp-yang/issues>.

This version of the draft:

- has collapsed some of the smaller sub-modules and rolled their definitions into other sub-modules.
- fixes the prefixes it uses for the modules that it imports
- adds a choice for operations that can be performed in the action to clear neighbors.
- Fixes some of the examples to make sure they validate with the latest version of yanglint
- Enhanced the example to demonstrate how to augment and add a new address family to the base model.

Thanks

> On Jul 11, 2021, at 9:48 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

Mahesh Jethanandani
[email-masked]