Subject: [Idr] WG adoption call - draft-li-idr-flowspec-srv6-05,txt

From: Aijun Wang <[email-masked]>
Date: Sat, 7 Aug 2021 00:22:01 +0800

Hi, Authors:

Is it more general to define one new “field type”, for example, “100” to represent to match “SID’s LOC:FUNC:ARGS” in component type “TBD2”,  also the whole SID, then there is no necessary to define component type “TBD1”?

And, it’s encoding follows Flowspec b1, how can it be developed as part of v2 drafts? Should the encoding be changed to follow the v2 specification?

Aijun Wang
China Telecom

> 
> From: Susan Hares <[email-masked]>
> Sent: Friday, July 23, 2021 12:57 PM
> To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
> Subject: WG adoption call - draft-li-idr-flowspec-srv6-05,txt
>  
> This begins a 2 week WG adoption call for draft-li-idr-flowspec-srv6-05.txt.
>  
> I am missing 3 IPR statements (Zhenbin Li , Lei Li , and Lei Liu). 
> These authors should send in their IPR statements in response to this call.
>  
> This draft is targeted for the V2 version of flow specification. 
> Flow specification v2 draft will be discussed at an interim on 9/13/2021.
>  
> If it is adopted, it will be developed as part of the v2 set of drafts.
>  
> Please consider if:
>  
> 1) if this draft is useful for networks,
> 2) if you wish to adopt this draft prior to adopting flow specification v2.
>  
> Cheerily, Susan Hares
>  
>

---

From: Huaimo Chen <[email-masked]>
Date: Fri, 6 Aug 2021 16:48:58 +0000

Hi Aijun,

    Thank you very much for your comments and suggestions.
    My responses are inline below with [HC].

Is it more general to define one new “field type”, for example, “100” to represent to match “SID’s LOC:FUNC:ARGS” in component type “TBD2”,  also the whole SID, then there is no necessary to define component type “TBD1”?
[HC]: You are right. A new “field type” can be defined to match “SID’s LOC:FUNC:ARGS” in component type “TBD2”. This will eliminate component type “TBD1”. We will update the draft accordingly.

And, it’s encoding follows Flowspec b1, how can it be developed as part of v2 drafts? Should the encoding be changed to follow the v2 specification?
[HC]: It seems that BGP Flow Specification v2 is encapsulated in a different NLRI which encapsulates previous flow specification v1 information.

Best Regards,
Huaimo
________________________________
From: [email-masked] <[email-masked]> on behalf of Aijun Wang <[email-masked]>
Sent: Friday, August 6, 2021 12:22 PM
To: [email-masked] <[email-masked]>
Cc: idr <[email-masked]>
Subject: WG adoption call - draft-li-idr-flowspec-srv6-05,txt

Hi, Authors:

Aijun Wang
China Telecom

> These authors should send in their IPR statements in response to this call

---

From: Aijun Wang <[email-masked]>
Date: Sat, 7 Aug 2021 08:41:55 +0800

Hi, Huaimo:

Thanks for your answer.
I support its adoption.

Aijun Wang
China Telecom

> On Aug 7, 2021, at 00:49, Huaimo Chen <[email-masked]> wrote:
> 
> 
> Hi Aijun,
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr