Subject: Re: [Ieprep] Public Safety?

From: "Marshall Eubanks" <[email-masked]>
Date: Mon, 01 Apr 2002 14:23:50 -0500

On Fri, 29 Mar 2002 16:06:21 -0800
 Fred Baker <[email-masked]> wrote:
> At 03:28 PM 3/29/2002, Marshall Eubanks wrote:
> >1.) There are _six_ different formats with some market
> >share.
> >
> >2.) Little wars break out to deny or gain
> interoperability,
> 
> Understood. That is the subject of 
> http://www.ietf.org/html.charters/impp-charter.html,
> where the little wars 
> happen in a teakettle, which in turns whistles
> continuously. It's quite 
> noisy, as you may guess.
> 
> The question before *this* house is whether there is
> something specific 
> that is required for IM to be useful to emergency workers
> - a specific 
> configuration, a specific diffserv service specified on
> the packets (and 
> please demonstrate that there is a problem that this
> solves), or whatever. 
> I'm right with you in voting for interoperability. That's
> not the issue 
> before this working group, except to add one set of votes
> for the actors in 
> the IM drama to stop their silly
> lets-be-anything-but-interoperable games.
> 

My guess is that this is an unsolveable problem for
political reasons, as the most interoperable solution would
be "use AIM", which my guess is not politically acceptable.

Regards
Marshall Eubanks

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: Fred Baker <[email-masked]>
Date: Mon, 01 Apr 2002 11:37:26 -0800

At 11:23 AM 4/1/2002, Marshall Eubanks wrote:
>My guess is that this is an unsolveable problem for political reasons, as 
>the most interoperable solution would be "use AIM", which my guess is not 
>politically acceptable.

It's not a matter of politics, it's a matter of what a standards body does. 
If the right answer in the US is "use AIM", then maybe the thing for the US 
Government to do is mandate that to all US agencies - that would be its 
choice. I'm fairly certain that "use AIM" is *not* the right answer in the 
People's Republic of China, which also uses IETF specifications, and it 
might not be the right answer for a global organization like the US Military.

The IETF is a body of engineers that design protocols, and whose protocols 
are used throughout the world. The IETF doesn't pick companies and 
recommend them. So for us, it's not a matter of the political acceptability 
or unacceptability of that particular service; we simply don't do that.

It would be good, though, if the IETF could design a single instant 
messaging standard and have all the services use that. The fact is, as 
Henning pointed out, that IMM attempted to do just that, and was thwarted 
by various services that fundamentally didn't want to be interoperable - 
they see what you describe as a "problem" as a "business opportunity". IMM 
ultimately got separated into three separate working groups, two of which 
appear to be moribund (the operators in question decided that their 
interests were not served by being "among the winners" unless they can also 
slow down the other "co-winners", so they have chosen to not work on it), 
and the third of which (which has been delayed by the jockeying in IMM) may 
or may not ultimately find itself being used by the operators - we'll see.