Subject: [ietf-dkim] NEW ISSUE: "does not exist"

From: Dave Crocker <[email-masked]>
Date: Sun, 09 Dec 2007 09:50:07 -0800

>>    4.  The domain does not exist; the message MUST be considered
>>        Suspicious.
> 
> Presumably "does not exist" means there is no DNS record.  (Otherwise, the
> phrase "does not exist" needs to be explained.)

If references to domain names that "do not exist" means specifically that they 
are not registered in the DNS -- ie, not visible on the public Internet's view 
of the DNS -- then the document should say this explicitly.

If it means something else, then that meaning needs to be made explicit.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 10 Dec 2007 08:14:53 +0100

> If it means something else, then that meaning needs to be made explicit.

IIRC it means "query MX and get NXDOMAIN".

---

From: Eliot Lear <[email-masked]>
Date: Mon, 10 Dec 2007 15:49:05 +0100

Dave,
> If references to domain names that "do not exist" means specifically
> that they are not registered in the DNS -- ie, not visible on the
> public Internet's view of the DNS -- then the document should say this
> explicitly.
>

IMHO Frank is correct that this refers to NXDOMAIN.  That wording seems
fairly precise.  How would you improve it?

Eliot

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Dec 2007 07:45:11 -0800

> fairly precise.  How would you improve it?

1. Obtain working group consensus that this is what it means.

2. Modify the specification to actually specify this.

d/

-- 

   Dave Crocker

---

From: Jim Fenton <[email-masked]>
Date: Tue, 11 Dec 2007 06:57:57 -0800

> If it means something else, then that meaning needs to be made explicit.

I believe the wording that is there is appropriate for the Operation
Overview section, which is the context in which the text you quoted
appears.  A more precise definition can be found in section 4.4, step 3.

-Jim

---

From: Dave Crocker <[email-masked]>
Date: Thu, 13 Dec 2007 07:07:52 -0800

>>> phrase "does not exist" needs to be explained.)
...
> appears.  A more precise definition can be found in section 4.4, step 3.

The statement in question is a normative statement.  The term used is not 
defined and the definition is not pointed to.  That makes for confused 
interpretation of meaning for the term.

d/

-- 

   Dave Crocker