Subject: [Ietf-dkim] requesting help understanding DKIM logs in Postfix

From: "Fazzina, Angelo" <[email-masked]>
Date: Wed, 19 Dec 2018 16:44:23 +0000

Hi, I am running Postfix 2.10.x and Opendkim 2.11.0.
Mail flow is to our MX in O365 and then to smtp server for students which are on Google's Gmail.
The smtp server is configured to verify and sign.

I am trying to figure out what these lines mean ?
Thank you.

Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: not authenticated
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: failed to parse Authentication-Results: header field
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: bad signature data

ENTIRE LOG:
Dec 19 11:33:45 mta4 postfix/smtpd[1111]: 1C7BF1805EE6: client=mail-cys01nam02lp2054.outbound.protection.outlook.com[104.47.37.54]
Dec 19 11:33:45 mta4 postfix/cleanup[954]: 1C7BF1805EE6: warning: header Subject: 15% off sparkling wines for ringing in the New Year! from mail-cys01nam02lp2054.outbound.protection.outlook.com[104.47.37.54]; from=<[email-masked]> to=<[email-masked]> proto=ESMTP helo=<NAM02-CY1-obe.outbound.protection.outlook.com>
Dec 19 11:33:45 mta4 postfix/cleanup[954]: 1C7BF1805EE6: message-id=<[email-masked]>
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: mail-cys01nam02lp2054.outbound.protection.outlook.com [104.47.37.54] not internal
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: not authenticated
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: failed to parse Authentication-Results: header field
Dec 19 11:33:45 mta4 opendkim[5108]: 1C7BF1805EE6: bad signature data
Dec 19 11:33:45 mta4 postfix/qmgr[13516]: 1C7BF1805EE6: from=<[email-masked]>, size=25385, nrcpt=1 (queue active)
Dec 19 11:33:45 mta4 postfix/smtp[32415]: 1C7BF1805EE6: to=<[email-masked]>, orig_to=<[email-masked]>, relay=aspmx.l.google.com[172.217.197.26]:25, delay=0.63, delays=0.32/0/0.07/0.24, dsn=2.0.0, status=sent (250 2.0.0 OK 1545237225 s127si2256693qkf.24 - gsmtp)
Dec 19 11:33:45 mta4 postfix/qmgr[13516]: 1C7BF1805EE6: removed

-ANGELO FAZZINA

ITS Service Manager:
Spam and Virus Prevention
Mass Mailing
G Suite/Gmail

[email-masked]
University of Connecticut,  ITS, SSG, Server Systems
860-486-9075

---

From: Dave Crocker <[email-masked]>
Date: Wed, 19 Dec 2018 08:54:01 -0800

On 12/19/2018 8:44 AM, Fazzina, Angelo wrote:
> Mail flow is to our MX in O365 and then to smtp server for students 
> which are on Google’s Gmail.
> 

This group is for discussion of the dkim specification.  Your question 
has to do with specific dkim software.

You should consult the opendkim users mailing list.  See:

    http://lists.opendkim.org/

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net