Subject: [Ietf-dkim] Looking for a little help testing DKIM failure reports, thank you.

From: "Fazzina, Angelo" <[email-masked]>
Date: Mon, 17 Dec 2018 16:36:33 +0000

Hi, I am trying to test my TXT records for the ability to report failures. Talking about RFC 6651

These are my records

dkim1._domainkey.mta5.uits.uconn.edu    text = "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
catzd6/iutxWbAiY51rRAvVdBs2YIoGO6Glzeev66ft8IfMnHgxND438KIsdOjUmJZuglFJUWGzCYDSC1eq/zqDVncFwTxWkKW/qtxQIDAQAB"

_report._domainkey.mta5.uits.uconn.edu  text = "ra=dkim-errors\; rp=100\; rr=all"

Here is a test email sig header
v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu; s=dkim1; t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=; h=To:From:Subject:Date:From; b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=

Here is a test email result header
spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu; uconn.mail.onmicrosoft.com; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com; dmarc=none action=none header.from=appmail.uconn.edu;compauth=pass reason=105

So I can simulate a failure, but cannot seem to get a report emailed to [email-masked]<mailto:[email-masked]> ?

I made sure account exists on server:
[root@mta5 home]# ls -l /home/|grep dkim
drwx------. 2 dkim-errors       dkim-errors         78 Dec 10 16:21 dkim-errors

How often are the failure reports generated ? did not see that mentioned in the RFC's ?

Does anyone see anything obvious that I am doing wrong ?
Thank you.

-ANGELO FAZZINA

ITS Service Manager:
Spam and Virus Prevention
Mass Mailing
G Suite/Gmail

[email-masked]
University of Connecticut,  ITS, SSG, Server Systems
860-486-9075

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 17 Dec 2018 09:02:48 -0800

DKIM verifiers are not required to generate reports.  It's completely
optional.  Does the place you're sending to advertise somehow that they
will be generated?

On Mon, Dec 17, 2018 at 8:36 AM Fazzina, Angelo <[email-masked]>
wrote:

> *These are my records*
> dkim1._domainkey.mta5.uits.uconn.edu    text = "v=DKIM1\; k=rsa\;
> p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
>
>
> *Here is a test email sig header*
>
> v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu; s=dkim1;
> t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=;
> h=To:From:Subject:Date:From;
> b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA
> ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0
> 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=
>
>
>
> *Here is a test email result header*
>
> spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu;
> uconn.mail.onmicrosoft.com; dkim=fail (invalid public key) header.d=
> mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com; dmarc=none action=none
> header.from=appmail.uconn.edu;compauth=pass reason=105
>
>
>
>
>
> So I can simulate a failure, but cannot seem to get a report emailed to
> [email-masked] ?
>
>
>
> *I made sure account exists on server:*
>
> How often are the failure reports generated ? did not see that mentioned
> in the RFC’s ?
>
>
>
> *ITS Service Manager:*
> _______________________________________________
> Ietf-dkim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-dkim
>

---

From: "Fazzina, Angelo" <[email-masked]>
Date: Mon, 17 Dec 2018 18:18:58 +0000

Hi, thank you.
Here are the headers of the test email I sent.
I sent it with Thunderbird through mta5 which signed it, and relayed it to next hop, and it was delivered.

I think you are saying since I configured the server to both verify and sign emails, it won’t bother verifying an email the server itself signed, so I won’t ever get a report ? I think I read something like that in the RFC’s ?

Sounds like my testing method may be flawed.  ☹

Received: from BYASPR01MB1.namprd05.prod.outlook.com (2603:10b6:406:80::38) by
BN7PR05MB5859.namprd05.prod.outlook.com with HTTPS via
BN7PR06CA0025.NAMPRD06.PROD.OUTLOOK.COM; Fri, 14 Dec 2018 20:50:45 +0000
Received: from CO2PR05CA0064.namprd05.prod.outlook.com (2603:10b6:102:2::32)
by BYASPR01MB1.namprd05.prod.outlook.com (2603:10b6:a02:ce::33) with
Microsoft SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.1446.9; Fri, 14 Dec
2018 20:50:44 +0000
Received: from SN1NAM01FT045.eop-nam01.prod.protection.outlook.com
(2a01:111:f400:7e40::209) by CO2PR05CA0064.outlook.office365.com
(2603:10b6:102:2::32) with Microsoft SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.20.1446.10 via Frontend
Transport; Fri, 14 Dec 2018 20:50:43 +0000
Authentication-Results: spf=none (sender IP is 137.99.25.249)
smtp.mailfrom=appmail.uconn.edu; uconn.mail.onmicrosoft.com; dkim=fail
(invalid public key) header.d=mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com;
dmarc=none action=none header.from=appmail.uconn.edu;compauth=pass reason=105
Received-SPF: None (protection.outlook.com: appmail.uconn.edu does not
designate permitted sender hosts)
Received: from mta5.uits.uconn.edu (137.99.25.249) by
SN1NAM01FT045.mail.protection.outlook.com (10.152.65.226) with Microsoft SMTP
Server id 15.20.1446.11 via Frontend Transport; Fri, 14 Dec 2018 20:50:43
+0000
DKIM-Filter: OpenDKIM Filter v2.11.0 mta5.uits.uconn.edu 088EA3000A2C
To: [email-masked]
From: "Fazzina, Angelo" <[email-masked]>
Subject: broken test number 2
Date: Fri, 14 Dec 2018 15:50:42 -0500
Thunderbird/60.3.3

-ANGELO FAZZINA

ITS Service Manager:

[email-masked]

From: Murray S. Kucherawy <[email-masked]>
Sent: Monday, December 17, 2018 12:03 PM
To: Fazzina, Angelo <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ietf-dkim] Looking for a little help testing DKIM failure reports, thank you.

DKIM verifiers are not required to generate reports.  It's completely optional.  Does the place you're sending to advertise somehow that they will be generated?

On Mon, Dec 17, 2018 at 8:36 AM Fazzina, Angelo <[email-masked]<mailto:[email-masked]>> wrote:
Hi, I am trying to test my TXT records for the ability to report failures. Talking about RFC 6651

These are my records

dkim1._domainkey.mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916294577&sdata=vM9oIARyakkvr%2B0MEePmLHTRA4O2thX57KWW4mgR9cI%3D&reserved=0>    text = "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
catzd6/iutxWbAiY51rRAvVdBs2YIoGO6Glzeev66ft8IfMnHgxND438KIsdOjUmJZuglFJUWGzCYDSC1eq/zqDVncFwTxWkKW/qtxQIDAQAB"

_report._domainkey.mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916304590&sdata=MGqgIykiwGftuN%2BEBOF2PGI73WCTf5zqzWaX4ywI7T4%3D&reserved=0>  text = "ra=dkim-errors\; rp=100\; rr=all"

Here is a test email sig header
v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916304590&sdata=Tnts9TCcl5Ew4iUUBm%2BgarAzWkfEoFiKADMaIh4UI%2Fc%3D&reserved=0>; s=dkim1; t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=; h=To:From:Subject:Date:From; b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=

Here is a test email result header
spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916314590&sdata=fETLZXDMtAavWtbHlB6CWVCDniKTTLV3nLM8KFgHEVw%3D&reserved=0>; uconn.mail.onmicrosoft.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916314590&sdata=1LzykOrAlxDAmmIkkmYGWS0SaVqdAZ3kZT0VJlhcQQA%3D&reserved=0>; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916324595&sdata=3r180lJRsbT%2F4rvsbeDbOMfhYbsE3%2BJgwIbkYvu5o3Y%3D&reserved=0>;uconn.mail.onmicrosoft.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916324595&sdata=mlL9WGOqI2meDT0NW9nIYUFSD1HKYgswQW286lF5XkY%3D&reserved=0>; dmarc=none action=none header.from=appmail.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916334604&sdata=CPfOWrDlnuTeyjcfrYfk6xhMmXVzwFIwtdL14Ou9m2Y%3D&reserved=0>;compauth=pass reason=105

How often are the failure reports generated ? did not see that mentioned in the RFC’s ?

-ANGELO FAZZINA

ITS Service Manager:

[email-masked]<mailto:[email-masked]>
University of Connecticut,  ITS, SSG, Server Systems
860-486-9075

_______________________________________________
Ietf-dkim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-dkim<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916334604&sdata=oYg%2BrdpATbemNnI6afrabJYGmtuvJJZ6gSAbr%2Bd2Yeo%3D&reserved=0>

---

From: Alessandro Vesely <[email-masked]>
Date: Mon, 17 Dec 2018 19:53:33 +0100

On Mon 17/Dec/2018 19:18:58 +0100 Fazzina, Angelo wrote:

> Sounds like my testing method may be flawed.  L

There are a number of sites for testing DKIM, for example:

	[email-masked]
        [email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]

In addition, one can try Gmail, Yahoo!, and the following three:
http://www.brandonchecketts.com/emailtest.php
http://www.appmaildev.com/en/dkim/
http://9vx.org/~dho/dkim_validate.php

HTH
Ale
--

---

From: Laura Atkins <[email-masked]>
Date: Tue, 18 Dec 2018 10:02:34 +0000

You never published your DKIM key in DNS.

https://tools.wordtothewise.com/dkim/check/mta5.uits.uconn.edu;/dkim1 <https://tools.wordtothewise.com/dkim/check/mta5.uits.uconn.edu;/dkim1>

So the mail is being signed, but the signature is failing because there’s no public key to use to verify. 

laura 

> On 17 Dec 2018, at 18:18, Fazzina, Angelo <[email-masked]> wrote:
> 
> Hi, thank you.
> Received: from BYASPR01MB1.namprd05.prod.outlook.com <http://byaspr01mb1.namprd05.prod.outlook.com/> (2603:10b6:406:80::38) by
> BN7PR05MB5859.namprd05.prod.outlook.com <http://bn7pr05mb5859.namprd05.prod.outlook.com/> with HTTPS via
> BN7PR06CA0025.NAMPRD06.PROD.OUTLOOK.COM <http://bn7pr06ca0025.namprd06.prod.outlook.com/>; Fri, 14 Dec 2018 20:50:45 +0000
> Received: from CO2PR05CA0064.namprd05.prod.outlook.com <http://co2pr05ca0064.namprd05.prod.outlook.com/> (2603:10b6:102:2::32)
> by BYASPR01MB1.namprd05.prod.outlook.com <http://byaspr01mb1.namprd05.prod.outlook.com/> (2603:10b6:a02:ce::33) with
> Received: from SN1NAM01FT045.eop-nam01.prod.protection.outlook.com <http://eop-nam01.prod.protection.outlook.com/>
> (2a01:111:f400:7e40::209) by CO2PR05CA0064.outlook.office365.com <http://co2pr05ca0064.outlook.office365.com/>
> smtp.mailfrom=appmail.uconn.edu <http://appmail.uconn.edu/>; uconn.mail.onmicrosoft.com <http://uconn.mail.onmicrosoft.com/>; dkim=fail
> (invalid public key) header.d=mta5.uits.uconn.edu <http://mta5.uits.uconn.edu/>;uconn.mail.onmicrosoft.com <http://uconn.mail.onmicrosoft.com/>;
> dmarc=none action=none header.from=appmail.uconn.edu <http://appmail.uconn.edu/>;compauth=pass reason=105
> Received-SPF: None (protection.outlook.com <http://protection.outlook.com/>: appmail.uconn.edu <http://appmail.uconn.edu/> does not
> Received: from mta5.uits.uconn.edu <http://mta5.uits.uconn.edu/> (137.99.25.249) by
> SN1NAM01FT045.mail.protection.outlook.com <http://sn1nam01ft045.mail.protection.outlook.com/> (10.152.65.226) with Microsoft SMTP
> Received: from [137.99.80.129] (angelo.uits.uconn.edu <http://angelo.uits.uconn.edu/> [137.99.80.129])
>                 by mta5.uits.uconn.edu <http://mta5.uits.uconn.edu/> (Postfix) with ESMTP id 088EA3000A2C
>                 for <[email-masked] <mailto:[email-masked]>>; Fri, 14 Dec 2018 15:50:43 -0500 (EST)
> DKIM-Filter: OpenDKIM Filter v2.11.0 mta5.uits.uconn.edu <http://mta5.uits.uconn.edu/> 088EA3000A2C
> DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu <http://mta5.uits.uconn.edu/>;
>                 s=dkim1; t=1544820643; r=y;
>                 bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=;
> To: [email-masked] <mailto:[email-masked]>
> From: "Fazzina, Angelo" <[email-masked] <mailto:[email-masked]>>
> Message-ID: <[email-masked] <mailto:[email-masked]>>
> User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101
> Thunderbird/60.3.3
> MIME-Version: 1.0
> Content-Type: text/plain; charset="utf-8"; format=flowed
> Content-Transfer-Encoding: 7bit
> Content-Language: en-US
> Return-Path: [email-masked] <mailto:[email-masked]>
>  
> -ANGELO FAZZINA
>  
> ITS Service Manager:
> [email-masked] <mailto:[email-masked]>
> From: Murray S. Kucherawy <[email-masked] <mailto:[email-masked]>> 
> To: Fazzina, Angelo <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> On Mon, Dec 17, 2018 at 8:36 AM Fazzina, Angelo <[email-masked] <mailto:[email-masked]>> wrote:
> dkim1._domainkey.mta5.uits.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916294577&sdata=vM9oIARyakkvr%2B0MEePmLHTRA4O2thX57KWW4mgR9cI%3D&reserved=0>    text = "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
> _report._domainkey.mta5.uits.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916304590&sdata=MGqgIykiwGftuN%2BEBOF2PGI73WCTf5zqzWaX4ywI7T4%3D&reserved=0>  text = "ra=dkim-errors\; rp=100\; rr=all"
>  
>  
> v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916304590&sdata=Tnts9TCcl5Ew4iUUBm%2BgarAzWkfEoFiKADMaIh4UI%2Fc%3D&reserved=0>; s=dkim1; t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=; h=To:From:Subject:Date:From; b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=
>  
> spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916314590&sdata=fETLZXDMtAavWtbHlB6CWVCDniKTTLV3nLM8KFgHEVw%3D&reserved=0>;uconn.mail.onmicrosoft.com <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916314590&sdata=1LzykOrAlxDAmmIkkmYGWS0SaVqdAZ3kZT0VJlhcQQA%3D&reserved=0>; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916324595&sdata=3r180lJRsbT%2F4rvsbeDbOMfhYbsE3%2BJgwIbkYvu5o3Y%3D&reserved=0>;uconn.mail.onmicrosoft.com <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916324595&sdata=mlL9WGOqI2meDT0NW9nIYUFSD1HKYgswQW286lF5XkY%3D&reserved=0>; dmarc=none action=none header.from=appmail.uconn.edu <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916334604&sdata=CPfOWrDlnuTeyjcfrYfk6xhMmXVzwFIwtdL14Ou9m2Y%3D&reserved=0>;compauth=pass reason=105
>  
>  
> So I can simulate a failure, but cannot seem to get a report emailed to [email-masked] <mailto:[email-masked]> ?
>  
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-dkim <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7Cd11a679d2df74fbeb63908d664418541%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806629916334604&sdata=oYg%2BrdpATbemNnI6afrabJYGmtuvJJZ6gSAbr%2Bd2Yeo%3D&reserved=0>_______________________________________________
> Ietf-dkim mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-dkim <https://www.ietf.org/mailman/listinfo/ietf-dkim>
-- 
Having an Email Crisis?  We can help! 800 823-9674 

Laura Atkins
Word to the Wise
[email-masked]
(650) 437-0741		

Email Delivery Blog: https://wordtothewise.com/blog

---

From: Steve Atkins <[email-masked]>
Date: Tue, 18 Dec 2018 11:25:18 +0000

> On Dec 18, 2018, at 10:02 AM, Laura Atkins <[email-masked]> wrote:
> 
> https://tools.wordtothewise.com/dkim/check/mta5.uits.uconn.edu;/dkim1
> 

No, it's published. You accidentally copied a semicolon with the hostname.

But it seems to be missing the leading "M" in p= relative to what's listed below now, which seems to be causing my tools to barf on it, and maybe validators too.

Cheers,
  Steve

>> Received: from [137.99.80.129] (angelo.uits.uconn.edu [137.99.80.129])
>>                 by mta5.uits.uconn.edu (Postfix) with ESMTP id 088EA3000A2C
>>                 for <[email-masked]>; Fri, 14 Dec 2018 15:50:43 -0500 (EST)
>> DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu;
>> Message-ID: <[email-masked]>
>> Return-Path: [email-masked]
>>  
>> -ANGELO FAZZINA
>>  
>> ITS Service Manager:
>> On Mon, Dec 17, 2018 at 8:36 AM Fazzina, Angelo <[email-masked]> wrote:
>> spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu;uconn.mail.onmicrosoft.com; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com; dmarc=none action=none header.from=appmail.uconn.edu;compauth=pass reason=105
>>  
>>  
>> So I can simulate a failure, but cannot seem to get a report emailed to [email-masked] ?
>>

---

From: "Fazzina, Angelo" <[email-masked]>
Date: Tue, 18 Dec 2018 14:43:29 +0000

Hi, sorry if I caused any confusion.  
I could only think of one way to test and force a failure in hopes of generating a report, and that was the "invalid" key.

I took the "M" out in DNS so the emails would fail DKIM on purpose, in hopes of generating a error report.

I should have been more explicit of my testing method.

It is still "broken" in DNS.
I have learned no one does this, generate DKIM error reporting that is, so I have setup a DMARC TXT record in DNS and try to generate reports with that.

[root@mta5 ~]#  dig +short -t txt _dmarc.mta5.uits.uconn.edu
"v=DMARC1\; p=none\; ri=3600\; rua=mailto:[email-masked]\; ruf=mailto:[email-masked]\; rf=afrf\; fo=1\; pct=100\; adkim=s\; aspf=s"

This is a test server so no mail going through it except my testing emails.

P.S. I sent 2 emails through last night around 5pm so waiting to see if reports get emailed still....

Thank you again for trying to help everyone.

-ANGELO FAZZINA

ITS Service Manager:

[email-masked]

-----Original Message-----
From: Ietf-dkim <[email-masked]> On Behalf Of Steve Atkins
Sent: Tuesday, December 18, 2018 6:25 AM
To: [email-masked]
Subject: Re: [Ietf-dkim] Looking for a little help testing DKIM failure reports, thank you.

> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.wordtothewise.com%2Fdkim%2Fcheck%2Fmta5.uits.uconn.edu%3B%2Fdkim1&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=AC2oE%2BPmNPSgt5MJYr4oPzUzn7kIdNVDQntA02nIJZc%3D&amp;reserved=0
> 

Cheers,
  Steve

>> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=YpRXmWvhB%2F7HBZdnRjyr5x%2FZy6mBiBRmm36hXtksSA8%3D&amp;reserved=0
>> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=YpRXmWvhB%2F7HBZdnRjyr5x%2FZy6mBiBRmm36hXtksSA8%3D&amp;reserved=0
> 
> -- 
> Email Delivery Blog: https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwordtothewise.com%2Fblog&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=KvzxIvA%2FBHMQcPB8w16%2BAkZFNbZGVNuL9D%2BhTkLzcNE%3D&amp;reserved=0	
> 
> 
> 
> 
> 
> 
> 
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=YpRXmWvhB%2F7HBZdnRjyr5x%2FZy6mBiBRmm36hXtksSA8%3D&amp;reserved=0

_______________________________________________
Ietf-dkim mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-dkim&amp;data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C4113cab40fb347c3ec9f08d664db8635%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636807291348941916&amp;sdata=YpRXmWvhB%2F7HBZdnRjyr5x%2FZy6mBiBRmm36hXtksSA8%3D&amp;reserved=0