Subject: Re: [Ietf-languages] Ganda / Luganda (forms)

From: "Doug Ewell" <[email-masked]>
Date: Tue, 13 Nov 2018 13:05:33 -0700

Comments are still welcome. This just starts the 2-week clock in case
there are no objections.

--

LANGUAGE SUBTAG MODIFICATION
File-Date: 2018-xx-xx
%%
Type: language
Subtag: lg
Description: Ganda
Description: Luganda
Added: 2005-10-16
%%

--

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: lg
Description: Ganda
Description: Luganda

4. Intended meaning of the subtag:

The meaning of the existing primary language subtag 'lg' is unchanged.

5. Reference to published description of the language (book or article):

6. Any other relevant information:

The name "Luganda" is used widely to refer to the language called
"Ganda" in ISO 639-2 and 639-3, not only as an endonym but in English-
language contexts.

Ethnologue lists "Luganda" as the autonym and "Baganda, LùGáànda,
luGanda" as alternate names.

The Wikipedia article on "Luganda" (renamed from "Ganda language" in
2010) begins, "The Ganda language, or Luganda..." and then refers to the
language exclusively as "Luganda." Reference:
https://en.wikipedia.org/wiki/Luganda

A CLDR ticket has been written to rename Ganda to Luganda. Adding this
Description field in the Registry may facilitate the decision on whether
to do this in CLDR. Reference: http://unicode.org/cldr/trac/ticket/11004

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Michael Everson <[email-masked]>
Date: Sat, 17 Nov 2018 20:31:05 +0000

I approve.

> On 13 Nov 2018, at 20:05, Doug Ewell <[email-masked]> wrote:
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Don Osborn <[email-masked]>
Date: Sun, 25 Nov 2018 23:09:09 -0500

Seems reasonable. "Ganda" (per "Ganda language") apparently was (is still?) common in linguistic references, but "Luganda" seems to be common in English generally.

A couple of questions to keep in sight when making the change. First, along the lines of Caoimhín's question: what is  precedent wrt languages that use prefixes to Caoimhín language, and the fashion to use endonyms in English? It's really not our place IMO to change the English references to endonyms. But if, on a case by case basis, the latter start to become more common, what's the threshold?

(The odd result, however, is that you inevitably end up with redundancies like "Luganda language" or "ChiBemba language" etc. - tho I realize that's an issue beyond IETF's or CLDR's concerns.)

Second is how this works across languages. For example, in Swahili, Luganda is Kiganda. Otoh, Chinese has 卢干达语 (lú gān/gàn dá yŭ) - Luganda language (effectively Ganda language language) - not clear whether this is from the endonym, or from English common usage (Chinese in some number of cases adapts English or French versions of names of African languages & ethnicities).

Don Osborn

  Original Message  

From: [email-masked]
 Sent: November 17, 2018 3:38 PM
 To: [email-masked]
 Subject: Re: [Ietf-languages] Ganda / Luganda (forms)

I approve.

---

From: "Don Osborn" <[email-masked]>
Date: Sun, 25 Nov 2018 23:23:29 -0500

[Trying this again - foibles of editing on a mobile device]

A couple of questions to keep in sight when making the change. First, along the lines of Caoimhín's question: What is  precedent wrt languages that use prefixes, and the fashion to use endonyms in English? It's really not our place IMO to change the English references to endonyms. But if, on a case by case basis, the latter start to become more common, what's the threshold?

Don Osborn

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Don Osborn
Sent: Sunday, November 25, 2018 11:09 PM
To: ietf-languages <[email-masked]>
Subject: Re: [Ietf-languages] Ganda / Luganda (forms)

Don Osborn

  Original Message  

I approve.

 > Comments are still welcome. This just starts the 2-week clock in case  > there are no objections.
 >
 > --
 >
 > 2. E-mail address of requester: doug at ewellic.org  >  > 3. Record Requested:
 >
 > Type: language
 > Subtag: lg
 > Description: Ganda
 > Description: Luganda
 >
 > The name "Luganda" is used widely to refer to the language called  > "Ganda" in ISO 639-2 and 639-3, not only as an endonym but in English-  > language contexts.
 >
 > Ethnologue lists "Luganda" as the autonym and "Baganda, LùGáànda,  > luGanda" as alternate names.
 >
 > The Wikipedia article on "Luganda" (renamed from "Ganda language" in  > 2010) begins, "The Ganda language, or Luganda..." and then refers to the  > language exclusively as "Luganda." Reference:
 > A CLDR ticket has been written to rename Ganda to Luganda. Adding this  > Description field in the Registry may facilitate the decision on whether  > to do this in CLDR. Reference: http://unicode.org/cldr/trac/ticket/11004
 >
 >
 > --
 > Doug Ewell | Thornton, CO, US | ewellic.org  >  >  > _______________________________________________

---

From: John Cowan <[email-masked]>
Date: Mon, 26 Nov 2018 09:44:45 -0500

On Sun, Nov 25, 2018 at 11:30 PM Don Osborn <[email-masked]> wrote:

(The odd result, however, is that you inevitably end up with redundancies
> like "Luganda language" or "ChiBemba language" etc. - tho I realize that's
> an issue beyond IETF's or CLDR's concerns.)
>

English has managed to live with Missisippi River and Gobi Desert, despite
their literal meanings 'big river river' and 'desert desert'.

"To speak English, it is only necessary to know the English language."
--Steve Dodson

-- 
John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
Income tax, if I may be pardoned for saying so, is a tax on income.
                --Lord Macnaghten (1901)