Subject: [Ietf-languages] UTS #35: Unicode Locale Data Markup Language (LDML)

From: "Gordon P. Hemsley" <[email-masked]>
Date: Mon, 22 Jul 2019 19:07:36 -0400

[I wouldn't expect this to be news to many of the people who are active
on this mailing list, given that they were apparently involved in its
creation, but it was news to me, so I wanted to share it.]

It appears that Unicode has defined what is effectively a superset of
BCP 47 for use in the CLDR:

https://www.unicode.org/reports/tr35/

This goes beyond maintaining the 't' and 'u' extensions to defining
their own rules for parsing and canonicalizing BCP 47 language tags.

Can someone who is familiar with the matter explain the relationship
between Unicode's UTS #35 and IETF's BCP 47 standards?

-- 
Gordon P. Hemsley
[email-masked]
http://gphemsley.org/

---

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 22 Jul 2019 18:42:00 -0700

See https://www.unicode.org/reports/tr35/#BCP_47_Conformance

Use of the *Unicode BCP 47 locale identifier* is preferred: it is valid BCP
47 language tag. (The term *Unicode CLDR locale identifier* applies where a
backwards compatibility syntax is used.)

Mark

On Mon, Jul 22, 2019 at 4:08 PM Gordon P. Hemsley <[email-masked]> wrote:

> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>