Subject: [ietf-smtp] Survival of arbitrary MIME Content-foo header field?

From: Dave Crocker <[email-masked]>
Date: Mon, 30 Jul 2018 09:53:50 -0700

Howdy.

If a random -- ie, unknown to the handling systems -- MIME Content-foo 
header field is attached to a body-part, how likely is it to survive, 
end2end transit on the net today?

What if it is at the message header level?  Any better/worse?

Tnx.

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Steve Atkins <[email-masked]>
Date: Mon, 30 Jul 2018 10:04:57 -0700

> On Jul 30, 2018, at 9:53 AM, Dave Crocker <[email-masked]> wrote:
> 
> Howdy.
> 
> If a random -- ie, unknown to the handling systems -- MIME Content-foo header field is attached to a body-part, how likely is it to survive, end2end transit on the net today?

I'd expect it was very likely to survive, particularly if the MIME was well-formed, as intermediate hosts are unlikely to randomly crack open a MIME body and rewrite it. That DKIM works remarkably well is a data point there.

The ones I've noticed that rewrite MIME have all been Exchange servers, so someone with more Exchange clue might be able to give some insight there.

A few hosts add additional MIME content (advertising, footers), but the ones I've paid any attention to seem to do so by fairly crude textual insertion, so probably wouldn't corrupt existing content too much.

> What if it is at the message header level?  Any better/worse?

That I'm less sure about. I'd expect it to be at best the same or more likely worse, as lots of intermediate hosts do look at and modify the headers.

Cheers,
  Steve

> _______________________________________________
> ietf-smtp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-smtp

---

From: Dave Crocker <[email-masked]>
Date: Mon, 30 Jul 2018 10:17:34 -0700

> I'd expect it was very likely to survive, particularly if the MIME was well-formed, as intermediate hosts are unlikely to randomly crack open a MIME body and rewrite it. That DKIM works remarkably…

thanks...

> A few hosts add additional MIME content (advertising, footers), but the ones I've paid any attention to seem to do so by fairly crude textual insertion, so probably wouldn't corrupt existing conten…

To the extent that the unknown MIME header field depends on the 
associated content to be unmodified, that's an obvious problem.

However my impression is that such additions by mediators, such as 
mailing lists or anti-abuse enterprise front-ends, are done to the 
primary body-part -- the cover note -- and not to any attachments.

So a MIME content-foo for a subordinate body-part ought to survive... 
mumble.

> That I'm less sure about. I'd expect it to be at best the same or more likely worse, as lots of intermediate hosts do look at and modify the headers.

I can't see a reason it should be better and for some reason I'd expect 
it to be somewhat (or very) worse.

d/

---

From: "John Levine" <[email-masked]>
Date: 30 Jul 2018 15:42:27 -0400

>> A few hosts add additional MIME content (advertising, footers), but the ones I've paid any attention to seem to do so by
>fairly crude textual insertion, so probably wouldn't corrupt existing content too much.
>

The ones I've seen look at the MIME type enough to know whether to add
text or to rewrite HTML, so they probably would not mess with a
mystery part.

>primary body-part -- the cover note -- and not to any attachments.

Or they splice on a new part and wrap it all in multipart/related.

I'd think a mystery type at the top level would be likely to trigger
spam and malware filters that not altogether unreasonably assume that
something mysterious is likely to be evil.

R's,
John