Subject: Re: [ietf-types] Registration of application/oxps MIME type (Was: Request for final approval for OpenXPS MIME type)

From: Pete Resnick <[email-masked]>
Date: Thu, 5 May 2011 12:10:41 -0700

Hearing no complaints, this will go to the IESG next week.

On 4/25/11 9:43 AM, Pete Resnick wrote:
> I am re-posting this with a new thread because I would like to get 
> some confirmation from the list that this is OK. I suspect it is, but 
> I'm going to postpone bringing before the IESG until the May 12 
> telechat to give the list some time to review.
>
> The proposal is to register application/oxps instead of 
> application/OpenXPS to better align with the Open XML Paper 
> Specification.
>
> pr
>
> -------- Original Message --------
> Subject:     Re: [ietf-types] Request for final approval for OpenXPS 
> MIME type
> Date:     Mon, 25 Apr 2011 16:09:20 +0000
> From:     Brian Clubb <[email-masked]>
> To:     Franklin Tse <[email-masked]>, Pete Resnick 
> <[email-masked]>
> CC:     [email-masked]' <[email-masked]>
>
>
>
> Franklin,
>
> The decision is to revert the registration back to application/oxps 
> and discuss in committee if we wish to also register 
> application/OpenXPS in the future as a separate registration.  I 
> appreciate you bringing this to our attention.
>
> I am attaching a final revision of the template and including in the 
> message below.
>
> Thanks!
> Brian
>
> <template>
> Type name: application/oxps
> Subtype name:  Standards Tree - OpenXPS
> Required parameters:  N/A
> Optional parameters:  N/A
> Encoding considerations:  binary
>
> Security considerations:
> OpenXPS uses ZIP compression as specified in .ZIP File Format 
> Specification from PKWARE, Inc., version 6.2.0 (2004).  ZIP compressed 
> XML requires parsing untrusted XML data and untrusted ZIP data.  The 
> consumer is responsible for validating the .zip archive, the XML 
> structure, and the resource content.  Per spec, there should be no 
> active content provided as part of the OpenXPS format.  The consumer 
> must ensure that no malicious active content is erroneously provided 
> in the OpenXPS document.  Valid content is described in the EMCA-388 
> specification 
> (http://www.ecma-international.org/publications/standards/Ecma-388.htm).  
> Especially take note of section E.3, which describes steps that can be 
> taken to validate the contents of the payload.
>
> Interoperability considerations:
> application/oxps documents are specified by the XML schemas 
> standardized in ECMA-388.  Applications and drivers currently 
> producing/consuming Microsoft XPS content cannot directly 
> produce/consume OpenXPS.  Changes are required to address differences 
> in the two specifications, such as namespace, print ticket usage, use 
> of JPEG XR, etc.
> To ensure interoperability, the clipboard format must be a complete 
> OpenXPS file with .oxps extension.
>
> Published specification:
> The published standard ECMA-388 is available at:
> http://www.ecma-international.org/publications/standards/Ecma-388.htm
>
> Applications that use this media type:
> The application/oxps MIME type can be used to identify CSTA XML 
> (ECMA-388) instance documents.  No published applications or print 
> drivers currently use OpenXPS.  The intent is for any application or 
> driver that can currently produce/consume Microsoft XPS to also adopt 
> OpenXPS.  Examples of such applications would include but are not 
> limited to:  Microsoft XPS Viewer, Microsoft XPS Document Writer, 
> Microsoft Internet Explorer 9.
>
> Additional information:
>   Magic number(s):  see application/zip.  Note that is it a 
> requirement of the consumer to ensure that the contents of the ZIP 
> archive is a valid OpenXPS structure.
>   File extension(s): .oxps
>   Macintosh file type code(s):  not available
>
>   Windows Clipboard Name: "OpenXPS"
>   Macintosh Uniform Type Identifier: org.ecma.oxps conforms to 
> com.pkware.zip-archive
>
> Person & email address to contact for further information:
> Ecma International Helpdesk
> Rue du Rhone 114
> CH-1204 Geneva
> Switzerland
> Ecma International Helpdesk<[email-masked]>
>
> Intended usage: COMMON
>
> Restrictions on usage:  N/A
>
> Author:  The ECMA-388 Standard is developed and maintained by the Ecma 
> Technical Committee TC46.
>
> Change controller:  The ECMA-388 Standard is developed and maintained 
> by the Ecma Technical Committee TC46.
> </template>
>
> -----Original Message-----
> From: Brian Clubb
> Sent: Sunday, April 24, 2011 10:30 PM
> To: Franklin Tse
> Subject: RE: [ietf-types] Request for final approval for OpenXPS MIME 
> type
>
> Franklin,
>
> Let me check with the working group and reply back.
>
> Thanks!
> Brian
>
> Sent from my Windows Phone
>
> -----Original Message-----
> From: Franklin Tse
> Sent: Sunday, April 24, 2011 9:57 PM
> To: Brian Clubb
> Subject: Re: [ietf-types] Request for final approval for OpenXPS MIME 
> type
>
>
> Dear Brian,
>
> I noticed that Section E.1 of the current Open XML Paper Specification 
> recommends "application/oxps" as the content type for .oxps documents, 
> which is different from the content type you are registering. Is it 
> the decision of the working group? Will interoperability be an issue?
>
> Thanks,
> Franklin
>
> MIMEReg.txt
>
>
> Type name: application/oxps
>
> Subtype name:  Standards Tree -- OpenXPS
>
> Required parameters:  N/A
>
> Optional parameters:  N/A
>
> Encoding considerations:  binary
>
> Security considerations:
> OpenXPS uses ZIP compression as specified in .ZIP File Format Specification from PKWARE, Inc., version 6.2.0 (2004).  ZIP compressed XML requires parsing untrusted XML data and untrusted ZIP data.  The consumer is responsible for validating the .zip archive, the XML structure, and the resource content.  Per spec, there should be no active content provided as part of the OpenXPS format.  The consumer must ensure that no malicious active content is erroneously provided in the OpenXPS document.  Valid content is described in the EMCA-388 specification (http://www.ecma-international.org/publications/standards/Ecma-388.htm).  Especially take note of section E.3, which describes steps that can be taken to validate the contents of the payload.
>
>
> Interoperability considerations:
> application/oxps documents are specified by the XML schemas standardized in ECMA-388.
> Applications and drivers currently producing/consuming Microsoft XPS content cannot directly produce/consume OpenXPS.  Changes are required to address differences in the two specifications, such as namespace, print ticket usage, use of JPEG XR, etc.
>
> To ensure interoperability, the clipboard format must be a complete OpenXPS file with .oxps extension.
>
> Published specification:
> The published standard ECMA-388 is available at:
> http://www.ecma-international.org/publications/standards/Ecma-388.htm
>
> Applications that use this media type:
> The application/oxps MIME type can be used to identify CSTA XML
> (ECMA-388) instance documents.  No published applications or print drivers currently use OpenXPS.  The intent is for any application or driver that can currently produce/consume Microsoft XPS to also adopt OpenXPS.  Examples of such applications would include but are not limited to:  Microsoft XPS Viewer, Microsoft XPS Document Writer, Microsoft Internet Explorer 9.
>
> Additional information:
>
>    Magic number(s):  ZIP archive CRC-32: 504b 0304 per http://www.pkware.com/documents/APPNOTE/APPNOTE-6.2.0.txt.  Note that is it a requirement of the consumer to ensure that the contents of the ZIP archive is a valid OpenXPS structure.
>    File extension(s): .oxps
>    Macintosh file type code(s):  not available
> 	
>    Windows Clipboard Name: "OpenXPS"
>    Macintosh Uniform Type Identifier: org.ecma.oxps conforms to com.pkware.zip-archive
>
> Person&  email address to contact for further information:
>
> Ecma International Helpdesk
> Rue du Rhone 114
> CH-1204 Geneva
> Switzerland
> Ecma International Helpdesk<[email-masked]>
>
> Intended usage: COMMON
>
>
> Restrictions on usage:  N/A
>
>
> Author:  The ECMA-388 Standard is developed and maintained by the Ecma Technical Committee TC46.
>
> Change controller:  The ECMA-388 Standard is developed and maintained by the Ecma Technical Committee TC46.
>    
>
>
> _______________________________________________
> ietf-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-types
>    

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Pete Resnick <[email-masked]>
Date: Thu, 5 May 2011 15:38:44 -0700

> Subtype name:  Standards Tree - OpenXPS

I assume this needs to be fixed to:

Type name: application
Subtype name:  oxps

Correct?

pr

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Fri, 06 May 2011 00:44:18 +0200

>I assume this needs to be fixed to:

Well, in my capacity as random person posting to this list every now and
then, I can confirm that, if the idea is to register "application/oxps".
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Brian Clubb <[email-masked]>
Date: Thu, 5 May 2011 22:47:11 +0000

Please do.  Definitely a copy/paste mistake between iterations.

Thanks!
Brian

-----Original Message-----
From: Pete Resnick
Sent: Thursday, May 05, 2011 6:38 PM
To: [email-masked]
Cc: Brian Clubb
Subject: Re: [ietf-types] Registration of application/oxps MIME type (Was: Request for final approval for OpenXPS MIME type)

Type name: application
Subtype name:  oxps

Correct?

pr