Subject: [ietf-types] Updated registration of media type application/vnd.iptc.g2.newsmessage+xml

From: "Michael Steidl \(IPTC\)" <[email-masked]>
Date: Tue, 4 Oct 2011 10:37:40 +0200

Updated after responses to first draft in mid September.

To:

[email-masked] 

Subject:

Registration of media type application/vnd.iptc.g2.newsmessage+xml

Media Type Name: application

Subtype name: vnd.iptc.g2.newsmessage+xml

Required parameters: none

Optional parameters: charset

Same as charset parameter of application/xml as specified in 

RFC 3023 [RFC3023]

Encoding considerations:Same as encoding considerations

of application/xml as specified in RFC 3023, section 3.2

Security considerations: In regards to general XML Security issues,

identical to those of "application/xml" as described in RFC3023,

section 10. Beyond these general XML Security issues, the media

type does not contain active or executable content. The information

contained in the media type does not require privacy or integrity

services, however the media type does support the use of the XML

syntax and processing rules for creating and representing digital

signatures as described by RFC3275.

Interoperability considerations:

Published specification:

NewsML-G2 version 2.9 specifications and implementation guidelines

http://www.iptc.org/std/NewsML-G2/

Applications which use this media type: content management systems, news exchange systems

Additional information:

Magic number(s): none

File extension(s): .xml

Macintosh File Type Code(s): Identical to those of

"application/xml" as described in RFC3023, "TEXT"

Windows Clipboard Flavor Name: "IPTC NewsMessage XML"

Macintosh Uniform Type Identifier: org.iptc.newsmessage conforms to public.xml

Object Identifier(s) or OID(s):

It must be possible to positively identify an Item as it moves

through the news workflow, and is transferred from place to place

and from system to system. An Item therefore gets a globally

unique identifier (guid), which is a persistent, universally unique

identifier, and a version which is incremented when the content of

the Item is updated. The first version is numbered 1: if the version

is not explicitly set, this value must be assumed by the recipient of

the Item. The guid is required to be in the form of a IRI. Any IRI

capable of acting as a globally unique identifier is accepted; the

IPTC provides a standard for this purpose in the form of an IETF RFC

[RFC-3085].

Intended usage:

A News Message is a wrapper of one or more IPTC G2 items for 

distribution and transmission purposes. It provides transmission-specific 

properties in a header which is shared by all included IPTC G2 items.

Other Information/General Comment: none

Person to contact for further information:

Michael Steidl <[email-masked]>

Author/Change controller:

Michael Steidl <[email-masked]>

 

Michael Steidl

Managing Director of the IPTC [[email-masked]]

International Press Telecommunications Council 
Web:  <http://www.iptc.org/> www.iptc.org - on Twitter  <http://www.twitter.com/IPTC> @IPTC

Business office address: 

20 Garrick Street, London WC2E 9BT, United Kingdom

Registered in England, company no 101096

---

From: Jan Algermissen <[email-masked]>
Date: Tue, 4 Oct 2011 16:57:44 +0200

Hi,

as per Mark Baker's comment, I'd suggest, too to use a specific file extension, such as newsml

Jan

On Oct 4, 2011, at 10:37 AM, Michael Steidl (IPTC) wrote:

> Web: www.iptc.org - on Twitter @IPTC
> Business office address:
> _______________________________________________
> ietf-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-types

---

From: "Michael Steidl \(IPTC\)" <[email-masked]>
Date: Fri, 7 Oct 2011 21:40:39 +0200

Hi Jan

The IPTC has already registered 4 MIME Types for our suite of news exchange formats (vnd.iptc.g2.conceptitem+xml, vnd.iptc.g2.knowledgeitem+xml, vnd.iptc.g2.newsitem+xml, vnd.iptc.g2.packageitem+xml), all without a specific file extension. The main reason is that such XML instances are usually not delivered by access to a file but by a API to a RESTful web service. So why should we start defining specific extension for additional MIME types with no urgent practical need for it.

Michael

> -----Original Message-----
> From: Jan Algermissen [mailto:[email-masked]]
> Sent: Tuesday, October 04, 2011 4:58 PM
> To: Michael Steidl (IPTC)
> Cc: [email-masked]
> Subject: Re: [ietf-types] Updated registration of media type
> application/vnd.iptc.g2.newsmessage+xml
> 
> Hi,
>