Subject: Re: Source Format of RFCs

From: Alan Blair <[email-masked]>
Date: Tue, 01 Dec 1998 01:23:01 -0500

Could not we use XML (vs. ASCII) as the RFC format?  We could have the switch occur in
January, 2000.  By then the tools should be strong, interoperable, and run on enough
platforms.  A URL source for XML tools is:   http://www.xmlsoftware.com/

                                                                    Alan

Bruce Balden wrote:

> A number of RFC's and drafts, such the ones regarding BGP, suffer negatively from the
> text-only format. It would be nicer to have a richer format, especially since such
> documents rarely originate in the text-only format, but are rendered into that format
> by MS-Word, nroff, LaTeX or whatever.
>
> Would it be asking too much for all RFC's too made available in some sort of rich
> format, and in particular their source format since that doesn't require additional
> work?
>
> -----Original Message-----
> From: Dunlap, Randy <[email-masked]>
> To: [email-masked]' <[email-masked]>
> Date: November 30, 1998 10:53 AM
> Subject: RE: Source Format of RFCs
>
> |I have only submitted older RFCs (i.e. converted early paper RFCs
> |to electronic form).  The RFC Editor's office asked for these in
> |simple ASCII text form so that they could convert them to nroff
> |if I remember correctly.  I think that they will take nroff input
> |also.  ;)
> |
> |~Randy
> |
> |
> |> -----Original Message-----
> |> From: Matt Crawford [mailto:[email-masked]]
> |> Sent: Monday, November 30, 1998 7:51 AM
> |> To: Stephen L. Favor
> |> Cc: [email-masked]
> |> Subject: Re: Source Format of RFCs
> |>
> |>
> |> > Could someone tell me what source formats are in use for
> |> writting RFCs?
> |> > Is it a DTD?  Are any standard tools/editors used? Etc.
> |> Any info would
> |> > be helpful.
> |>
> |> I may be hopelessly old-fashioned, but I use nroff to write
> |> internet-drafts.  I reckon the RFC editor is proficient at converting
> |> that format to the required RFC format.
> |>
> |> I have developed quite a few nroff macros and supporting perl and C
> |> programs for use with i-d's.  You can get them all, in fair-to-
> |> middling states of documentation, at
> |> ftp://berserk.fnal.gov/pub/id-tools/id-tools.tar.
> |>
> |> No promises, but they work for me.
> |>
> |> Matt Crawford
> |>
> |
> |-
> |This message was passed through [email-masked], which
> |is a sublist of [email-masked]. Not all messages are passed.
> |Decisions on what to pass are made solely by Harald Alvestrand.
> |

---

From: Alan Blair <[email-masked]>
Date: Tue, 01 Dec 1998 01:23:01 -0500

Alan

---

From: [email-masked] (Claus André Färber)
Date: 01 Dec 1998 10:19:00 +0100

Alan Blair <[email-masked]> schrieb:
> Could not we use XML (vs. ASCII) as the RFC format?

Yes, this is probably the best solution. We do need tools/stylesheets  
then that can create plain text and Postscript/PDF renderings from that.

However, not creating an ASCII-tty version at all is not an option IMO.

--
Claus Andre Faerber <http://www.faerber.muc.de>
PGP: ID=1024/527CADCD FP=12 20 49 F3 E1 04 9E 9E  25 56 69 A5 C6 A0 C9 DC

---

From: [email-masked] (Claus André Färber)
Date: 01 Dec 1998 10:19:00 +0100

---

From: Fred Baker <[email-masked]>
Date: Tue, 01 Dec 1998 09:27:53 -0800

>Could not we use XML (vs. ASCII) as the RFC format?

give us some arguments for that, concerning choice of word processor (what
UNIX, what Mac, and what PC word processors support it), searchability, and
readability?

I'm up for thinking about it, but I don't at the moment have the capability
to write an RFC, or read one, that uses it. Or at least I don't know that I
have that capability.

---

From: Fred Baker <[email-masked]>
Date: Tue, 01 Dec 1998 09:27:53 -0800

---

From: Randy Bush <[email-masked]>
Date: Tue, 1 Dec 1998 10:15:19 -0800 (PST)

> UNIX, what Mac, and what PC word processors support it)

please do not forget waits, tops-20, ibm and other lameframes, vms, ...

i wonder if the proponents of other-than-ascii, to better hone their
arguments, have read the archive of the previous times we have had this
discussion.

randy

---

From: Randy Bush <[email-masked]>
Date: Tue, 1 Dec 1998 10:15:19 -0800 (PST)

randy

---

From: Tripp Lilley <[email-masked]>
Date: Tue, 1 Dec 1998 13:59:19 -0500 (EST)

> to write an RFC, or read one, that uses it. Or at least I don't know that I

Part of the point of using SGML or XML is that you could still read the
ASCII-flattened version in whatever tool you liked. Thus, grep and the
like would still work. Stepping beyond that realm, though, you can use the
XML-specific tools to search with context (ie: searching for names in the
<author> tag instead of simple plaintext searches -- unfortunate if an
author's name is also a common word).

As for composition, I am unqualified to comment on specific tool
availability or quality. However, as I mentioned in a previous post, as
long as we're initially talking about the ASCII character set, you can
whack out SGML or XML docs in any editor that supports raw ASCII. There
are ways to coerce any word processor that supports templates and a
capable macro language into generating structured docs, but it's probably
better to push on the vendor to integrate true XML support. I suspect
you'll see Microsoft doing this soon, anyway, since they (at least for
now) are very much on the XML wagon.

------------------------------------------------------------------------------
Tripp Lilley, Innovative Workflow Engineering, Inc. ([email-masked])
------------------------------------------------------------------------------
         "Given enough eyeballs, all bugs are shallow" -- Linus's Law

---

From: Tripp Lilley <[email-masked]>
Date: Tue, 1 Dec 1998 13:59:19 -0500 (EST)

---

From: "Martin J. Duerst" <[email-masked]>
Date: Fri, 04 Dec 1998 04:55:19 +0900

At 20:28 98/11/30 -0500, Keith Moore wrote:

> However, as far as I can tell, there are several barriers to adoption 
> of HTML as an RFC format:

> 2. The Internet-drafts and RFC Editor people would need tools to let
>    them edit HTML, remove or alter tags that did not conform to the
>    standard, and perhaps to convert HTML to "RFC format" ASCII text.
>    (again, such tools would need to work with the garbage HTML that
>    is generated by some word processors)

Please have a look at http://www.w3.org/People/Raggett/tidy/,
which cleans up bad HTML. It may be possible to adapt it to
the specific needs of the RFC process. Also, for HTML->Text
conversion, please go to some page on http://www.w3.org/,
and append ",text" to the URI, and have a look at what you
get.

Regards,   Martin.

#-#-#  Martin J. Du"rst, World Wide Web Consortium
#-#-#  mailto:[email-masked]   http://www.w3.org

---

From: "Martin J. Duerst" <[email-masked]>
Date: Fri, 04 Dec 1998 04:55:19 +0900

Regards,   Martin.

---

From: "Martin J. Duerst" <[email-masked]>
Date: Sun, 06 Dec 1998 08:33:56 +0900

At 16:00 98/12/04 -0500, Henning Schulzrinne wrote:
> Martin J. Duerst wrote:
> http://cgi.w3.org/team-bin/html2txt?url=http://www.w3.org/MarkUp/
> 
> I get "The URL you are requesting requires proper authentication."

Really sorry about that, to everybody who tried it.. I wasn't aware
that this requires a password. It's using lynx from a shell script,
and that would have some conseqences for security. But there would
be no problem to make the setup public.

Below is an example of what the tool produces.

Regards,   Martin.

http://www.w3.org/,text results in:

W3C

Leading the Web to its Full Potential...

[1]W3C Issues Document Object Model (DOM) Level 1 as a Recommendation

     "The [2]Document Object Model (DOM) Level 1 Recommendation
     represents a major milestone towards interoperability for dynamic
     Web pages and XML applications. We are proud to have reached
     cross-industry agreement on this subject. Now, Web page authors
     have a standard way to manipulate an HTML document's content and
     structure, and this is even more important for the processing of
     XML documents and data."
     -- Arnaud Le Hors, Document Object Model Activity Lead
     
[3]Libwww 5.2 released
[4]Communications and Marketing Manager wanted
     _________________________________________________________________
   
[5]User Interface

   [6]HTML
          
   [7]Style Sheets
          
   [8]Document Object Model
          
   [9]Math
          
   [10]Graphics
          
   [11]Internationalization
          
   [12]Mobile Access
          
   [13]Amaya
          
[14]Technology and Society

   [15]Digital Signature Initiative
          
   [16]Metadata
          
   [17]PICS
          
   [18]Privacy [P3P]
          
   [19]Security
          
   [20]Policy
          
   [21]Electronic Commerce
          
[22]Architecture

   [23]HTTP
          
   [24]HTTP-NG
          
   [25]Web Characterization
          
   [26]Synchronized Multimedia
          
   [27]XML
          
   [28]Television and the Web
          
   [29]Jigsaw
          
   [30]Libwww
          
[31]Web Accessibility Initiative

W3C Services

   [32]HTML Validation Service
          CSS2 Package:
          
   キ [33]W3Core Styles
          
   キ [34]CSS2 Validation Service
          
   キ [35]CSS Test Suite
          
   [36]Mailing Lists
          
   [37]Search
          
Historical

Moved

   [38]Arena
          
   [39]Web Journal
          
   [40]Virtual Library
          
Unsupported

   [41]CERN Server
          
   [42]About W3C
   who we are, why we're here, and [43]how to become a Member [44]News &
   Announcements
   keep up with the latest events at the Consortium
   [45]About the Web
   history and general information about the Web [46]Member Area
   for [47]W3C Member employees only
   [apply for a personal [48]username and password set]
   [49]Press Information
   contacts, news releases, W3C in the press [50]W3C Folio
   the "big picture" of what we do
   [51]People of the W3C
   about us - on a personal note [52]Technical Reports & Publications
   W3C Specifications, including current Recommendations, Working Drafts,
   Notes and Submissions
   [53]How to Contact Us
   we're global -- North America, Europe and Asia [54]Sample Code
   W3C Reference Library, testbed and experimental software
   Search [W3C site and public mailing lists archives]
   ______________________________ Submit
     _________________________________________________________________
   
   W3C is hosted by the [55]Laboratory for Computer Science at [56]MIT,
   by [57]INRIA and [58]Keio University with support from [59]DARPA and
   the [60]European Commission.
   
   [61]MIT/LCS [62]INRIA[63]Keio [64]DARPA [65]CEC
     _________________________________________________________________
   
   [66]Valid HTML 4.0!
   
   [67]Help! on navigating this site.

    [68]Webmaster
    
   [69]Copyright ゥ 1997 - 1998 [70]W3C ([71]MIT, [72]INRIA, [73]Keio ),
   All Rights Reserved. W3C [74]liability, [75]trademark, [76]document
   use and [77]software licensing rules apply. Your interactions with
   this site are in accordance with our [78]public and [79]Member privacy
   statements.

References

   1. http://www.w3.org/Press/1998/DOM-REC
   2. http://www.w3.org/TR/REC-DOM-Level-1
   3. http://www.w3.org/Library
   4. http://www.w3.org/Consortium/Recruitment/98-CMPost
   5. http://www.w3.org/UI/
   6. http://www.w3.org/MarkUp/
   7. http://www.w3.org/Style/
   8. http://www.w3.org/DOM/
   9. http://www.w3.org/Math/
  10. http://www.w3.org/Graphics/Activity
  11. http://www.w3.org/International/
  12. http://www.w3.org/Mobile/
  13. http://www.w3.org/Amaya/
  14. http://www.w3.org/TandS/
  15. http://www.w3.org/DSig/Overview.html
  16. http://www.w3.org/Metadata/
  17. http://www.w3.org/PICS/
  18. http://www.w3.org/P3P/
  19. http://www.w3.org/Security/
  20. http://www.w3.org/Policy/
  21. http://www.w3.org/ECommerce/
  22. http://www.w3.org/Architecture/
  23. http://www.w3.org/Protocols/
  24. http://www.w3.org/Protocols/HTTP-NG/
  25. http://www.w3.org/WCA/
  26. http://www.w3.org/AudioVideo/
  27. http://www.w3.org/XML/
  28. http://www.w3.org/TV
  29. http://www.w3.org/Jigsaw/
  30. http://www.w3.org/Library/
  31. http://www.w3.org/WAI/
  32. http://validator.w3.org/
  33. http://www.w3.org/StyleSheets/Core/
  34. http://jigsaw.w3.org/css-validator/
  35. http://www.w3.org/Style/CSS/Test/
  36. http://www.w3.org/Mail
  37. http://search.w3.org/Public/
  38. http://www.w3.org/Arena/
  39. http://www.w3j.com/
  40. http://www.w3.org/vl/
  41. http://www.w3.org/Daemon/
  42. http://www.w3.org/Consortium/
  43. http://www.w3.org/Consortium/Prospectus/Joining
  44. http://www.w3.org/News/
  45. http://www.w3.org/WWW/
  46. http://www.w3.org/Member/
  47. http://www.w3.org/Consortium/Member/List
  48. http://cgi.w3.org/MemberAccess/
  49. http://www.w3.org/Press/
  50. http://www.w3.org/Press/98Folio.pdf
  51. http://www.w3.org/People/W3Cpeople.html
  52. http://www.w3.org/TR/
  53. http://www.w3.org/Consortium/Contact
  54. http://www.w3.org/Status.html
  55. http://www.lcs.mit.edu/
  56. http://web.mit.edu/
  57. http://www.inria.fr/
  58. http://www.keio.ac.jp/
  59. http://www.w3.org/Consortium/Prospectus/DARPA.html
  60. http://europa.eu.Int/
  61. http://www.lcs.mit.edu/
  62. http://www.inria.fr/
  63. http://www.keio.ac.jp/
  64. http://www.darpa.mil/
  65. http://europa.eu.Int/
  66. http://validator.w3.org/
  67. http://www.w3.org/Help/
  68. http://www.w3.org/Help/Webmaster.html
  69. http://www.w3.org/Consortium/Legal/ipr-notice.html#Copyright
  70. http://www.w3.org/
  71. http://www.lcs.mit.edu/
  72. http://www.inria.fr/
  73. http://www.keio.ac.jp/
  74. http://www.w3.org/Consortium/Legal/ipr-notice.html#Legal_Disclaimer
  75. http://www.w3.org/Consortium/Legal/ipr-notice.html#W3C_Trademarks
  76. http://www.w3.org/Consortium/Legal/copyright-documents.html
  77. http://www.w3.org/Consortium/Legal/copyright-software.html
  78. http://www.w3.org/Consortium/Legal/privacy-statement.html#Public
  79. http://www.w3.org/Consortium/Legal/privacy-statement.html#Members

---

From: "Martin J. Duerst" <[email-masked]>
Date: Sun, 06 Dec 1998 08:33:56 +0900

Regards,   Martin.

W3C

     
[3]Libwww 5.2 released
   
[5]User Interface

   [6]HTML
          
   [7]Style Sheets
          
   [8]Document Object Model
          
   [9]Math
          
   [10]Graphics
          
   [11]Internationalization
          
   [12]Mobile Access
          
   [13]Amaya

          
   [16]Metadata
          
   [17]PICS
          
   [18]Privacy [P3P]
          
   [19]Security
          
   [20]Policy
          
   [21]Electronic Commerce
          
[22]Architecture

   [23]HTTP
          
   [24]HTTP-NG
          
   [25]Web Characterization

   [27]XML

   [29]Jigsaw
          
   [30]Libwww

W3C Services

   キ [33]W3Core Styles

   キ [35]CSS Test Suite
          
   [36]Mailing Lists
          
   [37]Search
          
Historical

Moved

   [38]Arena
          
   [39]Web Journal
          
   [40]Virtual Library
          
Unsupported

   [41]CERN Server
          
   [42]About W3C

   
   [66]Valid HTML 4.0!

    [68]Webmaster

References