Subject: RE: Source Format of RFCs

From: Vernon Schryver <[email-masked]>
Date: Thu, 3 Dec 1998 17:36:45 -0700 (MST)

> From: "Mitch Denny" <[email-masked]>

> ...
> When an author puts out a document for a proposed
> standard, they are the expert, assuming it is a new
> protocol and not a rehash, they are the only ones
> with this knowledge.
>
> THERE ARE NO OTHER EXPERTS.  So this document
> has to be able to educate the readers so that
> they can then go out and implement it.

Again, RFCs that are not VI RFCs are the products of IETF Working <<GROUPS>>,
not "authors."  I've long argued that the use "author" instead of "editor"
by the IETF causes many distortions of the process and misunderstandings
by outsiders.  Because of that word, people aspire to be RFC authors
for bad reasons, most often to be famous and so improve their sex lives,
get a promotion at work, or help their private consulting businesses.

> There is no point listing arbitary command
> syntaxs without defining and showing how they
> work together to create a protocol.

I disagree.  Thank you very much, but let the RFC simply define the
protocol, so I can hack the code to implement it.  I'll go elsewhere to
learn its purpose or application, if I don't already know or can't figure
it out.

There is more than one kind of technical document.  One is a reference
manual, and another is a tutorial.  People who already have clues find
tutorials misleading and generally worse than useless.  People new to a
subject find reference manuals very difficult and often give up.  Document
that try to be both reference manuals and tutorials combine the worst of
both flavors and the virtues of neither.  Historically, RFC's were
reference manuals.  You, like others over the years, are urging that
the real RFC's become either turtorials or combination tutorials and
reference manuals.  That might help educate the masses, but it would hurt
the current readers of RFC's, implementors and protocol designers.

>                                  ... My point is
> that the documents produced can be both a reference
> and informative.
>
> We should create technical documents that address
> a wider audience, and are more complete.  We 
> shouldn't be elistist by excluding vital
> informative and educational information.
>
> The Information Technology industry as a whole
> is fairly elitist, I am guilty of it, I bet some
> of you are too.  If we devulged a little more
> information more readily in a better format,
> out technologies would be taken up quicker and
> we could go on to develop better systems.

Why don't those words apply equally or more to the documents produced by
lawyers and legislators?  Every law or serious contract I've tried to read
has "[exclued] vital informative and edutational information".  Why are
all lawyers and politicans so "elitist"?

Vernon Schryver    [email-masked]

---

From: "Mitch Denny" <[email-masked]>
Date: Fri, 4 Dec 1998 14:48:51 +1000

Vernon,

It is all about creating a resource that
everyone can use, ofcourse you merge the
two documents, you link them, make the
tutorial reference the reference.

My original point was use a rich format
to help convery _whatever_ information
better.  Why do people have a problem
with that.

Is there a working group dealing with
the issue of disemination of technical
information in a variety of formats.

Cheers,

Mitch Denny
[email-masked]

> -----Original Message-----
> From: Vernon Schryver [mailto:[email-masked]]
> Sent: Friday, December 04, 1998 10:37
> To: [email-masked]
> Subject: RE: Source Format of RFCs
>
>

---

From: "Mitch Denny" <[email-masked]>
Date: Fri, 4 Dec 1998 14:48:51 +1000

Vernon,

Cheers,

Mitch Denny
[email-masked]