Subject: RE: Acronims' ambiquity

From: Bob Braden <[email-masked]>
Date: Wed, 7 Jun 2000 21:23:36 GMT

*> 
  *> (Rename the relevant links under http://www.rfc-editor.org/ to use
  *>  ftp.rfc-editor.org instead of ftp.isi.edu, and that
  *>  'RFC editor publishes' argument becomes less quibbly and arguably
  *>  more futureproof.)
  *> 

The RFC Editor agrees with the futureproofing, and the renaming
you suggest has in fact been in progress for some time now.  However,
the RFC Editor cannot soon remove the original names, because lots of
folks have them buried in scripts, and pragmatic continuity is more
valuable to the IETF membership than quibbling.

Bob Braden

---

From: "Matt Crawford" <[email-masked]>
Date: Wed, 07 Jun 2000 17:13:03 -0500

> The RFC Editor agrees with the futureproofing, ...

In other words, it's easier to futureproof than to pastproof.

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 7 Jun 2000 23:53:48 +0100 (BST)

> In other words, it's easier to futureproof than to pastproof.

I strongly doubt that there are any scripts actually parsing the
www.rfc-editor.org webpages for instances of ftp.isi.edu.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 08 Jun 2000 09:57:54 -0500

Lloyd Wood wrote:
...
> www.rfc-editor.org webpages for instances of ftp.isi.edu.

Who said anything about parsing? There must be many scripts in the world
that start with something like this. You will notice the amount
of historical crud in there...

> #! /bin/sh
> # To tailor this script for local use:
> # 1) set DEST to a site  near you that houses RFCs.
> # 2) set pub  to the directory where you want to cache retreived RFCs
> # 3) change the "password" to your email address
> #
> # Usage:
> # rfc nnnn
> # fetches rfc nnnn.
> #
> # rfc -index
> # fetches an index of the RFC directory
> #
> # RFCs can be obtained via FTP from NIC.DDN.MIL, FTP.NISC.SRI.COM:rfc,
> # NIS.NSF.NET, NISC.JVNC.NET, VENERA.ISI.EDU, or WUARCHIVE.WUSTL.EDU.
> #
> #
> # Set DEST to the FTP site where rfcs are archived. Note that
> # different servers keep RFCs in different locations (tweak the FTP
> # commands below). Also, not all servers supply compressed
> # versions. :-(
> #
> DEST=venera.isi.edu
>                  
...

   Brian

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 8 Jun 2000 16:22:54 +0100 (BST)

On Thu, 8 Jun 2000, Brian E Carpenter wrote:

> Who said anything about parsing?

Whether the rfc-editor at http://www.rfc-editor.org/ appears to
publish its own RFCs using ftp.rfc-editor.org is entirely separate to 
the continued maintenance of ftp.isi.edu as an RFC mirror.

(I can't see why the rfc-editor webpages refer to isi urls when they
can now happily use ftp.rfc-editor.org urls, and I can't see that
change breaking any legacy stuff whatsoever.)

> There must be many scripts in the world

Red herring. Separate issue. unrelated.

L.