Subject: RE: Where is the OID "dot convention" spelled out?

From: Peter Furniss <[email-masked]>
Date: Fri, 23 Jun 2000 00:12:48 +0100

Michael Mealling sent :

> For all the ASN.1 folks out there:
> 
> I'm in the midst of writing up the OID URN namespace document 
> (see http://www.ietf.org/internet-drafts/draft-mealling-oid-urn-00.txt)
> and it has come to my attention that none of the ASN.1 standards 
> define the dot-notation that we use in all sorts of RFCs. I'm specifically
> referring to the practice of inserting dots in between each arc as in:
> 1.3.6.1.4.1
> 
> Is anyone aware if this is actually spelled out somewhere? I don't
> have the newest ASN.1 docs in front of me so if the're in there
> a page reference would be great.

It is an IETF convention, not one defined in the ASN.1 standards. It is used at least as early as RFC 1157 (snmp), which refers to "the familiar dot notation" - familiar, I'd assumed, in the dot notation of IP addresses. (which seems to be first mentioned in RFC 790, though it says it was already in use then (and had leading zeros)
 
The ASN.1 standards use spaces between the fields and {braces} round the whole lot in text representations. They also use name(number) to identify what the fields are, and the first part of a text representation can also be an assigned asn.1 value (so a whole subtree can be specified without repeating the value of the root all over the place)

Peter Furniss
ISO/IEC JTC1 OSI Maintenance Rapporteur (on behalf of BSI)
OSI Maintenance website: http://www.furniss.co.uk/maint

---

From: Christian Huitema <[email-masked]>
Date: Thu, 22 Jun 2000 18:07:24 -0700

The notation of OID strings as 1.3.6.1.4.1 started appearing in the ISODE
ASN.1 compiler, in the late 80's. It was not part of the ASN.1 standard; in
fact, ASN.1 defines its own set of format, that can mix numbers and
litterals. In ASN.1, this was called a "value notation." A standard ASN.1
textual representation would have been, for example, {1 3 6 1 4 1}, or {1 3
6 foo(1) bar(4) 1}, as in
	fooBar OBJECT IDENTIFIER ::= {1 3 6 foo(1) bar(4) 1}
Why the ASN.1 representation never really caught up in user interfaces is
left as an exercize for the reader...

> -----Original Message-----
> From: Peter Furniss [mailto:[email-masked]]
> Sent: Thursday, June 22, 2000 4:13 PM
> To: [email-masked]'; 'Michael Mealling'
> Subject: RE: Where is the OID "dot convention" spelled out?
> 
> 
> Michael Mealling sent :
> 
> > (see 
> http://www.ietf.org/internet-drafts/draft-mealling-oid-urn-00.txt)
> It is an IETF convention, not one defined in the ASN.1 
> standards. It is used at least as early as RFC 1157 (snmp), 
> which refers to "the familiar dot notation" - familiar, I'd 
> assumed, in the dot notation of IP addresses. (which seems to 
> be first mentioned in RFC 790, though it says it was already 
> in use then (and had leading zeros)
>  
> The ASN.1 standards use spaces between the fields and 
> {braces} round the whole lot in text representations. They 
> also use name(number) to identify what the fields are, and 
> the first part of a text representation can also be an 
> assigned asn.1 value (so a whole subtree can be specified 
> without repeating the value of the root all over the place)
> 
> 
> Peter Furniss

---

From: TSIGARIDAS PANAGIOTIS <[email-masked]>
Date: Fri, 23 Jun 2000 09:31:17 +0300

Right,

OID string representation is not part of the ASN.1 languange specification.
ASN.1 is used for specification of protocols, mostly in OSI, and ITU-T
standards. 
I think you should take a look at the RFCs dealing with string
representation syntaxes. 
In particular RFCs related to X.500 and LDAP technology.

Panagiotis Tsigaridas

IT Architecture Manager

---

From: Daryl Bunce <[email-masked]>
Date: Fri, 23 Jun 2000 12:53:55 -0700

try
http://www.alvestrand.no/objectid/top.html

Not spelled out, but a good starting spot (Thanks Harald!)