Subject: RE: VIRUS WARNING

From: "Michael B. Bellopede" <[email-masked]>
Date: Mon, 8 May 2000 09:27:14 -0400

It should be pretty obvious that the only reason that viruses are so
prolific on MS platforms, is that so many people are using them.  When
designing a virus to spread, the user base must be considered.  A virus
written to infect UNIX systems would not attract much attention anywhere
other than a small circle of professionals and engineers.

Michael B. Bellopede
[email-masked]

-----Original Message-----
From: Randall Stewart [mailto:[email-masked]]
Sent: Friday, May 05, 2000 8:05 PM
To: Michael H. Warfield
Cc: [email-masked]; Scot Mc Pherson; [email-masked]
Subject: Re: VIRUS WARNING

Michael:

I could not agree more, we have a few (possibly .. 3) virus that have
infect *nix systems. Even more telling, look at how linux systems
have NOT been infected or bothered much. I find this interesting
since the code - bugs, wart, and any holes are available to any
who want to look at it...

Now if I take and switch the machine I am typing on over to
that "other" o/s the virus scanner it has lists 100's and I
mean 100's of viruses...

I do understand that some of us are STUCK with that other
O/S... but there are options.. I too am in theory using it.. but
only when I have to... I do all my real work on the linux side and
only occasionaly fire up the other side to read a awful .doc or .ppt
file...

I simply refuse to allow our IT dept to have there way with me and
infect me with the worst virus... that other O/S :-)

R

"Michael H. Warfield" wrote:
>
> On Thu, May 04, 2000 at 11:13:03PM -0400, [email-masked] wrote:
> > On Thu, 04 May 2000 11:11:50 EDT, Scot Mc Pherson
<[email-masked]>  said:
> > > In fact to back up your statement, there are exactly 3 virii that
infect
> > > UNIX based systems.
>
> > Hmm.. the Morris worm of 1988.  What are the other 2?
>
>         Bliss?  Wasn't very sophisticated and it didn't propagate very
> well, but it did work.  It just fizzeled out because it's propagation
> coefficient never even came close to break even.
>
>         What's the other one?
>
> > Hmm.. if you count the 2 self-reproducing sample programs that
> > came with 'gcc', no others.  Or maybe there's more than 3, which
> > is likely since I've seen at least 4 different "proof of concept"
> > level creations...
>
>         I've seen some assembly code someone was proposing on one of the
> development lists.  One of the DOS virus writers claiming that it would
> work as a Linux virus.  No evidence that it does anything though.  I
> would marginally call that one a "proof of concept" or a "maybe of
> concept".
>
> >                               Valdis Kletnieks
> >                               Operating Systems Analyst
> >                               Virginia Tech
>
>         Mike
> --
>  Michael H. Warfield    |  (770) 985-6132   |  [email-masked]
>   (The Mad Wizard)      |  (770) 331-2437   |
http://www.wittsend.com/mhw/
>   NIC whois:  MHW9      |  An optimist believes we live in the best of all
>  PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!

--
Randall R. Stewart
Member Technical Staff
Network Architecture and Technology (NAT)
847-632-7438 fax:847-632-6733

---

From: Tim Salo <[email-masked]>
Date: Mon, 8 May 2000 09:11:08 -0500 (CDT)

> From: "Michael B. Bellopede" <[email-masked]>
> Subject: RE: VIRUS WARNING
> Date: Mon, 8 May 2000 09:27:14 -0400
> 
> prolific on MS platforms, is that so many people are using them....

Hardly.

Compare the apparent security considerations in the design of
Microsoft Outlook and Word (execute pretty much anything with few
limitations on the effects the executing code can have on the hosting
system) with those of Java and the Java virtual machine (provide
a sandbox in which the code executes and provide mechanisms (e.g., the
SecurityManager) that control the effects of the code executing in
the sandbox can have on the broader environment).

It should be pretty obvious that security is a greater design consideration
for some systems than for others.

-tjs