Subject: RE: VIRUS WARNING

From: "Castro, Edison M. (PCA)" <[email-masked]>
Date: Fri, 12 May 2000 08:44:42 -0400

Let's see if this reasoning holds water. Imagine your favorite OS, suppose
that I send you
a .pl file (Perl Script). You then make the "mistake" of saving it to the
file system and then
proceed to running the script. What do you think that script can do?. What
will you have to do
to fix your problem?. This is completely analogous to changing the default
selection on the
"Do you want to run this document's macros" dialog from "NO" to "YES".

We have become a society of excuses people, nothing is our fault. It is
always somebody
else's fault. 

WE HAVE TO TAKE RESPONSIBILITY FOR OUR OWN ACTIONS!!!!!!!!!!!!

ps: if I made this stupid mistake, I will immediately check what macros are
included in the
forsaken document and delete them.

-----Original Message-----
From: Doug Sauder [mailto:[email-masked]]
Sent: Thursday, May 11, 2000 5:55 PM
To: Castro, Edison M. (PCA); [email-masked]
Subject: RE: VIRUS WARNING

> -----Original Message-----
> From: Castro, Edison M. (PCA) [mailto:[email-masked]]
> That is exactly the same way that all Windows virus work. As a Windows 
> user (as well as other OSes), I can say that people have to be 
> responsible 
> for their actions.  Whenever you receive any Email attachment, 
> the only way
> that attachment can produce any damage is if you run it.
> 
> At least in my copy of MS Word anytime I open a word document and it
> contains
> any macros, Word readily ask me if I want to allow the macro to execute. 
> Not only that, this version of Word (2000) is configured to only 
> ask me when
> a signed (with a certificate of a trusted party) macro is included.

Suppose you made the mistake of opening a Word document with a VBA (Visual
Basic for Applications) script virus.  (I did this once and I am sharing a
real-life experience.)  The VBA script turns off the option that disables
automatically running scripts.  I kid you not!  Next time you open a Word
document that contains a script, you won't be asked whether you want to run
it.  If you go into the options settings and set the option to disable
running scripts, you have done nothing, because the virus script runs when
you close the document and turns the option back off again.

At least not allowing macros to disable the don't-run-macros option seems
reasonable to me, but it seemed to have escaped the engineers who created
Microsoft Word.

Doug Sauder
Software Engineer
Broadsoft, Inc

---

From: "Doug Sauder" <[email-masked]>
Date: Fri, 12 May 2000 09:43:46 -0400

Oh, I agree that we have to take responsibility for our own actions.  I am absolutely responsible for allowing the macro to run.

After I mistakenly ran the macro, my first thought was to neutralize it -- to stop it from spreading further -- by disabling the automatic running of macros.  Unfortunately, Word paid more attention to what the macro wanted, than what *I* the user wanted.  I said "DON'T RUN MACROS!!".  The macro said "run macros."  Guess who Word listened to?  Do you see the catch?  It's not a matter of not being responsible.  I take the blame.  But MS made it much easier for the virus to get the upper hand.  The don't-run-macros option is only halfway useful if you can only turn it off, but can never turn it on again.

At that time I knew very little about macros.  The VBA editor seemed non-intuitive to use.  I tried to remove the virus by deleting the VBA script, and that took several hours of research in MS Word How-To books.  I finally ended up going out to a store and buying the virus clean-up software.

--
Doug Sauder
Software Engineer
Broadsoft, Inc

> Sent: Friday, May 12, 2000 08:45
> To: 'Doug Sauder'; Castro, Edison M. (PCA); [email-masked]

---

From: "Dick St.Peters" <[email-masked]>
Date: Fri, 12 May 2000 12:30:57 -0400 (EDT)

> WE HAVE TO TAKE RESPONSIBILITY FOR OUR OWN ACTIONS!!!!!!!!!!!!

Yeah, right ... when it comes to shouting, all this "blame the victim"
has gone too far.

I have users who are *illiterate*.  They can click, but they can't
read.  They can click on little pictures and listen to greetings in
their native language or view videos of relatives they haven't seen in
decades.  I refuse to believe this is bad.

Some of my illiterate users just haven't learned to read *yet*.  They
will when they're old enough to go to school.  However, it will be a
long time before they can comprehend that the computer screen is a
window into a world full of bad people who want to damage their
mommy's computer.

These users are here in the US.  That the 'love bug' worm is believed
to have originated in the Philippines should be sufficient reminder
that not every potential victim is a literate English-speaking
resident of North Americal or Europe.  It may be that technology has
no way for the network to protect villagers in Bangladesh or central
Africa.  However, reaching that conclusion and saying the network
should not try as a matter of philosophical principle are very
different.  Of course capable users should protect themselves as best
they can, but who is prepared to say that helpless users don't belong
on our Internet?

--
Dick St.Peters, [email-masked] 
Gatekeeper, NetHeaven, Saratoga Springs, NY
Saratoga/Albany/Amsterdam/BoltonLanding/Cobleskill/Greenwich/
GlensFalls/LakePlacid/NorthCreek/Plattsburgh/...
    Oldest Internet service based in the Adirondack-Albany region