Subject: Seeking Open Mobile Messaging Protocols -- Efficient E-Mail

From: Mohsen BANAN-Public <[email-masked]>
Date: 26 Jun 2000 05:33:11 -0000

Existing SMTP/IMAP/TCP technology is not well suited for
mobile and wireless environments where bandwidth and
capacity are always limited and precious.

More efficient protocols are needed to address the new
reality of mobile and wireless networks. I am seeking
open protocols which are better suited to address the
requirements of mobile and wireless networks.

The key functional requirements for the protocols that
I am seeking are:

 -  Provide for the submission and delivery of short
    (4 kilobytes or less) Internet e-mail messages 
    with the same level of functionality (or higher)
    that the existing SMTP protocols provide.

 -  Provide the same (or better) level of reliability
    and security that the existing SMTP protocols provide.

 -  Make reasonable trade-offs between specification complexity,
    implementation complexity, extendibility, scalability and efficiency.

 -  Provide the required efficiency characteristics. These include:
    minimizing the number of transmissions, minimizing the number of
    bytes transmitted, minimizing the latency of message
    submission and delivery.

The protocols I seek are intended to be used primarily
in IP based wide area wireless environments (e.g., CDPD)
The devices used have a wide variety of form factors and
platforms.

Timely delivery ("push") to unconscious carry devices
similar to the two-way paging model is also an important
goal.

The origin of the open protocols that I am seeking can
be any individual, company, or organization, provided:

  - The protocols are intended to be patent-free and are 
    declared as such.
  
  - They are published as stable specifications and are
    readily and permanently available to anyone.
    RFC publication is the prefered method.

  - Participation in the maintenance and enhancement of the protocols
    is public, open and free. The maintenance process must
    also be such as to maintain the patent-free nature of the protocols.

The absence of a set of open protocols satisfying these requirements
has led to the adoption of patented protocols such as WAP, and the
appearance of closed systems such as BlackBerry (tm).

I consider the availability of open alternatives in this
area to be of benefit to the consumer and the industry.

If you are aware of any protocol specifications which
address the above mentioned requirements please send me
--
    Mohsen BANAN  mailto:[email-masked]
--
a note. I will compile the results, then make publicly available.

Please feel free to distribute this request wherever appropriate.

Thank you.

Mohsen BANAN

---

From: Randy Bush <[email-masked]>
Date: Mon, 26 Jun 2000 06:07:03 -0700

> capacity are always limited and precious.

ahhh yes.  that 640k video buffer again.  historically every time we have
made a large kludge to save bits we have looked very stupid in far less time
than we ever imagined.  and yes, i understand the bandwidth issue.

randy

---

From: Keith Moore <[email-masked]>
Date: Mon, 26 Jun 2000 09:13:21 -0400

> From: Mohsen BANAN-Public <[email-masked]>
> 

we are in agreement so far.  however I would say that the new
protocols need to operate effectively not only in a 
mobile/wireless network, but also in a wired network, or in
a mixed network that consists of both wireless and wired links.
 
>     bytes transmitted, minimizing the latency of message

let me suggest a few additional requirements:

- high degree of functional compatibility with existing mail protocols
  (SMTP/MIME/POP/IMAP) so that there is not a lot of information
  lost when mail is gatewayed between the two environments; also
  so that I18N is supported in a way compatible with existing standards.

- congestion avoidance that competes fairly with TCP

- ability to resist denial-of-service attacks that attempt to consume
  server connection/session state (similar to SYN flooding attacks)
 
Keith