Subject: about: L2 VPN over MPLS

From: xiaolee <[email-masked]>
Date: Thu, 4 Oct 2001 21:6:47 +0800

hi,

    i have some doubts about when we implement L2 VPN over MPLS we SHOULD keep loop free. See draft-lasserre-tls-mpls-00.txt. why?

    why not just use such a simple algorithm described below? 

    1. if the L2 frames are received from a interface connecting to a CE, forward the frames to all other local interfaces in the same VPN, and also to all other remote PEs which sites within the same VPN are connecting to.

    2. if the L2 frames are received from other PE, just forward the frames to all local interfaces in the same VPN with the frame.

    is it like the full mesh topology for the IBGP peers?

    and what will happen, if protocol operations in this way?

    thanks.

---

From: Giles Heron <[email-masked]>
Date: Thu, 04 Oct 2001 17:50:56 +0100

>     1. if the L2 frames are received from a interface connecting to a CE, forward the frames to all other local interfaces in the same VPN, and also to all other remote PEs which sites within the s…

Of course you should only do this if the destination of the frame is
broadcast, multicast or unknown...

>     2. if the L2 frames are received from other PE, just forward the frames to all local interfaces in the same VPN with the frame.

yes - with the above proviso again.

>     is it like the full mesh topology for the IBGP peers?

kind of.  iBGP is control plane.  This is forwarding plane (though both
draft-lasserre and the similar draft-vkompella rely on meshed LDP
sessions in the control plane.)

>     and what will happen, if protocol operations in this way?

It will behave exactly as specified in the draft?

The draft states:

"Each PE MUST support a "split-horizon" scheme in order to prevent
loops, that is, a PE MUST NOT forward traffic from one VC LSP to another
in the same VPN (since each PE has direct connectivity to all other PEs
in the same VPN)."

Isn't that the same as your suggestion?

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================