Subject: RE: Printing Internet Drafts

From: [email-masked]
Date: Tue, 23 Oct 2001 13:41:27 -0700

I tried COPY draft-xxx-yyy-NN.txt PRN, it has the same effect as 'type
draft-xxx-yyy-NN.txt > LPT1' on Windows 2000, that is, the page break occurs
at the right place, but a larger font was used and some text on the right
edge were cut off. 

I assume the ASCII standard for pagination is ^L and the document I am
playing does have the right character. 

Thanks for your help. 

Ting

-----Original Message-----
From: Keith Moore [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 1:37 PM
To: Ting Cai
Cc: [email-masked]
Subject: Re: Printing Internet Drafts 

> I have a question on how to print Internet Draft with the right pagination
on
> Windows machine.

there are two sub-classes of this problem:

1. internet-drafts with correct pagination won't print correctly on Windows 
   because Windows doesn't support printing ASCII documents.

   if you install DOS printing support for your printer, you might be able 
   to get such documents to print by opening a DOS window and typing

   COPY draft-xxx-yyy-NN.txt PRN

   I don't know whether this works in recent versions of Windows because 
   I don't use Windows.  

   Out of sympathy for Windows users, I set up the RFCs in PDF web page

   http://www.cs.utk.edu/~moore/RFC-PDF/

   I suppose I could do something similar for Internet-Drafts.

   Of course the best solution is to use operating systems that support
   open standards like ASCII.
   
2. internet-drafts with incorrect pagination

   many people produce internet drafts with incorrect pagination or no
   pagination.  these documents don't print correctly on *any* system.

Keith

---

From: TOMSON ERIC <[email-masked]>
Date: Wed, 24 Oct 2001 11:40:38 +0200

Dear,
 
"COPY FILENAME.EXT PRN" and "TYPE FILENAME.EXT > LPT1" do have the same effect : they send FILENAME.EXT to the printer, "as is".
Now, about the font used, you have to select the font needed directly on the printer.
 
Why? Because while a word processor allows you to format a document by selecting a beautiful font and sending its code to the printer, when sending a text file directly to the printer you don't specify a font, so the default printer font is used. And obviously the current one doesn't satisfy you.
 
So you have to configure your printer (through the menus for recent printers, or by pressing a combination of keys when starting the printer for older printers) and select the right font to be used when you send files directly to the printer (like with "COPY ... PRN" or "TYPE ... > LPT1").
 
Enjoy!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]

I tried COPY draft-xxx-yyy-NN.txt PRN, it has the same effect as 'type draft-xxx-yyy-NN.txt > LPT1' on Windows 2000, that is, the page break occurs at the right place, but a larger font was used and some text on the right edge were cut off. 

I assume the ASCII standard for pagination is ^L and the document I am playing does have the right character. 

Thanks for your help. 

Ting 

-----Original Message----- 
From: Keith Moore [ mailto:[email-masked] <mailto:[email-masked]> ] 

> I have a question on how to print Internet Draft with the right pagination on 
> Windows machine. 

   http://www.cs.utk.edu/~moore/RFC-PDF/ <http://www.cs.utk.edu/~moore/RFC-PDF/>  

   

Keith