Subject: Favored Base32 Alphabet?

From: "Gordon Mohr" <[email-masked]>
Date: Tue, 2 Oct 2001 17:25:11 -0700

There are multiple Base32 alphabets floating about
in Internet-Drafts. For example,

ABCDEFGHIJK MN PQRSTUVWXYZ  23456789
in http://www.ietf.org/internet-drafts/draft-ietf-idn-dude-02.txt

and

ABCDEFGHIJKLMNOPQRSTUVWXYZ  234567
in http://www.ietf.org/internet-drafts/draft-josefsson-base-encoding-02.txt

Is there any officious IETF document or statement favoring
one or the other Base32 alphabet for new work?

Any chance that the Josefsson I-D will become an RFC of
any sort?

- Gordon
____________________
Gordon Mohr, gojomo@
bitzi.com, Bitzi CTO
_ http://bitzi.com _

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 02 Oct 2001 23:47:52 -0600

> Any chance that the Josefsson I-D will become an RFC of

There is a good chance that it will become RFC as a document of SASL Working
Group.

Alexey Melnikov
__________________________________________
R & D, ACI Worldwide (formerly MessagingDirect Ltd.)
phone 780.424.4922 x357

I speak for myself only, not for my employer.
__________________________________________

---

From: Graham Klyne <[email-masked]>
Date: Wed, 03 Oct 2001 09:37:41 +0100

>one or the other Base32 alphabet for new work?

Also,

      BASE32DIGIT = DIGIT
                  / "A" / "B" / "C" / "D" / "E" / "F" / "G" / "H"
                  / "I" / "J" / "K" / "L" / "M" / "N" / "O" / "P"
                  / "Q" / "R" / "S" / "T" / "U" / "V"

in RFC 2938.  (I won't claim this is the best possible arrangement, or in 
any way an official preference;  it just seemed to be an easy way at the 
time, kind of like an extension of hexadecimal.  Hand transcription was not 
a significant requirement here.)

#g

------------
Graham Klyne
[email-masked]

---

From: "Gordon Mohr" <[email-masked]>
Date: Wed, 3 Oct 2001 14:06:17 -0700

Thanks, Graham, for the pointer to yet a third possible alphabet.
I think there may even be a fourth mentioned somewhere.

> There is a good chance that it will become RFC as a document of SASL Working

(FYI, I can't find the SASL group at the IETF working-groups lists.)

I would be really, REALLY interested in helping to make the
Josefsson I-D the officially-sanctioned definition of "Base32",
so that there will be no ambiguity in any future standards work/
applications.

What's the best IETF venue for (and shortest path to) such a 
goal? 

- Gordon

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 03 Oct 2001 16:56:52 -0600

> (FYI, I can't find the SASL group at the IETF working-groups lists.)

Sorry, I meant "soon to become a WG" (waiting for AD approval).

Alexey Melnikov