Subject: Re: Exception to "MUST NOT"

From: "Jiwoong Lee" <[email-masked]>
Date: Thu, 4 Oct 2001 09:38:49 +0900

Robert,

----- Original Message ----- 
From: "Robert Elz" <[email-masked]>
Sent: Saturday, September 29, 2001 2:09 AM
Subject: Re: Exception to "MUST NOT"

> To discover the reasons why ICMPs are sent in these cases you can
> go back and look in the archives - but I don't think that was the
> actual point of the original question.  More one of how to interpret
> what to do in the exception cases.   From the rule containing the
> exception alone you cannot - but read that with the rest of the doc
> and all is clear.

Good point. If something is unclear, it's always recommendable to review the discussion archive and the whole document. 

However, the specification should remain as a specification, rather than a literature; If possible, one statement should stay clear by itself.

2 cents.
Jiwoong

> kre

---

From: Robert Elz <[email-masked]>
Date: Mon, 08 Oct 2001 16:29:37 +0700

Jiwoong Lee <[email-masked]> said:
  | If something is unclear, it's always recommendable to
  | review the discussion archive and the whole document.

True, though not really applicable here, as nothing was really unclear.

  | However, the specification should remain as a specification, rather
  | than a literature; If possible, one statement should stay clear by
  | itself. 

yes, but we can't have the doc containing the same text multiple times
(or I guess we could, but that would get tedious to read - to avoid that
authors tend to make the text different, and that then leads to interpretation
problems).

The "one statement" here provided a reference to the exact place to go
to (in the same document) that contained the precise rule to apply (in the
exception case to the general rule being stated).  If that isn't sufficient,
nothing is.

kre