Subject: Forward value reference

From: chintan sheth <[email-masked]>
Date: Wed, 17 Oct 2001 12:11:16 -0700 (PDT)

Hello,

I was going through various MIBs and found that in few
of them "forward value reference" for an Object
identifier is used. I didnt find that in standard MIBs
like RMON, RMON2, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB,
RFC1213-MIB etc. 

Kindly let me know asap, if "forward value reference"
for an Object identifier is allowed or not.

-----------------------------------------------------

eg. testObj :: OBJECT IDENTIFIER { comingNext 1 }

    comingNext ::= OBJECT IDENTIFIER { mib-2 99 }

    here 'comingNext' is defined after 'testObj'

    Is this allowed?

-----------------------------------------------------

Thanks,

Chintan Sheth

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 17 Oct 2001 14:34:31 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Wed, 17 Oct 2001 12:11:16 -0700 (PDT)
> From: chintan sheth <[email-masked]>
> Subject: Forward value reference
> To: [email-masked]
...
> for an Object identifier is allowed or not.
...

Yes, it is allowed.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------