Subject: Generic Client Server Protocol

From: "Anirban Majumder" <[email-masked]>
Date: Tue, 05 Mar 2002 15:21:37 +0530

Hi Everybody,
I have done some work on standardizing a protocol to be used for Client Server applications on the TCP. So, it can also be used on Internet.

I have also written an ID on it. It can be found at:
http://www.ietf.org/internet-drafts/draft-majumder-gcsp-application-02.txt

I know there may be several flaws in it so I want further comments from you experts. PLease have a look at it and send me comments for improving it.

Thank you very much....
Anirban

2,000,000,000 Web Pages--you only need 1. Save time with My Lycos.
http://my.lycos.com

---

From: "Anirban Majumder" <[email-masked]>
Date: Tue, 05 Mar 2002 18:26:37 +0530

Hello Vinoo,
I know many people is going to ask me this question...about CORBA...and for that I've included a note in the draft itself. Actually CORBA infrastructure gives a lot of overheads.

This is another approach instead.Just think of a tool to which you will just provide the structure of information you like to interchange and it will generate the necessary, dedicated APIs for you to work with.

Generic means upto the point of implementation.After implementing the client/server is no more generic.They are attached to that particular information model.

regards,
Anirban
--

On Tue, 5 Mar 2002 11:25:30   
 Vinoo Das (EHS) wrote:
>hi anirban,
>     Tell me how is this thng different from CORBA
>     and how do you think u will be using it in commercial 
>     platform  and if u make  the protocol generic it is 
>     going to be slow
>regards
>vinoo das
>     
>     
>
>-----Original Message-----
>From: Anirban Majumder [mailto:[email-masked]]
>Sent: Tuesday, March 05, 2002 3:22 PM
>To: [email-masked]
>Subject: Generic Client Server Protocol
>
>
>Hi Everybody,
>I have done some work on standardizing a protocol to be used for Client
>Server applications on the TCP. So, it can also be used on Internet.
>
>I know there may be several flaws in it so I want further comments from you
>experts. PLease have a look at it and send me comments for improving it.
>
>Thank you very much....
>Anirban
>
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 06 Mar 2002 08:37:30 -0800

Have you looked at BEEP?  RFC 3080.

Eliot