Subject: Re: PPP

From: "Bill Cunningham" <[email-masked]>
Date: Fri, 1 Mar 2002 02:25:24 -0500

I have received several responses and most people say it's in the data
layer, and a couple of people think it's in the network layer. I don't
really pay much attention to the OSI model, I think it complicates the
complicated. I try to focus more on TCP/IP. Does PPP establish a link, then
terminate, or continue throughout session in UDP and TCP? I posted this
question on the PPP mailing list with less familiaritive response than ietf
general list.
----- Original Message -----
From: "Brian Lloyd" <[email-masked]>
To: "Bill Cunningham" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 28, 2002 11:52 AM
Subject: Re: PPP

> At 03:55 AM 2/28/2002, you wrote:
> >In what layer is PPP in the TCP/IP suite?
>
> I have read some of the other responses and it reinforces my belief that
> most people don't understand PPP's relationship to IP and either the
> 5-layer (internet) or 7-layer (ISO) models.
>
> PPP is really both the link and lower network layers. (The ISORMites
> discovered that layer three was really several layers in itself but found
> it difficult to say that the 7-layer model was really a 9-layer model so
> they created sublayers, i.e. layers 3A, 3B, and 3C.  Something about
> Padlipsky comes to mind here.) The best way to think of PPP is a
degenerate
> network of two nodes, not a link between two devices.  If you think of it
> in this way, things like multilink and L2TP begin to make some sense.  The
> problem occurs when people forget this.
>
> The way that I think of it is that the LCP negotiation represents
> configuration of the link layer while the NCP negotiation configuration at
> the network layer.
>
> And I continue to kick myself for allowing negotiation of multilink as
part
> of LCP instead of doing it after authentication.  I fear that this helped
> screw up L2TP too.  I admit I caved to people who were worried about how
> long it took PPP to complete negotiation, something that just isn't very
> important.
>
>
> Brian Lloyd
> [email-masked]
> +1.530.676.1113 - voice
> +1.360.838.9669 - fax
>

---

From: Christopher Evans <[email-masked]>
Date: Thu, 28 Feb 2002 23:58:30 -0800

I kinda working on my own tcp/ip lib  and this is how I interprete it.

Your dumb terminal scripter makes connection

that activates PPP (with LCP confsync)

if that get an IP and return good then you can splat (encapulate)
IP/TCP/UDP packets 
out the line

er. and I must warn you I havnt got a working version so dont listen to me,
I am a techno moron.

Why do they call it TCP/IP  ?   that sound reversed. it should be
IP/TCP-UDP   as that makes sense in 
my head.

---

From: "Bill Cunningham" <[email-masked]>
Date: Fri, 1 Mar 2002 08:01:58 -0500

Is IP actually encapsulated in PPP, or is PPP and IP sent out at the same
time at different protocol layers? Kinda holding hands in a sense to each
other.
----- Original Message -----
From: "vint cerf" <[email-masked]>
To: "Christopher Evans" <[email-masked]>; "Bill Cunningham"
<[email-masked]>; "Brian Lloyd" <[email-masked]>
Sent: Friday, March 01, 2002 7:16 AM
Subject: Re: PPP

> christopher,
>
> it is called tcp/ip because the encapsulation was read left to right
>
> so, for example:
>
> smtp/tcp/ip
> telnet/tcp/ip
> ftp/tcp/ip
> http/tcp/ip
>
> and
>
> ip/ppp/ethernet
> ip/ethernet
> ip/ppp/dial-up
> ip/ppp/dsl
>
> and so on
>
> the ordering is arbitrary, of course - we just picked "higher level
protocol to the left"
> as in "higher order bit to the left" as a way of presenting the protocol
layers.
>
> vint cerf
>
> At 11:58 PM 2/28/2002 -0800, Christopher Evans wrote:

---

From: vint cerf <[email-masked]>
Date: Fri, 01 Mar 2002 09:52:55 -0500

IP is encapsulated in PPP for all practical purposes. PPP can support
multiple protocols on a single point to point link in the same way
ethernet can support multiple protocols

vint