Subject: RE: get technical, please? , Re: Trees have one root

From: Mike Burns <[email-masked]>
Date: Wed, 31 Jul 2002 13:43:12 -0700

>BTW, please note that your case #6 just leads to an upper level, where
>it can again become decidable. For example, if two companies are named
>"Harris Motor Company" (which may legally happen, for 50 "Harris Motor
>Company" in all 50 States), then you would have:
>
>-------------------

This could get very complicated since a user could get overloaded with
information if every domain that matches memory.com is returned.

---------
This is an automated reply.  You selection for memory.com returned more than
one result.  Please choose one of the following 1,265,342 responses

memory.com "AAA memory - Ak"
memory.com "Silicon Memory - Ca"
memory.com "Silicon Memory - Mi"
memory.com "Silicon Memory - Mexico"
memory.com "Silicon Memory - Osaka"
...
memory.com "Improve Your Memory Corp - Ca"
memory.com "memory dist inc - Mi"
memory.com "memory dist llc - Mi"
memory.com "memory dist "
...
memory.com "The friendly Neighborhood Bank - State and Ohio Chicago,IL"
memory.com "The friendly Neighborhood Bank - Ridge and Damon Chicago,IL"
memory.com "The friendly Neighborhood Bank - Elm and Roosevelt Cambridge,
MA"
memory.com "The friendly Neighborhood Bank - Elm and Roosevelt Cambridge, MA
spam R us"
...  
PANIC! System Crash DUMP  Memory overflow (please go to memory.com to
purchase more memory and bandwidth.com for more bandwidth)

-----------

If the person has been to one or more memory.coms before, then only those
sites would have to be returned.  If none of those match, then the user
would have to be questioned to find the correct answer (type, country,
keyword, or etc.).

What happens if the person uses multiple computers (i.e coffee shop) and
must go through this list of 1,000,000+ choices to get to the location they
want?  

=============
Mike Burns

Mike

---

From: Ed Gerck <[email-masked]>
Date: Wed, 31 Jul 2002 15:50:38 -0700

Mike Burns wrote:

> This could get very complicated since a user could get overloaded with information if every domain that matches memory.com is returned.

Exactly. And this would tend to self-correct and favor self-correction mechanisms,
in two levels:

1. Think of this as a "game"  for the domain holders -- every player wants their domain
to be both uniquely decidable and easy to memorize. What is the winning strategy?
Choosing memory.com will get the second but not the first.

2. There is also a second "game" going on, for the users -- every such player
wants to minimize ambiguity and maximize connectivity. What's their winning strategy?
Re-use decisions (cache hit -- memory.com is "The friendly Neighborhood Bank -
Elm and Roosevelt Cambridge, MA"), allow the meta-system to choose for you based
on the most frequent choice for all users (a decision based on majority voting), define
what root you want use (which root you trust to be conflict-free), etc.

The combination of both games will have a best strategy for everyone, the now
famous Nash equilibrium.  A Nash equilibrium is a strategy profile having the property
that no player can strictly benefit from unilaterally changing its strategy, while all other
players stay fixed.  In other words, this is no  longer a zero-sum game as it is today,
but a game where some degree of cooperation pays off.

> ---------
> This is an automated reply.  You selection for memory.com returned more than one result.  Please choose one of the following 1,265,342 responses
>
> memory.com "The friendly Neighborhood Bank - Elm and Roosevelt Cambridge, MA"
> memory.com "The friendly Neighborhood Bank - Elm and Roosevelt Cambridge, MA spam R us"
> ...
> PANIC! System Crash DUMP  Memory overflow (please go to memory.com to purchase more memory and bandwidth.com for more bandwidth)
>
> -----------
>
> If the person has been to one or more memory.coms before, then only those sites would have to be returned.

Yes, if that is the choice (cache hit decides).

> If none of those match, then the user would have to be questioned to find the correct answer (type, country, keyword, or etc.).

or another rule could be used -- for example, what is the most used choice?

> What happens if the person uses multiple computers (i.e coffee shop) and must go through this list of 1,000,000+ choices to get to the location they want?

What happens if you want to access your Hotmail account through multiple computers?
No problem, you just point to that address, right? Here is pretty much the same -- you
just point to the meta-system that you trust, which would have your preferences and
cache as you have already set them.

Cheers,
Ed Gerck