Subject: Re: Pursuing question of mime types in W3C specifications and nextactions

From: "Ian B. Jacobs" <[email-masked]>
Date: Tue, 02 Jul 2002 15:39:50 -0400

Lloyd Wood wrote:
> On Fri, 28 Jun 2002, John Stracke wrote:
>
>
>>>>Yesterday I participated in a W3C/IETF coordination
>>>>call where one of the topics was about the registration
>>>>of mime types defined by W3C Recommendations. A summary
>>>>of the meeting will be available soon to the W3C Membership.
>>>
>>>what about the IETF membership?
>>
>>Why would the process be any different for the W3C than for anybody
>>else? It is perfectly possible to have a MIME registration RFC that
>>references a non-IETF document for the actual syntax of the format.
>>For example, see RFC-3240.
>
>
> The W3C members pay good money to see that their formats become
> standards, dammit.
>
> To be clear, I am asking why the summary of the meeting will only be
> made available to the (closed, fee-paying) W3C membership.

Lloyd,

I do not know whether there will be a public summary
of the meeting.

Joseph Reagle has captured in a public document [1]
the practical steps W3C WGs should take to register
a MIME type with IANA.

  - Ian

[1] http://www.w3.org/2002/06/registering-mediatype

-- 
Ian Jacobs ([email-masked])   http://www.w3.org/People/Jacobs
Tel:                     +1 718 260-9447

---

From: Mark Baker <[email-masked]>
Date: Wed, 3 Jul 2002 16:32:49 -0400

> [1] http://www.w3.org/2002/06/registering-mediatype

I've asked around about whether this document represents an agreement
between the relevant parties, but so far all I've heard second hand is
"I think so".

Can anybody confirm, for the public record, that this is the Way?

(FWIW, I'm very happy with it - it's simpler than even I was hoping for)

MB
-- 
Mark Baker, CTO, Idokorro Mobile (formerly Planetfred)
Ottawa, Ontario, CANADA.               [email-masked]
http://www.markbaker.ca        http://www.idokorro.com

---

From: [email-masked]
Date: Sun, 07 Jul 2002 11:49:22 -0700 (PDT)

> Can anybody confirm, for the public record, that this is the Way?

It certainly is A Way. I'm not sure it rises to the level of The Way, but I see
nothing procedurally wrong here.

> (FWIW, I'm very happy with it - it's simpler than even I was hoping for)

Good!

				Ned

---

From: Dan Connolly <[email-masked]>
Date: 03 Jul 2002 17:42:25 -0500

On Wed, 2002-07-03 at 15:32, Mark Baker wrote:
> between the relevant parties,

It was prepared at the request of some relevant IETF/W3C
folks, and after discussion among those folks, but it hasn't
been endorsed by anybody but Joseph (and you) in its present form.

I think I like it... hmm... Joseph, I don't see anything
explicit about "IANA considerations" in the internet draft;
did you leave that out on purpose?

> but so far all I've heard second hand is
> "I think so".
>

Not yet.

> (FWIW, I'm very happy with it - it's simpler than even I was hoping for)

Good to know.

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/

---

From: Chris Lilley <[email-masked]>
Date: Mon, 8 Jul 2002 14:11:47 +0200

>> Can anybody confirm, for the public record, that this is the Way?

nfmc> It certainly is A Way. I'm not sure it rises to the level of The Way, but I see
nfmc> nothing procedurally wrong here.

>> (FWIW, I'm very happy with it - it's simpler than even I was hoping for)

It is fairly simple. I note that, although the discussion period and
possibly IETF last call happens in sync with teh W3C last call (which
is good) the actual registration still only happens "Once the W3C
specification has become a Recommendation".

Thus, the catch-22 or chicken-and-egg situation is still not resolved:

- mime type registration requires a stable document
- stable document requires meeting W3C implementation criteria such as
Candidate Recommendation
- getting implementation experience for CR requires using the mime
type

So, shouldn't section  3.2 be renumbered  2.3?

In other words, register it before using it, use it to gain
implementation experience, and update the registration to take into
account implementor feedback, if needed.

Since W3C considers a CR stable enough to ask non-bleeding-edge
implementors to go implement it, it should also be stable enough to do
the registration, too?

-- 
 Chris                            mailto:[email-masked]